source: projects/specs/trunk/S/SysVinit/SysVinit-vl.spec @ 521

Revision 521, 11.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Programs which control basic system processes.
2Summary(ja): 基本的なシステムプロセスを制御するプログラム
3Name: SysVinit
4Version: 2.86
5Release: 1%{_dist_release}
6License: GPL
7Group: System Environment/Base
8Source: ftp://ftp.cistron.nl/pub/people/miquels/sysvinit/sysvinit-%{version}.tar.gz
9Patch1: sysvinit-2.78-man.patch
10Patch2: sysvinit-2.77-md5-be.patch
11Patch3: sysvinit-2.78-halt.patch
12Patch4: sysvinit-2.86-autofsck.patch
13Patch5: sysvinit-2.86-loginshell.patch
14Patch6: sysvinit-2.86-makefile.patch
15Patch7: sysvinit-2.86-chroot.patch
16Patch8: sysvinit-2.86-inittab.patch
17Patch9: sysvinit-2.86-environ.patch
18Patch10: sysvinit-2.86-pidof.patch
19Patch11: sysvinit-2.86-haltname.patch
20Patch12: sysvinit-2.86-haltman.patch
21Patch13: sysvinit-2.86-single.patch
22Patch14: sysvinit-2.86-maxproclen.patch
23Patch15: sysvinit-2.86-ipv6.patch
24Patch16: sysvinit-2.86-quiet.patch
25Patch17: sysvinit-2.86-godot.patch
26Patch18: sysvinit-2.86-timeval.patch
27Patch19: sysvinit-2.86-console-open.patch
28Patch22: 81_killall_avoid_init.dpatch
29Source1: change_console
30Source2: change_console.8
31Buildroot: %{_tmppath}/%{name}-%{version}-root
32Requires: pam >= 0.66-5
33
34%description
35The SysVinit package contains a group of processes that control
36the very basic functions of your system. SysVinit includes the init
37program, the first program started by the Linux kernel when the
38system boots. Init then controls the startup, running, and shutdown
39of all other programs.
40
41%description -l ja
42SysVinit パッケージには,システムの非常に基本的な機能を制御する
43プロセスが収められています.例えば,システム起動時に Linux カーネルに
44よって最初に起動されるプログラムである init 等です.init はその後
45システムの起動や,他のプログラムの起動/終了を制御します.
46
47
48%prep
49%setup -q -n sysvinit-%{version}
50# We use a shell, not sulogin. Other random man fixes go here (such as #192804)
51%patch1 -p1 -b .manpatch
52# Handle bigendian MD5
53%patch2 -p1 -b .be
54# Create /halt or /poweroff on shutdown
55%patch3 -p1 -b .halt
56# Unlink /.autofsck on shutdown -f
57%patch4 -p1 -b .autofsck
58# Invoke single-user shell as a login shell (#105653)
59%patch5 -p1 -b .loginshell
60# Various makefile adjustments
61%patch6 -p1 -b .makefile
62# Add -c option for only matching processes with the same root
63%patch7 -p1 -b .chroot
64# Adjust examples in inittab(5) to more accurately reflect RH/Fedora
65# usage (#173572)
66%patch8 -p1 -b .inittabdocs
67# Assumedly, if we're passing an environment as the last arg, we
68# want execle, not execl.
69%patch9 -p1 -b .environ
70# Fix various things in pidof - pidof /x/y matching /z/y, pidof -x
71# for scripts, etc.
72%patch10 -p1 -b .pidof
73# Fix halt when called by login
74%patch11 -p1 -b .haltname
75# Document pam_console usage
76%patch12 -p1 -b .haltman
77# Fix single user mode (#176348)
78%patch13 -p1 -b .single
79# Fix under-copy of proc title (#188160)
80%patch14 -p1 -b .maxproclen
81# ipv6 support in last
82%patch15 -p1 -b .ipv6
83# Be less verbose when booted with 'quiet'
84%patch16 -p1 -b .quiet
85# Preserve 'waiting' across re-exec (#199305, #201146, #143289)
86%patch17 -p1 -b .godot
87# Don't overwrite ut_addr_v6 on 64-bit platforms (#176494)
88%patch18 -p1 -b .timeval
89# Allow some time for failed opens to resolve themselves (#181546)
90%patch19 -p1 -b .console-open
91%patch22 -p1 -b .nopid1
92
93%build
94make %{?_smp_mflags} CC=%{__cc} -C src
95
96%install
97rm -rf $RPM_BUILD_ROOT
98for I in sbin %{_bindir} %{_mandir}/man{1,3,5,8} etc var/run dev %{_includedir}; do
99        mkdir -p $RPM_BUILD_ROOT/$I
100done
101install -d $RPM_BUILD_ROOT/bin
102make -C src ROOT=$RPM_BUILD_ROOT MANDIR=%{_mandir} \
103        BIN_OWNER=`id -nu` BIN_GROUP=`id -ng` install
104
105# If this already exists, just do nothing (the ||: part)
106mknod --mode=0600 $RPM_BUILD_ROOT/dev/initctl p ||:
107ln -snf killall5 $RPM_BUILD_ROOT/sbin/pidof
108
109chmod 755 $RPM_BUILD_ROOT%{_bindir}/utmpdump
110
111install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/sbin/change_console
112install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/change_console.8
113install -m 644 src/initreq.h $RPM_BUILD_ROOT%{_includedir}
114
115%post
116[ -e /var/run/initrunlvl ] && ln -s ../var/run/initrunlvl /etc/initrunlvl
117[ -x /sbin/telinit -a -p /dev/initctl -a -f /proc/1/exe -a -d /proc/1/root ] && /sbin/telinit u
118exit 0
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%files
124%defattr(-,root,root)
125%doc doc/Changelog doc/Install
126%doc doc/sysvinit-%{version}.lsm contrib/start-stop-daemon.*
127/sbin/halt
128/sbin/init
129/sbin/killall5
130/sbin/pidof
131/sbin/poweroff
132/sbin/reboot
133/sbin/runlevel
134/sbin/shutdown
135/sbin/sulogin
136/sbin/telinit
137/sbin/change_console
138%{_includedir}/initreq.h
139%{_bindir}/last
140%{_bindir}/lastb
141%{_bindir}/mesg
142%{_bindir}/utmpdump
143%{_sysbindir}/mountpoint
144%attr(2555,root,tty)  %{_bindir}/wall
145%{_mandir}/*/*
146/dev/initctl
147
148%changelog
149* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.86-1
150- new upstream release
151
152* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 2.85-5vl3
153- add script to create $RPM_BUILD_ROOT/bin in %%install section
154
155* Wed Dec 10 2003 <tkoba@vinelinux.org> 2.85-5vl2
156- install initreq.h
157
158* Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.85-5vl1
159- new upstream release
160- merged with fedora package.
161  * Tue Jul 17 2001 <sagami@vinelinux.org>
162  - 2.78-10vl3: fix orphan symlink in %%doc
163  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
164  - 2.78-10vl1
165  - rebuilt under new %%{_mandir} definition
166  - added Japanese summary and description
167  * Sat Nov 18 2000 Satoshi MACHINO <machino@vinelinux.org> 2.78-10vl1
168  - build with gcc-2.95.3
169  - partially used rpmmacros
170
171* Mon Sep 22 2003 Bill Nottingham <notting@redhat.com> 2.85-5
172- add change_console, for changing console used by init
173
174* Wed Jun 25 2003 Bill Nottingham <notting@redhat.com> 2.85-4
175- block signals when calling syslog() (#97534, <joden@lee.k12.nc.us>)
176
177* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
178- rebuilt
179
180* Fri May 23 2003 Bill Nottingham <notting@redhat.com> 2.85-2
181- clean up killall5 some
182
183* Thu May 22 2003 Florian La Roche <Florian.LaRoche@redhat.de>
184- update to 2.85, remove already applied patches
185
186* Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 2.84-13
187- fix s390x build
188- fix silly warning (#83943)
189
190* Mon Feb 10 2003 Arjan van de Ven <arjanv@redhat.com>
191- fix wait() handling wrt setting SIGCHLD to SIG_IGN in shutdown
192- fix segfault in spawn() function in shutdown
193
194* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
195- rebuilt
196
197* Thu Dec 05 2002 Elliot Lee <sopwith@redhat.com> 2.84-7
198- Pass __cc macro to build, to facilitate cross-compiling
199- _smp_mflags
200
201* Mon Dec  2 2002 Bill Nottingham <notting@redhat.com> 2.84-6
202- rebuild on all arches
203- change sulogin message to be slightly more correct (#65828)
204
205* Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
206- don't strip binaries
207- have wall not write to non-ttys (#65412)
208- update usage for halt/reboot (#57753)
209- allow '-t' argument to last for checking state at certain times (#56863)
210- make 'pidof /foo/bar' not match /baz/bar (#53918)
211
212* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
213- automated rebuild
214
215* Thu May 23 2002 Tim Powers <timp@redhat.com>
216- automated rebuild
217
218* Thu Mar 12 2002 Bill Nottingham <notting@redhat.com> 2.84-2
219- add patch to log messages on shutdown/reboot
220
221* Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 2.84-1
222- update to 2.84
223
224* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
225- automated rebuild
226
227* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.79-2
228- Fix pidof -o (#55954)
229- Handle RPM_OPT_FLAGS
230- s/Copyright/License/
231
232* Mon Sep 17 2001 Bill Nottingham <notting@redhat.com>
233- update to 2.79
234
235* Tue Aug 28 2001 Bill Nottingham <notting@redhat.com>
236- unlink /.autofsck on shutdown -f
237
238* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
239- Bump release + rebuild.
240
241* Thu Jun 21 2001 Bill Nottingham <notting@redhat.com>
242- update 'no logout' patch
243- fix setting of CREAD to work with 2.4.3+ kernels (#45284)
244
245* Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
246- show users with no login pid but no logout record as gone (#42550,
247  <cwolf@starclass.com>)
248- fix sulogin to *always* work without a tty (#40934)
249
250* Tue Apr  3 2001 Bill Nottingham <notting@redhat.com>
251- set umask 022 on startup
252- manpage tweaks (#21628, #27173)
253
254* Mon Apr  2 2001 Bill Nottingham <notting@redhat.com>
255- fix dangling symlink in %%doc (#34383)
256
257* Thu Mar 15 2001 Bill Nottingham <notting@redhat.com>
258- don't run telinit u if we don't appear to be on the root fs
259
260* Fri Feb 16 2001 Bill Nottingham <notting@redhat.com>
261- run telinit u on upgrade
262
263* Wed Jan 31 2001 Bill Nottingham <notting@redhat.com>
264- document '-n' option to wall, make it root-only (#18672)
265- don't open files in sulogin unless they're really ttys (#21862)
266
267* Tue Aug  8 2000 Bill Nottingham <notting@redhat.com>
268- set SHLVL in sulogin so /etc/profile.d stuff isn't run by default
269
270* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
271- automatic rebuild
272
273* Thu Jun  8 2000 Bill Nottingham <notting@redhat.com>
274- fix the md5 code (#11534)
275- rebuild for FHS & the like
276
277* Wed Apr 19 2000 Bill Nottingham <notting@redhat.com>
278- ignore sigint in sulogin (#9803)
279- touch file in root directory if powering off (#7318)
280
281* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
282- rebuild for sparc baud rates > 38400.
283
284* Thu Feb 24 2000 Bill Nottingham <notting@redhat.com>
285- update to 2.78-final
286
287* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
288- handle compressed manpages
289
290* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
291- build to fix dependency problem
292
293* Tue Jan 10 2000 Bill Nottingham <notting@redhat.com>
294- update to 2.78
295
296* Mon Sep 06 1999 Jakub Jelinek <jj@ultra.linux.cz>
297- on big endian machines use a kludge for broken pam md5 passwords
298
299* Fri Aug 27 1999 Bill Nottingham <notting@redhat.com>
300- update to 2.77
301
302* Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
303- move pam_console stuff to usermode package
304
305* Fri Jul 02 1999 Cristian Gafton <gafton@redhat.com>
306- requires usermode to express the dependency on /usr/bin/consolehelper
307(#2813)
308
309* Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
310- make man page references to single-user mode consistent with RH usage
311
312* Sat Apr 17 1999 Jeff Johnson <jbj@redhat.com>
313- remove /etc/initlvl compatibility symlink from file list (#2236).
314
315* Fri Mar 26 1999 Michael Johnson <johnsonm@redhat.com>
316- pam.d files marked noreplace
317- added poweroff as a console application
318
319* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
320- marked config files as such in consolehelper part of filelist
321
322* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
323- auto rebuild in the new build environment (release 8)
324
325* Fri Mar 19 1999 Michael Johnson <johnsonm@redhat.com>
326- consolehelper support
327
328* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
329- glibc 2.1
330
331* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
332- poweroff symlink not included (problem #762)
333
334* Thu Jul 09 1998 Chris Evans <chris@ferret.lmh.ox.ac.uk>
335- Fix a securelevel releated security hole. Go on, try and break append
336  only files + securelevel now ;-)
337
338* Wed Jul  8 1998 Jeff Johnson <jbj@redhat.com>
339- remove /etc/nologin at end of shutdown.
340- compile around missing SIGPWR on sparc
341
342* Thu May 07 1998 Prospector System <bugs@redhat.com>
343- translations modified for de, fr, tr
344
345* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
346- upgraded to 2.74
347- fixed the package source url... (yeah, it was wrong !)
348
349* Wed Oct 1 1997 Cristian Gafton <gafton@redhat.com>
350- fixed the MD5 check in sulogin (128 hash bits encoded with base64 gives
351  22 bytes, not 24...). Fix in -md5.patch
352
353* Thu Sep 11 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
354- /etc/initrunlvl gets linked to /tmp/init-root/var/run/initrunlvl which is
355  just plain wrong..
356- /usr/bin/utmpdump was missing in the files section, although it was
357  explicitly patched into PROGS.
358- added attr's to the files section.
359- various small fixes.
360
361* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
362- updated to 2.71
363- built against glibc 2.0.4
364
365* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
366- Added sulogin.8 man page to file list.
Note: See TracBrowser for help on using the repository browser.