source: projects/specs/trunk/S/SysVinit/SysVinit-vl.spec @ 11174

Revision 11174, 12.4 KB checked in by tomop, 7 years ago (diff)

SysVinit-2.88dsf-4

Line 
1Summary: Programs which control basic system processes.
2Summary(ja): 基本的なシステムプロセスを制御するプログラム
3Name: SysVinit
4Version: 2.88dsf
5Release: 4%{_dist_release}
6License: GPLv2+
7Group: System Environment/Base
8Source: http://download.savannah.gnu.org/releases/sysvinit/sysvinit-%{version}.tar.bz2
9URL: http://savannah.nongnu.org/projects/sysvinit/
10Patch1: sysvinit-2.78-man.patch
11Patch2: sysvinit-2.86-autofsck.patch
12Patch3: sysvinit-2.86-loginshell.patch
13Patch4: sysvinit-2.86-inittab.patch
14Patch5: sysvinit-2.86-single.patch
15Patch6: sysvinit-2.88-quiet.patch
16Patch14: sysvinit-2.88-ipv6.patch
17Patch15: sysvinit-2.88-omit.patch
18Patch16: sysvinit-2.88-wall-maxlines.patch
19Patch17: sysvinit-2.88-wall-broadcast-message.patch
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21Requires: pam >= 0.66-5
22Requires: %{name}-tools = %{version}-%{release}
23Requires: filesystem
24Requires: util-linux >= 2.30.1
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: daisuke
29
30
31%description
32The SysVinit package contains a group of processes that control
33the very basic functions of your system. SysVinit includes the init
34program, the first program started by the Linux kernel when the
35system boots. Init then controls the startup, running, and shutdown
36of all other programs.
37
38%description -l ja
39SysVinit パッケージには,システムの非常に基本的な機能を制御する
40プロセスが収められています.例えば,システム起動時に Linux カーネルに
41よって最初に起動されるプログラムである init 等です.init はその後
42システムの起動や,他のプログラムの起動/終了を制御します.
43
44%package tools
45Summary: Tools used for process management.
46Summary(ja): プロセス管理に使用するツール
47Group: System Environment/Base
48Requires: util-linux >= 2.30.1
49
50%description tools
51The sysvinit-tools package contains various tools used for process
52management.
53
54$description -l ja tools
55SysVinit-tools パッケージにはプロセス管理に使用するさまざまなツール
56が含まれています。
57
58%prep
59%setup -q -n sysvinit-%{version}
60# We use a shell, not sulogin. Other random man fixes go here (such as #192804)
61%patch1 -p1 -b .manpatch
62# Unlink /.autofsck on shutdown -f
63%patch2 -p1 -b .autofsck
64# Invoke single-user shell as a login shell (#105653)
65%patch3 -p1 -b .loginshell
66# Adjust examples in inittab(5) to more accurately reflect RH/Fedora
67# usage (#173572)
68%patch4 -p1 -b .inittabdocs
69# Fix single user mode (#176348)
70%patch5 -p1 -b .single
71# Be less verbose when booted with 'quiet'
72%patch6 -p1 -b .quiet
73# Change accepted ipv6 addresses (#573346)
74%patch14 -p1 -b .ipv6
75# Add option to pidof to exclude similar processes to omitted processes (#632321)
76%patch15 -p1 -b .omit
77# Fix counting MAXLINES in wall
78%patch16 -p1 -b .maxlines
79# Raise limit for broadcast message
80%patch17 -p1 -b .broadcast
81
82%build
83make %{?_smp_mflags} CC=%{__cc} CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" LDFLAGS="-lcrypt" -C src
84
85%install
86rm -rf $RPM_BUILD_ROOT
87for I in bin sbin %{_bindir} %{_mandir}/man{1,3,5,8} etc var/run dev %{_includedir}; do
88        mkdir -p $RPM_BUILD_ROOT/$I
89done
90make -C src ROOT=$RPM_BUILD_ROOT MANDIR=%{_mandir} STRIP=/bin/true \
91        BIN_OWNER=`id -nu` BIN_GROUP=`id -ng` install
92
93rm -f $RPM_BUILD_ROOT/bin/pidof
94ln -snf killall5 $RPM_BUILD_ROOT/sbin/pidof
95rm -f $RPM_BUILD_ROOT/sbin/bootlogd
96rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/bootlogd*
97chmod 755 $RPM_BUILD_ROOT/usr/bin/utmpdump
98
99# Remove these files, as we use upstart as /sbin/init.
100rm -f $RPM_BUILD_ROOT/sbin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}
101rm -f $RPM_BUILD_ROOT/%{_includedir}/initreq.h
102rm -f $RPM_BUILD_ROOT/%{_mandir}/man5/*
103rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}*
104
105# /sbin/fstab-decode is part of initscripts
106rm -f $RPM_BUILD_ROOT/sbin/fstab-decode
107rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/fstab-decode.8
108
109# /bin/mountpoint is part of util-linux >= 2.20
110rm -f $RPM_BUILD_ROOT/bin/mountpoint
111rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/mountpoint.*
112
113# utmpdump and sulogin is part of util-linux >= 2.22
114rm -f $RPM_BUILD_ROOT%{_bindir}/utmpdump
115rm -f $RPM_BUILD_ROOT/sbin/sulogin
116rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/utmpdump.*
117rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/sulogin.*
118
119rm -f $RPM_BUILD_ROOT%{_bindir}/*
120rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*
121
122%post
123[ -x /sbin/telinit -a -p /dev/initctl -a -f /proc/1/exe -a -d /proc/1/root ] && /sbin/telinit u
124exit 0
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%files tools
130%defattr(-,root,root)
131%doc doc/Changelog COPYRIGHT
132/sbin/pidof
133/sbin/killall5
134%{_mandir}/man8/killall5*
135%{_mandir}/man8/pidof*
136
137
138%changelog
139* Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.88dsf-4
140- removed last,lastb,mesg and wall which is part of util-linux = 2.30.
141
142* Tue Nov 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-3
143- remove sulogin and utmpdump which are part of util-linux >= 2.22
144
145* Tue Feb 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-2
146- remove mountpoint which is part of util-linux >= 2.20
147
148* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-1
149- update to 2.88dsf
150- only build -tools subpackage
151
152* Fri Apr 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.87dsf-1
153- new upstream release (2.87dsf)
154- remove upstreamed or obsoleted patches
155- split off a -tools subpackage to avoid upstart conflicts
156
157* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.86-1
158- new upstream release
159
160* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 2.85-5vl3
161- add script to create $RPM_BUILD_ROOT/bin in %%install section
162
163* Wed Dec 10 2003 <tkoba@vinelinux.org> 2.85-5vl2
164- install initreq.h
165
166* Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.85-5vl1
167- new upstream release
168- merged with fedora package.
169  * Tue Jul 17 2001 <sagami@vinelinux.org>
170  - 2.78-10vl3: fix orphan symlink in %%doc
171  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
172  - 2.78-10vl1
173  - rebuilt under new %%{_mandir} definition
174  - added Japanese summary and description
175  * Sat Nov 18 2000 Satoshi MACHINO <machino@vinelinux.org> 2.78-10vl1
176  - build with gcc-2.95.3
177  - partially used rpmmacros
178
179* Mon Sep 22 2003 Bill Nottingham <notting@redhat.com> 2.85-5
180- add change_console, for changing console used by init
181
182* Wed Jun 25 2003 Bill Nottingham <notting@redhat.com> 2.85-4
183- block signals when calling syslog() (#97534, <joden@lee.k12.nc.us>)
184
185* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
186- rebuilt
187
188* Fri May 23 2003 Bill Nottingham <notting@redhat.com> 2.85-2
189- clean up killall5 some
190
191* Thu May 22 2003 Florian La Roche <Florian.LaRoche@redhat.de>
192- update to 2.85, remove already applied patches
193
194* Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 2.84-13
195- fix s390x build
196- fix silly warning (#83943)
197
198* Mon Feb 10 2003 Arjan van de Ven <arjanv@redhat.com>
199- fix wait() handling wrt setting SIGCHLD to SIG_IGN in shutdown
200- fix segfault in spawn() function in shutdown
201
202* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
203- rebuilt
204
205* Thu Dec 05 2002 Elliot Lee <sopwith@redhat.com> 2.84-7
206- Pass __cc macro to build, to facilitate cross-compiling
207- _smp_mflags
208
209* Mon Dec  2 2002 Bill Nottingham <notting@redhat.com> 2.84-6
210- rebuild on all arches
211- change sulogin message to be slightly more correct (#65828)
212
213* Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
214- don't strip binaries
215- have wall not write to non-ttys (#65412)
216- update usage for halt/reboot (#57753)
217- allow '-t' argument to last for checking state at certain times (#56863)
218- make 'pidof /foo/bar' not match /baz/bar (#53918)
219
220* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
221- automated rebuild
222
223* Thu May 23 2002 Tim Powers <timp@redhat.com>
224- automated rebuild
225
226* Tue Mar 12 2002 Bill Nottingham <notting@redhat.com> 2.84-2
227- add patch to log messages on shutdown/reboot
228
229* Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 2.84-1
230- update to 2.84
231
232* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
233- automated rebuild
234
235* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.79-2
236- Fix pidof -o (#55954)
237- Handle RPM_OPT_FLAGS
238- s/Copyright/License/
239
240* Mon Sep 17 2001 Bill Nottingham <notting@redhat.com>
241- update to 2.79
242
243* Tue Aug 28 2001 Bill Nottingham <notting@redhat.com>
244- unlink /.autofsck on shutdown -f
245
246* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
247- Bump release + rebuild.
248
249* Thu Jun 21 2001 Bill Nottingham <notting@redhat.com>
250- update 'no logout' patch
251- fix setting of CREAD to work with 2.4.3+ kernels (#45284)
252
253* Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
254- show users with no login pid but no logout record as gone (#42550,
255  <cwolf@starclass.com>)
256- fix sulogin to *always* work without a tty (#40934)
257
258* Tue Apr  3 2001 Bill Nottingham <notting@redhat.com>
259- set umask 022 on startup
260- manpage tweaks (#21628, #27173)
261
262* Mon Apr  2 2001 Bill Nottingham <notting@redhat.com>
263- fix dangling symlink in %%doc (#34383)
264
265* Thu Mar 15 2001 Bill Nottingham <notting@redhat.com>
266- don't run telinit u if we don't appear to be on the root fs
267
268* Fri Feb 16 2001 Bill Nottingham <notting@redhat.com>
269- run telinit u on upgrade
270
271* Wed Jan 31 2001 Bill Nottingham <notting@redhat.com>
272- document '-n' option to wall, make it root-only (#18672)
273- don't open files in sulogin unless they're really ttys (#21862)
274
275* Tue Aug  8 2000 Bill Nottingham <notting@redhat.com>
276- set SHLVL in sulogin so /etc/profile.d stuff isn't run by default
277
278* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
279- automatic rebuild
280
281* Thu Jun  8 2000 Bill Nottingham <notting@redhat.com>
282- fix the md5 code (#11534)
283- rebuild for FHS & the like
284
285* Wed Apr 19 2000 Bill Nottingham <notting@redhat.com>
286- ignore sigint in sulogin (#9803)
287- touch file in root directory if powering off (#7318)
288
289* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
290- rebuild for sparc baud rates > 38400.
291
292* Thu Feb 24 2000 Bill Nottingham <notting@redhat.com>
293- update to 2.78-final
294
295* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
296- handle compressed manpages
297
298* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
299- build to fix dependency problem
300
301* Mon Jan 10 2000 Bill Nottingham <notting@redhat.com>
302- update to 2.78
303
304* Mon Sep 06 1999 Jakub Jelinek <jj@ultra.linux.cz>
305- on big endian machines use a kludge for broken pam md5 passwords
306
307* Fri Aug 27 1999 Bill Nottingham <notting@redhat.com>
308- update to 2.77
309
310* Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
311- move pam_console stuff to usermode package
312
313* Fri Jul 02 1999 Cristian Gafton <gafton@redhat.com>
314- requires usermode to express the dependency on /usr/bin/consolehelper
315(#2813)
316
317* Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
318- make man page references to single-user mode consistent with RH usage
319
320* Sat Apr 17 1999 Jeff Johnson <jbj@redhat.com>
321- remove /etc/initlvl compatibility symlink from file list (#2236).
322
323* Fri Mar 26 1999 Michael Johnson <johnsonm@redhat.com>
324- pam.d files marked noreplace
325- added poweroff as a console application
326
327* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
328- marked config files as such in consolehelper part of filelist
329
330* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
331- auto rebuild in the new build environment (release 8)
332
333* Fri Mar 19 1999 Michael Johnson <johnsonm@redhat.com>
334- consolehelper support
335
336* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
337- glibc 2.1
338
339* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
340- poweroff symlink not included (problem #762)
341
342* Thu Jul 09 1998 Chris Evans <chris@ferret.lmh.ox.ac.uk>
343- Fix a securelevel releated security hole. Go on, try and break append
344  only files + securelevel now ;-)
345
346* Wed Jul  8 1998 Jeff Johnson <jbj@redhat.com>
347- remove /etc/nologin at end of shutdown.
348- compile around missing SIGPWR on sparc
349
350* Thu May 07 1998 Prospector System <bugs@redhat.com>
351- translations modified for de, fr, tr
352
353* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
354- upgraded to 2.74
355- fixed the package source url... (yeah, it was wrong !)
356
357* Wed Oct 1 1997 Cristian Gafton <gafton@redhat.com>
358- fixed the MD5 check in sulogin (128 hash bits encoded with base64 gives
359  22 bytes, not 24...). Fix in -md5.patch
360
361* Thu Sep 11 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
362- /etc/initrunlvl gets linked to /tmp/init-root/var/run/initrunlvl which is
363  just plain wrong..
364- /usr/bin/utmpdump was missing in the files section, although it was
365  explicitly patched into PROGS.
366- added attr's to the files section.
367- various small fixes.
368
369* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
370- updated to 2.71
371- built against glibc 2.0.4
372
373* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
374- Added sulogin.8 man page to file list.
Note: See TracBrowser for help on using the repository browser.