source: projects/specs/trunk/S/STLport/STLport-vl.spec @ 521

Revision 521, 2.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:         STLport
2Version:      5.1.5
3Release:      2%{?_dist_release}
4Summary:      C++ STL library compatible with the latest ANSI/ISO C++ specification
5Summary(ja):  ANSI/ISO C++ 仕様に沿った C++ 標準テンプレートライブラリ
6Group:        System Environment/Libraries
7License:      Opensource (Free and Unrestricted)
8URL:          http://www.stlport.org/
9Source:       %{name}-%{version}.tar.bz2
10BuildRoot:    %{_tmppath}/%{name}-%{version}-root
11Vendor:       Project Vine
12Distribution: Vine Linux
13
14%description
15The ANSI/ISO C++ specifcation includes a standard C++ library, also known as
16the STL. GCC by default comes with an implementation that does not comply
17with this standard, but instead partly implements an older version. STLport
18is freely available version, based on the SGI STL implementation. It is
19fully-compliant, supported, and very fast. Includes special debugging
20facilities, and interesting and useful extensions to the standard.
21
22%package devel
23Summary:  STLport development headers and documentation
24Summary(ja):  STL の開発用ヘッダファイルとドキュメント
25Group:    Development/Libraries
26Requires: %{name} = %{version}-%{release}
27
28%description devel
29Documentarion and headers for STLport
30
31
32%prep
33%setup -q
34
35%build
36#cd src
37#make -f gcc.mak INSTALLDIR=$RPM_BUILD_ROOT%{_prefix} clean all
38pushd build/lib
39export OPT="${RPM_OPT_FLAGS} -fPIC"
40make %{?_smp_mflags} -f gcc.mak all
41popd
42
43%install
44rm -rf %{buildroot}
45#cd src
46#make -f gcc.mak INSTALLDIR=$RPM_BUILD_ROOT%{_prefix} install
47#cd $RPM_BUILD_ROOT/usr/include/stlport
48#ln -s . ext
49
50pushd build/lib
51make -f gcc.mak install
52make -f gcc.mak \
53    install-release-static \
54    install-dbg-static     \
55    install-stldbg-static
56popd
57
58echo "Installing libs"
59install -d $RPM_BUILD_ROOT%{_libdir}
60#install -m0755 lib/* $RPM_BUILD_ROOT%{_libdir}
61cp -a lib/* $RPM_BUILD_ROOT%{_libdir}
62
63echo "Installing includes"
64install -d $RPM_BUILD_ROOT%{_includedir}/stlport
65cp -a stlport $RPM_BUILD_ROOT%{_includedir}/stlport
66
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72%clean
73rm -rf %{buildroot}
74
75%files
76%defattr(-,root,root)
77%doc INSTALL README
78%defattr(0644,root,root,0755)
79%{_libdir}/*.so.*
80
81%files devel
82%defattr(0644,root,root,0755)
83%doc doc/*
84%{_includedir}/stlport
85%{_libdir}/*.a
86%{_libdir}/*.so
87
88
89%changelog
90* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.5-2vl5
91- fixed copy option for symlink at %%install
92
93* Sun Oct 05 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.5-1vl5
94- updated to 5.1.5
95- modified build, install scripts
96- applied new versioning policy, spec in utf-8
97
98* Wed Dec 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.2-0vl2
99- fixed typo at Group:
100
101* Mon Dec 19 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.2-0vl1
102- updated to 4.6.2
103- rebuilt with new toolchains
104- changed Group:
105- added Japanese summary
106- added %post, %postun section
107
108* Fri Sep 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0-0vl1
109- built for Vine
Note: See TracBrowser for help on using the repository browser.