source: projects/specs/trunk/S/STLport/STLport-vl.spec @ 2348

Revision 2348, 2.8 KB checked in by owa, 13 years ago (diff)

update: STLport, lm-sensors

Line 
1Name:         STLport
2Version:      5.2.1
3Release:      1%{?_dist_release}
4Summary:      C++ STL library compatible with the latest ANSI/ISO C++ specification
5Summary(ja):  ANSI/ISO C++ 仕様に沿った C++ 標準テンプレートライブラリ
6Group:        System Environment/Libraries
7License:      Opensource (Free and Unrestricted)
8URL:          http://www.stlport.org/
9Source:       %{name}-%{version}.tar.bz2
10BuildRoot:    %{_tmppath}/%{name}-%{version}-root
11Vendor:       Project Vine
12Distribution: Vine Linux
13
14%description
15The ANSI/ISO C++ specifcation includes a standard C++ library, also known as
16the STL. GCC by default comes with an implementation that does not comply
17with this standard, but instead partly implements an older version. STLport
18is freely available version, based on the SGI STL implementation. It is
19fully-compliant, supported, and very fast. Includes special debugging
20facilities, and interesting and useful extensions to the standard.
21
22%package devel
23Summary:  STLport development headers and documentation
24Summary(ja):  STL の開発用ヘッダファイルとドキュメント
25Group:    Development/Libraries
26Requires: %{name} = %{version}-%{release}
27
28%description devel
29Documentarion and headers for STLport
30
31
32%prep
33%setup -q
34
35
36%build
37./configure \
38        --prefix=%{_prefix} \
39        --bindir=%{_bindir} \
40        --libdir=%{_libdir} \
41        --includedir=%{_includedir} \
42        --use-compiler-family=gcc \
43        --enable-static \
44        ;
45
46pushd build/lib
47export OPT="${RPM_OPT_FLAGS}"
48make clean all %{?_smp_mflags}
49popd
50
51
52%check
53make check
54
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make DESTDIR=$RPM_BUILD_ROOT install
59
60# fix library path
61mv $RPM_BUILD_ROOT$RPM_BUILD_ROOT%{_prefix}/lib/* $RPM_BUILD_ROOT%{_libdir}/
62rm -rf $RPM_BUILD_ROOT/home
63
64
65%post -p /sbin/ldconfig
66%postun -p /sbin/ldconfig
67%post devel -p /sbin/ldconfig
68%postun devel -p /sbin/ldconfig
69%clean
70rm -rf %{buildroot}
71
72
73%files
74%defattr(-,root,root)
75%doc INSTALL INSTALL.unixes README doc etc
76%{_libdir}/libstlport.so.*
77%{_libdir}/libstlportg.so.*
78%{_libdir}/libstlportstlg.so.*
79
80%files devel
81%defattr(-,root,root)
82%{_includedir}/stlport
83%{_libdir}/libstlport*.a
84%{_libdir}/libstlport*.so
85
86
87%changelog
88* Tue Dec 14 2010 Shu KONNO <owa@bg.wakwak.com> 5.2.1-1
89- updated STLport to 5.2.1
90
91* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.5-2vl5
92- fixed copy option for symlink at %%install
93
94* Sun Oct 05 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.5-1vl5
95- updated to 5.1.5
96- modified build, install scripts
97- applied new versioning policy, spec in utf-8
98
99* Wed Dec 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.2-0vl2
100- fixed typo at Group:
101
102* Mon Dec 19 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.2-0vl1
103- updated to 4.6.2
104- rebuilt with new toolchains
105- changed Group:
106- added Japanese summary
107- added %post, %postun section
108
109* Fri Sep 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0-0vl1
110- built for Vine
Note: See TracBrowser for help on using the repository browser.