source: projects/specs/trunk/S/SDL_gfx/SDL_gfx-vl.spec @ 6414

Revision 6414, 5.3 KB checked in by Takemikaduchi, 12 years ago (diff)

supertuxkart: rebuild
others: new upstream release

Line 
1Summary:        SDL graphics drawing primitives and other support functions
2Summary(ja):    SDLの基本的な描画機能とその他の機能を提供するライブラリ
3Name:           SDL_gfx
4Version:        2.0.23
5Release:        1%{?_dist_release}
6Source0:        %{name}-%{version}.tar.gz
7License:        LGPL
8Group:          System Environment/Libraries
9URL:            http://www.ferzkopp.net/joomla/
10
11BuildRequires:  SDL-devel >= 1.2.0
12BuildRequires:  libX11-devel
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15%define all_x86 i386 i586 i686 athlon
16
17
18%description
19The SDL_gfx library evolved out of the SDL_gfxPrimitives code which
20provided basic drawing routines such as lines, circles or polygons and
21SDL_rotozoom which implemented a interpolating rotozoomer for SDL
22surfaces.
23
24The current components of the SDL_gfx library are:
25
26   * Graphic Primitives (SDL_gfxPrimitves.h)
27   * Rotozoomer (SDL_rotozoom.h)
28   * Framerate control (SDL_framerate.h)
29%ifarch %{all_x86}
30   * MMX image filters (SDL_imageFilter.h)
31%endif
32
33The library is backwards compatible to the above mentioned code. Its
34is written in plain C and can be used in C++ code.
35
36
37%description -l ja
38SDL_gfx は SDL_gfxPrimitives コードから発展したライブラリであり、線や
39円、ポリゴンの描画を行う基本的な機能と、SDL サーフェースの回転・拡大
40・縮小を行う SDL_rotozoom を提供します。
41
42現在の SDL_gfx ライブラリに含まれているのは:
43
44   * 基本的な画像の描画 (SDL_gfxPrimitves.h)
45   * SDL サーフェースの回転、拡大、縮小 (SDL_rotozoom.h)
46   * フレームレート制御 (SDL_framerate.h)
47%ifarch %{all_x86}
48   * MMX イメージフィルタ (SDL_imageFilter.h)
49%endif
50
51このライブラリは先に述べたコードとの後方互換性を持っています。この
52ライブラリは C 言語で記述されており、C++ からでも使用できます。
53
54#-----------------------------------------------------------------------------
55
56%package devel
57Summary:        Libraries and includes to develop SDL_gfx programs
58Summary(ja):    SDL_gfx 用の開発ライブラリおよびヘッダファイル
59Group:          Development/Libraries
60Requires:       %{name} = %{version}
61
62%description devel
63This package includes the files needed for developing and compiling
64applications which use the SDL_gfx  library.
65
66You should install the SDL_gfx-devel package if you would like to
67develop applications based on SDL_gfx.
68
69%description devel -l ja
70このパッケージは SDL_gfx ライブラリを使用するアプリケーションを開発
71するのに必要なライブラリやヘッダファイルを含んでいます。
72
73SDL_gfx をベースにしたアプリケーションを開発するなら、このパッケージ
74をインストールしてください。
75
76#-----------------------------------------------------------------------------
77
78%package demos
79Summary:        SDL_gfx demo programs
80Summary(ja):    SDL_gfx デモプログラム
81Group:          Applications/Other
82Requires:       %{name} = %{version}
83AutoReqProv: no
84
85%description demos
86SDL_gfx demo applications and source code.
87It is necessary to compile to run demo applications.
88
89%description demos -l ja
90SDL_gfx のデモアプリケーションとソースコードです。
91デモアプリケーションを実行するには自分でコンパイルする必要があります。
92
93#-----------------------------------------------------------------------------
94
95%prep
96%setup -q
97
98%build
99%ifarch %{ix86}
100%configure --disable-static
101%else
102%configure --disable-static --disable-mmx
103%endif
104%__make
105
106
107%install
108%__rm -rf $RPM_BUILD_ROOT
109%__make install DESTDIR=$RPM_BUILD_ROOT
110
111%__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
112%__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos/m4
113%__install -m644 %{_builddir}/%{name}-%{version}/Test/m4/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos/m4
114%__rm -rf %{_builddir}/%{name}-%{version}/Test/m4
115%__install -m755 %{_builddir}/%{name}-%{version}/Test/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
116
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
118
119%clean
120%__rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126%files
127%defattr(-,root,root)
128%doc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README*
129%doc Docs/
130%{_libdir}/libSDL_gfx.so.*
131
132%files devel
133%defattr(-,root,root)
134%{_libdir}/pkgconfig/SDL_gfx.pc
135%{_libdir}/libSDL_gfx.so
136%{_includedir}/SDL/*
137
138%files demos
139%defattr(-,root,root)
140%{_datadir}/SDL_gfx-demos
141
142
143%changelog
144* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.23-1
145- new upstream release
146- add BuildRequires: libX11-devel
147
148* Mon Sep 20 2010 IWAI, Masaharu <iwai@alib.jp> 2.0.22-1
149- new upstream release
150- add pkg-config file in devel package
151- remove *.a
152- move *.so file: main to devel
153
154* Sat Sep 20 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-1
155- new upstream release
156- applied new versioning policy
157- spec in UTF-8
158
159* Mon Jan 15 2007 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
160- new upstream release
161- added %post and %postun section
162
163* Mon Jun 26 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-1vl2
164- rebuild to correct version mismatch.(1vl1 already exist in Vine Plus/3.0)
165- change SDL_gfx-demos Group to Applications/Other.
166- add SDL_gfx-demos description.
167
168* Wed Aug 24 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.13-0vl2
169- disable MMX on non-x86 archtecture
170
171* Sat May 14 2005 kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-0vl1
172- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.