source: projects/specs/trunk/S/SDL_gfx/SDL_gfx-vl.spec @ 8073

Revision 8073, 5.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary:        SDL graphics drawing primitives and other support functions
2Summary(ja):    SDLの基本的な描画機能とその他の機能を提供するライブラリ
3Name:           SDL_gfx
4Version:        2.0.23
5Release:        2%{?_dist_release}
6Source0:        %{name}-%{version}.tar.gz
7License:        LGPL
8Group:          System Environment/Libraries
9URL:            http://www.ferzkopp.net/joomla/
10
11BuildRequires:  SDL-devel >= 1.2.0
12BuildRequires:  libX11-devel
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15%define all_x86 i386 i586 i686 athlon
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21The SDL_gfx library evolved out of the SDL_gfxPrimitives code which
22provided basic drawing routines such as lines, circles or polygons and
23SDL_rotozoom which implemented a interpolating rotozoomer for SDL
24surfaces.
25
26The current components of the SDL_gfx library are:
27
28   * Graphic Primitives (SDL_gfxPrimitves.h)
29   * Rotozoomer (SDL_rotozoom.h)
30   * Framerate control (SDL_framerate.h)
31%ifarch %{all_x86}
32   * MMX image filters (SDL_imageFilter.h)
33%endif
34
35The library is backwards compatible to the above mentioned code. Its
36is written in plain C and can be used in C++ code.
37
38
39%description -l ja
40SDL_gfx は SDL_gfxPrimitives コードから発展したライブラリであり、線や
41円、ポリゴンの描画を行う基本的な機能と、SDL サーフェースの回転・拡大
42・縮小を行う SDL_rotozoom を提供します。
43
44現在の SDL_gfx ライブラリに含まれているのは:
45
46   * 基本的な画像の描画 (SDL_gfxPrimitves.h)
47   * SDL サーフェースの回転、拡大、縮小 (SDL_rotozoom.h)
48   * フレームレート制御 (SDL_framerate.h)
49%ifarch %{all_x86}
50   * MMX イメージフィルタ (SDL_imageFilter.h)
51%endif
52
53このライブラリは先に述べたコードとの後方互換性を持っています。この
54ライブラリは C 言語で記述されており、C++ からでも使用できます。
55
56#-----------------------------------------------------------------------------
57
58%package devel
59Summary:        Libraries and includes to develop SDL_gfx programs
60Summary(ja):    SDL_gfx 用の開発ライブラリおよびヘッダファイル
61Group:          Development/Libraries
62Requires:       %{name} = %{version}
63
64%description devel
65This package includes the files needed for developing and compiling
66applications which use the SDL_gfx  library.
67
68You should install the SDL_gfx-devel package if you would like to
69develop applications based on SDL_gfx.
70
71%description devel -l ja
72このパッケージは SDL_gfx ライブラリを使用するアプリケーションを開発
73するのに必要なライブラリやヘッダファイルを含んでいます。
74
75SDL_gfx をベースにしたアプリケーションを開発するなら、このパッケージ
76をインストールしてください。
77
78#-----------------------------------------------------------------------------
79
80%package demos
81Summary:        SDL_gfx demo programs
82Summary(ja):    SDL_gfx デモプログラム
83Group:          Applications/Other
84Requires:       %{name} = %{version}
85AutoReqProv: no
86
87%description demos
88SDL_gfx demo applications and source code.
89It is necessary to compile to run demo applications.
90
91%description demos -l ja
92SDL_gfx のデモアプリケーションとソースコードです。
93デモアプリケーションを実行するには自分でコンパイルする必要があります。
94
95#-----------------------------------------------------------------------------
96
97%prep
98%setup -q
99
100%build
101%ifarch %{ix86}
102%configure --disable-static
103%else
104%configure --disable-static --disable-mmx
105%endif
106%__make
107
108
109%install
110%__rm -rf $RPM_BUILD_ROOT
111%__make install DESTDIR=$RPM_BUILD_ROOT
112
113%__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
114%__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos/m4
115%__install -m644 %{_builddir}/%{name}-%{version}/Test/m4/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos/m4
116%__rm -rf %{_builddir}/%{name}-%{version}/Test/m4
117%__install -m755 %{_builddir}/%{name}-%{version}/Test/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
118
119rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
120
121%clean
122%__rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125
126%postun -p /sbin/ldconfig
127
128%files
129%defattr(-,root,root)
130%doc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README*
131%doc Docs/
132%{_libdir}/libSDL_gfx.so.*
133
134%files devel
135%defattr(-,root,root)
136%{_libdir}/pkgconfig/SDL_gfx.pc
137%{_libdir}/libSDL_gfx.so
138%{_includedir}/SDL/*
139
140%files demos
141%defattr(-,root,root)
142%{_datadir}/SDL_gfx-demos
143
144
145%changelog
146* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.23-2
147- rebuild with VineSeed environment
148
149* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.23-1
150- new upstream release
151- add BuildRequires: libX11-devel
152
153* Mon Sep 20 2010 IWAI, Masaharu <iwai@alib.jp> 2.0.22-1
154- new upstream release
155- add pkg-config file in devel package
156- remove *.a
157- move *.so file: main to devel
158
159* Sat Sep 20 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-1
160- new upstream release
161- applied new versioning policy
162- spec in UTF-8
163
164* Mon Jan 15 2007 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
165- new upstream release
166- added %post and %postun section
167
168* Mon Jun 26 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-1vl2
169- rebuild to correct version mismatch.(1vl1 already exist in Vine Plus/3.0)
170- change SDL_gfx-demos Group to Applications/Other.
171- add SDL_gfx-demos description.
172
173* Wed Aug 24 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.13-0vl2
174- disable MMX on non-x86 archtecture
175
176* Sat May 14 2005 kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-0vl1
177- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.