source: projects/specs/trunk/S/SDL2/SDL2-vl.spec @ 11031

Revision 11031, 6.1 KB checked in by iwaim, 7 years ago (diff)

SDL2 2.0.5-1

Line 
1%define ver 2.0.5
2%define rel 1
3
4%bcond_with wayland
5
6Name:           SDL2
7Version:        %{ver}
8Release:        %{rel}%{?_dist_release}
9Summary:        A cross-platform multimedia library
10Group:          System Environment/Libraries
11URL:            http://www.libsdl.org/
12License:        zlib and MIT
13Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
14Source1:        SDL_config.h
15Patch0:         multilib.patch
16
17BuildRequires:  alsa-lib-devel
18BuildRequires:  audiofile-devel
19BuildRequires:  mesa-libGL-devel
20BuildRequires:  mesa-libGLU-devel
21BuildRequires:  mesa-libEGL-devel
22BuildRequires:  mesa-libGLES-devel
23BuildRequires:  libXext-devel
24BuildRequires:  libX11-devel
25BuildRequires:  libXi-devel
26BuildRequires:  libXrandr-devel
27BuildRequires:  libXrender-devel
28BuildRequires:  dbus-devel
29BuildRequires:  libXScrnSaver-devel
30BuildRequires:  libusb-devel
31BuildRequires:  pulseaudio-libs-devel
32BuildRequires:  libXinerama-devel
33BuildRequires:  libXcursor-devel
34# Wayland
35%if %{with wayland}
36BuildRequires:  libwayland-client-devel
37BuildRequires:  libwayland-egl-devel
38BuildRequires:  libwayland-cursor-devel
39%endif
40BuildRequires:  libxkbcommon-devel
41
42%description
43Simple DirectMedia Layer (SDL) is a cross-platform multimedia library designed
44to provide fast access to the graphics frame buffer and audio device.
45
46%package devel
47Summary:    Files needed to develop Simple DirectMedia Layer applications
48Group:      Development/Libraries
49Requires:   %{name}%{?_isa} = %{version}-%{release}
50Requires:   alsa-lib-devel
51Requires:   mesa-libGL-devel
52Requires:   mesa-libGLU-devel
53Requires:   mesa-libEGL-devel
54Requires:   mesa-libGLES-devel
55Requires:   libX11-devel
56Requires:   libXi-devel
57Requires:   libXext-devel
58Requires:   libXrandr-devel
59Requires:   libXrender-devel
60Requires:   libXScrnSaver-devel
61Requires:   libXinerama-devel
62Requires:   libXcursor-devel
63%if %{with wayland}
64# Wayland
65Requires:   libwayland-client-devel
66Requires:   libwayland-egl-devel
67Requires:   libwayland-cursor-devel
68%endif
69Requires:   libxkbcommon-devel
70
71%description devel
72Simple DirectMedia Layer (SDL) is a cross-platform multimedia library designed
73to provide fast access to the graphics frame buffer and audio device. This
74package provides the libraries, include files, and other resources needed for
75developing SDL applications.
76
77Vendor: Project Vine
78Distribution: Vine Linux
79Packager: iwaim
80
81%prep
82%setup -q
83#%patch0 -p1 -b .multilib
84# Compilation without ESD
85sed -i -e 's/.*AM_PATH_ESD.*//' configure.in
86sed -i -e 's/\r//g' TODO.txt README.txt WhatsNew.txt BUGS.txt COPYING.txt CREDITS.txt README-SDL.txt
87
88%build
89%configure \
90    --enable-sdl-dlopen \
91    --disable-arts \
92    --disable-esd \
93    --disable-nas \
94    --enable-pulseaudio-shared \
95    --enable-alsa \
96%if %{with wayland}
97    --enable-video-wayland \
98%endif
99    --disable-rpath
100make %{?_smp_mflags}
101
102%install
103%make_install
104
105# Rename SDL_config.h to SDL_config-<arch>.h to avoid file conflicts on
106# multilib systems and install SDL_config.h wrapper
107mv %{buildroot}%{_includedir}/SDL2/SDL_config.h %{buildroot}%{_includedir}/SDL2/SDL_config-%{_arch}.h
108install -p -m 644 %{SOURCE1} %{buildroot}%{_includedir}/SDL2/SDL_config.h
109
110# remove libtool .la file
111rm -f %{buildroot}%{_libdir}/*.la
112# remove static .a file
113rm -f %{buildroot}%{_libdir}/*.a
114
115%post -p /sbin/ldconfig
116
117%postun -p /sbin/ldconfig
118
119%files
120%doc BUGS.txt CREDITS.txt COPYING.txt README-SDL.txt
121%{_libdir}/lib*.so.*
122
123%files devel
124%doc README.txt TODO.txt WhatsNew.txt
125%{_bindir}/*-config
126%{_libdir}/lib*.so
127%{_libdir}/pkgconfig/sdl2.pc
128%dir %{_libdir}/cmake/SDL2
129%{_libdir}/cmake/SDL2/sdl2-config.cmake
130%{_includedir}/SDL2
131%{_datadir}/aclocal/*
132
133%changelog
134* Sat Apr 15 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.5-1
135- initial build for Vine Linux
136
137* Wed Nov 18 2015 Ding-Yi Chen <dchen@redhat.com> - 2.0.3-9
138- Use bcond instead
139
140* Tue Aug 11 2015 Ding-Yi Chen <dchen@redhat.com> - 2.0.3-8
141- Remove wayland support for Requires.
142
143* Thu Aug 06 2015 Ding-Yi Chen <dchen@redhat.com> - 2.0.3-7
144- Remove wayland support.
145
146* Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-6
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
148
149* Tue Jun  2 2015 Tom Callaway <spot@fedoraproject.org> - 2.0.3-5
150- remove code preventing builds with ancient gcc
151
152* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-4
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
154
155* Wed Jun 11 2014 Karsten Hopp <karsten@redhat.com> 2.0.3-3
156- fix filename of SDL_config.h for ppc64le
157
158* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-2
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
160
161* Wed Mar 19 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.3-1
162- 2.0.3 upstream release
163
164* Sat Mar 08 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.2-1
165- 2.0.2 upstream release
166- Enable wayland backend
167
168* Tue Dec 10 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.1-2
169- Add libXinerama, libudev, libXcursor support (RHBZ #1039702)
170
171* Thu Oct 24 2013 Tom Callaway <spot@fedoraproject.org> - 2.0.1-1
172- update to 2.0.1
173
174* Sat Aug 24 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-3
175- Fix multilib issues
176
177* Tue Aug 13 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-2
178- SDL2 is released. Announce:
179- http://lists.libsdl.org/pipermail/sdl-libsdl.org/2013-August/089854.html
180
181* Sat Aug 10 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-1.rc4
182- Update to latest SDL2 (08.08.2013)
183
184* Tue Jul 30 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-1.rc3
185- Fix Licenses
186- some cleanups in spec
187
188* Tue Jul 30 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-1.rc2
189- Delete -static package
190- Fix License tag
191- Fix end-of-line in documents
192- Remove all spike-nails EL-specify (if someone will want to do - 'patches are welcome')
193- Change Release tag to .rcX%%{?dist} (maintainer has changed released tarballs)
194
195* Mon Jul 29 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-1.rc1
196- Some fixes in spec and cleanup
197
198* Mon Jul 29 2013 Jon Ciesla <limburgher@gmail.com> - 2.0.0-1
199- Ported from SDL 1.2.15-10
Note: See TracBrowser for help on using the repository browser.