source: projects/specs/trunk/S/SDL/SDL-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Simple DirectMedia Layer
2Name: SDL
3Version: 1.2.13
4Release: 2%{?_dist_release}
5License: LGPL
6Group: System Environment/Libraries
7URL: http://www.libsdl.org/
8Source0: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
9
10Patch0: SDL-1.2.10-byteorder.patch
11Patch1: SDL-1.2.12-prefersounddaemons.patch
12Patch2: SDL-1.2.13-libdir.patch
13
14#BuildRequires: XOrg-devel, XOrg-gl-devel
15BuildRequires: xorg-x11-devel, mesa-libGL-devel
16BuildRequires: alsa-lib-devel, esound-devel, arts-devel
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19%description
20This is the Simple DirectMedia Layer, a generic API that provides low
21level access to audio, keyboard, mouse, and display framebuffer across
22multiple platforms.
23
24%description -l ja
25このパッケージはSimple DirectMedia Layerであり、複数のプラットホーム間の
26オーディオ、キーボード、マウスやディスプレイフレームバッファにlow level
27アクセスするための一般的なAPIです。
28
29%package devel
30Summary: Libraries, includes and more to develop SDL applications.
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33
34%description devel
35This is the Simple DirectMedia Layer, a generic API that provides low
36level access to audio, keyboard, mouse, and display framebuffer across
37multiple platforms.
38
39This is the libraries, include files and other resources you can use
40to develop SDL applications.
41
42%description devel -l ja
43このパッケージはSimple DirectMedia Layerであり、複数のプラットホーム間の
44オーディオ、キーボード、マウスやディスプレイフレームバッファにlow level
45アクセスするための一般的なAPIです。
46
47このパッケージはSDLアプリケーションを開発するために使用されるincludeファイルや
48その他リソースを含んでいます。
49
50%prep
51%setup -q
52%patch0 -p1 -b .byte
53%patch1 -p1 -b .prefer
54%patch2 -p1 -b .libdir
55
56%build
57#libtoolize --force
58aclocal
59autoconf
60
61%configure \
62        --disable-video-svga --disable-video-ggi --disable-video-aalib \
63        --disable-video-directfb \
64        --disable-debug \
65        --enable-dlopen \
66        --enable-arts-shared \
67        --enable-esd-shared \
68        --enable-alsa-shared \
69        --enable-sdl-dlopen \
70        --disable-rpath
71make
72
73%install
74rm -rf %{buildroot}
75%makeinstall
76
77## remove unuse files
78rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
79
80%clean
81rm -rf %{buildroot}
82
83%post -p /sbin/ldconfig
84%postun -p /sbin/ldconfig
85
86%files
87%defattr(-,root,root)
88%doc README-SDL.txt COPYING CREDITS BUGS
89%{_libdir}/lib*.so.*
90
91%files devel
92%defattr(-,root,root)
93%doc README README-SDL.txt COPYING CREDITS BUGS WhatsNew docs.html
94%doc docs/index.html docs/html
95%{_bindir}/*-config
96%{_libdir}/lib*.so
97%{_libdir}/*a
98%{_libdir}/pkgconfig/*.pc
99%{_includedir}/SDL/
100%{_mandir}/man3/*
101%{_datadir}/aclocal/*
102
103%changelog
104* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.13-2vl5
105- spec in utf-8
106- remove *.la
107
108* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-1vl5
109- new upstream release
110- updated Patch3
111
112* Tue Jul 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-0vl1
113- new upstream release
114- remove obsolete Patch10 which is merged in upstream
115
116* Wed Jul 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-0vl3
117- update Patch10 to add missing X11 symbols for X11 dynamic loading.
118
119* Fri Jul 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-0vl2
120- add Patch10 to support XIM on SDL-X11
121  (see http://bugzilla.libsdl.org/show_bug.cgi?id=429)
122
123* Thu Dec 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.11-0vl1
124- new upstream release
125- update byteorder.patch (patch0), prefersounddaemons.patch (patch1)
126- drop c++.patch (patch2), no_rpath.patch (patch5), x86_64.patch (patch7)
127- import libdir.patch (patch2) from FC
128- update %%configure options:
129  - add '--disable-video-directfb --disable-rpath --enable-sdl-dlopen'
130  - add '--enable-{esd,arts,alsa}-shared'
131  - drop '--enable-xfree86-glidehack'
132- add *.pc to SDL-devel package
133- add BuildRequires: {XOrg,XOrg-gl,alsa-lib,esound,arts}-devel
134- add Requires: pkgconfig to -devel package
135
136* Tue Oct 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.8-0vl2
137- fixed x86_64 endian problem with x86_64 patch
138
139* Sat Mar 19 2005 Satoshi MACHINO <machino@vinelinux.org> 1.2.8-0vl1
140- new upstream version
141        -- dropped patch4 and patch6
142
143* Fri Sep 10 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.7-0vl2
144- rebuilt without alsa-lib (sorry, ppc.rpm had dependencies with alsa-lib)
145
146* Mon May 03 2004 Satoshi MACHINO <machino@vinelinux.org> 1.2.7-0vl1
147- new upstream version
148        -- dropped patch3
149        -- added patch4,5,6 from fedora
150- added Japanese description
151
152* Mon May 05 2003 Satoshi MACHINO <machino@vinelinux.org> 1.2.5-0vl2
153- changed configure option
154        -- --disable-arts --enable-dlopen
155- added BuildPrereq:   automake autoconf libtool
156- added some patches from rawhide SDL-1.2.5-3
157        -- SDL-1.2.3-prefersounddaemons.patch
158        -- SDL-1.2.3-c++.patch
159        -- SDL-1.2.5-dgavideo-modes.patch
160- didn't to use libtool/config.{sub,guess}, autogen.sh
161
162
163* Sun Oct 13 2002 Satoshi MACHINO <machino@vinelinux.org> 1.2.5-0vl1
164- new upstream version.
165
166* Thu Apr 30 2002 Satoshi MACHINO <machino@vinelinux.org> 1.2.4-0vl1
167- updated SDL-1.2.4
168
169* Thu Jan 10 2002 akira yamada <akira@vinelinux.org> 1.2.3-0vl1
170- new upstream version.
171
172* Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.2-0vl2
173- rebuild on current Seed
174
175* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
176- 1.2.2-0vl1: updated to 1.2.2 with better macros
177
178* Wed Jan 19 2000 Sam Lantinga <slouken@libsdl.org>
179- Re-integrated spec file into SDL distribution
180- 'name' and 'version' come from configure
181- Some of the documentation is devel specific
182- Removed SMP support from %build - it doesn't work with libtool anyway
183
184* Tue Jan 18 2000 Hakan Tandogan <hakan@iconsult.com>
185- Hacked Mandrake sdl spec to build 1.1
186
187* Sun Dec 19 1999 John Buswell <johnb@mandrakesoft.com>
188- Build Release
189
190* Sat Dec 18 1999 John Buswell <johnb@mandrakesoft.com>
191- Add symlink for libSDL-1.0.so.0 required by sdlbomber
192- Added docs
193
194* Thu Dec 09 1999 Lenny Cartier <lenny@mandrakesoft.com>
195- v 1.0.0
196
197* Mon Nov  1 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
198- First spec file for Mandrake distribution.
199
200# end of file
Note: See TracBrowser for help on using the repository browser.