source: projects/specs/trunk/R/R/R-vl.spec @ 9800

Revision 9800, 16.8 KB checked in by Takemikaduchi, 9 years ago (diff)

R, glabels: rebuild
others: new upstream release

Line 
1%define pkg_version 3.2.2
2%define pkg_release 2%{?_dist_release}
3
4Summary:     A language for data analysis and graphics
5Summary(ja): データ解析・グラフィック化の言語
6Name:        R
7Version:     %{pkg_version}
8Release:     %{pkg_release}
9
10License:     GPLv
11Group:       Applications/Edutainment
12URL:         http://www.r-project.org
13
14Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
15Source1:     R.desktop
16# Patch0:      R-release.diff.gz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gcc-c++
20BuildRequires: gcc-gfortran libgfortran
21BuildRequires: texinfo
22
23%if %{?_dist_release} == "vl6"
24BuildRequires: tcl tk
25%endif
26%if %{?_dist_release} == "vl7"
27BuildRequires: tcl-devel tk-devel
28%endif
29
30BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
31BuildRequires: readline-devel ncurses-devel
32BuildRequires: zlib-devel bzip2-devel
33BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
34BuildRequires: cairo-devel pango-devel
35BuildRequires: libicu-devel
36BuildRequires: texlive-common
37BuildRequires: texlive-collection-basic
38BuildRequires: texlive-collection-latexextra
39BuildRequires: texlive-collection-fontsextra
40
41%if %{?_dist_release} == "vl6"
42BuildRequires: texlive-collection-texinfo
43BuildRequires: java-1.6.0-openjdk-devel
44%endif
45%if %{?_dist_release} == "vl7"
46BuildRequires: texlive-collection-plainextra
47BuildRequires: texlive-collection-fontsrecommended
48BuildRequires: java-1.7.0-openjdk-devel
49%endif
50
51Requires: libgfortran
52Requires: libicu
53Requires: tcl tk
54
55Vendor: Project Vine
56Distribution: Vine Linux
57Packager: Toshiaki Ara <ara_t@384.jp>
58
59%description
60'GNU S' - A language and environment for statistical computing and
61graphics. R is similar to the award-winning S system, which was
62developed at Bell Laboratories by John Chambers et al. It provides
63a wide variety of statistical and graphical techniques (linear and
64nonlinear modelling, statistical tests, time series analysis,
65classification, clustering, ...).
66
67R is designed as a true computer language with control-flow
68constructions for iteration and alternation, and it allows users to
69add additional functionality by defining new functions.
70For computationally intensive tasks, C, C++ and Fortran code
71can be linked and called at run time.
72
73%description -l ja
74'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
75Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
76線形・非線型モデル、統計検定、時系列分析、クラスター分析など
77幅広い統計解析・視覚化手法を提供する。
78Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
79として設計されており、ユーザが新たに関数を組み込むことが可能である。
80また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
81使用することができる。
82
83%package devel
84Summary:          files for development of R packages.
85Summary(ja):      Rパッケージ開発用ファイル
86Group:            Development/Libraries
87Requires:         R = %{version}-%{release}
88
89%description devel
90Install R-devel if you are going to develop or compile R packages.
91
92This is just a stub package containing the documentation on
93"Writing R Extensions".  However, installing it will ensure that
94the build environment for R packages is correct.
95
96%description -l ja devel
97Rパッケージを開発したりコンパイルする場合には、このR-develを
98インストールします。R-exts.pdf ("Writing R Extensions": 英文)
99が含まれているだけのサブパッケージですが、正しくRパッケージを
100開発するための助けになるでしょう。
101
102%package -n libRmath
103Summary:          standalone math library from the R project
104Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
105Group:            System Environment/Libraries
106
107%description -n libRmath
108A standalone library of mathematical and statistical functions derived
109from the R project.  This packages provides the shared libRmath library.
110
111%description -l ja -n libRmath
112単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
113共有ライブラリを提供する。
114
115%package -n libRmath-devel
116Summary:          standalone math library from the R project
117Summary(ja):      libRmathの開発ライブラリ
118Group:            Development/Libraries
119Requires:         libRmath = %{version}-%{release}
120
121%description -n libRmath-devel
122A standalone library of mathematical and statistical functions derived
123from the R project.  This packages provides the header files.
124
125%description -l ja -n libRmath-devel
126libRmathのヘッダファイル(Rmath.h)
127
128%package -n libRmath-static
129Summary: Static R Standalone math library
130Summary(ja): libRmath の静的ライブラリ
131Group: Development/Libraries
132Requires: libRmath-devel = %{version}-%{release}
133
134%description -n libRmath-static
135A standalone library of mathematical and statistical functions derived
136from the R project.  This package provides the static libRmath library.
137
138
139%prep
140%{__rm} -rf ${RPM_BUILD_ROOT}
141%setup -q
142# %patch0 -p1
143
144%build
145export R_PDFVIEWER="%{_bindir}/xdg-open"
146export R_PRINTCMD="lpr"
147export R_BROWSER="%{_bindir}/xdg-open"
148
149%configure --enable-R-shlib --with-tcltk
150
151%{__make} %{?_smp_mflags}
152(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
153LANG=C %{__make} check
154%{__make} pdf
155# We can only "make info" if we have an up to date version of texinfo
156%{?INFO: %{__make} info}
157
158
159%install
160%{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
161%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
162%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
163
164#Install libRmath files
165(cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
166
167mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
168echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
169
170#Fix lication of R_HOME_DIR in shell wrapper
171sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
172  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
173chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
174sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
175  > ${RPM_BUILD_ROOT}%{_bindir}/R
176chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
177
178# add R into menu
179mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
180mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/icons
181
182cp -a %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/
183cp -a doc/html/logosm.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
184
185
186%clean
187%{__rm} -rf ${RPM_BUILD_ROOT}
188
189
190%post
191%if 0%{?INFO}
192   # Create directory entries for info files
193   # (optional doc files, so we must check that they are installed)
194   for doc in admin data exts FAQ intro lang; do
195      file=%{_infodir}/R-${doc}.info.gz
196      if [ -e $file ]; then
197         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
198      fi
199   done
200%endif
201%{_syssbindir}/ldconfig
202
203
204%preun
205%if 0%{?INFO}
206   if [ $1 = 0 ]; then
207      # Delete directory entries for info files (if they were installed)
208      for doc in admin data exts FAQ intro lang; do
209         file=%{_infodir}/R-${doc}.info.gz
210         if [ -e ${file} ]; then
211            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
212         fi
213      done
214   fi
215%endif
216
217%postun -p %{_syssbindir}/ldconfig
218
219%post -n libRmath -p %{_syssbindir}/ldconfig
220
221%postun -n libRmath -p %{_syssbindir}/ldconfig
222
223
224%files
225%defattr(-, root, root)
226%{_bindir}/R
227%{_bindir}/Rscript
228%{_libdir}/R
229%{_datadir}/applications/*
230%{_datadir}/icons/*
231%{?INFO:%{_infodir}/R-*.info*}
232%{_mandir}/man1/*
233/etc/ld.so.conf.d/*
234
235%files devel
236%defattr(-, root, root)
237%doc doc/manual/R-exts.pdf
238
239%files -n libRmath
240%defattr(-, root, root)
241%{_libdir}/libRmath.so
242
243%files -n libRmath-devel
244%defattr(-, root, root)
245%{_libdir}/pkgconfig/*.pc
246%{_includedir}/Rmath.h
247
248%files -n libRmath-static
249%defattr(-, root, root)
250%{_libdir}/libRmath.a
251
252
253%changelog
254* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
255- rebuild with icu-56.1
256
257* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
258- Updated to 3.2.2
259
260* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
261- add configure options: --with-tcltk
262- add BuildRequires: tcl-devel tk-devel
263- add Requires: tcl tk
264
265* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
266- Updated to 3.2.1
267
268* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
269- add "LIBS=-lbz2" to configure option
270
271* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
272- Updated to 3.2.0
273
274* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
275- Updated to 3.1.3
276- added BuildRequires: texlive-collection-fontsextra for Vine6
277- changed option "make check-all" to "make check"
278-   to avoid error in checking of mgcv package
279- changed orders of BuildRequires
280
281* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
282- rebuild with icu-54.1
283
284* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
285- Updated to 3.1.2
286
287* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
288- Updated to 3.1.1
289- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
290
291* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
292- add patch (2014-04-26)
293
294* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
295- Updated to 3.1.0
296
297* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
298- Updated to 3.0.3
299
300* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
301- rebuild current VineSeed
302- add patch (2014-01-06)
303
304* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
305- add Requires: libicu
306
307* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
308- combine spec files Vine6 and VineSeed
309- correct the days of the week in changelog
310
311* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
312- delete BuildRequires: texlive-collection-texinfo
313- add BuildRequires: texlive-collection-plainextra
314- add BuildRequires: texlive-collection-latexextra
315- add BuildRequires: texlive-collection-fontsrecommended
316-   for VineSeed
317
318* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
319- Updated to 3.0.2
320
321* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
322- Updated to 3.0.1
323- add BuildRequires: java-1.6.0-openjdk-devel
324
325* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
326- Updated to 3.0.0
327
328* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
329- Updated to 2.15.3
330- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
331- use BuildRequires ncurses-devel instead of libtermcap-devel
332
333* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
334- Updated to 2.15.2
335
336* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
337- changed group to Applications/Edutainment
338- added R to menu
339
340* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
341- Updated to 2.15.1
342
343* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
344- Updated to 2.15.0
345
346* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
347- Updated to 2.14.2
348
349* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
350- Updated to 2.14.1
351
352* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
353- Updated to 2.14.0
354- add BuildRequires: texlive-collection-fontsextra
355
356* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
357- Updated to 2.13.2
358- add BuildRequires: texlive-common
359- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
360- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
361
362* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
363- synchronized to VinePlus/5 package
364  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
365  - Updated to 2.13.1
366  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
367  - Updated to 2.13.0
368  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
369  - Updated to 2.12.2
370
371* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
372- add BuildRequires: libicu-devel
373
374* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
375- synchronized to VinePlus/5 package
376  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
377  - Updated to 2.12.1
378- added --enable-R-shlib option to %%configure
379- added static subpackage
380- use BR: texlive instead of tetex on VineSeed
381
382* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
383- rebuilt with rpm-4.8.1 for pkg-config
384
385* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
386- recompiled because tcl/tk were not linked
387
388* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
389- Updated to 2.11.0
390- added Requires: libgfortran
391
392* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
393- Updated to 2.10.1
394
395* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
396- patched to 2.10.0
397
398* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
399- spec in UTF-8
400
401* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
402- Updated to 2.10.0
403
404* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
405- Updated to 2.9.2
406- deleted BuildRequires: lapack-devel blas-devel
407- rewrote SPEC file
408
409* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
410- Updated to 2.5.1
411- added BuildRequires: gcc-gfortran for VineSeed
412- added BuildRequires: lapack-devel blas-devel
413v- fixed %preun script
414
415* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
416- Updated to 2.4.1
417- Added INFO option
418- Exclude Japanese Rprofile.site
419
420* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
421- Updated to 2.4.0
422
423* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
424- Added optimization flags
425
426* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
427- Packaged for VineLinux3.2
428
429* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
430- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
431
432* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
433- Packaged for VineLinux3.2
434- Slipped texinfo
435- Fixed preun error
436- Preset Japanese fonts
437
438* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
439- Packaged for VineLinux3.2
440
441* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
442- Restored CAPABILITIES file lost in 2.2.1beta
443
444* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
445- Configure uses --without-blas by default.
446- Install pdf manuals.
447- All toplevel documentation files are installed into _libdir/R
448  as they may be required by R (qv note on AUTHORS and THANKS below).
449- Legacy scripts for rebuilding package indices removed.
450
451* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
452- R now compiles with gcc 4.0.1 and default rpm optimization flags.
453
454* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
455- The files AUTHORS and THANKS need to be installed into _libdir/R
456  as they are required by the function contributors().  Previously
457  they were installed only as documentation files.
458
459* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
460- Corrected date error in SPEC file.
461
462* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
463- Dropped support for Red Hat boxed set.
464- Synchronized with Fedora Extras 4 RPM by Tom Calloway
465  including support for shared R library.
466- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
467  with the default optimization flags, so there is a temporary work-around.
468
469* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
470- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
471
472* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
473- Install R-data.info file as well.
474- Make info processing conditional on texinfo version, not platform release,
475  so that if a new enough version is installed, we will build and install info.
476
477* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
478- Built R 2.1.0.  R now supports internationalization, so the patch
479  to set the locale to "C" is now dropped.
480- install.packages() exits gracefully with a helpful message if
481  the file INSTALL is not present, so this is now included in the
482  R-devel package.
483
484* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
485- Added support for Scientific Linux (http://www.scientificlinux.org)
486  A distribution based on RHEL. Thanks to Jon Peatfield.
487
488* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
489- Fixed file ownership in R-devel and libRmath packages
490
491* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
492- R-devel package is now a stub package with no files, except a documentation
493  file (RPM won't accept sub-packages with no files). R now conflicts
494  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
495- Created libRmath subpackage with shared library.
496
497* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
498- Created R-devel and libRmath-devel subpackages
499
500* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
501- Built R 2.0.1
502
503* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
504- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
505  gives "lpr".
506- Define macro fcx for all Fedora distributions. This replaces Rinfo
507
508* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
509- Info support is now conditional on the macro Rinfo, which is only
510  defined for Fedora 1 and 2.
511
512* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
513- Built R 2.0.0
514- There is no longer a BUGS file, so this is not installed as a
515  documentation file.
Note: See TracBrowser for help on using the repository browser.