source: projects/specs/trunk/R/R/R-vl.spec @ 9222

Revision 9222, 15.9 KB checked in by Takemikaduchi, 9 years ago (diff)

R: rebuild
openbabel: add BR
k3b: new upstream release
others: KDE-4.14.3

Line 
1%define pkg_version 3.1.2
2%define pkg_release 2%{?_dist_release}
3
4Summary:          A language for data analysis and graphics
5Summary(ja):      データ解析・グラフィック化の言語
6Name:             R
7Version:          %{pkg_version}
8Release:          %{pkg_release}
9
10License:          GPLv2+
11Group:            Applications/Edutainment
12URL:              http://www.r-project.org
13
14Source0:          ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
15Source1:          R.desktop
16# Patch0:           R-release.diff.gz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gcc-c++
20BuildRequires: gcc-gfortran libgfortran
21BuildRequires: texlive-common
22BuildRequires: texlive-collection-basic
23BuildRequires: texlive-collection-latexextra
24
25%if %{?_dist_release} == "vl6"
26BuildRequires: texlive-collection-texinfo
27BuildRequires: java-1.6.0-openjdk-devel
28%else
29BuildRequires: texlive-collection-plainextra
30BuildRequires: texlive-collection-fontsextra
31BuildRequires: texlive-collection-fontsrecommended
32BuildRequires: java-1.7.0-openjdk-devel
33%endif
34
35BuildRequires: texinfo tcl tk
36BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
37BuildRequires: readline-devel libtermcap-devel
38BuildRequires: zlib-devel bzip2-devel
39BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
40BuildRequires: cairo-devel pango-devel
41BuildRequires: libicu-devel
42
43Requires: libgfortran
44Requires: libicu
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: Toshiaki Ara <ara_t@384.jp>
49
50%description
51'GNU S' - A language and environment for statistical computing and
52graphics. R is similar to the award-winning S system, which was
53developed at Bell Laboratories by John Chambers et al. It provides
54a wide variety of statistical and graphical techniques (linear and
55nonlinear modelling, statistical tests, time series analysis,
56classification, clustering, ...).
57
58R is designed as a true computer language with control-flow
59constructions for iteration and alternation, and it allows users to
60add additional functionality by defining new functions.
61For computationally intensive tasks, C, C++ and Fortran code
62can be linked and called at run time.
63
64%description -l ja
65'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
66Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
67線形・非線型モデル、統計検定、時系列分析、クラスター分析など
68幅広い統計解析・視覚化手法を提供する。
69Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
70として設計されており、ユーザが新たに関数を組み込むことが可能である。
71また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
72使用することができる。
73
74%package devel
75Summary:          files for development of R packages.
76Summary(ja):      Rパッケージ開発用ファイル
77Group:            Development/Libraries
78Requires:         R = %{version}-%{release}
79
80%description devel
81Install R-devel if you are going to develop or compile R packages.
82
83This is just a stub package containing the documentation on
84"Writing R Extensions".  However, installing it will ensure that
85the build environment for R packages is correct.
86
87%description -l ja devel
88Rパッケージを開発したりコンパイルする場合には、このR-develを
89インストールします。R-exts.pdf ("Writing R Extensions": 英文)
90が含まれているだけのサブパッケージですが、正しくRパッケージを
91開発するための助けになるでしょう。
92
93%package -n libRmath
94Summary:          standalone math library from the R project
95Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
96Group:            System Environment/Libraries
97
98%description -n libRmath
99A standalone library of mathematical and statistical functions derived
100from the R project.  This packages provides the shared libRmath library.
101
102%description -l ja -n libRmath
103単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
104共有ライブラリを提供する。
105
106%package -n libRmath-devel
107Summary:          standalone math library from the R project
108Summary(ja):      libRmathの開発ライブラリ
109Group:            Development/Libraries
110Requires:         libRmath = %{version}-%{release}
111
112%description -n libRmath-devel
113A standalone library of mathematical and statistical functions derived
114from the R project.  This packages provides the header files.
115
116%description -l ja -n libRmath-devel
117libRmathのヘッダファイル(Rmath.h)
118
119%package -n libRmath-static
120Summary: Static R Standalone math library
121Summary(ja): libRmath の静的ライブラリ
122Group: Development/Libraries
123Requires: libRmath-devel = %{version}-%{release}
124
125%description -n libRmath-static
126A standalone library of mathematical and statistical functions derived
127from the R project.  This package provides the static libRmath library.
128
129
130%prep
131%{__rm} -rf ${RPM_BUILD_ROOT}
132%setup -q
133# %patch0 -p1
134
135%build
136export R_PDFVIEWER="%{_bindir}/xdg-open"
137export R_PRINTCMD="lpr"
138export R_BROWSER="%{_bindir}/xdg-open"
139
140%configure --enable-R-shlib
141
142%{__make} %{?_smp_mflags}
143(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
144LANG=C make check-all
145%{__make} pdf
146#We can only "make info" if we have an up to date version of texinfo
147%{?INFO: %{__make} info}
148
149
150%install
151%{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
152%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
153%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
154
155#Install libRmath files
156(cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
157
158mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
159echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
160
161#Fix lication of R_HOME_DIR in shell wrapper
162sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
163  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
164chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
165sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
166  > ${RPM_BUILD_ROOT}%{_bindir}/R
167chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
168
169# add R into menu
170mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
171mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/icons
172
173cp -a %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/
174cp -a doc/html/logosm.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
175
176
177%clean
178%{__rm} -rf ${RPM_BUILD_ROOT}
179
180
181%post
182%if 0%{?INFO}
183   # Create directory entries for info files
184   # (optional doc files, so we must check that they are installed)
185   for doc in admin data exts FAQ intro lang; do
186      file=%{_infodir}/R-${doc}.info.gz
187      if [ -e $file ]; then
188         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
189      fi
190   done
191%endif
192%{_syssbindir}/ldconfig
193
194
195%preun
196%if 0%{?INFO}
197   if [ $1 = 0 ]; then
198      # Delete directory entries for info files (if they were installed)
199      for doc in admin data exts FAQ intro lang; do
200         file=%{_infodir}/R-${doc}.info.gz
201         if [ -e ${file} ]; then
202            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
203         fi
204      done
205   fi
206%endif
207
208%postun -p %{_syssbindir}/ldconfig
209
210%post -n libRmath -p %{_syssbindir}/ldconfig
211
212%postun -n libRmath -p %{_syssbindir}/ldconfig
213
214
215%files
216%defattr(-, root, root)
217%{_bindir}/R
218%{_bindir}/Rscript
219%{_libdir}/R
220%{_datadir}/applications/*
221%{_datadir}/icons/*
222%{?INFO:%{_infodir}/R-*.info*}
223%{_mandir}/man1/*
224/etc/ld.so.conf.d/*
225
226%files devel
227%defattr(-, root, root)
228%doc doc/manual/R-exts.pdf
229
230%files -n libRmath
231%defattr(-, root, root)
232%{_libdir}/libRmath.so
233
234%files -n libRmath-devel
235%defattr(-, root, root)
236%{_libdir}/pkgconfig/*.pc
237%{_includedir}/Rmath.h
238
239%files -n libRmath-static
240%defattr(-, root, root)
241%{_libdir}/libRmath.a
242
243
244%changelog
245* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
246- rebuild with icu-54.1
247
248* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
249- Updated to 3.1.2
250
251* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
252- Updated to 3.1.1
253- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
254
255* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
256- add patch (2014-04-26)
257
258* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
259- Updated to 3.1.0
260
261* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
262- Updated to 3.0.3
263
264* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
265- rebuild current VineSeed
266- add patch (2014-01-06)
267
268* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
269- add Requires: libicu
270
271* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
272- combine spec files Vine6 and VineSeed
273- correct the days of the week in changelog
274
275* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
276- delete BuildRequires: texlive-collection-texinfo
277- add BuildRequires: texlive-collection-plainextra
278- add BuildRequires: texlive-collection-latexextra
279- add BuildRequires: texlive-collection-fontsrecommended
280-   for VineSeed
281
282* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
283- Updated to 3.0.2
284
285* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
286- Updated to 3.0.1
287- add BuildRequires: java-1.6.0-openjdk-devel
288
289* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
290- Updated to 3.0.0
291
292* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
293- Updated to 2.15.3
294- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
295- use BuildRequires ncurses-devel instead of libtermcap-devel
296
297* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
298- Updated to 2.15.2
299
300* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
301- changed group to Applications/Edutainment
302- added R to menu
303
304* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
305- Updated to 2.15.1
306
307* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
308- Updated to 2.15.0
309
310* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
311- Updated to 2.14.2
312
313* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
314- Updated to 2.14.1
315
316* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
317- Updated to 2.14.0
318- add BuildRequires: texlive-collection-fontsextra
319
320* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
321- Updated to 2.13.2
322- add BuildRequires: texlive-common
323- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
324- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
325
326* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
327- synchronized to VinePlus/5 package
328  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
329  - Updated to 2.13.1
330  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
331  - Updated to 2.13.0
332  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
333  - Updated to 2.12.2
334
335* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
336- add BuildRequires: libicu-devel
337
338* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
339- synchronized to VinePlus/5 package
340  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
341  - Updated to 2.12.1
342- added --enable-R-shlib option to %%configure
343- added static subpackage
344- use BR: texlive instead of tetex on VineSeed
345
346* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
347- rebuilt with rpm-4.8.1 for pkg-config
348
349* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
350- recompiled because tcl/tk were not linked
351
352* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
353- Updated to 2.11.0
354- added Requires: libgfortran
355
356* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
357- Updated to 2.10.1
358
359* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
360- patched to 2.10.0
361
362* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
363- spec in UTF-8
364
365* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
366- Updated to 2.10.0
367
368* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
369- Updated to 2.9.2
370- deleted BuildRequires: lapack-devel blas-devel
371- rewrote SPEC file
372
373* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
374- Updated to 2.5.1
375- added BuildRequires: gcc-gfortran for VineSeed
376- added BuildRequires: lapack-devel blas-devel
377v- fixed %preun script
378
379* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
380- Updated to 2.4.1
381- Added INFO option
382- Exclude Japanese Rprofile.site
383
384* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
385- Updated to 2.4.0
386
387* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
388- Added optimization flags
389
390* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
391- Packaged for VineLinux3.2
392
393* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
394- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
395
396* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
397- Packaged for VineLinux3.2
398- Slipped texinfo
399- Fixed preun error
400- Preset Japanese fonts
401
402* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
403- Packaged for VineLinux3.2
404
405* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
406- Restored CAPABILITIES file lost in 2.2.1beta
407
408* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
409- Configure uses --without-blas by default.
410- Install pdf manuals.
411- All toplevel documentation files are installed into _libdir/R
412  as they may be required by R (qv note on AUTHORS and THANKS below).
413- Legacy scripts for rebuilding package indices removed.
414
415* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
416- R now compiles with gcc 4.0.1 and default rpm optimization flags.
417
418* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
419- The files AUTHORS and THANKS need to be installed into _libdir/R
420  as they are required by the function contributors().  Previously
421  they were installed only as documentation files.
422
423* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
424- Corrected date error in SPEC file.
425
426* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
427- Dropped support for Red Hat boxed set.
428- Synchronized with Fedora Extras 4 RPM by Tom Calloway
429  including support for shared R library.
430- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
431  with the default optimization flags, so there is a temporary work-around.
432
433* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
434- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
435
436* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
437- Install R-data.info file as well.
438- Make info processing conditional on texinfo version, not platform release,
439  so that if a new enough version is installed, we will build and install info.
440
441* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
442- Built R 2.1.0.  R now supports internationalization, so the patch
443  to set the locale to "C" is now dropped.
444- install.packages() exits gracefully with a helpful message if
445  the file INSTALL is not present, so this is now included in the
446  R-devel package.
447
448* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
449- Added support for Scientific Linux (http://www.scientificlinux.org)
450  A distribution based on RHEL. Thanks to Jon Peatfield.
451
452* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
453- Fixed file ownership in R-devel and libRmath packages
454
455* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
456- R-devel package is now a stub package with no files, except a documentation
457  file (RPM won't accept sub-packages with no files). R now conflicts
458  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
459- Created libRmath subpackage with shared library.
460
461* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
462- Created R-devel and libRmath-devel subpackages
463
464* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
465- Built R 2.0.1
466
467* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
468- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
469  gives "lpr".
470- Define macro fcx for all Fedora distributions. This replaces Rinfo
471
472* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
473- Info support is now conditional on the macro Rinfo, which is only
474  defined for Fedora 1 and 2.
475
476* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
477- Built R 2.0.0
478- There is no longer a BUGS file, so this is not installed as a
479  documentation file.
Note: See TracBrowser for help on using the repository browser.