source: projects/specs/trunk/R/R/R-vl.spec @ 521

Revision 521, 11.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkg_version 2.10.1
2%define pkg_release 1%{?_dist_release}
3
4Summary:          A language for data analysis and graphics
5Summary(ja):      データ解析・グラフィック化の言語
6Name:             R
7Version:          %{pkg_version}
8Release:          %{pkg_release}
9Source0:          ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
10#Patch0:           R-release.diff.gz
11License:          GPL2
12Group:            Applications/Engineering
13URL:              http://www.r-project.org
14
15BuildRequires: gcc-c++
16BuildRequires: gcc-gfortran
17BuildRequires: tetex texinfo tcl tk
18BuildRequires: libpng-devel libjpeg-devel
19BuildRequires: readline-devel libtermcap-devel
20BuildRequires: zlib-devel bzip2-devel XOrg-devel
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: Toshiaki Ara <ara_t@384.jp>
26
27%description
28'GNU S' - A language and environment for statistical computing and
29graphics. R is similar to the award-winning S system, which was
30developed at Bell Laboratories by John Chambers et al. It provides
31a wide variety of statistical and graphical techniques (linear and
32nonlinear modelling, statistical tests, time series analysis,
33classification, clustering, ...).
34
35R is designed as a true computer language with control-flow
36constructions for iteration and alternation, and it allows users to
37add additional functionality by defining new functions.
38For computationally intensive tasks, C, C++ and Fortran code
39can be linked and called at run time.
40
41%description -l ja
42'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
43Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
44線形・非線型モデル、統計検定、時系列分析、クラスター分析など
45幅広い統計解析・視覚化手法を提供する。
46Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
47として設計されており、ユーザが新たに関数を組み込むことが可能である。
48また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
49使用することができる。
50
51%package devel
52Summary:          files for development of R packages.
53Summary(ja):      Rパッケージ開発用ファイル
54Group:            Development/Libraries
55Requires:         R = %{version}-%{release}
56
57%description devel
58Install R-devel if you are going to develop or compile R packages.
59
60This is just a stub package containing the documentation on "Writing R
61Extensions".  However, installing it will ensure that the build
62environment for R packages is correct.
63
64%description -l ja devel
65Rパッケージを開発したりコンパイルする場合には、このR-develを
66インストールします。R-exts.pdf ("Writing R Extensions": 英文)
67が含まれているだけのサブパッケージですが、正しくRパッケージを
68開発するための助けになるでしょう。
69
70%package -n libRmath
71Summary:          standalone math library from the R project
72Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
73Group:            System Environment/Libraries
74
75%description -n libRmath
76A standalone library of mathematical and statistical functions derived
77from the R project.  This packages provides the shared libRmath library.
78
79%description -l ja -n libRmath
80単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
81共有ライブラリを提供する。
82
83%package -n libRmath-devel
84Summary:          standalone math library from the R project
85Summary(ja):      libRmathの開発ライブラリ
86Group:            Development/Libraries
87Requires:         libRmath = %{version}-%{release}
88
89%description -n libRmath-devel
90A standalone library of mathematical and statistical functions derived
91from the R project.  This packages provides the header files.
92
93%description -l ja -n libRmath-devel
94libRmathのヘッダファイル(Rmath.h)
95
96%prep
97%{__rm} -rf ${RPM_BUILD_ROOT}
98%setup -q
99#%patch0 -p1
100
101%build
102export R_BROWSER="%{_bindir}/firefox"
103%configure
104%{__make} %{?_smp_mflags}
105(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
106LANG=C make check-all
107%{__make} pdf
108#We can only "make info" if we have an up to date version of texinfo
109%{?INFO: %{__make} info}
110
111
112%install
113%{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
114%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
115%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
116
117#Install libRmath files
118(cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
119
120mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
121echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
122
123#Fix lication of R_HOME_DIR in shell wrapper
124sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
125  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
126chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
127sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
128  > ${RPM_BUILD_ROOT}%{_bindir}/R
129chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
130
131
132%files
133%defattr(-, root, root)
134%{_bindir}/R
135%{_bindir}/Rscript
136%{_libdir}/R
137%{?INFO:%{_infodir}/R-*.info*}
138%{_mandir}/man1/*
139/etc/ld.so.conf.d/*
140
141%files devel
142%defattr(-, root, root)
143%doc doc/manual/R-exts.pdf
144
145%files -n libRmath
146%defattr(-, root, root)
147%{_libdir}/libRmath.so
148
149%files -n libRmath-devel
150%defattr(-, root, root)
151%{_libdir}/pkgconfig/*.pc
152%{_includedir}/Rmath.h
153
154%clean
155%{__rm} -rf ${RPM_BUILD_ROOT}
156
157
158%post
159%if 0%{?INFO}
160   # Create directory entries for info files
161   # (optional doc files, so we must check that they are installed)
162   for doc in admin data exts FAQ intro lang; do
163      file=%{_infodir}/R-${doc}.info.gz
164      if [ -e $file ]; then
165         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
166      fi
167   done
168%endif
169%{_syssbindir}/ldconfig
170
171%preun
172%if 0%{?INFO}
173   if [ $1 = 0 ]; then
174      # Delete directory entries for info files (if they were installed)
175      for doc in admin data exts FAQ intro lang; do
176         file=%{_infodir}/R-${doc}.info.gz
177         if [ -e ${file} ]; then
178            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
179         fi
180      done
181   fi
182%endif
183
184%postun -p %{_syssbindir}/ldconfig
185
186%post -n libRmath -p %{_syssbindir}/ldconfig
187
188%postun -n libRmath -p %{_syssbindir}/ldconfig
189
190
191%changelog
192* Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
193- Updated to 2.10.1
194
195* Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
196- patched to 2.10.0
197
198* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
199- spec in UTF-8
200
201* Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
202- Updated to 2.10.0
203
204* Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
205- Updated to 2.9.2
206- deleted BuildRequires: lapack-devel blas-devel
207- rewrote SPEC file
208
209* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
210- Updated to 2.5.1
211- added BuildRequires: gcc-gfortran for VineSeed
212- added BuildRequires: lapack-devel blas-devel
213- fixed %preun script
214
215* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
216- Updated to 2.4.1
217- Added INFO option
218- Exclude Japanese Rprofile.site
219
220* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
221- Updated to 2.4.0
222
223* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
224- Added optimization flags
225
226* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
227- Packaged for VineLinux3.2
228
229* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
230- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
231
232* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
233- Packaged for VineLinux3.2
234- Slipped texinfo
235- Fixed preun error
236- Preset Japanese fonts
237
238* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
239- Packaged for VineLinux3.2
240
241* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
242- Restored CAPABILITIES file lost in 2.2.1beta
243
244* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
245- Configure uses --without-blas by default.
246- Install pdf manuals.
247- All toplevel documentation files are installed into _libdir/R
248  as they may be required by R (qv note on AUTHORS and THANKS below).
249- Legacy scripts for rebuilding package indices removed.
250
251* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
252- R now compiles with gcc 4.0.1 and default rpm optimization flags.
253
254* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
255- The files AUTHORS and THANKS need to be installed into _libdir/R
256  as they are required by the function contributors().  Previously
257  they were installed only as documentation files.
258
259* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
260- Corrected date error in SPEC file.
261
262* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
263- Dropped support for Red Hat boxed set.
264- Synchronized with Fedora Extras 4 RPM by Tom Calloway
265  including support for shared R library.
266- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
267  with the default optimization flags, so there is a temporary work-around.
268
269* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
270- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
271
272* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
273- Install R-data.info file as well.
274- Make info processing conditional on texinfo version, not platform release,
275  so that if a new enough version is installed, we will build and install info.
276
277* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
278- Built R 2.1.0.  R now supports internationalization, so the patch
279  to set the locale to "C" is now dropped.
280- install.packages() exits gracefully with a helpful message if
281  the file INSTALL is not present, so this is now included in the
282  R-devel package.
283
284* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
285- Added support for Scientific Linux (http://www.scientificlinux.org)
286  A distribution based on RHEL. Thanks to Jon Peatfield.
287
288* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
289- Fixed file ownership in R-devel and libRmath packages
290
291* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
292- R-devel package is now a stub package with no files, except a documentation
293  file (RPM won't accept sub-packages with no files). R now conflicts
294  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
295- Created libRmath subpackage with shared library.
296
297* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
298- Created R-devel and libRmath-devel subpackages
299
300* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
301- Built R 2.0.1
302
303* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
304- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
305  gives "lpr".
306- Define macro fcx for all Fedora distributions. This replaces Rinfo
307
308* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
309- Info support is now conditional on the macro Rinfo, which is only
310  defined for Fedora 1 and 2.
311
312* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
313- Built R 2.0.0
314- There is no longer a BUGS file, so this is not installed as a
315  documentation file.
Note: See TracBrowser for help on using the repository browser.