source: projects/specs/trunk/R/R/R-vl.spec @ 12237

Revision 12237, 20.7 KB checked in by ara_t, 5 years ago (diff)

R: rebuild with tcl-8.6/tk-8.6

Line 
1%define pkg_name    R
2%define pkg_version 3.6.1
3%define pkg_release 3%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16Source1:     Rprofile.site
17# Patch0:      R-release.diff.gz
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20%if %{?_dist_release} >= "vl7"
21%ifarch x86_64
22BuildRequires: clang
23%endif
24%endif
25BuildRequires: gcc-gfortran libgfortran
26BuildRequires: texinfo
27
28%if %{?_dist_release} == "vl6"
29BuildRequires: R-pcre-devel
30BuildRequires: tcl85-devel tk85-devel
31%endif
32%if %{?_dist_release} >= "vl7"
33BuildRequires: pcre2-devel
34BuildRequires: tcl-devel tk-devel
35%endif
36BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
37BuildRequires: readline-devel ncurses-devel
38BuildRequires: zlib-devel bzip2-devel xz-devel
39BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
40BuildRequires: cairo-devel pango-devel
41BuildRequires: libicu-devel
42BuildRequires: curl-devel
43BuildRequires: blas-devel
44
45BuildRequires: texlive-common
46BuildRequires: texlive-collection-basic
47BuildRequires: texlive-collection-latexextra
48BuildRequires: texlive-collection-fontsextra
49%if %{?_dist_release} == "vl6"
50BuildRequires: texlive-collection-texinfo
51%endif
52%if %{?_dist_release} >= "vl7"
53BuildRequires: texlive-collection-plaingeneric
54BuildRequires: texlive-collection-fontsrecommended
55%endif
56BuildRequires: java-devel
57
58%if %{?_dist_release} >= "vl7"
59%ifarch x86_64
60Requires: clang
61%endif
62%endif
63Requires: gcc-gfortran
64Requires: libgfortran
65Requires: libicu
66%if %{?_dist_release} == "vl6"
67Requires: tcl85 tk85
68Requires: R-pcre
69%endif
70%if %{?_dist_release} >= "vl7"
71Requires: tcl tk
72Requires: pcre2
73Obsoletes: tcl85 tk85
74Obsoletes: R-pcre
75%endif
76
77Requires: blas
78Requires: openblas-Rblas
79
80Obsoletes: R-devel < %{version}-%{release}
81
82Vendor: Project Vine
83Distribution: Vine Linux
84Packager: ara_t
85
86
87%description
88'GNU S' - A language and environment for statistical computing and
89graphics. R is similar to the award-winning S system, which was
90developed at Bell Laboratories by John Chambers et al. It provides
91a wide variety of statistical and graphical techniques (linear and
92nonlinear modelling, statistical tests, time series analysis,
93classification, clustering, ...).
94
95R is designed as a true computer language with control-flow
96constructions for iteration and alternation, and it allows users to
97add additional functionality by defining new functions.
98For computationally intensive tasks, C, C++ and Fortran code
99can be linked and called at run time.
100
101%description -l ja
102'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
103Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
104線形・非線型モデル、統計検定、時系列分析、クラスター分析など
105幅広い統計解析・視覚化手法を提供する。
106Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
107として設計されており、ユーザが新たに関数を組み込むことが可能である。
108また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
109使用することができる。
110
111%package -n libRmath
112Summary:     standalone math library from the R project
113Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
114Group:       System Environment/Libraries
115
116%description -n libRmath
117A standalone library of mathematical and statistical functions derived
118from the R project.  This packages provides the shared libRmath library.
119
120%description -l ja -n libRmath
121単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
122共有ライブラリを提供する。
123
124%package -n libRmath-devel
125Summary:     standalone math library from the R project
126Summary(ja): libRmathの開発ライブラリ
127Group:       Development/Libraries
128Requires:    libRmath = %{version}-%{release}
129
130%description -n libRmath-devel
131A standalone library of mathematical and statistical functions derived
132from the R project.  This packages provides the header files.
133
134%description -l ja -n libRmath-devel
135libRmathのヘッダファイル(Rmath.h)
136
137%package -n libRmath-static
138Summary: Static R Standalone math library
139Summary(ja): libRmath の静的ライブラリ
140Group: Development/Libraries
141Requires: libRmath-devel = %{version}-%{release}
142
143%description -n libRmath-static
144A standalone library of mathematical and statistical functions derived
145from the R project.  This package provides the static libRmath library.
146
147
148%prep
149%{__rm} -rf ${RPM_BUILD_ROOT}
150%setup -q
151# %patch0 -p1
152
153cat > R.desktop <<EOF
154[Desktop Entry]
155Name=GNU R
156Comment=A language for data analysis and graphics
157TryExec=/usr/bin/R
158Exec=/usr/bin/R
159Icon=/usr/share/icons/logo.jpg
160Terminal=true
161Type=Application
162Categories=Education;Science;
163StartupNotify=false
164EOF
165
166%build
167export R_PDFVIEWER="%{_bindir}/xdg-open"
168export R_PRINTCMD="lpr"
169export R_BROWSER="%{_bindir}/xdg-open"
170%if %{?_dist_release} == "vl6"
171export LD_LIBRARY_PATH=%{_libdir}/R/lib
172%endif
173
174%if %{?_dist_release} >= "vl7"
175%ifarch x86_64
176export CFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
177export CXXFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
178%endif
179%endif
180
181# Add PATHS to Renviron for R_LIBS_SITE
182echo 'R_LIBS_SITE=${R_LIBS_SITE-'"'/usr/local/lib/R/site-library:%{_libdir}/R/site-library:%{_libdir}/R/library'"'}' \
183  >> etc/Renviron.in
184
185%{configure} --enable-R-shlib --with-tcltk \
186 --with-blas="-lblas" \
187%if %{?_dist_release} >= "vl7"
188%ifarch x86_64
189 CC=clang CXX=clang++ \
190%endif
191%endif
192%if %{?_dist_release} == "vl6"
193 --with-tcl-config=%{_libdir}/tclConfig85.sh \
194 --with-tk-config=%{_libdir}/tkConfig85.sh \
195 CPPFLAGS="-I%{_libdir}/R/include" \
196 LDFLAGS="-L%{_libdir}/R/lib"
197%endif
198
199%{__make} %{?_smp_mflags}
200pushd src/nmath/standalone
201%{__make} %{?_smp_mflags}
202popd
203%{__make} pdf
204
205%install
206%{make_install}
207%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
208%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
209%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
210
211# Remove libRblas.so
212%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/R/lib/libRblas.so
213
214# Install libRmath files
215pushd src/nmath/standalone
216%{make_install}
217popd
218
219%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
220echo "%{_libdir}/R/lib" > \
221     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
222
223# Fix lication of R_HOME_DIR in shell wrapper
224%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
225  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
226%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
227%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
228  > ${RPM_BUILD_ROOT}%{_bindir}/R
229%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
230
231# add R into menu
232%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
233%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
234%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
235%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
236
237# move manuals
238%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
239%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
240 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
241
242# make symlink for libblas.so.3 (No need to use blas-devel)
243pushd ${RPM_BUILD_ROOT}%{_libdir}/R/lib
244%{__ln_s} %{_libdir}/libblas.so.3 libblas.so
245popd
246
247# Add folders for R_LIBS_SITE
248%{__mkdir_p} ${RPM_BUILD_ROOT}%{_libdir}/R/site-library
249
250# install Rprofile.site
251%{__install} %{SOURCE1} ${RPM_BUILD_ROOT}%{_libdir}/R/etc
252
253
254%check
255%{__make} check
256
257%clean
258%{__rm} -rf ${RPM_BUILD_ROOT}
259
260
261%post
262%{_syssbindir}/ldconfig
263%{__mkdir_p} %{_prefix}/local/lib/R/site-library
264
265%preun
266if [ "$1" = "0" ]
267then
268    %{__rm} -f %{_libdir}/R/lib/libblas*.so.*
269    %{__rm} -f %{_libdir}/R/lib/libopenblas*.so.*
270fi
271
272%postun -p %{_syssbindir}/ldconfig
273
274%post -n libRmath -p %{_syssbindir}/ldconfig
275
276%postun -n libRmath -p %{_syssbindir}/ldconfig
277
278
279%files
280%defattr(-, root, root)
281%{_bindir}/R
282%{_bindir}/Rscript
283%{_libdir}/R
284%{_datadir}/applications/*
285%{_datadir}/icons/*
286%{_mandir}/man1/*
287%{_docdir}/%{name}-%{version}
288%{_sysconfdir}/ld.so.conf.d/*
289
290%files -n libRmath
291%defattr(-, root, root)
292%{_libdir}/libRmath.so
293
294%files -n libRmath-devel
295%defattr(-, root, root)
296%{_libdir}/pkgconfig/*.pc
297%{_includedir}/Rmath.h
298
299%files -n libRmath-static
300%defattr(-, root, root)
301%{_libdir}/libRmath.a
302
303
304%changelog
305* Sat Oct 05 2019 Toshiaki Ara <ara_t@384.jp> 3.6.1-3
306- rebuild with tcl-8.6/tk-8.6
307
308* Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 3.6.1-2
309- rebuild with readline-8.0
310
311* Sat Jul 06 2019 Toshiaki Ara <ara_t@384.jp> 3.6.1-1
312- update to 3.6.1
313
314* Thu May 09 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-2
315- drop "-fno-schedule-insns2" option for clang/clang++ in VineSeed (x86_64)
316
317* Fri Apr 26 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-1
318- update to 3.6.0
319- build using clang/clang++ for VineSeed (x86_64)
320- change install path for external library
321- add PATHS to Renviron for R_LIBS_SITE
322- set default CRAN mirror
323
324* Mon Mar 11 2019 Toshiaki Ara <ara_t@384.jp> 3.5.3-1
325- update to 3.5.3
326
327* Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
328- rebuild with gfortran-8.2.0
329
330* Thu Dec 20 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-1
331- update to 3.5.2
332
333* Mon Jul 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.1-1
334- update to 3.5.1
335
336* Fri Jun 29 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-2
337- add Requires: openblas-Rblas
338- change using system blas
339
340* Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
341- update to 3.5.0
342- drop Patch 1 and 2
343
344* Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
345- updated to 3.4.4
346- add Obsoletes: tcl85 tk85 R-pcre for VineSeed
347
348* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
349- rebuild under icu-60.2
350
351* Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
352- Updated to 3.4.3
353
354* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
355- Updated to 3.4.2
356- change download URL
357
358* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
359- left %%{_libdir}/R/doc
360
361* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
362- Updated to 3.4.1
363- rebuild under R-pcre (pcre-8.39) for Vine6
364- add Requires: gcc-gfortran
365- change to BuildRequires: texlive-collection-plaingeneric
366- delete unnecessary descriptions
367
368* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
369- Updated to 3.4.0
370- add Patch1 and Patch2 to avoid 'make check' error
371- add export TZ="Asia/Tokyo" to avoid 'make check' error
372- delete descrption about info
373
374* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
375- Updated to 3.3.3
376
377* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
378- use tcl-8.5/tk-8.5 for Vine6.5
379  - BuildRequires to tcl85-devel/tk85-devel
380  - Requires to tcl85/tk85
381
382* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
383- merge SPEC file for Vine6
384- drop devel package
385- move PDF manuals to /usr/share/doc/R-%%{version}
386- revert logo of menu item to logo.jpg
387
388* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
389- Updated to 3.3.2
390
391* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
392- Updated to 3.3.1
393- delete BuildRequires: texlive-collection-lang*
394
395* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
396- add BuildRequires: texlive-collection-lang*
397
398* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
399- Updated to 3.3.0
400- add BuildRequires: pcre-devel xz-devel
401- change logo of menu item to Rlogo.svg
402
403* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
404- correct SPEC file
405
406* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
407- Updated to 3.2.4-revised
408
409* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
410- Updated to 3.2.4
411- fixed build error in src/extra/xz
412
413* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
414- add BuildRequires: curl-devel
415- add BuildRequires: libgomp
416
417* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
418- Updated to 3.2.3
419
420* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
421- rebuild with icu-56.1
422
423* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
424- Updated to 3.2.2
425
426* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
427- add configure options: --with-tcltk
428- add BuildRequires: tcl-devel tk-devel
429- add Requires: tcl tk
430
431* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
432- Updated to 3.2.1
433
434* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
435- add "LIBS=-lbz2" to configure option
436
437* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
438- Updated to 3.2.0
439
440* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
441- Updated to 3.1.3
442- added BuildRequires: texlive-collection-fontsextra for Vine6
443- changed option "make check-all" to "make check"
444-   to avoid error in checking of mgcv package
445- changed orders of BuildRequires
446
447* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
448- rebuild with icu-54.1
449
450* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
451- Updated to 3.1.2
452
453* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
454- Updated to 3.1.1
455- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
456
457* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
458- add patch (2014-04-26)
459
460* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
461- Updated to 3.1.0
462
463* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
464- Updated to 3.0.3
465
466* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
467- rebuild current VineSeed
468- add patch (2014-01-06)
469
470* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
471- add Requires: libicu
472
473* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
474- combine spec files Vine6 and VineSeed
475- correct the days of the week in changelog
476
477* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
478- delete BuildRequires: texlive-collection-texinfo
479- add BuildRequires: texlive-collection-plainextra
480- add BuildRequires: texlive-collection-latexextra
481- add BuildRequires: texlive-collection-fontsrecommended
482-   for VineSeed
483
484* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
485- Updated to 3.0.2
486
487* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
488- Updated to 3.0.1
489- add BuildRequires: java-1.6.0-openjdk-devel
490
491* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
492- Updated to 3.0.0
493
494* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
495- Updated to 2.15.3
496- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
497- use BuildRequires ncurses-devel instead of libtermcap-devel
498
499* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
500- Updated to 2.15.2
501
502* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
503- changed group to Applications/Edutainment
504- added R to menu
505
506* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
507- Updated to 2.15.1
508
509* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
510- Updated to 2.15.0
511
512* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
513- Updated to 2.14.2
514
515* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
516- Updated to 2.14.1
517
518* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
519- Updated to 2.14.0
520- add BuildRequires: texlive-collection-fontsextra
521
522* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
523- Updated to 2.13.2
524- add BuildRequires: texlive-common
525- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
526- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
527
528* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
529- synchronized to VinePlus/5 package
530  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
531  - Updated to 2.13.1
532  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
533  - Updated to 2.13.0
534  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
535  - Updated to 2.12.2
536
537* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
538- add BuildRequires: libicu-devel
539
540* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
541- synchronized to VinePlus/5 package
542  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
543  - Updated to 2.12.1
544- added --enable-R-shlib option to %%configure
545- added static subpackage
546- use BR: texlive instead of tetex on VineSeed
547
548* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
549- rebuilt with rpm-4.8.1 for pkg-config
550
551* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
552- recompiled because tcl/tk were not linked
553
554* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
555- Updated to 2.11.0
556- added Requires: libgfortran
557
558* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
559- Updated to 2.10.1
560
561* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
562- patched to 2.10.0
563
564* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
565- spec in UTF-8
566
567* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
568- Updated to 2.10.0
569
570* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
571- Updated to 2.9.2
572- deleted BuildRequires: lapack-devel blas-devel
573- rewrote SPEC file
574
575* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
576- Updated to 2.5.1
577- added BuildRequires: gcc-gfortran for VineSeed
578- added BuildRequires: lapack-devel blas-devel
579- fixed %preun script
580
581* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
582- Updated to 2.4.1
583- Added INFO option
584- Exclude Japanese Rprofile.site
585
586* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
587- Updated to 2.4.0
588
589* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
590- Added optimization flags
591
592* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
593- Packaged for VineLinux3.2
594
595* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
596- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
597
598* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
599- Packaged for VineLinux3.2
600- Slipped texinfo
601- Fixed preun error
602- Preset Japanese fonts
603
604* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
605- Packaged for VineLinux3.2
606
607* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
608- Restored CAPABILITIES file lost in 2.2.1beta
609
610* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
611- Configure uses --without-blas by default.
612- Install pdf manuals.
613- All toplevel documentation files are installed into _libdir/R
614  as they may be required by R (qv note on AUTHORS and THANKS below).
615- Legacy scripts for rebuilding package indices removed.
616
617* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
618- R now compiles with gcc 4.0.1 and default rpm optimization flags.
619
620* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
621- The files AUTHORS and THANKS need to be installed into _libdir/R
622  as they are required by the function contributors().  Previously
623  they were installed only as documentation files.
624
625* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
626- Corrected date error in SPEC file.
627
628* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
629- Dropped support for Red Hat boxed set.
630- Synchronized with Fedora Extras 4 RPM by Tom Calloway
631  including support for shared R library.
632- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
633  with the default optimization flags, so there is a temporary work-around.
634
635* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
636- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
637
638* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
639- Install R-data.info file as well.
640- Make info processing conditional on texinfo version, not platform release,
641  so that if a new enough version is installed, we will build and install info.
642
643* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
644- Built R 2.1.0.  R now supports internationalization, so the patch
645  to set the locale to "C" is now dropped.
646- install.packages() exits gracefully with a helpful message if
647  the file INSTALL is not present, so this is now included in the
648  R-devel package.
649
650* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
651- Added support for Scientific Linux (http://www.scientificlinux.org)
652  A distribution based on RHEL. Thanks to Jon Peatfield.
653
654* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
655- Fixed file ownership in R-devel and libRmath packages
656
657* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
658- R-devel package is now a stub package with no files, except a documentation
659  file (RPM won't accept sub-packages with no files). R now conflicts
660  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
661- Created libRmath subpackage with shared library.
662
663* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
664- Created R-devel and libRmath-devel subpackages
665
666* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
667- Built R 2.0.1
668
669* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
670- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
671  gives "lpr".
672- Define macro fcx for all Fedora distributions. This replaces Rinfo
673
674* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
675- Info support is now conditional on the macro Rinfo, which is only
676  defined for Fedora 1 and 2.
677
678* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
679- Built R 2.0.0
680- There is no longer a BUGS file, so this is not installed as a
681  documentation file.
Note: See TracBrowser for help on using the repository browser.