source: projects/specs/trunk/R/R/R-vl.spec @ 12122

Revision 12122, 20.5 KB checked in by ara_t, 5 years ago (diff)

R: update to 3.6.1

Line 
1%define pkg_name    R
2%define pkg_version 3.6.1
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16Source1:     Rprofile.site
17# Patch0:      R-release.diff.gz
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20%if %{?_dist_release} >= "vl7"
21%ifarch x86_64
22BuildRequires: clang
23%endif
24%endif
25BuildRequires: gcc-gfortran libgfortran
26BuildRequires: texinfo
27
28%if %{?_dist_release} == "vl6"
29BuildRequires: R-pcre-devel
30BuildRequires: tcl85-devel tk85-devel
31%endif
32%if %{?_dist_release} >= "vl7"
33BuildRequires: pcre2-devel
34BuildRequires: tcl-devel tk-devel
35%endif
36BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
37BuildRequires: readline-devel ncurses-devel
38BuildRequires: zlib-devel bzip2-devel xz-devel
39BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
40BuildRequires: cairo-devel pango-devel
41BuildRequires: libicu-devel
42BuildRequires: curl-devel
43BuildRequires: blas-devel
44
45BuildRequires: texlive-common
46BuildRequires: texlive-collection-basic
47BuildRequires: texlive-collection-latexextra
48BuildRequires: texlive-collection-fontsextra
49%if %{?_dist_release} == "vl6"
50BuildRequires: texlive-collection-texinfo
51%endif
52%if %{?_dist_release} >= "vl7"
53BuildRequires: texlive-collection-plaingeneric
54BuildRequires: texlive-collection-fontsrecommended
55%endif
56BuildRequires: java-devel
57
58%if %{?_dist_release} >= "vl7"
59%ifarch x86_64
60Requires: clang
61%endif
62%endif
63Requires: gcc-gfortran
64Requires: libgfortran
65Requires: libicu
66%if %{?_dist_release} == "vl6"
67Requires: tcl85 tk85
68Requires: R-pcre
69%endif
70%if %{?_dist_release} >= "vl7"
71Requires: tcl tk
72Requires: pcre2
73Obsoletes: tcl85 tk85
74Obsoletes: R-pcre
75%endif
76
77Requires: blas
78Requires: openblas-Rblas
79
80Obsoletes: R-devel < %{version}-%{release}
81
82Vendor: Project Vine
83Distribution: Vine Linux
84Packager: ara_t
85
86
87%description
88'GNU S' - A language and environment for statistical computing and
89graphics. R is similar to the award-winning S system, which was
90developed at Bell Laboratories by John Chambers et al. It provides
91a wide variety of statistical and graphical techniques (linear and
92nonlinear modelling, statistical tests, time series analysis,
93classification, clustering, ...).
94
95R is designed as a true computer language with control-flow
96constructions for iteration and alternation, and it allows users to
97add additional functionality by defining new functions.
98For computationally intensive tasks, C, C++ and Fortran code
99can be linked and called at run time.
100
101%description -l ja
102'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
103Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
104線形・非線型モデル、統計検定、時系列分析、クラスター分析など
105幅広い統計解析・視覚化手法を提供する。
106Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
107として設計されており、ユーザが新たに関数を組み込むことが可能である。
108また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
109使用することができる。
110
111%package -n libRmath
112Summary:     standalone math library from the R project
113Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
114Group:       System Environment/Libraries
115
116%description -n libRmath
117A standalone library of mathematical and statistical functions derived
118from the R project.  This packages provides the shared libRmath library.
119
120%description -l ja -n libRmath
121単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
122共有ライブラリを提供する。
123
124%package -n libRmath-devel
125Summary:     standalone math library from the R project
126Summary(ja): libRmathの開発ライブラリ
127Group:       Development/Libraries
128Requires:    libRmath = %{version}-%{release}
129
130%description -n libRmath-devel
131A standalone library of mathematical and statistical functions derived
132from the R project.  This packages provides the header files.
133
134%description -l ja -n libRmath-devel
135libRmathのヘッダファイル(Rmath.h)
136
137%package -n libRmath-static
138Summary: Static R Standalone math library
139Summary(ja): libRmath の静的ライブラリ
140Group: Development/Libraries
141Requires: libRmath-devel = %{version}-%{release}
142
143%description -n libRmath-static
144A standalone library of mathematical and statistical functions derived
145from the R project.  This package provides the static libRmath library.
146
147
148%prep
149%{__rm} -rf ${RPM_BUILD_ROOT}
150%setup -q
151# %patch0 -p1
152
153cat > R.desktop <<EOF
154[Desktop Entry]
155Name=GNU R
156Comment=A language for data analysis and graphics
157TryExec=/usr/bin/R
158Exec=/usr/bin/R
159Icon=/usr/share/icons/logo.jpg
160Terminal=true
161Type=Application
162Categories=Education;Science;
163StartupNotify=false
164EOF
165
166%build
167export R_PDFVIEWER="%{_bindir}/xdg-open"
168export R_PRINTCMD="lpr"
169export R_BROWSER="%{_bindir}/xdg-open"
170%if %{?_dist_release} == "vl6"
171export LD_LIBRARY_PATH=%{_libdir}/R/lib
172%endif
173
174%if %{?_dist_release} >= "vl7"
175%ifarch x86_64
176export CFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
177export CXXFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
178%endif
179%endif
180
181# Add PATHS to Renviron for R_LIBS_SITE
182echo 'R_LIBS_SITE=${R_LIBS_SITE-'"'/usr/local/lib/R/site-library:%{_libdir}/R/site-library:%{_libdir}/R/library'"'}' \
183  >> etc/Renviron.in
184
185%{configure} --enable-R-shlib --with-tcltk \
186 --with-blas="-lblas" \
187%if %{?_dist_release} >= "vl7"
188%ifarch x86_64
189 CC=clang CXX=clang++ \
190%endif
191%endif
192%if %{?_dist_release} == "vl6"
193 --with-tcl-config=%{_libdir}/tclConfig85.sh \
194 --with-tk-config=%{_libdir}/tkConfig85.sh \
195 CPPFLAGS="-I%{_libdir}/R/include" \
196 LDFLAGS="-L%{_libdir}/R/lib"
197%endif
198
199%{__make} %{?_smp_mflags}
200pushd src/nmath/standalone
201%{__make} %{?_smp_mflags}
202popd
203%{__make} pdf
204
205%install
206%{make_install}
207%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
208%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
209%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
210
211# Remove libRblas.so
212%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/R/lib/libRblas.so
213
214# Install libRmath files
215pushd src/nmath/standalone
216%{make_install}
217popd
218
219%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
220echo "%{_libdir}/R/lib" > \
221     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
222
223# Fix lication of R_HOME_DIR in shell wrapper
224%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
225  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
226%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
227%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
228  > ${RPM_BUILD_ROOT}%{_bindir}/R
229%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
230
231# add R into menu
232%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
233%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
234%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
235%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
236
237# move manuals
238%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
239%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
240 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
241
242# make symlink for libblas.so.3 (No need to use blas-devel)
243pushd ${RPM_BUILD_ROOT}%{_libdir}/R/lib
244%{__ln_s} %{_libdir}/libblas.so.3 libblas.so
245popd
246
247# Add folders for R_LIBS_SITE
248%{__mkdir_p} ${RPM_BUILD_ROOT}%{_libdir}/R/site-library
249
250# install Rprofile.site
251%{__install} %{SOURCE1} ${RPM_BUILD_ROOT}%{_libdir}/R/etc
252
253
254%check
255%{__make} check
256
257%clean
258%{__rm} -rf ${RPM_BUILD_ROOT}
259
260
261%post
262%{_syssbindir}/ldconfig
263%{__mkdir_p} %{_prefix}/local/lib/R/site-library
264
265%preun
266if [ "$1" = "0" ]
267then
268    %{__rm} -f %{_libdir}/R/lib/libblas*.so.*
269    %{__rm} -f %{_libdir}/R/lib/libopenblas*.so.*
270fi
271
272%postun -p %{_syssbindir}/ldconfig
273
274%post -n libRmath -p %{_syssbindir}/ldconfig
275
276%postun -n libRmath -p %{_syssbindir}/ldconfig
277
278
279%files
280%defattr(-, root, root)
281%{_bindir}/R
282%{_bindir}/Rscript
283%{_libdir}/R
284%{_datadir}/applications/*
285%{_datadir}/icons/*
286%{_mandir}/man1/*
287%{_docdir}/%{name}-%{version}
288%{_sysconfdir}/ld.so.conf.d/*
289
290%files -n libRmath
291%defattr(-, root, root)
292%{_libdir}/libRmath.so
293
294%files -n libRmath-devel
295%defattr(-, root, root)
296%{_libdir}/pkgconfig/*.pc
297%{_includedir}/Rmath.h
298
299%files -n libRmath-static
300%defattr(-, root, root)
301%{_libdir}/libRmath.a
302
303
304%changelog
305* Sat Jul 06 2019 Toshiaki Ara <ara_t@384.jp> 3.6.1-1
306- update to 3.6.1
307
308* Thu May 09 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-2
309- drop "-fno-schedule-insns2" option for clang/clang++ in VineSeed (x86_64)
310
311* Fri Apr 26 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-1
312- update to 3.6.0
313- build using clang/clang++ for VineSeed (x86_64)
314- change install path for external library
315- add PATHS to Renviron for R_LIBS_SITE
316- set default CRAN mirror
317
318* Mon Mar 11 2019 Toshiaki Ara <ara_t@384.jp> 3.5.3-1
319- update to 3.5.3
320
321* Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
322- rebuild with gfortran-8.2.0
323
324* Thu Dec 20 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-1
325- update to 3.5.2
326
327* Mon Jul 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.1-1
328- update to 3.5.1
329
330* Fri Jun 29 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-2
331- add Requires: openblas-Rblas
332- change using system blas
333
334* Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
335- update to 3.5.0
336- drop Patch 1 and 2
337
338* Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
339- updated to 3.4.4
340- add Obsoletes: tcl85 tk85 R-pcre for VineSeed
341
342* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
343- rebuild under icu-60.2
344
345* Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
346- Updated to 3.4.3
347
348* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
349- Updated to 3.4.2
350- change download URL
351
352* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
353- left %%{_libdir}/R/doc
354
355* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
356- Updated to 3.4.1
357- rebuild under R-pcre (pcre-8.39) for Vine6
358- add Requires: gcc-gfortran
359- change to BuildRequires: texlive-collection-plaingeneric
360- delete unnecessary descriptions
361
362* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
363- Updated to 3.4.0
364- add Patch1 and Patch2 to avoid 'make check' error
365- add export TZ="Asia/Tokyo" to avoid 'make check' error
366- delete descrption about info
367
368* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
369- Updated to 3.3.3
370
371* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
372- use tcl-8.5/tk-8.5 for Vine6.5
373  - BuildRequires to tcl85-devel/tk85-devel
374  - Requires to tcl85/tk85
375
376* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
377- merge SPEC file for Vine6
378- drop devel package
379- move PDF manuals to /usr/share/doc/R-%%{version}
380- revert logo of menu item to logo.jpg
381
382* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
383- Updated to 3.3.2
384
385* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
386- Updated to 3.3.1
387- delete BuildRequires: texlive-collection-lang*
388
389* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
390- add BuildRequires: texlive-collection-lang*
391
392* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
393- Updated to 3.3.0
394- add BuildRequires: pcre-devel xz-devel
395- change logo of menu item to Rlogo.svg
396
397* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
398- correct SPEC file
399
400* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
401- Updated to 3.2.4-revised
402
403* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
404- Updated to 3.2.4
405- fixed build error in src/extra/xz
406
407* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
408- add BuildRequires: curl-devel
409- add BuildRequires: libgomp
410
411* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
412- Updated to 3.2.3
413
414* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
415- rebuild with icu-56.1
416
417* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
418- Updated to 3.2.2
419
420* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
421- add configure options: --with-tcltk
422- add BuildRequires: tcl-devel tk-devel
423- add Requires: tcl tk
424
425* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
426- Updated to 3.2.1
427
428* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
429- add "LIBS=-lbz2" to configure option
430
431* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
432- Updated to 3.2.0
433
434* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
435- Updated to 3.1.3
436- added BuildRequires: texlive-collection-fontsextra for Vine6
437- changed option "make check-all" to "make check"
438-   to avoid error in checking of mgcv package
439- changed orders of BuildRequires
440
441* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
442- rebuild with icu-54.1
443
444* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
445- Updated to 3.1.2
446
447* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
448- Updated to 3.1.1
449- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
450
451* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
452- add patch (2014-04-26)
453
454* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
455- Updated to 3.1.0
456
457* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
458- Updated to 3.0.3
459
460* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
461- rebuild current VineSeed
462- add patch (2014-01-06)
463
464* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
465- add Requires: libicu
466
467* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
468- combine spec files Vine6 and VineSeed
469- correct the days of the week in changelog
470
471* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
472- delete BuildRequires: texlive-collection-texinfo
473- add BuildRequires: texlive-collection-plainextra
474- add BuildRequires: texlive-collection-latexextra
475- add BuildRequires: texlive-collection-fontsrecommended
476-   for VineSeed
477
478* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
479- Updated to 3.0.2
480
481* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
482- Updated to 3.0.1
483- add BuildRequires: java-1.6.0-openjdk-devel
484
485* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
486- Updated to 3.0.0
487
488* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
489- Updated to 2.15.3
490- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
491- use BuildRequires ncurses-devel instead of libtermcap-devel
492
493* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
494- Updated to 2.15.2
495
496* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
497- changed group to Applications/Edutainment
498- added R to menu
499
500* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
501- Updated to 2.15.1
502
503* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
504- Updated to 2.15.0
505
506* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
507- Updated to 2.14.2
508
509* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
510- Updated to 2.14.1
511
512* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
513- Updated to 2.14.0
514- add BuildRequires: texlive-collection-fontsextra
515
516* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
517- Updated to 2.13.2
518- add BuildRequires: texlive-common
519- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
520- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
521
522* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
523- synchronized to VinePlus/5 package
524  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
525  - Updated to 2.13.1
526  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
527  - Updated to 2.13.0
528  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
529  - Updated to 2.12.2
530
531* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
532- add BuildRequires: libicu-devel
533
534* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
535- synchronized to VinePlus/5 package
536  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
537  - Updated to 2.12.1
538- added --enable-R-shlib option to %%configure
539- added static subpackage
540- use BR: texlive instead of tetex on VineSeed
541
542* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
543- rebuilt with rpm-4.8.1 for pkg-config
544
545* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
546- recompiled because tcl/tk were not linked
547
548* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
549- Updated to 2.11.0
550- added Requires: libgfortran
551
552* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
553- Updated to 2.10.1
554
555* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
556- patched to 2.10.0
557
558* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
559- spec in UTF-8
560
561* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
562- Updated to 2.10.0
563
564* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
565- Updated to 2.9.2
566- deleted BuildRequires: lapack-devel blas-devel
567- rewrote SPEC file
568
569* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
570- Updated to 2.5.1
571- added BuildRequires: gcc-gfortran for VineSeed
572- added BuildRequires: lapack-devel blas-devel
573- fixed %preun script
574
575* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
576- Updated to 2.4.1
577- Added INFO option
578- Exclude Japanese Rprofile.site
579
580* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
581- Updated to 2.4.0
582
583* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
584- Added optimization flags
585
586* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
587- Packaged for VineLinux3.2
588
589* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
590- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
591
592* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
593- Packaged for VineLinux3.2
594- Slipped texinfo
595- Fixed preun error
596- Preset Japanese fonts
597
598* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
599- Packaged for VineLinux3.2
600
601* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
602- Restored CAPABILITIES file lost in 2.2.1beta
603
604* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
605- Configure uses --without-blas by default.
606- Install pdf manuals.
607- All toplevel documentation files are installed into _libdir/R
608  as they may be required by R (qv note on AUTHORS and THANKS below).
609- Legacy scripts for rebuilding package indices removed.
610
611* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
612- R now compiles with gcc 4.0.1 and default rpm optimization flags.
613
614* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
615- The files AUTHORS and THANKS need to be installed into _libdir/R
616  as they are required by the function contributors().  Previously
617  they were installed only as documentation files.
618
619* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
620- Corrected date error in SPEC file.
621
622* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
623- Dropped support for Red Hat boxed set.
624- Synchronized with Fedora Extras 4 RPM by Tom Calloway
625  including support for shared R library.
626- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
627  with the default optimization flags, so there is a temporary work-around.
628
629* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
630- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
631
632* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
633- Install R-data.info file as well.
634- Make info processing conditional on texinfo version, not platform release,
635  so that if a new enough version is installed, we will build and install info.
636
637* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
638- Built R 2.1.0.  R now supports internationalization, so the patch
639  to set the locale to "C" is now dropped.
640- install.packages() exits gracefully with a helpful message if
641  the file INSTALL is not present, so this is now included in the
642  R-devel package.
643
644* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
645- Added support for Scientific Linux (http://www.scientificlinux.org)
646  A distribution based on RHEL. Thanks to Jon Peatfield.
647
648* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
649- Fixed file ownership in R-devel and libRmath packages
650
651* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
652- R-devel package is now a stub package with no files, except a documentation
653  file (RPM won't accept sub-packages with no files). R now conflicts
654  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
655- Created libRmath subpackage with shared library.
656
657* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
658- Created R-devel and libRmath-devel subpackages
659
660* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
661- Built R 2.0.1
662
663* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
664- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
665  gives "lpr".
666- Define macro fcx for all Fedora distributions. This replaces Rinfo
667
668* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
669- Info support is now conditional on the macro Rinfo, which is only
670  defined for Fedora 1 and 2.
671
672* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
673- Built R 2.0.0
674- There is no longer a BUGS file, so this is not installed as a
675  documentation file.
Note: See TracBrowser for help on using the repository browser.