source: projects/specs/trunk/R/R/R-vl.spec @ 12063

Revision 12063, 20.5 KB checked in by ara_t, 5 years ago (diff)

R: drop '-fno-schedule-insns2' option for VineSeed (x86_64)

Line 
1%define pkg_name    R
2%define pkg_version 3.6.0
3%define pkg_release 2%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16Source1:     Rprofile.site
17# Patch0:      R-release.diff.gz
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20%if %{?_dist_release} >= "vl7"
21%ifarch x86_64
22BuildRequires: clang
23%endif
24%endif
25BuildRequires: gcc-gfortran libgfortran
26BuildRequires: texinfo
27
28%if %{?_dist_release} == "vl6"
29BuildRequires: R-pcre-devel
30BuildRequires: tcl85-devel tk85-devel
31%endif
32%if %{?_dist_release} >= "vl7"
33BuildRequires: pcre2-devel
34BuildRequires: tcl-devel tk-devel
35%endif
36BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
37BuildRequires: readline-devel ncurses-devel
38BuildRequires: zlib-devel bzip2-devel xz-devel
39BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
40BuildRequires: cairo-devel pango-devel
41BuildRequires: libicu-devel
42BuildRequires: curl-devel
43BuildRequires: blas-devel
44
45BuildRequires: texlive-common
46BuildRequires: texlive-collection-basic
47BuildRequires: texlive-collection-latexextra
48BuildRequires: texlive-collection-fontsextra
49%if %{?_dist_release} == "vl6"
50BuildRequires: texlive-collection-texinfo
51%endif
52%if %{?_dist_release} >= "vl7"
53BuildRequires: texlive-collection-plaingeneric
54BuildRequires: texlive-collection-fontsrecommended
55%endif
56BuildRequires: java-devel
57
58%if %{?_dist_release} >= "vl7"
59%ifarch x86_64
60Requires: clang
61%endif
62%endif
63Requires: gcc-gfortran
64Requires: libgfortran
65Requires: libicu
66%if %{?_dist_release} == "vl6"
67Requires: tcl85 tk85
68Requires: R-pcre
69%endif
70%if %{?_dist_release} >= "vl7"
71Requires: tcl tk
72Requires: pcre2
73Obsoletes: tcl85 tk85
74Obsoletes: R-pcre
75%endif
76
77Requires: blas
78Requires: openblas-Rblas
79
80Obsoletes: R-devel < %{version}-%{release}
81
82Vendor: Project Vine
83Distribution: Vine Linux
84Packager: ara_t
85
86
87%description
88'GNU S' - A language and environment for statistical computing and
89graphics. R is similar to the award-winning S system, which was
90developed at Bell Laboratories by John Chambers et al. It provides
91a wide variety of statistical and graphical techniques (linear and
92nonlinear modelling, statistical tests, time series analysis,
93classification, clustering, ...).
94
95R is designed as a true computer language with control-flow
96constructions for iteration and alternation, and it allows users to
97add additional functionality by defining new functions.
98For computationally intensive tasks, C, C++ and Fortran code
99can be linked and called at run time.
100
101%description -l ja
102'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
103Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
104線形・非線型モデル、統計検定、時系列分析、クラスター分析など
105幅広い統計解析・視覚化手法を提供する。
106Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
107として設計されており、ユーザが新たに関数を組み込むことが可能である。
108また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
109使用することができる。
110
111%package -n libRmath
112Summary:     standalone math library from the R project
113Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
114Group:       System Environment/Libraries
115
116%description -n libRmath
117A standalone library of mathematical and statistical functions derived
118from the R project.  This packages provides the shared libRmath library.
119
120%description -l ja -n libRmath
121単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
122共有ライブラリを提供する。
123
124%package -n libRmath-devel
125Summary:     standalone math library from the R project
126Summary(ja): libRmathの開発ライブラリ
127Group:       Development/Libraries
128Requires:    libRmath = %{version}-%{release}
129
130%description -n libRmath-devel
131A standalone library of mathematical and statistical functions derived
132from the R project.  This packages provides the header files.
133
134%description -l ja -n libRmath-devel
135libRmathのヘッダファイル(Rmath.h)
136
137%package -n libRmath-static
138Summary: Static R Standalone math library
139Summary(ja): libRmath の静的ライブラリ
140Group: Development/Libraries
141Requires: libRmath-devel = %{version}-%{release}
142
143%description -n libRmath-static
144A standalone library of mathematical and statistical functions derived
145from the R project.  This package provides the static libRmath library.
146
147
148%prep
149%{__rm} -rf ${RPM_BUILD_ROOT}
150%setup -q
151# %patch0 -p1
152
153cat > R.desktop <<EOF
154[Desktop Entry]
155Name=GNU R
156Comment=A language for data analysis and graphics
157TryExec=/usr/bin/R
158Exec=/usr/bin/R
159Icon=/usr/share/icons/logo.jpg
160Terminal=true
161Type=Application
162Categories=Education;Science;
163StartupNotify=false
164EOF
165
166%build
167export R_PDFVIEWER="%{_bindir}/xdg-open"
168export R_PRINTCMD="lpr"
169export R_BROWSER="%{_bindir}/xdg-open"
170%if %{?_dist_release} == "vl6"
171export LD_LIBRARY_PATH=%{_libdir}/R/lib
172%endif
173
174%if %{?_dist_release} >= "vl7"
175%ifarch x86_64
176export CFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
177export CXXFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
178%endif
179%endif
180
181# Add PATHS to Renviron for R_LIBS_SITE
182echo 'R_LIBS_SITE=${R_LIBS_SITE-'"'/usr/local/lib/R/site-library:%{_libdir}/R/site-library:%{_libdir}/R/library'"'}' \
183  >> etc/Renviron.in
184
185%{configure} --enable-R-shlib --with-tcltk \
186 --with-blas="-lblas" \
187%if %{?_dist_release} >= "vl7"
188%ifarch x86_64
189 CC=clang CXX=clang++ \
190%endif
191%endif
192%if %{?_dist_release} == "vl6"
193 --with-tcl-config=%{_libdir}/tclConfig85.sh \
194 --with-tk-config=%{_libdir}/tkConfig85.sh \
195 CPPFLAGS="-I%{_libdir}/R/include" \
196 LDFLAGS="-L%{_libdir}/R/lib"
197%endif
198
199%{__make} %{?_smp_mflags}
200pushd src/nmath/standalone
201%{__make} %{?_smp_mflags}
202popd
203%{__make} pdf
204
205%install
206%{make_install}
207%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
208%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
209%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
210
211# Remove libRblas.so
212%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/R/lib/libRblas.so
213
214# Install libRmath files
215pushd src/nmath/standalone
216%{make_install}
217popd
218
219%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
220echo "%{_libdir}/R/lib" > \
221     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
222
223# Fix lication of R_HOME_DIR in shell wrapper
224%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
225  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
226%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
227%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
228  > ${RPM_BUILD_ROOT}%{_bindir}/R
229%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
230
231# add R into menu
232%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
233%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
234%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
235%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
236
237# move manuals
238%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
239%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
240 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
241
242# make symlink for libblas.so.3 (No need to use blas-devel)
243pushd ${RPM_BUILD_ROOT}%{_libdir}/R/lib
244%{__ln_s} %{_libdir}/libblas.so.3 libblas.so
245popd
246
247# Add folders for R_LIBS_SITE
248%{__mkdir_p} ${RPM_BUILD_ROOT}%{_libdir}/R/site-library
249
250# install Rprofile.site
251%{__install} %{SOURCE1} ${RPM_BUILD_ROOT}%{_libdir}/R/etc
252
253
254%check
255%{__make} check
256
257%clean
258%{__rm} -rf ${RPM_BUILD_ROOT}
259
260
261%post
262%{_syssbindir}/ldconfig
263%{__mkdir_p} %{_prefix}/local/lib/R/site-library
264
265%preun
266if [ "$1" = "0" ]
267then
268    %{__rm} -f %{_libdir}/R/lib/libblas*.so.*
269    %{__rm} -f %{_libdir}/R/lib/libopenblas*.so.*
270fi
271
272%postun -p %{_syssbindir}/ldconfig
273
274%post -n libRmath -p %{_syssbindir}/ldconfig
275
276%postun -n libRmath -p %{_syssbindir}/ldconfig
277
278
279%files
280%defattr(-, root, root)
281%{_bindir}/R
282%{_bindir}/Rscript
283%{_libdir}/R
284%{_datadir}/applications/*
285%{_datadir}/icons/*
286%{_mandir}/man1/*
287%{_docdir}/%{name}-%{version}
288%{_sysconfdir}/ld.so.conf.d/*
289
290%files -n libRmath
291%defattr(-, root, root)
292%{_libdir}/libRmath.so
293
294%files -n libRmath-devel
295%defattr(-, root, root)
296%{_libdir}/pkgconfig/*.pc
297%{_includedir}/Rmath.h
298
299%files -n libRmath-static
300%defattr(-, root, root)
301%{_libdir}/libRmath.a
302
303
304%changelog
305* Thu May 09 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-2
306- drop "-fno-schedule-insns2" option for clang/clang++ in VineSeed (x86_64)
307
308* Fri Apr 26 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-1
309- update to 3.6.0
310- build using clang/clang++ for VineSeed (x86_64)
311- change install path for external library
312- add PATHS to Renviron for R_LIBS_SITE
313- set default CRAN mirror
314
315* Mon Mar 11 2019 Toshiaki Ara <ara_t@384.jp> 3.5.3-1
316- update to 3.5.3
317
318* Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
319- rebuild with gfortran-8.2.0
320
321* Thu Dec 20 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-1
322- update to 3.5.2
323
324* Mon Jul 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.1-1
325- update to 3.5.1
326
327* Fri Jun 29 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-2
328- add Requires: openblas-Rblas
329- change using system blas
330
331* Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
332- update to 3.5.0
333- drop Patch 1 and 2
334
335* Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
336- updated to 3.4.4
337- add Obsoletes: tcl85 tk85 R-pcre for VineSeed
338
339* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
340- rebuild under icu-60.2
341
342* Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
343- Updated to 3.4.3
344
345* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
346- Updated to 3.4.2
347- change download URL
348
349* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
350- left %%{_libdir}/R/doc
351
352* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
353- Updated to 3.4.1
354- rebuild under R-pcre (pcre-8.39) for Vine6
355- add Requires: gcc-gfortran
356- change to BuildRequires: texlive-collection-plaingeneric
357- delete unnecessary descriptions
358
359* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
360- Updated to 3.4.0
361- add Patch1 and Patch2 to avoid 'make check' error
362- add export TZ="Asia/Tokyo" to avoid 'make check' error
363- delete descrption about info
364
365* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
366- Updated to 3.3.3
367
368* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
369- use tcl-8.5/tk-8.5 for Vine6.5
370  - BuildRequires to tcl85-devel/tk85-devel
371  - Requires to tcl85/tk85
372
373* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
374- merge SPEC file for Vine6
375- drop devel package
376- move PDF manuals to /usr/share/doc/R-%%{version}
377- revert logo of menu item to logo.jpg
378
379* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
380- Updated to 3.3.2
381
382* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
383- Updated to 3.3.1
384- delete BuildRequires: texlive-collection-lang*
385
386* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
387- add BuildRequires: texlive-collection-lang*
388
389* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
390- Updated to 3.3.0
391- add BuildRequires: pcre-devel xz-devel
392- change logo of menu item to Rlogo.svg
393
394* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
395- correct SPEC file
396
397* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
398- Updated to 3.2.4-revised
399
400* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
401- Updated to 3.2.4
402- fixed build error in src/extra/xz
403
404* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
405- add BuildRequires: curl-devel
406- add BuildRequires: libgomp
407
408* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
409- Updated to 3.2.3
410
411* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
412- rebuild with icu-56.1
413
414* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
415- Updated to 3.2.2
416
417* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
418- add configure options: --with-tcltk
419- add BuildRequires: tcl-devel tk-devel
420- add Requires: tcl tk
421
422* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
423- Updated to 3.2.1
424
425* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
426- add "LIBS=-lbz2" to configure option
427
428* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
429- Updated to 3.2.0
430
431* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
432- Updated to 3.1.3
433- added BuildRequires: texlive-collection-fontsextra for Vine6
434- changed option "make check-all" to "make check"
435-   to avoid error in checking of mgcv package
436- changed orders of BuildRequires
437
438* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
439- rebuild with icu-54.1
440
441* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
442- Updated to 3.1.2
443
444* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
445- Updated to 3.1.1
446- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
447
448* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
449- add patch (2014-04-26)
450
451* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
452- Updated to 3.1.0
453
454* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
455- Updated to 3.0.3
456
457* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
458- rebuild current VineSeed
459- add patch (2014-01-06)
460
461* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
462- add Requires: libicu
463
464* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
465- combine spec files Vine6 and VineSeed
466- correct the days of the week in changelog
467
468* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
469- delete BuildRequires: texlive-collection-texinfo
470- add BuildRequires: texlive-collection-plainextra
471- add BuildRequires: texlive-collection-latexextra
472- add BuildRequires: texlive-collection-fontsrecommended
473-   for VineSeed
474
475* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
476- Updated to 3.0.2
477
478* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
479- Updated to 3.0.1
480- add BuildRequires: java-1.6.0-openjdk-devel
481
482* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
483- Updated to 3.0.0
484
485* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
486- Updated to 2.15.3
487- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
488- use BuildRequires ncurses-devel instead of libtermcap-devel
489
490* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
491- Updated to 2.15.2
492
493* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
494- changed group to Applications/Edutainment
495- added R to menu
496
497* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
498- Updated to 2.15.1
499
500* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
501- Updated to 2.15.0
502
503* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
504- Updated to 2.14.2
505
506* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
507- Updated to 2.14.1
508
509* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
510- Updated to 2.14.0
511- add BuildRequires: texlive-collection-fontsextra
512
513* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
514- Updated to 2.13.2
515- add BuildRequires: texlive-common
516- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
517- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
518
519* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
520- synchronized to VinePlus/5 package
521  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
522  - Updated to 2.13.1
523  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
524  - Updated to 2.13.0
525  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
526  - Updated to 2.12.2
527
528* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
529- add BuildRequires: libicu-devel
530
531* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
532- synchronized to VinePlus/5 package
533  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
534  - Updated to 2.12.1
535- added --enable-R-shlib option to %%configure
536- added static subpackage
537- use BR: texlive instead of tetex on VineSeed
538
539* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
540- rebuilt with rpm-4.8.1 for pkg-config
541
542* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
543- recompiled because tcl/tk were not linked
544
545* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
546- Updated to 2.11.0
547- added Requires: libgfortran
548
549* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
550- Updated to 2.10.1
551
552* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
553- patched to 2.10.0
554
555* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
556- spec in UTF-8
557
558* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
559- Updated to 2.10.0
560
561* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
562- Updated to 2.9.2
563- deleted BuildRequires: lapack-devel blas-devel
564- rewrote SPEC file
565
566* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
567- Updated to 2.5.1
568- added BuildRequires: gcc-gfortran for VineSeed
569- added BuildRequires: lapack-devel blas-devel
570- fixed %preun script
571
572* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
573- Updated to 2.4.1
574- Added INFO option
575- Exclude Japanese Rprofile.site
576
577* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
578- Updated to 2.4.0
579
580* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
581- Added optimization flags
582
583* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
584- Packaged for VineLinux3.2
585
586* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
587- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
588
589* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
590- Packaged for VineLinux3.2
591- Slipped texinfo
592- Fixed preun error
593- Preset Japanese fonts
594
595* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
596- Packaged for VineLinux3.2
597
598* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
599- Restored CAPABILITIES file lost in 2.2.1beta
600
601* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
602- Configure uses --without-blas by default.
603- Install pdf manuals.
604- All toplevel documentation files are installed into _libdir/R
605  as they may be required by R (qv note on AUTHORS and THANKS below).
606- Legacy scripts for rebuilding package indices removed.
607
608* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
609- R now compiles with gcc 4.0.1 and default rpm optimization flags.
610
611* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
612- The files AUTHORS and THANKS need to be installed into _libdir/R
613  as they are required by the function contributors().  Previously
614  they were installed only as documentation files.
615
616* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
617- Corrected date error in SPEC file.
618
619* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
620- Dropped support for Red Hat boxed set.
621- Synchronized with Fedora Extras 4 RPM by Tom Calloway
622  including support for shared R library.
623- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
624  with the default optimization flags, so there is a temporary work-around.
625
626* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
627- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
628
629* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
630- Install R-data.info file as well.
631- Make info processing conditional on texinfo version, not platform release,
632  so that if a new enough version is installed, we will build and install info.
633
634* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
635- Built R 2.1.0.  R now supports internationalization, so the patch
636  to set the locale to "C" is now dropped.
637- install.packages() exits gracefully with a helpful message if
638  the file INSTALL is not present, so this is now included in the
639  R-devel package.
640
641* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
642- Added support for Scientific Linux (http://www.scientificlinux.org)
643  A distribution based on RHEL. Thanks to Jon Peatfield.
644
645* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
646- Fixed file ownership in R-devel and libRmath packages
647
648* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
649- R-devel package is now a stub package with no files, except a documentation
650  file (RPM won't accept sub-packages with no files). R now conflicts
651  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
652- Created libRmath subpackage with shared library.
653
654* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
655- Created R-devel and libRmath-devel subpackages
656
657* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
658- Built R 2.0.1
659
660* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
661- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
662  gives "lpr".
663- Define macro fcx for all Fedora distributions. This replaces Rinfo
664
665* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
666- Info support is now conditional on the macro Rinfo, which is only
667  defined for Fedora 1 and 2.
668
669* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
670- Built R 2.0.0
671- There is no longer a BUGS file, so this is not installed as a
672  documentation file.
Note: See TracBrowser for help on using the repository browser.