source: projects/specs/trunk/R/R/R-vl.spec @ 11736

Revision 11736, 19.0 KB checked in by ara_t, 6 years ago (diff)

R: update to 3.5.1

Line 
1%define pkg_name    R
2%define pkg_version 3.5.1
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16# Patch0:      R-release.diff.gz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gcc-c++
20BuildRequires: gcc-gfortran libgfortran
21BuildRequires: texinfo
22
23%if %{?_dist_release} == "vl6"
24BuildRequires: R-pcre-devel
25BuildRequires: tcl85-devel tk85-devel
26%endif
27%if %{?_dist_release} >= "vl7"
28BuildRequires: pcre2-devel
29BuildRequires: tcl-devel tk-devel
30%endif
31BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
32BuildRequires: readline-devel ncurses-devel
33BuildRequires: zlib-devel bzip2-devel xz-devel
34BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
35BuildRequires: cairo-devel pango-devel
36BuildRequires: libicu-devel
37BuildRequires: curl-devel
38BuildRequires: blas-devel
39
40BuildRequires: texlive-common
41BuildRequires: texlive-collection-basic
42BuildRequires: texlive-collection-latexextra
43BuildRequires: texlive-collection-fontsextra
44%if %{?_dist_release} == "vl6"
45BuildRequires: texlive-collection-texinfo
46%endif
47%if %{?_dist_release} >= "vl7"
48BuildRequires: texlive-collection-plaingeneric
49BuildRequires: texlive-collection-fontsrecommended
50%endif
51BuildRequires: java-devel
52
53Requires: gcc-gfortran
54Requires: libgfortran
55Requires: libicu
56%if %{?_dist_release} == "vl6"
57Requires: tcl85 tk85
58Requires: R-pcre
59%endif
60%if %{?_dist_release} >= "vl7"
61Requires: tcl tk
62Requires: pcre2
63Obsoletes: tcl85 tk85
64Obsoletes: R-pcre
65%endif
66
67Requires: blas
68Requires: openblas-Rblas
69
70Obsoletes: R-devel < %{version}-%{release}
71
72Vendor: Project Vine
73Distribution: Vine Linux
74Packager: ara_t
75
76
77%description
78'GNU S' - A language and environment for statistical computing and
79graphics. R is similar to the award-winning S system, which was
80developed at Bell Laboratories by John Chambers et al. It provides
81a wide variety of statistical and graphical techniques (linear and
82nonlinear modelling, statistical tests, time series analysis,
83classification, clustering, ...).
84
85R is designed as a true computer language with control-flow
86constructions for iteration and alternation, and it allows users to
87add additional functionality by defining new functions.
88For computationally intensive tasks, C, C++ and Fortran code
89can be linked and called at run time.
90
91%description -l ja
92'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
93Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
94線形・非線型モデル、統計検定、時系列分析、クラスター分析など
95幅広い統計解析・視覚化手法を提供する。
96Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
97として設計されており、ユーザが新たに関数を組み込むことが可能である。
98また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
99使用することができる。
100
101%package -n libRmath
102Summary:     standalone math library from the R project
103Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
104Group:       System Environment/Libraries
105
106%description -n libRmath
107A standalone library of mathematical and statistical functions derived
108from the R project.  This packages provides the shared libRmath library.
109
110%description -l ja -n libRmath
111単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
112共有ライブラリを提供する。
113
114%package -n libRmath-devel
115Summary:     standalone math library from the R project
116Summary(ja): libRmathの開発ライブラリ
117Group:       Development/Libraries
118Requires:    libRmath = %{version}-%{release}
119
120%description -n libRmath-devel
121A standalone library of mathematical and statistical functions derived
122from the R project.  This packages provides the header files.
123
124%description -l ja -n libRmath-devel
125libRmathのヘッダファイル(Rmath.h)
126
127%package -n libRmath-static
128Summary: Static R Standalone math library
129Summary(ja): libRmath の静的ライブラリ
130Group: Development/Libraries
131Requires: libRmath-devel = %{version}-%{release}
132
133%description -n libRmath-static
134A standalone library of mathematical and statistical functions derived
135from the R project.  This package provides the static libRmath library.
136
137
138%prep
139%{__rm} -rf ${RPM_BUILD_ROOT}
140%setup -q
141# %patch0 -p1
142
143cat > R.desktop <<EOF
144[Desktop Entry]
145Name=GNU R
146Comment=A language for data analysis and graphics
147TryExec=/usr/bin/R
148Exec=/usr/bin/R
149Icon=/usr/share/icons/logo.jpg
150Terminal=true
151Type=Application
152Categories=Education;Science;
153StartupNotify=false
154EOF
155
156%build
157export R_PDFVIEWER="%{_bindir}/xdg-open"
158export R_PRINTCMD="lpr"
159export R_BROWSER="%{_bindir}/xdg-open"
160%if %{?_dist_release} == "vl6"
161export LD_LIBRARY_PATH=%{_libdir}/R/lib
162%endif
163
164%{configure} --enable-R-shlib --with-tcltk \
165 --with-blas="-lblas" \
166%if %{?_dist_release} == "vl6"
167 --with-tcl-config=%{_libdir}/tclConfig85.sh \
168 --with-tk-config=%{_libdir}/tkConfig85.sh \
169 CPPFLAGS="-I%{_libdir}/R/include" \
170 LDFLAGS="-L%{_libdir}/R/lib"
171%endif
172
173%{__make} %{?_smp_mflags}
174pushd src/nmath/standalone
175%{__make} %{?_smp_mflags}
176popd
177%{__make} pdf
178
179%install
180%{make_install}
181%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
182%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
183%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
184
185# Install libRmath files
186pushd src/nmath/standalone
187%{make_install}
188popd
189
190%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
191echo "%{_libdir}/R/lib" > \
192     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
193
194# Fix lication of R_HOME_DIR in shell wrapper
195%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
196  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
197%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
198%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
199  > ${RPM_BUILD_ROOT}%{_bindir}/R
200%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
201
202# add R into menu
203%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
204%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
205%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
206%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
207
208# move manuals
209%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
210%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
211 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
212
213# make symlink for libblas.so.3 (No need to use blas-devel)
214pushd ${RPM_BUILD_ROOT}%{_libdir}/R/lib
215%{__ln_s} %{_libdir}/libblas.so.3 libblas.so
216popd
217
218
219%check
220%{__make} check
221
222%clean
223%{__rm} -rf ${RPM_BUILD_ROOT}
224
225
226%post -p %{_syssbindir}/ldconfig
227
228%preun
229if [ "$1" = "0" ]
230then
231    %{__rm} -f %{_libdir}/R/lib/libblas*.so.*
232    %{__rm} -f %{_libdir}/R/lib/libopenblas*.so.*
233fi
234
235%postun -p %{_syssbindir}/ldconfig
236
237%post -n libRmath -p %{_syssbindir}/ldconfig
238
239%postun -n libRmath -p %{_syssbindir}/ldconfig
240
241
242%files
243%defattr(-, root, root)
244%{_bindir}/R
245%{_bindir}/Rscript
246%{_libdir}/R
247%{_datadir}/applications/*
248%{_datadir}/icons/*
249%{_mandir}/man1/*
250%{_docdir}/%{name}-%{version}
251%{_sysconfdir}/ld.so.conf.d/*
252
253%files -n libRmath
254%defattr(-, root, root)
255%{_libdir}/libRmath.so
256
257%files -n libRmath-devel
258%defattr(-, root, root)
259%{_libdir}/pkgconfig/*.pc
260%{_includedir}/Rmath.h
261
262%files -n libRmath-static
263%defattr(-, root, root)
264%{_libdir}/libRmath.a
265
266
267%changelog
268* Mon Jul 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.1-1
269- update to 3.5.1
270
271* Fri Jun 29 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-2
272- add Requires: openblas-Rblas
273- change using system blas
274
275* Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
276- update to 3.5.0
277- drop Patch 1 and 2
278
279* Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
280- updated to 3.4.4
281- add Obsoletes: tcl85 tk85 R-pcre for VineSeed
282
283* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
284- rebuild under icu-60.2
285
286* Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
287- Updated to 3.4.3
288
289* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
290- Updated to 3.4.2
291- change download URL
292
293* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
294- left %%{_libdir}/R/doc
295
296* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
297- Updated to 3.4.1
298- rebuild under R-pcre (pcre-8.39) for Vine6
299- add Requires: gcc-gfortran
300- change to BuildRequires: texlive-collection-plaingeneric
301- delete unnecessary descriptions
302
303* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
304- Updated to 3.4.0
305- add Patch1 and Patch2 to avoid 'make check' error
306- add export TZ="Asia/Tokyo" to avoid 'make check' error
307- delete descrption about info
308
309* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
310- Updated to 3.3.3
311
312* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
313- use tcl-8.5/tk-8.5 for Vine6.5
314  - BuildRequires to tcl85-devel/tk85-devel
315  - Requires to tcl85/tk85
316
317* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
318- merge SPEC file for Vine6
319- drop devel package
320- move PDF manuals to /usr/share/doc/R-%%{version}
321- revert logo of menu item to logo.jpg
322
323* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
324- Updated to 3.3.2
325
326* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
327- Updated to 3.3.1
328- delete BuildRequires: texlive-collection-lang*
329
330* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
331- add BuildRequires: texlive-collection-lang*
332
333* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
334- Updated to 3.3.0
335- add BuildRequires: pcre-devel xz-devel
336- change logo of menu item to Rlogo.svg
337
338* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
339- correct SPEC file
340
341* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
342- Updated to 3.2.4-revised
343
344* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
345- Updated to 3.2.4
346- fixed build error in src/extra/xz
347
348* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
349- add BuildRequires: curl-devel
350- add BuildRequires: libgomp
351
352* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
353- Updated to 3.2.3
354
355* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
356- rebuild with icu-56.1
357
358* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
359- Updated to 3.2.2
360
361* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
362- add configure options: --with-tcltk
363- add BuildRequires: tcl-devel tk-devel
364- add Requires: tcl tk
365
366* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
367- Updated to 3.2.1
368
369* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
370- add "LIBS=-lbz2" to configure option
371
372* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
373- Updated to 3.2.0
374
375* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
376- Updated to 3.1.3
377- added BuildRequires: texlive-collection-fontsextra for Vine6
378- changed option "make check-all" to "make check"
379-   to avoid error in checking of mgcv package
380- changed orders of BuildRequires
381
382* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
383- rebuild with icu-54.1
384
385* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
386- Updated to 3.1.2
387
388* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
389- Updated to 3.1.1
390- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
391
392* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
393- add patch (2014-04-26)
394
395* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
396- Updated to 3.1.0
397
398* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
399- Updated to 3.0.3
400
401* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
402- rebuild current VineSeed
403- add patch (2014-01-06)
404
405* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
406- add Requires: libicu
407
408* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
409- combine spec files Vine6 and VineSeed
410- correct the days of the week in changelog
411
412* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
413- delete BuildRequires: texlive-collection-texinfo
414- add BuildRequires: texlive-collection-plainextra
415- add BuildRequires: texlive-collection-latexextra
416- add BuildRequires: texlive-collection-fontsrecommended
417-   for VineSeed
418
419* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
420- Updated to 3.0.2
421
422* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
423- Updated to 3.0.1
424- add BuildRequires: java-1.6.0-openjdk-devel
425
426* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
427- Updated to 3.0.0
428
429* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
430- Updated to 2.15.3
431- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
432- use BuildRequires ncurses-devel instead of libtermcap-devel
433
434* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
435- Updated to 2.15.2
436
437* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
438- changed group to Applications/Edutainment
439- added R to menu
440
441* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
442- Updated to 2.15.1
443
444* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
445- Updated to 2.15.0
446
447* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
448- Updated to 2.14.2
449
450* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
451- Updated to 2.14.1
452
453* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
454- Updated to 2.14.0
455- add BuildRequires: texlive-collection-fontsextra
456
457* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
458- Updated to 2.13.2
459- add BuildRequires: texlive-common
460- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
461- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
462
463* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
464- synchronized to VinePlus/5 package
465  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
466  - Updated to 2.13.1
467  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
468  - Updated to 2.13.0
469  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
470  - Updated to 2.12.2
471
472* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
473- add BuildRequires: libicu-devel
474
475* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
476- synchronized to VinePlus/5 package
477  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
478  - Updated to 2.12.1
479- added --enable-R-shlib option to %%configure
480- added static subpackage
481- use BR: texlive instead of tetex on VineSeed
482
483* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
484- rebuilt with rpm-4.8.1 for pkg-config
485
486* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
487- recompiled because tcl/tk were not linked
488
489* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
490- Updated to 2.11.0
491- added Requires: libgfortran
492
493* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
494- Updated to 2.10.1
495
496* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
497- patched to 2.10.0
498
499* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
500- spec in UTF-8
501
502* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
503- Updated to 2.10.0
504
505* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
506- Updated to 2.9.2
507- deleted BuildRequires: lapack-devel blas-devel
508- rewrote SPEC file
509
510* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
511- Updated to 2.5.1
512- added BuildRequires: gcc-gfortran for VineSeed
513- added BuildRequires: lapack-devel blas-devel
514- fixed %preun script
515
516* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
517- Updated to 2.4.1
518- Added INFO option
519- Exclude Japanese Rprofile.site
520
521* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
522- Updated to 2.4.0
523
524* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
525- Added optimization flags
526
527* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
528- Packaged for VineLinux3.2
529
530* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
531- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
532
533* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
534- Packaged for VineLinux3.2
535- Slipped texinfo
536- Fixed preun error
537- Preset Japanese fonts
538
539* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
540- Packaged for VineLinux3.2
541
542* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
543- Restored CAPABILITIES file lost in 2.2.1beta
544
545* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
546- Configure uses --without-blas by default.
547- Install pdf manuals.
548- All toplevel documentation files are installed into _libdir/R
549  as they may be required by R (qv note on AUTHORS and THANKS below).
550- Legacy scripts for rebuilding package indices removed.
551
552* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
553- R now compiles with gcc 4.0.1 and default rpm optimization flags.
554
555* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
556- The files AUTHORS and THANKS need to be installed into _libdir/R
557  as they are required by the function contributors().  Previously
558  they were installed only as documentation files.
559
560* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
561- Corrected date error in SPEC file.
562
563* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
564- Dropped support for Red Hat boxed set.
565- Synchronized with Fedora Extras 4 RPM by Tom Calloway
566  including support for shared R library.
567- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
568  with the default optimization flags, so there is a temporary work-around.
569
570* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
571- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
572
573* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
574- Install R-data.info file as well.
575- Make info processing conditional on texinfo version, not platform release,
576  so that if a new enough version is installed, we will build and install info.
577
578* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
579- Built R 2.1.0.  R now supports internationalization, so the patch
580  to set the locale to "C" is now dropped.
581- install.packages() exits gracefully with a helpful message if
582  the file INSTALL is not present, so this is now included in the
583  R-devel package.
584
585* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
586- Added support for Scientific Linux (http://www.scientificlinux.org)
587  A distribution based on RHEL. Thanks to Jon Peatfield.
588
589* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
590- Fixed file ownership in R-devel and libRmath packages
591
592* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
593- R-devel package is now a stub package with no files, except a documentation
594  file (RPM won't accept sub-packages with no files). R now conflicts
595  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
596- Created libRmath subpackage with shared library.
597
598* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
599- Created R-devel and libRmath-devel subpackages
600
601* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
602- Built R 2.0.1
603
604* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
605- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
606  gives "lpr".
607- Define macro fcx for all Fedora distributions. This replaces Rinfo
608
609* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
610- Info support is now conditional on the macro Rinfo, which is only
611  defined for Fedora 1 and 2.
612
613* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
614- Built R 2.0.0
615- There is no longer a BUGS file, so this is not installed as a
616  documentation file.
Note: See TracBrowser for help on using the repository browser.