source: projects/specs/trunk/R/R/R-vl.spec @ 11620

Revision 11620, 18.7 KB checked in by ara_t, 6 years ago (diff)

R: update to 3.5.0

Line 
1%define pkg_name    R
2%define pkg_version 3.5.0
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16# Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
17# Patch0:      R-release.diff.gz
18
19# To avoid 'make check error'
20# Patch1:      reg-tests-3.R.patch
21# Patch2:      reg-tests-3.Rout.save.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: gcc-c++
25BuildRequires: gcc-gfortran libgfortran
26BuildRequires: texinfo
27%if %{?_dist_release} == "vl6"
28BuildRequires: R-pcre-devel
29BuildRequires: tcl85-devel tk85-devel
30%endif
31%if %{?_dist_release} >= "vl7"
32BuildRequires: pcre-devel
33BuildRequires: tcl-devel tk-devel
34%endif
35BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
36BuildRequires: readline-devel ncurses-devel
37BuildRequires: zlib-devel bzip2-devel xz-devel
38BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
39BuildRequires: cairo-devel pango-devel
40BuildRequires: libicu-devel
41BuildRequires: curl-devel
42BuildRequires: texlive-common
43BuildRequires: texlive-collection-basic
44BuildRequires: texlive-collection-latexextra
45BuildRequires: texlive-collection-fontsextra
46%if %{?_dist_release} == "vl6"
47BuildRequires: texlive-collection-texinfo
48%endif
49%if %{?_dist_release} >= "vl7"
50BuildRequires: texlive-collection-plaingeneric
51BuildRequires: texlive-collection-fontsrecommended
52%endif
53BuildRequires: java-devel
54
55Requires: gcc-gfortran
56Requires: libgfortran
57Requires: libicu
58%if %{?_dist_release} == "vl6"
59Requires: tcl85 tk85
60Requires: R-pcre
61%endif
62%if %{?_dist_release} >= "vl7"
63Requires: tcl tk
64Obsoletes: tcl85 tk85
65Obsoletes: R-pcre
66%endif
67
68Obsoletes: R-devel < %{version}-%{release}
69
70Vendor: Project Vine
71Distribution: Vine Linux
72Packager: ara_t
73
74
75%description
76'GNU S' - A language and environment for statistical computing and
77graphics. R is similar to the award-winning S system, which was
78developed at Bell Laboratories by John Chambers et al. It provides
79a wide variety of statistical and graphical techniques (linear and
80nonlinear modelling, statistical tests, time series analysis,
81classification, clustering, ...).
82
83R is designed as a true computer language with control-flow
84constructions for iteration and alternation, and it allows users to
85add additional functionality by defining new functions.
86For computationally intensive tasks, C, C++ and Fortran code
87can be linked and called at run time.
88
89%description -l ja
90'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
91Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
92線形・非線型モデル、統計検定、時系列分析、クラスター分析など
93幅広い統計解析・視覚化手法を提供する。
94Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
95として設計されており、ユーザが新たに関数を組み込むことが可能である。
96また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
97使用することができる。
98
99%package -n libRmath
100Summary:          standalone math library from the R project
101Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
102Group:            System Environment/Libraries
103
104%description -n libRmath
105A standalone library of mathematical and statistical functions derived
106from the R project.  This packages provides the shared libRmath library.
107
108%description -l ja -n libRmath
109単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
110共有ライブラリを提供する。
111
112%package -n libRmath-devel
113Summary:          standalone math library from the R project
114Summary(ja):      libRmathの開発ライブラリ
115Group:            Development/Libraries
116Requires:         libRmath = %{version}-%{release}
117
118%description -n libRmath-devel
119A standalone library of mathematical and statistical functions derived
120from the R project.  This packages provides the header files.
121
122%description -l ja -n libRmath-devel
123libRmathのヘッダファイル(Rmath.h)
124
125%package -n libRmath-static
126Summary: Static R Standalone math library
127Summary(ja): libRmath の静的ライブラリ
128Group: Development/Libraries
129Requires: libRmath-devel = %{version}-%{release}
130
131%description -n libRmath-static
132A standalone library of mathematical and statistical functions derived
133from the R project.  This package provides the static libRmath library.
134
135
136%prep
137%{__rm} -rf ${RPM_BUILD_ROOT}
138%setup -q
139# %patch0 -p1
140# %patch1
141# %patch2
142
143cat > R.desktop <<EOF
144[Desktop Entry]
145Name=GNU R
146Comment=A language for data analysis and graphics
147TryExec=/usr/bin/R
148Exec=/usr/bin/R
149Icon=/usr/share/icons/logo.jpg
150Terminal=true
151Type=Application
152Categories=Education;Science;
153StartupNotify=false
154EOF
155
156%build
157export R_PDFVIEWER="%{_bindir}/xdg-open"
158export R_PRINTCMD="lpr"
159export R_BROWSER="%{_bindir}/xdg-open"
160%if %{?_dist_release} == "vl6"
161export LD_LIBRARY_PATH=%{_libdir}/R/lib
162%endif
163
164%{configure} --enable-R-shlib --with-tcltk \
165%if %{?_dist_release} == "vl6"
166 --with-tcl-config=%{_libdir}/tclConfig85.sh \
167 --with-tk-config=%{_libdir}/tkConfig85.sh \
168 CPPFLAGS="-I%{_libdir}/R/include" \
169 LDFLAGS="-L%{_libdir}/R/lib"
170%endif
171
172%{__make} %{?_smp_mflags}
173(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
174%{__make} pdf
175
176%install
177%{make_install}
178%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
179%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
180%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
181
182# Install libRmath files
183(cd src/nmath/standalone; %{make_install})
184
185%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
186echo "%{_libdir}/R/lib" > \
187     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
188
189# Fix lication of R_HOME_DIR in shell wrapper
190%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
191  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
192%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
193%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
194  > ${RPM_BUILD_ROOT}%{_bindir}/R
195%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
196
197# add R into menu
198%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
199%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
200%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
201%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
202
203# move manuals
204%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
205%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
206 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
207
208%check
209export TZ="Asia/Tokyo"
210LANG=C %{__make} check
211
212%clean
213%{__rm} -rf ${RPM_BUILD_ROOT}
214
215
216%post -p %{_syssbindir}/ldconfig
217
218%postun -p %{_syssbindir}/ldconfig
219
220%post -n libRmath -p %{_syssbindir}/ldconfig
221
222%postun -n libRmath -p %{_syssbindir}/ldconfig
223
224
225%files
226%defattr(-, root, root)
227%{_bindir}/R
228%{_bindir}/Rscript
229%{_libdir}/R
230%{_datadir}/applications/*
231%{_datadir}/icons/*
232%{_mandir}/man1/*
233%{_docdir}/%{name}-%{version}
234%{_sysconfdir}/ld.so.conf.d/*
235
236%files -n libRmath
237%defattr(-, root, root)
238%{_libdir}/libRmath.so
239
240%files -n libRmath-devel
241%defattr(-, root, root)
242%{_libdir}/pkgconfig/*.pc
243%{_includedir}/Rmath.h
244
245%files -n libRmath-static
246%defattr(-, root, root)
247%{_libdir}/libRmath.a
248
249
250%changelog
251* Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
252- updated to 3.5.0
253- drop Patch 1 and 2
254
255* Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
256- updated to 3.4.4
257- add Obsoletes: tcl85 tk85 R-pcre for VineSeed
258
259* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
260- rebuild under icu-60.2
261
262* Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
263- Updated to 3.4.3
264
265* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
266- Updated to 3.4.2
267- change download URL
268
269* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
270- left %%{_libdir}/R/doc
271
272* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
273- Updated to 3.4.1
274- rebuild under R-pcre (pcre-8.39) for Vine6
275- add Requires: gcc-gfortran
276- change to BuildRequires: texlive-collection-plaingeneric
277- delete unnecessary descriptions
278
279* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
280- Updated to 3.4.0
281- add Patch1 and Patch2 to avoid 'make check' error
282- add export TZ="Asia/Tokyo" to avoid 'make check' error
283- delete descrption about info
284
285* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
286- Updated to 3.3.3
287
288* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
289- use tcl-8.5/tk-8.5 for Vine6.5
290  - BuildRequires to tcl85-devel/tk85-devel
291  - Requires to tcl85/tk85
292
293* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
294- merge SPEC file for Vine6
295- drop devel package
296- move PDF manuals to /usr/share/doc/R-%%{version}
297- revert logo of menu item to logo.jpg
298
299* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
300- Updated to 3.3.2
301
302* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
303- Updated to 3.3.1
304- delete BuildRequires: texlive-collection-lang*
305
306* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
307- add BuildRequires: texlive-collection-lang*
308
309* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
310- Updated to 3.3.0
311- add BuildRequires: pcre-devel xz-devel
312- change logo of menu item to Rlogo.svg
313
314* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
315- correct SPEC file
316
317* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
318- Updated to 3.2.4-revised
319
320* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
321- Updated to 3.2.4
322- fixed build error in src/extra/xz
323
324* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
325- add BuildRequires: curl-devel
326- add BuildRequires: libgomp
327
328* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
329- Updated to 3.2.3
330
331* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
332- rebuild with icu-56.1
333
334* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
335- Updated to 3.2.2
336
337* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
338- add configure options: --with-tcltk
339- add BuildRequires: tcl-devel tk-devel
340- add Requires: tcl tk
341
342* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
343- Updated to 3.2.1
344
345* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
346- add "LIBS=-lbz2" to configure option
347
348* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
349- Updated to 3.2.0
350
351* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
352- Updated to 3.1.3
353- added BuildRequires: texlive-collection-fontsextra for Vine6
354- changed option "make check-all" to "make check"
355-   to avoid error in checking of mgcv package
356- changed orders of BuildRequires
357
358* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
359- rebuild with icu-54.1
360
361* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
362- Updated to 3.1.2
363
364* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
365- Updated to 3.1.1
366- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
367
368* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
369- add patch (2014-04-26)
370
371* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
372- Updated to 3.1.0
373
374* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
375- Updated to 3.0.3
376
377* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
378- rebuild current VineSeed
379- add patch (2014-01-06)
380
381* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
382- add Requires: libicu
383
384* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
385- combine spec files Vine6 and VineSeed
386- correct the days of the week in changelog
387
388* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
389- delete BuildRequires: texlive-collection-texinfo
390- add BuildRequires: texlive-collection-plainextra
391- add BuildRequires: texlive-collection-latexextra
392- add BuildRequires: texlive-collection-fontsrecommended
393-   for VineSeed
394
395* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
396- Updated to 3.0.2
397
398* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
399- Updated to 3.0.1
400- add BuildRequires: java-1.6.0-openjdk-devel
401
402* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
403- Updated to 3.0.0
404
405* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
406- Updated to 2.15.3
407- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
408- use BuildRequires ncurses-devel instead of libtermcap-devel
409
410* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
411- Updated to 2.15.2
412
413* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
414- changed group to Applications/Edutainment
415- added R to menu
416
417* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
418- Updated to 2.15.1
419
420* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
421- Updated to 2.15.0
422
423* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
424- Updated to 2.14.2
425
426* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
427- Updated to 2.14.1
428
429* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
430- Updated to 2.14.0
431- add BuildRequires: texlive-collection-fontsextra
432
433* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
434- Updated to 2.13.2
435- add BuildRequires: texlive-common
436- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
437- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
438
439* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
440- synchronized to VinePlus/5 package
441  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
442  - Updated to 2.13.1
443  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
444  - Updated to 2.13.0
445  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
446  - Updated to 2.12.2
447
448* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
449- add BuildRequires: libicu-devel
450
451* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
452- synchronized to VinePlus/5 package
453  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
454  - Updated to 2.12.1
455- added --enable-R-shlib option to %%configure
456- added static subpackage
457- use BR: texlive instead of tetex on VineSeed
458
459* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
460- rebuilt with rpm-4.8.1 for pkg-config
461
462* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
463- recompiled because tcl/tk were not linked
464
465* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
466- Updated to 2.11.0
467- added Requires: libgfortran
468
469* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
470- Updated to 2.10.1
471
472* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
473- patched to 2.10.0
474
475* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
476- spec in UTF-8
477
478* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
479- Updated to 2.10.0
480
481* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
482- Updated to 2.9.2
483- deleted BuildRequires: lapack-devel blas-devel
484- rewrote SPEC file
485
486* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
487- Updated to 2.5.1
488- added BuildRequires: gcc-gfortran for VineSeed
489- added BuildRequires: lapack-devel blas-devel
490v- fixed %preun script
491
492* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
493- Updated to 2.4.1
494- Added INFO option
495- Exclude Japanese Rprofile.site
496
497* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
498- Updated to 2.4.0
499
500* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
501- Added optimization flags
502
503* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
504- Packaged for VineLinux3.2
505
506* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
507- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
508
509* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
510- Packaged for VineLinux3.2
511- Slipped texinfo
512- Fixed preun error
513- Preset Japanese fonts
514
515* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
516- Packaged for VineLinux3.2
517
518* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
519- Restored CAPABILITIES file lost in 2.2.1beta
520
521* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
522- Configure uses --without-blas by default.
523- Install pdf manuals.
524- All toplevel documentation files are installed into _libdir/R
525  as they may be required by R (qv note on AUTHORS and THANKS below).
526- Legacy scripts for rebuilding package indices removed.
527
528* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
529- R now compiles with gcc 4.0.1 and default rpm optimization flags.
530
531* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
532- The files AUTHORS and THANKS need to be installed into _libdir/R
533  as they are required by the function contributors().  Previously
534  they were installed only as documentation files.
535
536* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
537- Corrected date error in SPEC file.
538
539* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
540- Dropped support for Red Hat boxed set.
541- Synchronized with Fedora Extras 4 RPM by Tom Calloway
542  including support for shared R library.
543- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
544  with the default optimization flags, so there is a temporary work-around.
545
546* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
547- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
548
549* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
550- Install R-data.info file as well.
551- Make info processing conditional on texinfo version, not platform release,
552  so that if a new enough version is installed, we will build and install info.
553
554* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
555- Built R 2.1.0.  R now supports internationalization, so the patch
556  to set the locale to "C" is now dropped.
557- install.packages() exits gracefully with a helpful message if
558  the file INSTALL is not present, so this is now included in the
559  R-devel package.
560
561* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
562- Added support for Scientific Linux (http://www.scientificlinux.org)
563  A distribution based on RHEL. Thanks to Jon Peatfield.
564
565* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
566- Fixed file ownership in R-devel and libRmath packages
567
568* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
569- R-devel package is now a stub package with no files, except a documentation
570  file (RPM won't accept sub-packages with no files). R now conflicts
571  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
572- Created libRmath subpackage with shared library.
573
574* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
575- Created R-devel and libRmath-devel subpackages
576
577* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
578- Built R 2.0.1
579
580* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
581- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
582  gives "lpr".
583- Define macro fcx for all Fedora distributions. This replaces Rinfo
584
585* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
586- Info support is now conditional on the macro Rinfo, which is only
587  defined for Fedora 1 and 2.
588
589* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
590- Built R 2.0.0
591- There is no longer a BUGS file, so this is not installed as a
592  documentation file.
Note: See TracBrowser for help on using the repository browser.