source: projects/specs/trunk/R/R/R-vl.spec @ 11380

Revision 11380, 18.4 KB checked in by ara_t, 6 years ago (diff)

rebuild under icu-60.2

Line 
1%define pkg_name    R
2%define pkg_version 3.4.3
3%define pkg_release 2%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16# Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
17# Patch0:      R-release.diff.gz
18
19# To avoid 'make check error'
20Patch1:      reg-tests-3.R.patch
21Patch2:      reg-tests-3.Rout.save.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: gcc-c++
25BuildRequires: gcc-gfortran libgfortran
26BuildRequires: texinfo
27%if %{?_dist_release} == "vl6"
28BuildRequires: R-pcre-devel
29BuildRequires: tcl85-devel tk85-devel
30%endif
31%if %{?_dist_release} >= "vl7"
32BuildRequires: pcre-devel
33BuildRequires: tcl-devel tk-devel
34%endif
35BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
36BuildRequires: readline-devel ncurses-devel
37BuildRequires: zlib-devel bzip2-devel xz-devel
38BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
39BuildRequires: cairo-devel pango-devel
40BuildRequires: libicu-devel
41BuildRequires: curl-devel
42BuildRequires: texlive-common
43BuildRequires: texlive-collection-basic
44BuildRequires: texlive-collection-latexextra
45BuildRequires: texlive-collection-fontsextra
46%if %{?_dist_release} == "vl6"
47BuildRequires: texlive-collection-texinfo
48%endif
49%if %{?_dist_release} >= "vl7"
50BuildRequires: texlive-collection-plaingeneric
51BuildRequires: texlive-collection-fontsrecommended
52%endif
53BuildRequires: java-devel
54
55Requires: gcc-gfortran
56Requires: libgfortran
57Requires: libicu
58%if %{?_dist_release} == "vl6"
59Requires: tcl85 tk85
60Requires: R-pcre
61%endif
62%if %{?_dist_release} >= "vl7"
63Requires: tcl tk
64%endif
65
66Conflicts: R-devel < %{version}-%{release}
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: ara_t
71
72
73%description
74'GNU S' - A language and environment for statistical computing and
75graphics. R is similar to the award-winning S system, which was
76developed at Bell Laboratories by John Chambers et al. It provides
77a wide variety of statistical and graphical techniques (linear and
78nonlinear modelling, statistical tests, time series analysis,
79classification, clustering, ...).
80
81R is designed as a true computer language with control-flow
82constructions for iteration and alternation, and it allows users to
83add additional functionality by defining new functions.
84For computationally intensive tasks, C, C++ and Fortran code
85can be linked and called at run time.
86
87%description -l ja
88'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
89Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
90線形・非線型モデル、統計検定、時系列分析、クラスター分析など
91幅広い統計解析・視覚化手法を提供する。
92Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
93として設計されており、ユーザが新たに関数を組み込むことが可能である。
94また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
95使用することができる。
96
97%package -n libRmath
98Summary:          standalone math library from the R project
99Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
100Group:            System Environment/Libraries
101
102%description -n libRmath
103A standalone library of mathematical and statistical functions derived
104from the R project.  This packages provides the shared libRmath library.
105
106%description -l ja -n libRmath
107単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
108共有ライブラリを提供する。
109
110%package -n libRmath-devel
111Summary:          standalone math library from the R project
112Summary(ja):      libRmathの開発ライブラリ
113Group:            Development/Libraries
114Requires:         libRmath = %{version}-%{release}
115
116%description -n libRmath-devel
117A standalone library of mathematical and statistical functions derived
118from the R project.  This packages provides the header files.
119
120%description -l ja -n libRmath-devel
121libRmathのヘッダファイル(Rmath.h)
122
123%package -n libRmath-static
124Summary: Static R Standalone math library
125Summary(ja): libRmath の静的ライブラリ
126Group: Development/Libraries
127Requires: libRmath-devel = %{version}-%{release}
128
129%description -n libRmath-static
130A standalone library of mathematical and statistical functions derived
131from the R project.  This package provides the static libRmath library.
132
133
134%prep
135%{__rm} -rf ${RPM_BUILD_ROOT}
136%setup -q
137# %patch0 -p1
138%patch1
139%patch2
140
141cat > R.desktop <<EOF
142[Desktop Entry]
143Name=GNU R
144Comment=A language for data analysis and graphics
145TryExec=/usr/bin/R
146Exec=/usr/bin/R
147Icon=/usr/share/icons/logo.jpg
148Terminal=true
149Type=Application
150Categories=Education;Science;
151StartupNotify=false
152EOF
153
154%build
155export R_PDFVIEWER="%{_bindir}/xdg-open"
156export R_PRINTCMD="lpr"
157export R_BROWSER="%{_bindir}/xdg-open"
158%if %{?_dist_release} == "vl6"
159export LD_LIBRARY_PATH=%{_libdir}/R/lib
160%endif
161
162%{configure} --enable-R-shlib --with-tcltk \
163%if %{?_dist_release} == "vl6"
164 --with-tcl-config=%{_libdir}/tclConfig85.sh \
165 --with-tk-config=%{_libdir}/tkConfig85.sh \
166 CPPFLAGS="-I%{_libdir}/R/include" \
167 LDFLAGS="-L%{_libdir}/R/lib"
168%endif
169
170%{__make} %{?_smp_mflags}
171(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
172%{__make} pdf
173
174%install
175%{make_install}
176%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
177%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
178%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
179
180# Install libRmath files
181(cd src/nmath/standalone; %{make_install})
182
183%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
184echo "%{_libdir}/R/lib" > \
185     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
186
187# Fix lication of R_HOME_DIR in shell wrapper
188%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
189  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
190%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
191%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
192  > ${RPM_BUILD_ROOT}%{_bindir}/R
193%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
194
195# add R into menu
196%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
197%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
198%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
199%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
200
201# move manuals
202%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
203%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
204 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
205
206%check
207export TZ="Asia/Tokyo"
208LANG=C %{__make} check
209
210%clean
211%{__rm} -rf ${RPM_BUILD_ROOT}
212
213
214%post -p %{_syssbindir}/ldconfig
215
216%postun -p %{_syssbindir}/ldconfig
217
218%post -n libRmath -p %{_syssbindir}/ldconfig
219
220%postun -n libRmath -p %{_syssbindir}/ldconfig
221
222
223%files
224%defattr(-, root, root)
225%{_bindir}/R
226%{_bindir}/Rscript
227%{_libdir}/R
228%{_datadir}/applications/*
229%{_datadir}/icons/*
230%{_mandir}/man1/*
231%{_docdir}/%{name}-%{version}
232%{_sysconfdir}/ld.so.conf.d/*
233
234%files -n libRmath
235%defattr(-, root, root)
236%{_libdir}/libRmath.so
237
238%files -n libRmath-devel
239%defattr(-, root, root)
240%{_libdir}/pkgconfig/*.pc
241%{_includedir}/Rmath.h
242
243%files -n libRmath-static
244%defattr(-, root, root)
245%{_libdir}/libRmath.a
246
247
248%changelog
249* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
250- rebuild under icu-60.2
251
252* Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
253- Updated to 3.4.3
254
255* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
256- Updated to 3.4.2
257- change download URL
258
259* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
260- left %%{_libdir}/R/doc
261
262* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
263- Updated to 3.4.1
264- rebuild under R-pcre (pcre-8.39) for Vine6
265- add Requires: gcc-gfortran
266- change to BuildRequires: texlive-collection-plaingeneric
267- delete unnecessary descriptions
268
269* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
270- Updated to 3.4.0
271- add Patch1 and Patch2 to avoid 'make check' error
272- add export TZ="Asia/Tokyo" to avoid 'make check' error
273- delete descrption about info
274
275* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
276- Updated to 3.3.3
277
278* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
279- use tcl-8.5/tk-8.5 for Vine6.5
280  - BuildRequires to tcl85-devel/tk85-devel
281  - Requires to tcl85/tk85
282
283* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
284- merge SPEC file for Vine6
285- drop devel package
286- move PDF manuals to /usr/share/doc/R-%%{version}
287- revert logo of menu item to logo.jpg
288
289* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
290- Updated to 3.3.2
291
292* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
293- Updated to 3.3.1
294- delete BuildRequires: texlive-collection-lang*
295
296* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
297- add BuildRequires: texlive-collection-lang*
298
299* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
300- Updated to 3.3.0
301- add BuildRequires: pcre-devel xz-devel
302- change logo of menu item to Rlogo.svg
303
304* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
305- correct SPEC file
306
307* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
308- Updated to 3.2.4-revised
309
310* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
311- Updated to 3.2.4
312- fixed build error in src/extra/xz
313
314* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
315- add BuildRequires: curl-devel
316- add BuildRequires: libgomp
317
318* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
319- Updated to 3.2.3
320
321* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
322- rebuild with icu-56.1
323
324* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
325- Updated to 3.2.2
326
327* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
328- add configure options: --with-tcltk
329- add BuildRequires: tcl-devel tk-devel
330- add Requires: tcl tk
331
332* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
333- Updated to 3.2.1
334
335* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
336- add "LIBS=-lbz2" to configure option
337
338* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
339- Updated to 3.2.0
340
341* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
342- Updated to 3.1.3
343- added BuildRequires: texlive-collection-fontsextra for Vine6
344- changed option "make check-all" to "make check"
345-   to avoid error in checking of mgcv package
346- changed orders of BuildRequires
347
348* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
349- rebuild with icu-54.1
350
351* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
352- Updated to 3.1.2
353
354* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
355- Updated to 3.1.1
356- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
357
358* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
359- add patch (2014-04-26)
360
361* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
362- Updated to 3.1.0
363
364* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
365- Updated to 3.0.3
366
367* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
368- rebuild current VineSeed
369- add patch (2014-01-06)
370
371* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
372- add Requires: libicu
373
374* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
375- combine spec files Vine6 and VineSeed
376- correct the days of the week in changelog
377
378* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
379- delete BuildRequires: texlive-collection-texinfo
380- add BuildRequires: texlive-collection-plainextra
381- add BuildRequires: texlive-collection-latexextra
382- add BuildRequires: texlive-collection-fontsrecommended
383-   for VineSeed
384
385* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
386- Updated to 3.0.2
387
388* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
389- Updated to 3.0.1
390- add BuildRequires: java-1.6.0-openjdk-devel
391
392* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
393- Updated to 3.0.0
394
395* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
396- Updated to 2.15.3
397- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
398- use BuildRequires ncurses-devel instead of libtermcap-devel
399
400* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
401- Updated to 2.15.2
402
403* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
404- changed group to Applications/Edutainment
405- added R to menu
406
407* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
408- Updated to 2.15.1
409
410* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
411- Updated to 2.15.0
412
413* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
414- Updated to 2.14.2
415
416* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
417- Updated to 2.14.1
418
419* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
420- Updated to 2.14.0
421- add BuildRequires: texlive-collection-fontsextra
422
423* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
424- Updated to 2.13.2
425- add BuildRequires: texlive-common
426- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
427- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
428
429* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
430- synchronized to VinePlus/5 package
431  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
432  - Updated to 2.13.1
433  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
434  - Updated to 2.13.0
435  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
436  - Updated to 2.12.2
437
438* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
439- add BuildRequires: libicu-devel
440
441* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
442- synchronized to VinePlus/5 package
443  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
444  - Updated to 2.12.1
445- added --enable-R-shlib option to %%configure
446- added static subpackage
447- use BR: texlive instead of tetex on VineSeed
448
449* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
450- rebuilt with rpm-4.8.1 for pkg-config
451
452* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
453- recompiled because tcl/tk were not linked
454
455* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
456- Updated to 2.11.0
457- added Requires: libgfortran
458
459* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
460- Updated to 2.10.1
461
462* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
463- patched to 2.10.0
464
465* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
466- spec in UTF-8
467
468* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
469- Updated to 2.10.0
470
471* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
472- Updated to 2.9.2
473- deleted BuildRequires: lapack-devel blas-devel
474- rewrote SPEC file
475
476* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
477- Updated to 2.5.1
478- added BuildRequires: gcc-gfortran for VineSeed
479- added BuildRequires: lapack-devel blas-devel
480v- fixed %preun script
481
482* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
483- Updated to 2.4.1
484- Added INFO option
485- Exclude Japanese Rprofile.site
486
487* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
488- Updated to 2.4.0
489
490* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
491- Added optimization flags
492
493* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
494- Packaged for VineLinux3.2
495
496* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
497- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
498
499* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
500- Packaged for VineLinux3.2
501- Slipped texinfo
502- Fixed preun error
503- Preset Japanese fonts
504
505* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
506- Packaged for VineLinux3.2
507
508* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
509- Restored CAPABILITIES file lost in 2.2.1beta
510
511* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
512- Configure uses --without-blas by default.
513- Install pdf manuals.
514- All toplevel documentation files are installed into _libdir/R
515  as they may be required by R (qv note on AUTHORS and THANKS below).
516- Legacy scripts for rebuilding package indices removed.
517
518* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
519- R now compiles with gcc 4.0.1 and default rpm optimization flags.
520
521* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
522- The files AUTHORS and THANKS need to be installed into _libdir/R
523  as they are required by the function contributors().  Previously
524  they were installed only as documentation files.
525
526* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
527- Corrected date error in SPEC file.
528
529* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
530- Dropped support for Red Hat boxed set.
531- Synchronized with Fedora Extras 4 RPM by Tom Calloway
532  including support for shared R library.
533- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
534  with the default optimization flags, so there is a temporary work-around.
535
536* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
537- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
538
539* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
540- Install R-data.info file as well.
541- Make info processing conditional on texinfo version, not platform release,
542  so that if a new enough version is installed, we will build and install info.
543
544* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
545- Built R 2.1.0.  R now supports internationalization, so the patch
546  to set the locale to "C" is now dropped.
547- install.packages() exits gracefully with a helpful message if
548  the file INSTALL is not present, so this is now included in the
549  R-devel package.
550
551* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
552- Added support for Scientific Linux (http://www.scientificlinux.org)
553  A distribution based on RHEL. Thanks to Jon Peatfield.
554
555* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
556- Fixed file ownership in R-devel and libRmath packages
557
558* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
559- R-devel package is now a stub package with no files, except a documentation
560  file (RPM won't accept sub-packages with no files). R now conflicts
561  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
562- Created libRmath subpackage with shared library.
563
564* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
565- Created R-devel and libRmath-devel subpackages
566
567* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
568- Built R 2.0.1
569
570* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
571- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
572  gives "lpr".
573- Define macro fcx for all Fedora distributions. This replaces Rinfo
574
575* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
576- Info support is now conditional on the macro Rinfo, which is only
577  defined for Fedora 1 and 2.
578
579* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
580- Built R 2.0.0
581- There is no longer a BUGS file, so this is not installed as a
582  documentation file.
Note: See TracBrowser for help on using the repository browser.