source: projects/specs/trunk/R/R/R-vl.spec @ 11126

Revision 11126, 18.1 KB checked in by ara_t, 7 years ago (diff)

R-3.4.1-2vl

Line 
1%define pkg_name    R
2%define pkg_version 3.4.1
3%define pkg_release 2%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
16# Patch0:      R-release.diff.gz
17
18# To avoid 'make check error'
19Patch1:      reg-tests-3.R.patch
20Patch2:      reg-tests-3.Rout.save.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: gcc-c++
24BuildRequires: gcc-gfortran libgfortran
25BuildRequires: texinfo
26%if %{?_dist_release} == "vl6"
27BuildRequires: R-pcre-devel
28BuildRequires: tcl85-devel tk85-devel
29%endif
30%if %{?_dist_release} >= "vl7"
31BuildRequires: pcre-devel
32BuildRequires: tcl-devel tk-devel
33%endif
34BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
35BuildRequires: readline-devel ncurses-devel
36BuildRequires: zlib-devel bzip2-devel xz-devel
37BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
38BuildRequires: cairo-devel pango-devel
39BuildRequires: libicu-devel
40BuildRequires: curl-devel
41BuildRequires: texlive-common
42BuildRequires: texlive-collection-basic
43BuildRequires: texlive-collection-latexextra
44BuildRequires: texlive-collection-fontsextra
45%if %{?_dist_release} == "vl6"
46BuildRequires: texlive-collection-texinfo
47%endif
48%if %{?_dist_release} >= "vl7"
49BuildRequires: texlive-collection-plaingeneric
50BuildRequires: texlive-collection-fontsrecommended
51%endif
52BuildRequires: java-devel
53
54Requires: gcc-gfortran
55Requires: libgfortran
56Requires: libicu
57%if %{?_dist_release} == "vl6"
58Requires: tcl85 tk85
59Requires: R-pcre
60%endif
61%if %{?_dist_release} >= "vl7"
62Requires: tcl tk
63%endif
64
65Conflicts: R-devel < %{version}-%{release}
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: ara_t
70
71
72%description
73'GNU S' - A language and environment for statistical computing and
74graphics. R is similar to the award-winning S system, which was
75developed at Bell Laboratories by John Chambers et al. It provides
76a wide variety of statistical and graphical techniques (linear and
77nonlinear modelling, statistical tests, time series analysis,
78classification, clustering, ...).
79
80R is designed as a true computer language with control-flow
81constructions for iteration and alternation, and it allows users to
82add additional functionality by defining new functions.
83For computationally intensive tasks, C, C++ and Fortran code
84can be linked and called at run time.
85
86%description -l ja
87'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
88Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
89線形・非線型モデル、統計検定、時系列分析、クラスター分析など
90幅広い統計解析・視覚化手法を提供する。
91Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
92として設計されており、ユーザが新たに関数を組み込むことが可能である。
93また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
94使用することができる。
95
96%package -n libRmath
97Summary:          standalone math library from the R project
98Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
99Group:            System Environment/Libraries
100
101%description -n libRmath
102A standalone library of mathematical and statistical functions derived
103from the R project.  This packages provides the shared libRmath library.
104
105%description -l ja -n libRmath
106単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
107共有ライブラリを提供する。
108
109%package -n libRmath-devel
110Summary:          standalone math library from the R project
111Summary(ja):      libRmathの開発ライブラリ
112Group:            Development/Libraries
113Requires:         libRmath = %{version}-%{release}
114
115%description -n libRmath-devel
116A standalone library of mathematical and statistical functions derived
117from the R project.  This packages provides the header files.
118
119%description -l ja -n libRmath-devel
120libRmathのヘッダファイル(Rmath.h)
121
122%package -n libRmath-static
123Summary: Static R Standalone math library
124Summary(ja): libRmath の静的ライブラリ
125Group: Development/Libraries
126Requires: libRmath-devel = %{version}-%{release}
127
128%description -n libRmath-static
129A standalone library of mathematical and statistical functions derived
130from the R project.  This package provides the static libRmath library.
131
132
133%prep
134%{__rm} -rf ${RPM_BUILD_ROOT}
135%setup -q
136# %patch0 -p1
137%patch1
138%patch2
139
140cat > R.desktop <<EOF
141[Desktop Entry]
142Name=GNU R
143Comment=A language for data analysis and graphics
144TryExec=/usr/bin/R
145Exec=/usr/bin/R
146Icon=/usr/share/icons/logo.jpg
147Terminal=true
148Type=Application
149Categories=Education;Science;
150StartupNotify=false
151EOF
152
153%build
154export R_PDFVIEWER="%{_bindir}/xdg-open"
155export R_PRINTCMD="lpr"
156export R_BROWSER="%{_bindir}/xdg-open"
157%if %{?_dist_release} == "vl6"
158export LD_LIBRARY_PATH=%{_libdir}/R/lib
159%endif
160
161%{configure} --enable-R-shlib --with-tcltk \
162%if %{?_dist_release} == "vl6"
163 --with-tcl-config=%{_libdir}/tclConfig85.sh \
164 --with-tk-config=%{_libdir}/tkConfig85.sh \
165 CPPFLAGS="-I%{_libdir}/R/include" \
166 LDFLAGS="-L%{_libdir}/R/lib"
167%endif
168
169%{__make} %{?_smp_mflags}
170(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
171%{__make} pdf
172
173%install
174%{make_install}
175%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
176%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
177%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
178
179# Install libRmath files
180(cd src/nmath/standalone; %{make_install})
181
182%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
183echo "%{_libdir}/R/lib" > \
184     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
185
186# Fix lication of R_HOME_DIR in shell wrapper
187%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
188  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
189%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
190%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
191  > ${RPM_BUILD_ROOT}%{_bindir}/R
192%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
193
194# add R into menu
195%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
196%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
197%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
198%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
199
200# move manuals
201%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
202%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
203 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
204
205%check
206export TZ="Asia/Tokyo"
207LANG=C %{__make} check
208
209%clean
210%{__rm} -rf ${RPM_BUILD_ROOT}
211
212
213%post -p %{_syssbindir}/ldconfig
214
215%postun -p %{_syssbindir}/ldconfig
216
217%post -n libRmath -p %{_syssbindir}/ldconfig
218
219%postun -n libRmath -p %{_syssbindir}/ldconfig
220
221
222%files
223%defattr(-, root, root)
224%{_bindir}/R
225%{_bindir}/Rscript
226%{_libdir}/R
227%{_datadir}/applications/*
228%{_datadir}/icons/*
229%{_mandir}/man1/*
230%{_docdir}/%{name}-%{version}
231%{_sysconfdir}/ld.so.conf.d/*
232
233%files -n libRmath
234%defattr(-, root, root)
235%{_libdir}/libRmath.so
236
237%files -n libRmath-devel
238%defattr(-, root, root)
239%{_libdir}/pkgconfig/*.pc
240%{_includedir}/Rmath.h
241
242%files -n libRmath-static
243%defattr(-, root, root)
244%{_libdir}/libRmath.a
245
246
247%changelog
248* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
249- left %%{_libdir}/R/doc
250
251* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
252- Updated to 3.4.1
253- rebuild under R-pcre (pcre-8.39) for Vine6
254- add Requires: gcc-gfortran
255- change to BuildRequires: texlive-collection-plaingeneric
256- delete unnecessary descriptions
257
258* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
259- Updated to 3.4.0
260- add Patch1 and Patch2 to avoid 'make check' error
261- add export TZ="Asia/Tokyo" to avoid 'make check' error
262- delete descrption about info
263
264* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
265- Updated to 3.3.3
266
267* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
268- use tcl-8.5/tk-8.5 for Vine6.5
269  - BuildRequires to tcl85-devel/tk85-devel
270  - Requires to tcl85/tk85
271
272* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
273- merge SPEC file for Vine6
274- drop devel package
275- move PDF manuals to /usr/share/doc/R-%%{version}
276- revert logo of menu item to logo.jpg
277
278* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
279- Updated to 3.3.2
280
281* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
282- Updated to 3.3.1
283- delete BuildRequires: texlive-collection-lang*
284
285* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
286- add BuildRequires: texlive-collection-lang*
287
288* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
289- Updated to 3.3.0
290- add BuildRequires: pcre-devel xz-devel
291- change logo of menu item to Rlogo.svg
292
293* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
294- correct SPEC file
295
296* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
297- Updated to 3.2.4-revised
298
299* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
300- Updated to 3.2.4
301- fixed build error in src/extra/xz
302
303* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
304- add BuildRequires: curl-devel
305- add BuildRequires: libgomp
306
307* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
308- Updated to 3.2.3
309
310* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
311- rebuild with icu-56.1
312
313* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
314- Updated to 3.2.2
315
316* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
317- add configure options: --with-tcltk
318- add BuildRequires: tcl-devel tk-devel
319- add Requires: tcl tk
320
321* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
322- Updated to 3.2.1
323
324* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
325- add "LIBS=-lbz2" to configure option
326
327* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
328- Updated to 3.2.0
329
330* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
331- Updated to 3.1.3
332- added BuildRequires: texlive-collection-fontsextra for Vine6
333- changed option "make check-all" to "make check"
334-   to avoid error in checking of mgcv package
335- changed orders of BuildRequires
336
337* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
338- rebuild with icu-54.1
339
340* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
341- Updated to 3.1.2
342
343* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
344- Updated to 3.1.1
345- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
346
347* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
348- add patch (2014-04-26)
349
350* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
351- Updated to 3.1.0
352
353* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
354- Updated to 3.0.3
355
356* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
357- rebuild current VineSeed
358- add patch (2014-01-06)
359
360* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
361- add Requires: libicu
362
363* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
364- combine spec files Vine6 and VineSeed
365- correct the days of the week in changelog
366
367* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
368- delete BuildRequires: texlive-collection-texinfo
369- add BuildRequires: texlive-collection-plainextra
370- add BuildRequires: texlive-collection-latexextra
371- add BuildRequires: texlive-collection-fontsrecommended
372-   for VineSeed
373
374* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
375- Updated to 3.0.2
376
377* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
378- Updated to 3.0.1
379- add BuildRequires: java-1.6.0-openjdk-devel
380
381* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
382- Updated to 3.0.0
383
384* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
385- Updated to 2.15.3
386- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
387- use BuildRequires ncurses-devel instead of libtermcap-devel
388
389* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
390- Updated to 2.15.2
391
392* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
393- changed group to Applications/Edutainment
394- added R to menu
395
396* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
397- Updated to 2.15.1
398
399* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
400- Updated to 2.15.0
401
402* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
403- Updated to 2.14.2
404
405* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
406- Updated to 2.14.1
407
408* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
409- Updated to 2.14.0
410- add BuildRequires: texlive-collection-fontsextra
411
412* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
413- Updated to 2.13.2
414- add BuildRequires: texlive-common
415- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
416- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
417
418* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
419- synchronized to VinePlus/5 package
420  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
421  - Updated to 2.13.1
422  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
423  - Updated to 2.13.0
424  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
425  - Updated to 2.12.2
426
427* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
428- add BuildRequires: libicu-devel
429
430* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
431- synchronized to VinePlus/5 package
432  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
433  - Updated to 2.12.1
434- added --enable-R-shlib option to %%configure
435- added static subpackage
436- use BR: texlive instead of tetex on VineSeed
437
438* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
439- rebuilt with rpm-4.8.1 for pkg-config
440
441* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
442- recompiled because tcl/tk were not linked
443
444* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
445- Updated to 2.11.0
446- added Requires: libgfortran
447
448* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
449- Updated to 2.10.1
450
451* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
452- patched to 2.10.0
453
454* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
455- spec in UTF-8
456
457* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
458- Updated to 2.10.0
459
460* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
461- Updated to 2.9.2
462- deleted BuildRequires: lapack-devel blas-devel
463- rewrote SPEC file
464
465* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
466- Updated to 2.5.1
467- added BuildRequires: gcc-gfortran for VineSeed
468- added BuildRequires: lapack-devel blas-devel
469v- fixed %preun script
470
471* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
472- Updated to 2.4.1
473- Added INFO option
474- Exclude Japanese Rprofile.site
475
476* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
477- Updated to 2.4.0
478
479* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
480- Added optimization flags
481
482* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
483- Packaged for VineLinux3.2
484
485* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
486- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
487
488* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
489- Packaged for VineLinux3.2
490- Slipped texinfo
491- Fixed preun error
492- Preset Japanese fonts
493
494* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
495- Packaged for VineLinux3.2
496
497* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
498- Restored CAPABILITIES file lost in 2.2.1beta
499
500* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
501- Configure uses --without-blas by default.
502- Install pdf manuals.
503- All toplevel documentation files are installed into _libdir/R
504  as they may be required by R (qv note on AUTHORS and THANKS below).
505- Legacy scripts for rebuilding package indices removed.
506
507* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
508- R now compiles with gcc 4.0.1 and default rpm optimization flags.
509
510* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
511- The files AUTHORS and THANKS need to be installed into _libdir/R
512  as they are required by the function contributors().  Previously
513  they were installed only as documentation files.
514
515* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
516- Corrected date error in SPEC file.
517
518* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
519- Dropped support for Red Hat boxed set.
520- Synchronized with Fedora Extras 4 RPM by Tom Calloway
521  including support for shared R library.
522- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
523  with the default optimization flags, so there is a temporary work-around.
524
525* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
526- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
527
528* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
529- Install R-data.info file as well.
530- Make info processing conditional on texinfo version, not platform release,
531  so that if a new enough version is installed, we will build and install info.
532
533* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
534- Built R 2.1.0.  R now supports internationalization, so the patch
535  to set the locale to "C" is now dropped.
536- install.packages() exits gracefully with a helpful message if
537  the file INSTALL is not present, so this is now included in the
538  R-devel package.
539
540* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
541- Added support for Scientific Linux (http://www.scientificlinux.org)
542  A distribution based on RHEL. Thanks to Jon Peatfield.
543
544* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
545- Fixed file ownership in R-devel and libRmath packages
546
547* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
548- R-devel package is now a stub package with no files, except a documentation
549  file (RPM won't accept sub-packages with no files). R now conflicts
550  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
551- Created libRmath subpackage with shared library.
552
553* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
554- Created R-devel and libRmath-devel subpackages
555
556* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
557- Built R 2.0.1
558
559* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
560- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
561  gives "lpr".
562- Define macro fcx for all Fedora distributions. This replaces Rinfo
563
564* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
565- Info support is now conditional on the macro Rinfo, which is only
566  defined for Fedora 1 and 2.
567
568* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
569- Built R 2.0.0
570- There is no longer a BUGS file, so this is not installed as a
571  documentation file.
Note: See TracBrowser for help on using the repository browser.