source: projects/specs/trunk/R/R/R-vl.spec @ 11051

Revision 11051, 18.5 KB checked in by ara_t, 7 years ago (diff)

R: update to 3.4.0

Line 
1%define pkg_name    R
2%define pkg_version 3.4.0
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
16# Source1:     R.desktop
17# Patch0:      R-release.diff.gz
18
19# To avoid 'make check error'
20Patch1:      reg-tests-3.R.patch
21Patch2:      reg-tests-3.Rout.save.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: gcc-c++
25BuildRequires: gcc-gfortran libgfortran
26BuildRequires: texinfo
27%if %{?_dist_release} == "vl6"
28# BuildRequires: tcl tk
29BuildRequires: tcl85-devel tk85-devel
30%endif
31%if %{?_dist_release} >= "vl7"
32BuildRequires: tcl-devel tk-devel
33%endif
34BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
35BuildRequires: readline-devel ncurses-devel
36BuildRequires: zlib-devel bzip2-devel xz-devel
37BuildRequires: pcre-devel
38BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
39BuildRequires: cairo-devel pango-devel
40BuildRequires: libicu-devel
41BuildRequires: curl-devel
42BuildRequires: texlive-common
43BuildRequires: texlive-collection-basic
44BuildRequires: texlive-collection-latexextra
45BuildRequires: texlive-collection-fontsextra
46%if %{?_dist_release} == "vl6"
47BuildRequires: texlive-collection-texinfo
48%endif
49%if %{?_dist_release} >= "vl7"
50BuildRequires: texlive-collection-plainextra
51BuildRequires: texlive-collection-fontsrecommended
52%endif
53BuildRequires: java-devel
54
55Requires: libgfortran
56Requires: libicu
57# Requires: tcl tk
58%if %{?_dist_release} == "vl6"
59Requires: tcl85 tk85
60%endif
61%if %{?_dist_release} >= "vl7"
62Requires: tcl tk
63%endif
64
65Conflicts: R-devel < %{version}-%{release}
66
67Vendor: Project Vine
68Distribution: Vine Linux
69Packager: ara_t
70
71
72%description
73'GNU S' - A language and environment for statistical computing and
74graphics. R is similar to the award-winning S system, which was
75developed at Bell Laboratories by John Chambers et al. It provides
76a wide variety of statistical and graphical techniques (linear and
77nonlinear modelling, statistical tests, time series analysis,
78classification, clustering, ...).
79
80R is designed as a true computer language with control-flow
81constructions for iteration and alternation, and it allows users to
82add additional functionality by defining new functions.
83For computationally intensive tasks, C, C++ and Fortran code
84can be linked and called at run time.
85
86%description -l ja
87'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
88Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
89線形・非線型モデル、統計検定、時系列分析、クラスター分析など
90幅広い統計解析・視覚化手法を提供する。
91Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
92として設計されており、ユーザが新たに関数を組み込むことが可能である。
93また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
94使用することができる。
95
96# %package devel
97# Summary:          files for development of R packages.
98# Summary(ja):      Rパッケージ開発用ファイル
99# Group:            Development/Libraries
100# Requires:         R = %{version}-%{release}
101
102# %description devel
103# Install R-devel if you are going to develop or compile R packages.
104
105# This is just a stub package containing the documentation on
106# "Writing R Extensions".  However, installing it will ensure that
107# the build environment for R packages is correct.
108
109# %description -l ja devel
110# Rパッケージを開発したりコンパイルする場合には、このR-develを
111# インストールします。R-exts.pdf ("Writing R Extensions": 英文)
112# が含まれているだけのサブパッケージですが、正しくRパッケージを
113# 開発するための助けになるでしょう。
114
115%package -n libRmath
116Summary:          standalone math library from the R project
117Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
118Group:            System Environment/Libraries
119
120%description -n libRmath
121A standalone library of mathematical and statistical functions derived
122from the R project.  This packages provides the shared libRmath library.
123
124%description -l ja -n libRmath
125単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
126共有ライブラリを提供する。
127
128%package -n libRmath-devel
129Summary:          standalone math library from the R project
130Summary(ja):      libRmathの開発ライブラリ
131Group:            Development/Libraries
132Requires:         libRmath = %{version}-%{release}
133
134%description -n libRmath-devel
135A standalone library of mathematical and statistical functions derived
136from the R project.  This packages provides the header files.
137
138%description -l ja -n libRmath-devel
139libRmathのヘッダファイル(Rmath.h)
140
141%package -n libRmath-static
142Summary: Static R Standalone math library
143Summary(ja): libRmath の静的ライブラリ
144Group: Development/Libraries
145Requires: libRmath-devel = %{version}-%{release}
146
147%description -n libRmath-static
148A standalone library of mathematical and statistical functions derived
149from the R project.  This package provides the static libRmath library.
150
151
152%prep
153%{__rm} -rf ${RPM_BUILD_ROOT}
154%setup -q
155# %patch0 -p1
156%patch1
157%patch2
158
159cat > R.desktop <<EOF
160[Desktop Entry]
161Name=GNU R
162Comment=A language for data analysis and graphics
163TryExec=/usr/bin/R
164Exec=/usr/bin/R
165Icon=/usr/share/icons/logo.jpg
166Terminal=true
167Type=Application
168Categories=Education;Science;
169StartupNotify=false
170EOF
171
172%build
173export R_PDFVIEWER="%{_bindir}/xdg-open"
174export R_PRINTCMD="lpr"
175export R_BROWSER="%{_bindir}/xdg-open"
176export TZ="Asia/Tokyo"
177
178%{configure} --enable-R-shlib --with-tcltk \
179%if %{?_dist_release} == "vl6"
180 --with-tcl-config=%{_libdir}/tclConfig85.sh \
181 --with-tk-config=%{_libdir}/tkConfig85.sh
182%endif
183
184%{__make} %{?_smp_mflags}
185(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
186LANG=C %{__make} check
187%{__make} pdf
188
189%install
190%{make_install}
191%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
192%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
193%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
194
195# Install libRmath files
196(cd src/nmath/standalone; %{make_install})
197
198%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
199echo "%{_libdir}/R/lib" > \
200     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
201
202# Fix lication of R_HOME_DIR in shell wrapper
203%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
204  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
205%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
206%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
207  > ${RPM_BUILD_ROOT}%{_bindir}/R
208%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
209
210# add R into menu
211%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
212%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
213%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
214%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
215
216# move PDF manuals
217%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
218%{__mv} ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/manual/*.pdf \
219 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
220
221%clean
222%{__rm} -rf ${RPM_BUILD_ROOT}
223
224
225%post -p %{_syssbindir}/ldconfig
226
227%postun -p %{_syssbindir}/ldconfig
228
229%post -n libRmath -p %{_syssbindir}/ldconfig
230
231%postun -n libRmath -p %{_syssbindir}/ldconfig
232
233
234%files
235%defattr(-, root, root)
236%{_bindir}/R
237%{_bindir}/Rscript
238%{_libdir}/R
239%{_datadir}/applications/*
240%{_datadir}/icons/*
241%{_mandir}/man1/*
242%{_docdir}/%{name}-%{version}/*
243%{_sysconfdir}/ld.so.conf.d/*
244
245# %files devel
246# %defattr(-, root, root)
247# %doc doc/manual/R-exts.pdf
248
249%files -n libRmath
250%defattr(-, root, root)
251%{_libdir}/libRmath.so
252
253%files -n libRmath-devel
254%defattr(-, root, root)
255%{_libdir}/pkgconfig/*.pc
256%{_includedir}/Rmath.h
257
258%files -n libRmath-static
259%defattr(-, root, root)
260%{_libdir}/libRmath.a
261
262
263%changelog
264* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
265- Updated to 3.4.0
266- add Patch1 and Patch2 to avoid 'make check' error
267- add export TZ="Asia/Tokyo" to avoid 'make check' error
268- delete descrption about info
269
270* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
271- Updated to 3.3.3
272
273* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
274- use tcl-8.5/tk-8.5 for Vine6.5
275  - BuildRequires to tcl85-devel/tk85-devel
276  - Requires to tcl85/tk85
277
278* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
279- merge SPEC file for Vine6
280- drop devel package
281- move PDF manuals to /usr/share/doc/R-%%{version}
282- revert logo of menu item to logo.jpg
283
284* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
285- Updated to 3.3.2
286
287* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
288- Updated to 3.3.1
289- delete BuildRequires: texlive-collection-lang*
290
291* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
292- add BuildRequires: texlive-collection-lang*
293
294* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
295- Updated to 3.3.0
296- add BuildRequires: pcre-devel xz-devel
297- change logo of menu item to Rlogo.svg
298
299* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
300- correct SPEC file
301
302* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
303- Updated to 3.2.4-revised
304
305* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
306- Updated to 3.2.4
307- fixed build error in src/extra/xz
308
309* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
310- add BuildRequires: curl-devel
311- add BuildRequires: libgomp
312
313* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
314- Updated to 3.2.3
315
316* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
317- rebuild with icu-56.1
318
319* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
320- Updated to 3.2.2
321
322* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
323- add configure options: --with-tcltk
324- add BuildRequires: tcl-devel tk-devel
325- add Requires: tcl tk
326
327* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
328- Updated to 3.2.1
329
330* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
331- add "LIBS=-lbz2" to configure option
332
333* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
334- Updated to 3.2.0
335
336* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
337- Updated to 3.1.3
338- added BuildRequires: texlive-collection-fontsextra for Vine6
339- changed option "make check-all" to "make check"
340-   to avoid error in checking of mgcv package
341- changed orders of BuildRequires
342
343* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
344- rebuild with icu-54.1
345
346* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
347- Updated to 3.1.2
348
349* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
350- Updated to 3.1.1
351- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
352
353* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
354- add patch (2014-04-26)
355
356* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
357- Updated to 3.1.0
358
359* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
360- Updated to 3.0.3
361
362* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
363- rebuild current VineSeed
364- add patch (2014-01-06)
365
366* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
367- add Requires: libicu
368
369* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
370- combine spec files Vine6 and VineSeed
371- correct the days of the week in changelog
372
373* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
374- delete BuildRequires: texlive-collection-texinfo
375- add BuildRequires: texlive-collection-plainextra
376- add BuildRequires: texlive-collection-latexextra
377- add BuildRequires: texlive-collection-fontsrecommended
378-   for VineSeed
379
380* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
381- Updated to 3.0.2
382
383* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
384- Updated to 3.0.1
385- add BuildRequires: java-1.6.0-openjdk-devel
386
387* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
388- Updated to 3.0.0
389
390* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
391- Updated to 2.15.3
392- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
393- use BuildRequires ncurses-devel instead of libtermcap-devel
394
395* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
396- Updated to 2.15.2
397
398* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
399- changed group to Applications/Edutainment
400- added R to menu
401
402* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
403- Updated to 2.15.1
404
405* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
406- Updated to 2.15.0
407
408* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
409- Updated to 2.14.2
410
411* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
412- Updated to 2.14.1
413
414* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
415- Updated to 2.14.0
416- add BuildRequires: texlive-collection-fontsextra
417
418* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
419- Updated to 2.13.2
420- add BuildRequires: texlive-common
421- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
422- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
423
424* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
425- synchronized to VinePlus/5 package
426  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
427  - Updated to 2.13.1
428  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
429  - Updated to 2.13.0
430  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
431  - Updated to 2.12.2
432
433* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
434- add BuildRequires: libicu-devel
435
436* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
437- synchronized to VinePlus/5 package
438  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
439  - Updated to 2.12.1
440- added --enable-R-shlib option to %%configure
441- added static subpackage
442- use BR: texlive instead of tetex on VineSeed
443
444* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
445- rebuilt with rpm-4.8.1 for pkg-config
446
447* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
448- recompiled because tcl/tk were not linked
449
450* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
451- Updated to 2.11.0
452- added Requires: libgfortran
453
454* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
455- Updated to 2.10.1
456
457* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
458- patched to 2.10.0
459
460* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
461- spec in UTF-8
462
463* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
464- Updated to 2.10.0
465
466* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
467- Updated to 2.9.2
468- deleted BuildRequires: lapack-devel blas-devel
469- rewrote SPEC file
470
471* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
472- Updated to 2.5.1
473- added BuildRequires: gcc-gfortran for VineSeed
474- added BuildRequires: lapack-devel blas-devel
475v- fixed %preun script
476
477* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
478- Updated to 2.4.1
479- Added INFO option
480- Exclude Japanese Rprofile.site
481
482* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
483- Updated to 2.4.0
484
485* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
486- Added optimization flags
487
488* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
489- Packaged for VineLinux3.2
490
491* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
492- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
493
494* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
495- Packaged for VineLinux3.2
496- Slipped texinfo
497- Fixed preun error
498- Preset Japanese fonts
499
500* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
501- Packaged for VineLinux3.2
502
503* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
504- Restored CAPABILITIES file lost in 2.2.1beta
505
506* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
507- Configure uses --without-blas by default.
508- Install pdf manuals.
509- All toplevel documentation files are installed into _libdir/R
510  as they may be required by R (qv note on AUTHORS and THANKS below).
511- Legacy scripts for rebuilding package indices removed.
512
513* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
514- R now compiles with gcc 4.0.1 and default rpm optimization flags.
515
516* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
517- The files AUTHORS and THANKS need to be installed into _libdir/R
518  as they are required by the function contributors().  Previously
519  they were installed only as documentation files.
520
521* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
522- Corrected date error in SPEC file.
523
524* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
525- Dropped support for Red Hat boxed set.
526- Synchronized with Fedora Extras 4 RPM by Tom Calloway
527  including support for shared R library.
528- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
529  with the default optimization flags, so there is a temporary work-around.
530
531* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
532- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
533
534* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
535- Install R-data.info file as well.
536- Make info processing conditional on texinfo version, not platform release,
537  so that if a new enough version is installed, we will build and install info.
538
539* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
540- Built R 2.1.0.  R now supports internationalization, so the patch
541  to set the locale to "C" is now dropped.
542- install.packages() exits gracefully with a helpful message if
543  the file INSTALL is not present, so this is now included in the
544  R-devel package.
545
546* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
547- Added support for Scientific Linux (http://www.scientificlinux.org)
548  A distribution based on RHEL. Thanks to Jon Peatfield.
549
550* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
551- Fixed file ownership in R-devel and libRmath packages
552
553* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
554- R-devel package is now a stub package with no files, except a documentation
555  file (RPM won't accept sub-packages with no files). R now conflicts
556  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
557- Created libRmath subpackage with shared library.
558
559* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
560- Created R-devel and libRmath-devel subpackages
561
562* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
563- Built R 2.0.1
564
565* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
566- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
567  gives "lpr".
568- Define macro fcx for all Fedora distributions. This replaces Rinfo
569
570* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
571- Info support is now conditional on the macro Rinfo, which is only
572  defined for Fedora 1 and 2.
573
574* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
575- Built R 2.0.0
576- There is no longer a BUGS file, so this is not installed as a
577  documentation file.
Note: See TracBrowser for help on using the repository browser.