source: projects/specs/trunk/R/R/R-vl.spec @ 10817

Revision 10817, 19.0 KB checked in by ara_t, 8 years ago (diff)

update to 3.3.2-3

Line 
1%define pkg_name    R
2%define pkg_version 3.3.2
3%define pkg_release 3%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
16# Source1:     R.desktop
17# Patch0:      R-release.diff.gz
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: gcc-c++
21BuildRequires: gcc-gfortran libgfortran
22BuildRequires: texinfo
23%if %{?_dist_release} == "vl6"
24# BuildRequires: tcl tk
25BuildRequires: tcl85-devel tk85-devel
26%endif
27%if %{?_dist_release} >= "vl7"
28BuildRequires: tcl-devel tk-devel
29%endif
30BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
31BuildRequires: readline-devel ncurses-devel
32BuildRequires: zlib-devel bzip2-devel xz-devel
33BuildRequires: pcre-devel
34BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
35BuildRequires: cairo-devel pango-devel
36BuildRequires: libicu-devel
37BuildRequires: curl-devel
38BuildRequires: texlive-common
39BuildRequires: texlive-collection-basic
40BuildRequires: texlive-collection-latexextra
41BuildRequires: texlive-collection-fontsextra
42%if %{?_dist_release} == "vl6"
43BuildRequires: texlive-collection-texinfo
44%endif
45%if %{?_dist_release} >= "vl7"
46BuildRequires: texlive-collection-plainextra
47BuildRequires: texlive-collection-fontsrecommended
48%endif
49BuildRequires: java-devel
50
51Requires: libgfortran
52Requires: libicu
53# Requires: tcl tk
54%if %{?_dist_release} == "vl6"
55Requires: tcl85 tk85
56%endif
57%if %{?_dist_release} >= "vl7"
58Requires: tcl tk
59%endif
60
61Conflicts: R-devel < %{version}-%{release}
62
63Vendor: Project Vine
64Distribution: Vine Linux
65Packager: ara_t
66
67
68%description
69'GNU S' - A language and environment for statistical computing and
70graphics. R is similar to the award-winning S system, which was
71developed at Bell Laboratories by John Chambers et al. It provides
72a wide variety of statistical and graphical techniques (linear and
73nonlinear modelling, statistical tests, time series analysis,
74classification, clustering, ...).
75
76R is designed as a true computer language with control-flow
77constructions for iteration and alternation, and it allows users to
78add additional functionality by defining new functions.
79For computationally intensive tasks, C, C++ and Fortran code
80can be linked and called at run time.
81
82%description -l ja
83'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
84Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
85線形・非線型モデル、統計検定、時系列分析、クラスター分析など
86幅広い統計解析・視覚化手法を提供する。
87Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
88として設計されており、ユーザが新たに関数を組み込むことが可能である。
89また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
90使用することができる。
91
92# %package devel
93# Summary:          files for development of R packages.
94# Summary(ja):      Rパッケージ開発用ファイル
95# Group:            Development/Libraries
96# Requires:         R = %{version}-%{release}
97
98# %description devel
99# Install R-devel if you are going to develop or compile R packages.
100
101# This is just a stub package containing the documentation on
102# "Writing R Extensions".  However, installing it will ensure that
103# the build environment for R packages is correct.
104
105# %description -l ja devel
106# Rパッケージを開発したりコンパイルする場合には、このR-develを
107# インストールします。R-exts.pdf ("Writing R Extensions": 英文)
108# が含まれているだけのサブパッケージですが、正しくRパッケージを
109# 開発するための助けになるでしょう。
110
111%package -n libRmath
112Summary:          standalone math library from the R project
113Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
114Group:            System Environment/Libraries
115
116%description -n libRmath
117A standalone library of mathematical and statistical functions derived
118from the R project.  This packages provides the shared libRmath library.
119
120%description -l ja -n libRmath
121単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
122共有ライブラリを提供する。
123
124%package -n libRmath-devel
125Summary:          standalone math library from the R project
126Summary(ja):      libRmathの開発ライブラリ
127Group:            Development/Libraries
128Requires:         libRmath = %{version}-%{release}
129
130%description -n libRmath-devel
131A standalone library of mathematical and statistical functions derived
132from the R project.  This packages provides the header files.
133
134%description -l ja -n libRmath-devel
135libRmathのヘッダファイル(Rmath.h)
136
137%package -n libRmath-static
138Summary: Static R Standalone math library
139Summary(ja): libRmath の静的ライブラリ
140Group: Development/Libraries
141Requires: libRmath-devel = %{version}-%{release}
142
143%description -n libRmath-static
144A standalone library of mathematical and statistical functions derived
145from the R project.  This package provides the static libRmath library.
146
147
148%prep
149%{__rm} -rf ${RPM_BUILD_ROOT}
150%setup -q
151# %patch0 -p1
152
153cat > R.desktop <<EOF
154[Desktop Entry]
155Name=GNU R
156Comment=A language for data analysis and graphics
157TryExec=/usr/bin/R
158Exec=/usr/bin/R
159Icon=/usr/share/icons/logo.jpg
160Terminal=true
161Type=Application
162Categories=Education;Science;
163StartupNotify=false
164EOF
165
166%build
167export R_PDFVIEWER="%{_bindir}/xdg-open"
168export R_PRINTCMD="lpr"
169export R_BROWSER="%{_bindir}/xdg-open"
170
171# %{configure} --enable-R-shlib --with-tcltk
172%{configure} --enable-R-shlib --with-tcltk \
173%if %{?_dist_release} == "vl6"
174 --with-tcl-config=%{_libdir}/tclConfig85.sh \
175 --with-tk-config=%{_libdir}/tkConfig85.sh
176%endif
177
178%{__make} %{?_smp_mflags}
179(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
180LANG=C %{__make} check
181%{__make} pdf
182# We can only "make info" if we have an up to date version of texinfo
183%{?INFO: %{__make} info}
184
185%install
186%{make_install}
187%{__make} install-pdf %{?INFO:install-info} DESTDIR=${RPM_BUILD_ROOT}
188%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
189%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
190
191#Install libRmath files
192(cd src/nmath/standalone; %{make_install})
193
194%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
195echo "%{_libdir}/R/lib" > \
196     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
197
198#Fix lication of R_HOME_DIR in shell wrapper
199%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
200  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
201%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
202%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
203  > ${RPM_BUILD_ROOT}%{_bindir}/R
204%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
205
206# add R into menu
207%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
208%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
209%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
210%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
211
212# move PDF manuals
213%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
214%{__mv} ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/manual/*.pdf \
215 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
216
217%clean
218%{__rm} -rf ${RPM_BUILD_ROOT}
219
220
221%post
222%if 0%{?INFO}
223   # Create directory entries for info files
224   # (optional doc files, so we must check that they are installed)
225   for doc in admin data exts FAQ intro lang; do
226      file=%{_infodir}/R-${doc}.info.gz
227      if [ -e $file ]; then
228         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
229      fi
230   done
231%endif
232%{_syssbindir}/ldconfig
233
234
235%preun
236%if 0%{?INFO}
237   if [ $1 = 0 ]; then
238      # Delete directory entries for info files (if they were installed)
239      for doc in admin data exts FAQ intro lang; do
240         file=%{_infodir}/R-${doc}.info.gz
241         if [ -e ${file} ]; then
242            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
243         fi
244      done
245   fi
246%endif
247
248%postun -p %{_syssbindir}/ldconfig
249
250%post -n libRmath -p %{_syssbindir}/ldconfig
251
252%postun -n libRmath -p %{_syssbindir}/ldconfig
253
254
255%files
256%defattr(-, root, root)
257%{_bindir}/R
258%{_bindir}/Rscript
259%{_libdir}/R
260%{_datadir}/applications/*
261%{_datadir}/icons/*
262%{?INFO:%{_infodir}/R-*.info*}
263%{_mandir}/man1/*
264%{_docdir}/%{name}-%{version}/*
265%{_sysconfdir}/ld.so.conf.d/*
266
267# %files devel
268# %defattr(-, root, root)
269# %doc doc/manual/R-exts.pdf
270
271%files -n libRmath
272%defattr(-, root, root)
273%{_libdir}/libRmath.so
274
275%files -n libRmath-devel
276%defattr(-, root, root)
277%{_libdir}/pkgconfig/*.pc
278%{_includedir}/Rmath.h
279
280%files -n libRmath-static
281%defattr(-, root, root)
282%{_libdir}/libRmath.a
283
284
285%changelog
286* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
287- use tcl-8.5/tk-8.5 for Vine6.5
288  - BuildRequires to tcl85-devel/tk85-devel
289  - Requires to tcl85/tk85
290
291* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
292- merge SPEC file for Vine6
293- drop devel package
294- move PDF manuals to /usr/share/doc/R-%%{version}
295- revert logo of menu item to logo.jpg
296
297* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
298- Updated to 3.3.2
299
300* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
301- Updated to 3.3.1
302- delete BuildRequires: texlive-collection-lang*
303
304* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
305- add BuildRequires: texlive-collection-lang*
306
307* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
308- Updated to 3.3.0
309- add BuildRequires: pcre-devel xz-devel
310- change logo of menu item to Rlogo.svg
311
312* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
313- correct SPEC file
314
315* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
316- Updated to 3.2.4-revised
317
318* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
319- Updated to 3.2.4
320- fixed build error in src/extra/xz
321
322* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
323- add BuildRequires: curl-devel
324- add BuildRequires: libgomp
325
326* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
327- Updated to 3.2.3
328
329* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
330- rebuild with icu-56.1
331
332* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
333- Updated to 3.2.2
334
335* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
336- add configure options: --with-tcltk
337- add BuildRequires: tcl-devel tk-devel
338- add Requires: tcl tk
339
340* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
341- Updated to 3.2.1
342
343* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
344- add "LIBS=-lbz2" to configure option
345
346* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
347- Updated to 3.2.0
348
349* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
350- Updated to 3.1.3
351- added BuildRequires: texlive-collection-fontsextra for Vine6
352- changed option "make check-all" to "make check"
353-   to avoid error in checking of mgcv package
354- changed orders of BuildRequires
355
356* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
357- rebuild with icu-54.1
358
359* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
360- Updated to 3.1.2
361
362* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
363- Updated to 3.1.1
364- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
365
366* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
367- add patch (2014-04-26)
368
369* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
370- Updated to 3.1.0
371
372* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
373- Updated to 3.0.3
374
375* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
376- rebuild current VineSeed
377- add patch (2014-01-06)
378
379* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
380- add Requires: libicu
381
382* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
383- combine spec files Vine6 and VineSeed
384- correct the days of the week in changelog
385
386* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
387- delete BuildRequires: texlive-collection-texinfo
388- add BuildRequires: texlive-collection-plainextra
389- add BuildRequires: texlive-collection-latexextra
390- add BuildRequires: texlive-collection-fontsrecommended
391-   for VineSeed
392
393* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
394- Updated to 3.0.2
395
396* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
397- Updated to 3.0.1
398- add BuildRequires: java-1.6.0-openjdk-devel
399
400* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
401- Updated to 3.0.0
402
403* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
404- Updated to 2.15.3
405- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
406- use BuildRequires ncurses-devel instead of libtermcap-devel
407
408* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
409- Updated to 2.15.2
410
411* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
412- changed group to Applications/Edutainment
413- added R to menu
414
415* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
416- Updated to 2.15.1
417
418* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
419- Updated to 2.15.0
420
421* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
422- Updated to 2.14.2
423
424* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
425- Updated to 2.14.1
426
427* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
428- Updated to 2.14.0
429- add BuildRequires: texlive-collection-fontsextra
430
431* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
432- Updated to 2.13.2
433- add BuildRequires: texlive-common
434- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
435- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
436
437* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
438- synchronized to VinePlus/5 package
439  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
440  - Updated to 2.13.1
441  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
442  - Updated to 2.13.0
443  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
444  - Updated to 2.12.2
445
446* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
447- add BuildRequires: libicu-devel
448
449* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
450- synchronized to VinePlus/5 package
451  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
452  - Updated to 2.12.1
453- added --enable-R-shlib option to %%configure
454- added static subpackage
455- use BR: texlive instead of tetex on VineSeed
456
457* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
458- rebuilt with rpm-4.8.1 for pkg-config
459
460* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
461- recompiled because tcl/tk were not linked
462
463* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
464- Updated to 2.11.0
465- added Requires: libgfortran
466
467* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
468- Updated to 2.10.1
469
470* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
471- patched to 2.10.0
472
473* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
474- spec in UTF-8
475
476* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
477- Updated to 2.10.0
478
479* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
480- Updated to 2.9.2
481- deleted BuildRequires: lapack-devel blas-devel
482- rewrote SPEC file
483
484* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
485- Updated to 2.5.1
486- added BuildRequires: gcc-gfortran for VineSeed
487- added BuildRequires: lapack-devel blas-devel
488v- fixed %preun script
489
490* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
491- Updated to 2.4.1
492- Added INFO option
493- Exclude Japanese Rprofile.site
494
495* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
496- Updated to 2.4.0
497
498* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
499- Added optimization flags
500
501* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
502- Packaged for VineLinux3.2
503
504* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
505- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
506
507* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
508- Packaged for VineLinux3.2
509- Slipped texinfo
510- Fixed preun error
511- Preset Japanese fonts
512
513* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
514- Packaged for VineLinux3.2
515
516* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
517- Restored CAPABILITIES file lost in 2.2.1beta
518
519* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
520- Configure uses --without-blas by default.
521- Install pdf manuals.
522- All toplevel documentation files are installed into _libdir/R
523  as they may be required by R (qv note on AUTHORS and THANKS below).
524- Legacy scripts for rebuilding package indices removed.
525
526* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
527- R now compiles with gcc 4.0.1 and default rpm optimization flags.
528
529* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
530- The files AUTHORS and THANKS need to be installed into _libdir/R
531  as they are required by the function contributors().  Previously
532  they were installed only as documentation files.
533
534* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
535- Corrected date error in SPEC file.
536
537* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
538- Dropped support for Red Hat boxed set.
539- Synchronized with Fedora Extras 4 RPM by Tom Calloway
540  including support for shared R library.
541- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
542  with the default optimization flags, so there is a temporary work-around.
543
544* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
545- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
546
547* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
548- Install R-data.info file as well.
549- Make info processing conditional on texinfo version, not platform release,
550  so that if a new enough version is installed, we will build and install info.
551
552* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
553- Built R 2.1.0.  R now supports internationalization, so the patch
554  to set the locale to "C" is now dropped.
555- install.packages() exits gracefully with a helpful message if
556  the file INSTALL is not present, so this is now included in the
557  R-devel package.
558
559* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
560- Added support for Scientific Linux (http://www.scientificlinux.org)
561  A distribution based on RHEL. Thanks to Jon Peatfield.
562
563* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
564- Fixed file ownership in R-devel and libRmath packages
565
566* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
567- R-devel package is now a stub package with no files, except a documentation
568  file (RPM won't accept sub-packages with no files). R now conflicts
569  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
570- Created libRmath subpackage with shared library.
571
572* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
573- Created R-devel and libRmath-devel subpackages
574
575* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
576- Built R 2.0.1
577
578* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
579- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
580  gives "lpr".
581- Define macro fcx for all Fedora distributions. This replaces Rinfo
582
583* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
584- Info support is now conditional on the macro Rinfo, which is only
585  defined for Fedora 1 and 2.
586
587* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
588- Built R 2.0.0
589- There is no longer a BUGS file, so this is not installed as a
590  documentation file.
Note: See TracBrowser for help on using the repository browser.