source: projects/specs/trunk/R/R/R-vl.spec @ 10391

Revision 10391, 17.5 KB checked in by ara_t, 8 years ago (diff)

update to 3.3.1

Line 
1%define pkg_name    R
2%define pkg_version 3.3.1
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
16Source1:     R.desktop
17# Patch0:      R-release.diff.gz
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: gcc-c++
21BuildRequires: gcc-gfortran libgfortran
22BuildRequires: texinfo
23BuildRequires: tcl-devel tk-devel
24BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
25BuildRequires: readline-devel ncurses-devel
26BuildRequires: zlib-devel bzip2-devel xz-devel
27BuildRequires: pcre-devel
28BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
29BuildRequires: cairo-devel pango-devel
30BuildRequires: libicu-devel
31BuildRequires: curl-devel
32BuildRequires: texlive-common
33BuildRequires: texlive-collection-basic
34BuildRequires: texlive-collection-latexextra
35BuildRequires: texlive-collection-fontsextra
36BuildRequires: texlive-collection-plainextra
37BuildRequires: texlive-collection-fontsrecommended
38
39BuildRequires: java-1.7.0-openjdk-devel
40
41Requires: libgfortran
42Requires: libicu
43Requires: tcl tk
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: ara_t
48
49
50%description
51'GNU S' - A language and environment for statistical computing and
52graphics. R is similar to the award-winning S system, which was
53developed at Bell Laboratories by John Chambers et al. It provides
54a wide variety of statistical and graphical techniques (linear and
55nonlinear modelling, statistical tests, time series analysis,
56classification, clustering, ...).
57
58R is designed as a true computer language with control-flow
59constructions for iteration and alternation, and it allows users to
60add additional functionality by defining new functions.
61For computationally intensive tasks, C, C++ and Fortran code
62can be linked and called at run time.
63
64%description -l ja
65'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
66Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
67線形・非線型モデル、統計検定、時系列分析、クラスター分析など
68幅広い統計解析・視覚化手法を提供する。
69Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
70として設計されており、ユーザが新たに関数を組み込むことが可能である。
71また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
72使用することができる。
73
74%package devel
75Summary:          files for development of R packages.
76Summary(ja):      Rパッケージ開発用ファイル
77Group:            Development/Libraries
78Requires:         R = %{version}-%{release}
79
80%description devel
81Install R-devel if you are going to develop or compile R packages.
82
83This is just a stub package containing the documentation on
84"Writing R Extensions".  However, installing it will ensure that
85the build environment for R packages is correct.
86
87%description -l ja devel
88Rパッケージを開発したりコンパイルする場合には、このR-develを
89インストールします。R-exts.pdf ("Writing R Extensions": 英文)
90が含まれているだけのサブパッケージですが、正しくRパッケージを
91開発するための助けになるでしょう。
92
93%package -n libRmath
94Summary:          standalone math library from the R project
95Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
96Group:            System Environment/Libraries
97
98%description -n libRmath
99A standalone library of mathematical and statistical functions derived
100from the R project.  This packages provides the shared libRmath library.
101
102%description -l ja -n libRmath
103単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
104共有ライブラリを提供する。
105
106%package -n libRmath-devel
107Summary:          standalone math library from the R project
108Summary(ja):      libRmathの開発ライブラリ
109Group:            Development/Libraries
110Requires:         libRmath = %{version}-%{release}
111
112%description -n libRmath-devel
113A standalone library of mathematical and statistical functions derived
114from the R project.  This packages provides the header files.
115
116%description -l ja -n libRmath-devel
117libRmathのヘッダファイル(Rmath.h)
118
119%package -n libRmath-static
120Summary: Static R Standalone math library
121Summary(ja): libRmath の静的ライブラリ
122Group: Development/Libraries
123Requires: libRmath-devel = %{version}-%{release}
124
125%description -n libRmath-static
126A standalone library of mathematical and statistical functions derived
127from the R project.  This package provides the static libRmath library.
128
129
130%prep
131%{__rm} -rf ${RPM_BUILD_ROOT}
132%setup -q
133# %patch0 -p1
134
135%build
136export R_PDFVIEWER="%{_bindir}/xdg-open"
137export R_PRINTCMD="lpr"
138export R_BROWSER="%{_bindir}/xdg-open"
139
140%{configure} --enable-R-shlib --with-tcltk
141
142%{__make} %{?_smp_mflags}
143(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
144LANG=C %{__make} check
145%{__make} pdf
146# We can only "make info" if we have an up to date version of texinfo
147%{?INFO: %{__make} info}
148
149%install
150%{make_install}
151%{__make} install-pdf %{?INFO:install-info} DESTDIR=${RPM_BUILD_ROOT}
152%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
153%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
154
155#Install libRmath files
156(cd src/nmath/standalone; %{make_install})
157
158%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
159echo "%{_libdir}/R/lib" > \
160     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
161
162#Fix lication of R_HOME_DIR in shell wrapper
163%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
164  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
165%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
166%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
167  > ${RPM_BUILD_ROOT}%{_bindir}/R
168%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
169
170# add R into menu
171%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
172%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
173%{__cp} -a %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/
174%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
175
176%clean
177%{__rm} -rf ${RPM_BUILD_ROOT}
178
179
180%post
181%if 0%{?INFO}
182   # Create directory entries for info files
183   # (optional doc files, so we must check that they are installed)
184   for doc in admin data exts FAQ intro lang; do
185      file=%{_infodir}/R-${doc}.info.gz
186      if [ -e $file ]; then
187         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
188      fi
189   done
190%endif
191%{_syssbindir}/ldconfig
192
193
194%preun
195%if 0%{?INFO}
196   if [ $1 = 0 ]; then
197      # Delete directory entries for info files (if they were installed)
198      for doc in admin data exts FAQ intro lang; do
199         file=%{_infodir}/R-${doc}.info.gz
200         if [ -e ${file} ]; then
201            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
202         fi
203      done
204   fi
205%endif
206
207%postun -p %{_syssbindir}/ldconfig
208
209%post -n libRmath -p %{_syssbindir}/ldconfig
210
211%postun -n libRmath -p %{_syssbindir}/ldconfig
212
213
214%files
215%defattr(-, root, root)
216%{_bindir}/R
217%{_bindir}/Rscript
218%{_libdir}/R
219%{_datadir}/applications/*
220%{_datadir}/icons/*
221%{?INFO:%{_infodir}/R-*.info*}
222%{_mandir}/man1/*
223/etc/ld.so.conf.d/*
224
225%files devel
226%defattr(-, root, root)
227%doc doc/manual/R-exts.pdf
228
229%files -n libRmath
230%defattr(-, root, root)
231%{_libdir}/libRmath.so
232
233%files -n libRmath-devel
234%defattr(-, root, root)
235%{_libdir}/pkgconfig/*.pc
236%{_includedir}/Rmath.h
237
238%files -n libRmath-static
239%defattr(-, root, root)
240%{_libdir}/libRmath.a
241
242
243%changelog
244* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
245- Updated to 3.3.1
246- delete BuildRequires: texlive-collection-lang*
247
248* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
249- add BuildRequires: texlive-collection-lang*
250
251* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
252- Updated to 3.3.0
253- add BuildRequires: pcre-devel xz-devel
254- change logo of menu item to Rlogo.svg
255
256* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
257- correct SPEC file
258
259* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
260- Updated to 3.2.4-revised
261
262* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
263- Updated to 3.2.4
264- fixed build error in src/extra/xz
265
266* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
267- add BuildRequires: curl-devel
268- add BuildRequires: libgomp
269
270* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
271- Updated to 3.2.3
272
273* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
274- rebuild with icu-56.1
275
276* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
277- Updated to 3.2.2
278
279* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
280- add configure options: --with-tcltk
281- add BuildRequires: tcl-devel tk-devel
282- add Requires: tcl tk
283
284* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
285- Updated to 3.2.1
286
287* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
288- add "LIBS=-lbz2" to configure option
289
290* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
291- Updated to 3.2.0
292
293* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
294- Updated to 3.1.3
295- added BuildRequires: texlive-collection-fontsextra for Vine6
296- changed option "make check-all" to "make check"
297-   to avoid error in checking of mgcv package
298- changed orders of BuildRequires
299
300* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
301- rebuild with icu-54.1
302
303* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
304- Updated to 3.1.2
305
306* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
307- Updated to 3.1.1
308- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
309
310* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
311- add patch (2014-04-26)
312
313* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
314- Updated to 3.1.0
315
316* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
317- Updated to 3.0.3
318
319* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
320- rebuild current VineSeed
321- add patch (2014-01-06)
322
323* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
324- add Requires: libicu
325
326* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
327- combine spec files Vine6 and VineSeed
328- correct the days of the week in changelog
329
330* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
331- delete BuildRequires: texlive-collection-texinfo
332- add BuildRequires: texlive-collection-plainextra
333- add BuildRequires: texlive-collection-latexextra
334- add BuildRequires: texlive-collection-fontsrecommended
335-   for VineSeed
336
337* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
338- Updated to 3.0.2
339
340* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
341- Updated to 3.0.1
342- add BuildRequires: java-1.6.0-openjdk-devel
343
344* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
345- Updated to 3.0.0
346
347* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
348- Updated to 2.15.3
349- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
350- use BuildRequires ncurses-devel instead of libtermcap-devel
351
352* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
353- Updated to 2.15.2
354
355* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
356- changed group to Applications/Edutainment
357- added R to menu
358
359* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
360- Updated to 2.15.1
361
362* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
363- Updated to 2.15.0
364
365* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
366- Updated to 2.14.2
367
368* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
369- Updated to 2.14.1
370
371* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
372- Updated to 2.14.0
373- add BuildRequires: texlive-collection-fontsextra
374
375* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
376- Updated to 2.13.2
377- add BuildRequires: texlive-common
378- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
379- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
380
381* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
382- synchronized to VinePlus/5 package
383  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
384  - Updated to 2.13.1
385  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
386  - Updated to 2.13.0
387  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
388  - Updated to 2.12.2
389
390* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
391- add BuildRequires: libicu-devel
392
393* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
394- synchronized to VinePlus/5 package
395  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
396  - Updated to 2.12.1
397- added --enable-R-shlib option to %%configure
398- added static subpackage
399- use BR: texlive instead of tetex on VineSeed
400
401* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
402- rebuilt with rpm-4.8.1 for pkg-config
403
404* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
405- recompiled because tcl/tk were not linked
406
407* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
408- Updated to 2.11.0
409- added Requires: libgfortran
410
411* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
412- Updated to 2.10.1
413
414* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
415- patched to 2.10.0
416
417* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
418- spec in UTF-8
419
420* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
421- Updated to 2.10.0
422
423* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
424- Updated to 2.9.2
425- deleted BuildRequires: lapack-devel blas-devel
426- rewrote SPEC file
427
428* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
429- Updated to 2.5.1
430- added BuildRequires: gcc-gfortran for VineSeed
431- added BuildRequires: lapack-devel blas-devel
432v- fixed %preun script
433
434* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
435- Updated to 2.4.1
436- Added INFO option
437- Exclude Japanese Rprofile.site
438
439* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
440- Updated to 2.4.0
441
442* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
443- Added optimization flags
444
445* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
446- Packaged for VineLinux3.2
447
448* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
449- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
450
451* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
452- Packaged for VineLinux3.2
453- Slipped texinfo
454- Fixed preun error
455- Preset Japanese fonts
456
457* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
458- Packaged for VineLinux3.2
459
460* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
461- Restored CAPABILITIES file lost in 2.2.1beta
462
463* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
464- Configure uses --without-blas by default.
465- Install pdf manuals.
466- All toplevel documentation files are installed into _libdir/R
467  as they may be required by R (qv note on AUTHORS and THANKS below).
468- Legacy scripts for rebuilding package indices removed.
469
470* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
471- R now compiles with gcc 4.0.1 and default rpm optimization flags.
472
473* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
474- The files AUTHORS and THANKS need to be installed into _libdir/R
475  as they are required by the function contributors().  Previously
476  they were installed only as documentation files.
477
478* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
479- Corrected date error in SPEC file.
480
481* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
482- Dropped support for Red Hat boxed set.
483- Synchronized with Fedora Extras 4 RPM by Tom Calloway
484  including support for shared R library.
485- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
486  with the default optimization flags, so there is a temporary work-around.
487
488* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
489- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
490
491* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
492- Install R-data.info file as well.
493- Make info processing conditional on texinfo version, not platform release,
494  so that if a new enough version is installed, we will build and install info.
495
496* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
497- Built R 2.1.0.  R now supports internationalization, so the patch
498  to set the locale to "C" is now dropped.
499- install.packages() exits gracefully with a helpful message if
500  the file INSTALL is not present, so this is now included in the
501  R-devel package.
502
503* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
504- Added support for Scientific Linux (http://www.scientificlinux.org)
505  A distribution based on RHEL. Thanks to Jon Peatfield.
506
507* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
508- Fixed file ownership in R-devel and libRmath packages
509
510* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
511- R-devel package is now a stub package with no files, except a documentation
512  file (RPM won't accept sub-packages with no files). R now conflicts
513  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
514- Created libRmath subpackage with shared library.
515
516* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
517- Created R-devel and libRmath-devel subpackages
518
519* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
520- Built R 2.0.1
521
522* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
523- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
524  gives "lpr".
525- Define macro fcx for all Fedora distributions. This replaces Rinfo
526
527* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
528- Info support is now conditional on the macro Rinfo, which is only
529  defined for Fedora 1 and 2.
530
531* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
532- Built R 2.0.0
533- There is no longer a BUGS file, so this is not installed as a
534  documentation file.
Note: See TracBrowser for help on using the repository browser.