source: projects/specs/trunk/R/R/R-vl.spec @ 10222

Revision 10222, 17.2 KB checked in by ara_t, 8 years ago (diff)

update to 3.3.0

Line 
1%define pkg_name    R
2%define pkg_version 3.3.0
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
16Source1:     R.desktop
17# Patch0:      R-release.diff.gz
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: gcc-c++
21BuildRequires: gcc-gfortran libgfortran
22BuildRequires: texinfo
23BuildRequires: tcl-devel tk-devel
24BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
25BuildRequires: readline-devel ncurses-devel
26BuildRequires: zlib-devel bzip2-devel xz-devel
27BuildRequires: pcre-devel
28BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
29BuildRequires: cairo-devel pango-devel
30BuildRequires: libicu-devel
31BuildRequires: curl-devel
32BuildRequires: texlive-common
33BuildRequires: texlive-collection-basic
34BuildRequires: texlive-collection-latexextra
35BuildRequires: texlive-collection-fontsextra
36BuildRequires: texlive-collection-plainextra
37BuildRequires: texlive-collection-fontsrecommended
38BuildRequires: java-1.7.0-openjdk-devel
39
40Requires: libgfortran
41Requires: libicu
42Requires: tcl tk
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: ara_t
47
48
49%description
50'GNU S' - A language and environment for statistical computing and
51graphics. R is similar to the award-winning S system, which was
52developed at Bell Laboratories by John Chambers et al. It provides
53a wide variety of statistical and graphical techniques (linear and
54nonlinear modelling, statistical tests, time series analysis,
55classification, clustering, ...).
56
57R is designed as a true computer language with control-flow
58constructions for iteration and alternation, and it allows users to
59add additional functionality by defining new functions.
60For computationally intensive tasks, C, C++ and Fortran code
61can be linked and called at run time.
62
63%description -l ja
64'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
65Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
66線形・非線型モデル、統計検定、時系列分析、クラスター分析など
67幅広い統計解析・視覚化手法を提供する。
68Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
69として設計されており、ユーザが新たに関数を組み込むことが可能である。
70また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
71使用することができる。
72
73%package devel
74Summary:          files for development of R packages.
75Summary(ja):      Rパッケージ開発用ファイル
76Group:            Development/Libraries
77Requires:         R = %{version}-%{release}
78
79%description devel
80Install R-devel if you are going to develop or compile R packages.
81
82This is just a stub package containing the documentation on
83"Writing R Extensions".  However, installing it will ensure that
84the build environment for R packages is correct.
85
86%description -l ja devel
87Rパッケージを開発したりコンパイルする場合には、このR-develを
88インストールします。R-exts.pdf ("Writing R Extensions": 英文)
89が含まれているだけのサブパッケージですが、正しくRパッケージを
90開発するための助けになるでしょう。
91
92%package -n libRmath
93Summary:          standalone math library from the R project
94Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
95Group:            System Environment/Libraries
96
97%description -n libRmath
98A standalone library of mathematical and statistical functions derived
99from the R project.  This packages provides the shared libRmath library.
100
101%description -l ja -n libRmath
102単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
103共有ライブラリを提供する。
104
105%package -n libRmath-devel
106Summary:          standalone math library from the R project
107Summary(ja):      libRmathの開発ライブラリ
108Group:            Development/Libraries
109Requires:         libRmath = %{version}-%{release}
110
111%description -n libRmath-devel
112A standalone library of mathematical and statistical functions derived
113from the R project.  This packages provides the header files.
114
115%description -l ja -n libRmath-devel
116libRmathのヘッダファイル(Rmath.h)
117
118%package -n libRmath-static
119Summary: Static R Standalone math library
120Summary(ja): libRmath の静的ライブラリ
121Group: Development/Libraries
122Requires: libRmath-devel = %{version}-%{release}
123
124%description -n libRmath-static
125A standalone library of mathematical and statistical functions derived
126from the R project.  This package provides the static libRmath library.
127
128
129%prep
130%{__rm} -rf ${RPM_BUILD_ROOT}
131%setup -q
132# %patch0 -p1
133
134%build
135export R_PDFVIEWER="%{_bindir}/xdg-open"
136export R_PRINTCMD="lpr"
137export R_BROWSER="%{_bindir}/xdg-open"
138
139%{configure} --enable-R-shlib --with-tcltk
140
141%{__make} %{?_smp_mflags}
142(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
143LANG=C %{__make} check
144%{__make} pdf
145# We can only "make info" if we have an up to date version of texinfo
146%{?INFO: %{__make} info}
147
148
149%install
150%{make_install}
151%{__make} install-pdf %{?INFO:install-info}
152%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
153%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
154
155#Install libRmath files
156(cd src/nmath/standalone; %{make_install})
157
158%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
159echo "%{_libdir}/R/lib" > \
160     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
161
162#Fix lication of R_HOME_DIR in shell wrapper
163%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
164  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
165%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
166%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
167  > ${RPM_BUILD_ROOT}%{_bindir}/R
168%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
169
170# add R into menu
171%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
172%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
173%{__cp} -a %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/
174%{__cp} -a doc/html/Rlogo.svg ${RPM_BUILD_ROOT}%{_datadir}/icons/
175
176%clean
177%{__rm} -rf ${RPM_BUILD_ROOT}
178
179
180%post
181%if 0%{?INFO}
182   # Create directory entries for info files
183   # (optional doc files, so we must check that they are installed)
184   for doc in admin data exts FAQ intro lang; do
185      file=%{_infodir}/R-${doc}.info.gz
186      if [ -e $file ]; then
187         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
188      fi
189   done
190%endif
191%{_syssbindir}/ldconfig
192
193
194%preun
195%if 0%{?INFO}
196   if [ $1 = 0 ]; then
197      # Delete directory entries for info files (if they were installed)
198      for doc in admin data exts FAQ intro lang; do
199         file=%{_infodir}/R-${doc}.info.gz
200         if [ -e ${file} ]; then
201            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
202         fi
203      done
204   fi
205%endif
206
207%postun -p %{_syssbindir}/ldconfig
208
209%post -n libRmath -p %{_syssbindir}/ldconfig
210
211%postun -n libRmath -p %{_syssbindir}/ldconfig
212
213
214%files
215%defattr(-, root, root)
216%{_bindir}/R
217%{_bindir}/Rscript
218%{_libdir}/R
219%{_datadir}/applications/*
220%{_datadir}/icons/*
221%{?INFO:%{_infodir}/R-*.info*}
222%{_mandir}/man1/*
223/etc/ld.so.conf.d/*
224
225%files devel
226%defattr(-, root, root)
227%doc doc/manual/R-exts.pdf
228
229%files -n libRmath
230%defattr(-, root, root)
231%{_libdir}/libRmath.so
232
233%files -n libRmath-devel
234%defattr(-, root, root)
235%{_libdir}/pkgconfig/*.pc
236%{_includedir}/Rmath.h
237
238%files -n libRmath-static
239%defattr(-, root, root)
240%{_libdir}/libRmath.a
241
242
243%changelog
244* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
245- Updated to 3.3.0
246- add BuildRequires: pcre-devel xz-devel
247- change logo of menu item to Rlogo.svg
248
249* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
250- correct SPEC file
251
252* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
253- Updated to 3.2.4-revised
254
255* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
256- Updated to 3.2.4
257- fixed build error in src/extra/xz
258
259* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
260- add BuildRequires: curl-devel
261- add BuildRequires: libgomp
262
263* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
264- Updated to 3.2.3
265
266* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
267- rebuild with icu-56.1
268
269* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
270- Updated to 3.2.2
271
272* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
273- add configure options: --with-tcltk
274- add BuildRequires: tcl-devel tk-devel
275- add Requires: tcl tk
276
277* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
278- Updated to 3.2.1
279
280* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
281- add "LIBS=-lbz2" to configure option
282
283* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
284- Updated to 3.2.0
285
286* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
287- Updated to 3.1.3
288- added BuildRequires: texlive-collection-fontsextra for Vine6
289- changed option "make check-all" to "make check"
290-   to avoid error in checking of mgcv package
291- changed orders of BuildRequires
292
293* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
294- rebuild with icu-54.1
295
296* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
297- Updated to 3.1.2
298
299* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
300- Updated to 3.1.1
301- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
302
303* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
304- add patch (2014-04-26)
305
306* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
307- Updated to 3.1.0
308
309* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
310- Updated to 3.0.3
311
312* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
313- rebuild current VineSeed
314- add patch (2014-01-06)
315
316* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
317- add Requires: libicu
318
319* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
320- combine spec files Vine6 and VineSeed
321- correct the days of the week in changelog
322
323* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
324- delete BuildRequires: texlive-collection-texinfo
325- add BuildRequires: texlive-collection-plainextra
326- add BuildRequires: texlive-collection-latexextra
327- add BuildRequires: texlive-collection-fontsrecommended
328-   for VineSeed
329
330* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
331- Updated to 3.0.2
332
333* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
334- Updated to 3.0.1
335- add BuildRequires: java-1.6.0-openjdk-devel
336
337* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
338- Updated to 3.0.0
339
340* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
341- Updated to 2.15.3
342- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
343- use BuildRequires ncurses-devel instead of libtermcap-devel
344
345* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
346- Updated to 2.15.2
347
348* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
349- changed group to Applications/Edutainment
350- added R to menu
351
352* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
353- Updated to 2.15.1
354
355* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
356- Updated to 2.15.0
357
358* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
359- Updated to 2.14.2
360
361* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
362- Updated to 2.14.1
363
364* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
365- Updated to 2.14.0
366- add BuildRequires: texlive-collection-fontsextra
367
368* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
369- Updated to 2.13.2
370- add BuildRequires: texlive-common
371- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
372- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
373
374* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
375- synchronized to VinePlus/5 package
376  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
377  - Updated to 2.13.1
378  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
379  - Updated to 2.13.0
380  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
381  - Updated to 2.12.2
382
383* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
384- add BuildRequires: libicu-devel
385
386* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
387- synchronized to VinePlus/5 package
388  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
389  - Updated to 2.12.1
390- added --enable-R-shlib option to %%configure
391- added static subpackage
392- use BR: texlive instead of tetex on VineSeed
393
394* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
395- rebuilt with rpm-4.8.1 for pkg-config
396
397* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
398- recompiled because tcl/tk were not linked
399
400* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
401- Updated to 2.11.0
402- added Requires: libgfortran
403
404* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
405- Updated to 2.10.1
406
407* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
408- patched to 2.10.0
409
410* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
411- spec in UTF-8
412
413* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
414- Updated to 2.10.0
415
416* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
417- Updated to 2.9.2
418- deleted BuildRequires: lapack-devel blas-devel
419- rewrote SPEC file
420
421* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
422- Updated to 2.5.1
423- added BuildRequires: gcc-gfortran for VineSeed
424- added BuildRequires: lapack-devel blas-devel
425v- fixed %preun script
426
427* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
428- Updated to 2.4.1
429- Added INFO option
430- Exclude Japanese Rprofile.site
431
432* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
433- Updated to 2.4.0
434
435* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
436- Added optimization flags
437
438* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
439- Packaged for VineLinux3.2
440
441* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
442- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
443
444* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
445- Packaged for VineLinux3.2
446- Slipped texinfo
447- Fixed preun error
448- Preset Japanese fonts
449
450* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
451- Packaged for VineLinux3.2
452
453* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
454- Restored CAPABILITIES file lost in 2.2.1beta
455
456* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
457- Configure uses --without-blas by default.
458- Install pdf manuals.
459- All toplevel documentation files are installed into _libdir/R
460  as they may be required by R (qv note on AUTHORS and THANKS below).
461- Legacy scripts for rebuilding package indices removed.
462
463* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
464- R now compiles with gcc 4.0.1 and default rpm optimization flags.
465
466* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
467- The files AUTHORS and THANKS need to be installed into _libdir/R
468  as they are required by the function contributors().  Previously
469  they were installed only as documentation files.
470
471* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
472- Corrected date error in SPEC file.
473
474* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
475- Dropped support for Red Hat boxed set.
476- Synchronized with Fedora Extras 4 RPM by Tom Calloway
477  including support for shared R library.
478- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
479  with the default optimization flags, so there is a temporary work-around.
480
481* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
482- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
483
484* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
485- Install R-data.info file as well.
486- Make info processing conditional on texinfo version, not platform release,
487  so that if a new enough version is installed, we will build and install info.
488
489* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
490- Built R 2.1.0.  R now supports internationalization, so the patch
491  to set the locale to "C" is now dropped.
492- install.packages() exits gracefully with a helpful message if
493  the file INSTALL is not present, so this is now included in the
494  R-devel package.
495
496* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
497- Added support for Scientific Linux (http://www.scientificlinux.org)
498  A distribution based on RHEL. Thanks to Jon Peatfield.
499
500* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
501- Fixed file ownership in R-devel and libRmath packages
502
503* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
504- R-devel package is now a stub package with no files, except a documentation
505  file (RPM won't accept sub-packages with no files). R now conflicts
506  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
507- Created libRmath subpackage with shared library.
508
509* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
510- Created R-devel and libRmath-devel subpackages
511
512* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
513- Built R 2.0.1
514
515* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
516- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
517  gives "lpr".
518- Define macro fcx for all Fedora distributions. This replaces Rinfo
519
520* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
521- Info support is now conditional on the macro Rinfo, which is only
522  defined for Fedora 1 and 2.
523
524* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
525- Built R 2.0.0
526- There is no longer a BUGS file, so this is not installed as a
527  documentation file.
Note: See TracBrowser for help on using the repository browser.