source: projects/specs/trunk/R/R/R-vl.spec @ 10138

Revision 10138, 17.4 KB checked in by ara_t, 8 years ago (diff)

update R-3.2.4-revised

Line 
1%define pkg_version 3.2.4
2%define pkg_release 3%{?_dist_release}
3
4Summary:     A language for data analysis and graphics
5Summary(ja): データ解析・グラフィック化の言語
6Name:        R
7Version:     %{pkg_version}
8Release:     %{pkg_release}
9
10License:     GPLv
11Group:       Applications/Edutainment
12URL:         http://www.r-project.org
13
14# Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
15Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}-revised.tar.gz
16Source1:     R.desktop
17# Patch0:      R-release.diff.gz
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: gcc-c++
21BuildRequires: gcc-gfortran libgfortran
22BuildRequires: texinfo
23
24%if %{?_dist_release} == "vl6"
25BuildRequires: tcl tk
26%endif
27%if %{?_dist_release} == "vl7"
28BuildRequires: tcl-devel tk-devel
29%endif
30
31BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
32BuildRequires: readline-devel ncurses-devel
33BuildRequires: zlib-devel bzip2-devel
34BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
35BuildRequires: cairo-devel pango-devel
36BuildRequires: libicu-devel
37BuildRequires: curl-devel
38BuildRequires: texlive-common
39BuildRequires: texlive-collection-basic
40BuildRequires: texlive-collection-latexextra
41BuildRequires: texlive-collection-fontsextra
42
43%if %{?_dist_release} == "vl6"
44BuildRequires: texlive-collection-texinfo
45BuildRequires: java-1.6.0-openjdk-devel
46%endif
47%if %{?_dist_release} == "vl7"
48BuildRequires: texlive-collection-plainextra
49BuildRequires: texlive-collection-fontsrecommended
50BuildRequires: java-1.7.0-openjdk-devel
51%endif
52
53Requires: libgfortran
54Requires: libicu
55Requires: tcl tk
56
57Vendor: Project Vine
58Distribution: Vine Linux
59Packager: Toshiaki Ara <ara_t@384.jp>
60
61%description
62'GNU S' - A language and environment for statistical computing and
63graphics. R is similar to the award-winning S system, which was
64developed at Bell Laboratories by John Chambers et al. It provides
65a wide variety of statistical and graphical techniques (linear and
66nonlinear modelling, statistical tests, time series analysis,
67classification, clustering, ...).
68
69R is designed as a true computer language with control-flow
70constructions for iteration and alternation, and it allows users to
71add additional functionality by defining new functions.
72For computationally intensive tasks, C, C++ and Fortran code
73can be linked and called at run time.
74
75%description -l ja
76'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
77Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
78線形・非線型モデル、統計検定、時系列分析、クラスター分析など
79幅広い統計解析・視覚化手法を提供する。
80Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
81として設計されており、ユーザが新たに関数を組み込むことが可能である。
82また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
83使用することができる。
84
85%package devel
86Summary:          files for development of R packages.
87Summary(ja):      Rパッケージ開発用ファイル
88Group:            Development/Libraries
89Requires:         R = %{version}-%{release}
90
91%description devel
92Install R-devel if you are going to develop or compile R packages.
93
94This is just a stub package containing the documentation on
95"Writing R Extensions".  However, installing it will ensure that
96the build environment for R packages is correct.
97
98%description -l ja devel
99Rパッケージを開発したりコンパイルする場合には、このR-develを
100インストールします。R-exts.pdf ("Writing R Extensions": 英文)
101が含まれているだけのサブパッケージですが、正しくRパッケージを
102開発するための助けになるでしょう。
103
104%package -n libRmath
105Summary:     standalone math library from the R project
106Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
107Group:       System Environment/Libraries
108
109%description -n libRmath
110A standalone library of mathematical and statistical functions derived
111from the R project.  This packages provides the shared libRmath library.
112
113%description -l ja -n libRmath
114単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
115共有ライブラリを提供する。
116
117%package -n libRmath-devel
118Summary:     standalone math library from the R project
119Summary(ja): libRmathの開発ライブラリ
120Group:       Development/Libraries
121Requires:    libRmath = %{version}-%{release}
122
123%description -n libRmath-devel
124A standalone library of mathematical and statistical functions derived
125from the R project.  This packages provides the header files.
126
127%description -l ja -n libRmath-devel
128libRmathのヘッダファイル(Rmath.h)
129
130%package -n libRmath-static
131Summary:     Static R Standalone math library
132Summary(ja): libRmath の静的ライブラリ
133Group:       Development/Libraries
134Requires:    libRmath-devel = %{version}-%{release}
135
136%description -n libRmath-static
137A standalone library of mathematical and statistical functions derived
138from the R project.  This package provides the static libRmath library.
139
140
141%prep
142%{__rm} -rf ${RPM_BUILD_ROOT}
143# %setup -q
144%setup -q -n R-revised
145# %patch0 -p1
146
147%build
148export R_PDFVIEWER="%{_bindir}/xdg-open"
149export R_PRINTCMD="lpr"
150export R_BROWSER="%{_bindir}/xdg-open"
151
152%{configure} --enable-R-shlib --with-tcltk
153
154%{__make} %{?_smp_mflags}
155(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
156LANG=C %{__make} check
157%{__make} pdf
158# We can only "make info" if we have an up to date version of texinfo
159%{?INFO: %{__make} info}
160
161
162%install
163%{make_install}
164%{__make} install-pdf %{?INFO:install-info}
165%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
166%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
167
168#Install libRmath files
169(cd src/nmath/standalone; %{make_install})
170
171%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
172echo "%{_libdir}/R/lib" > \
173     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
174
175#Fix lication of R_HOME_DIR in shell wrapper
176%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
177  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
178%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
179%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
180  > ${RPM_BUILD_ROOT}%{_bindir}/R
181%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
182
183# add R into menu
184%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
185%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
186%{__cp} -a %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/
187%{__cp} -a doc/html/logosm.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
188
189%clean
190%{__rm} -rf ${RPM_BUILD_ROOT}
191
192
193%post
194%if 0%{?INFO}
195   # Create directory entries for info files
196   # (optional doc files, so we must check that they are installed)
197   for doc in admin data exts FAQ intro lang; do
198      file=%{_infodir}/R-${doc}.info.gz
199      if [ -e $file ]; then
200         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
201      fi
202   done
203%endif
204%{_syssbindir}/ldconfig
205
206
207%preun
208%if 0%{?INFO}
209   if [ $1 = 0 ]; then
210      # Delete directory entries for info files (if they were installed)
211      for doc in admin data exts FAQ intro lang; do
212         file=%{_infodir}/R-${doc}.info.gz
213         if [ -e ${file} ]; then
214            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
215         fi
216      done
217   fi
218%endif
219
220%postun -p %{_syssbindir}/ldconfig
221
222%post -n libRmath -p %{_syssbindir}/ldconfig
223
224%postun -n libRmath -p %{_syssbindir}/ldconfig
225
226
227%files
228%defattr(-, root, root)
229%{_bindir}/R
230%{_bindir}/Rscript
231%{_libdir}/R
232%{_datadir}/applications/*
233%{_datadir}/icons/*
234%{?INFO:%{_infodir}/R-*.info*}
235%{_mandir}/man1/*
236/etc/ld.so.conf.d/*
237
238%files devel
239%defattr(-, root, root)
240%doc doc/manual/R-exts.pdf
241
242%files -n libRmath
243%defattr(-, root, root)
244%{_libdir}/libRmath.so
245
246%files -n libRmath-devel
247%defattr(-, root, root)
248%{_libdir}/pkgconfig/*.pc
249%{_includedir}/Rmath.h
250
251%files -n libRmath-static
252%defattr(-, root, root)
253%{_libdir}/libRmath.a
254
255
256%changelog
257* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
258- correct SPEC file
259
260* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
261- Updated to 3.2.4-revised
262
263* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
264- Updated to 3.2.4
265- fixed build error in src/extra/xz
266
267* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
268- add BuildRequires: curl-devel
269- add BuildRequires: libgomp
270
271* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
272- Updated to 3.2.3
273
274* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
275- rebuild with icu-56.1
276
277* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
278- Updated to 3.2.2
279
280* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
281- add configure options: --with-tcltk
282- add BuildRequires: tcl-devel tk-devel
283- add Requires: tcl tk
284
285* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
286- Updated to 3.2.1
287
288* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
289- add "LIBS=-lbz2" to configure option
290
291* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
292- Updated to 3.2.0
293
294* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
295- Updated to 3.1.3
296- added BuildRequires: texlive-collection-fontsextra for Vine6
297- changed option "make check-all" to "make check"
298-   to avoid error in checking of mgcv package
299- changed orders of BuildRequires
300
301* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
302- rebuild with icu-54.1
303
304* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
305- Updated to 3.1.2
306
307* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
308- Updated to 3.1.1
309- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
310
311* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
312- add patch (2014-04-26)
313
314* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
315- Updated to 3.1.0
316
317* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
318- Updated to 3.0.3
319
320* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
321- rebuild current VineSeed
322- add patch (2014-01-06)
323
324* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
325- add Requires: libicu
326
327* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
328- combine spec files Vine6 and VineSeed
329- correct the days of the week in changelog
330
331* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
332- delete BuildRequires: texlive-collection-texinfo
333- add BuildRequires: texlive-collection-plainextra
334- add BuildRequires: texlive-collection-latexextra
335- add BuildRequires: texlive-collection-fontsrecommended
336-   for VineSeed
337
338* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
339- Updated to 3.0.2
340
341* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
342- Updated to 3.0.1
343- add BuildRequires: java-1.6.0-openjdk-devel
344
345* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
346- Updated to 3.0.0
347
348* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
349- Updated to 2.15.3
350- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
351- use BuildRequires ncurses-devel instead of libtermcap-devel
352
353* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
354- Updated to 2.15.2
355
356* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
357- changed group to Applications/Edutainment
358- added R to menu
359
360* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
361- Updated to 2.15.1
362
363* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
364- Updated to 2.15.0
365
366* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
367- Updated to 2.14.2
368
369* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
370- Updated to 2.14.1
371
372* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
373- Updated to 2.14.0
374- add BuildRequires: texlive-collection-fontsextra
375
376* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
377- Updated to 2.13.2
378- add BuildRequires: texlive-common
379- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
380- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
381
382* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
383- synchronized to VinePlus/5 package
384  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
385  - Updated to 2.13.1
386  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
387  - Updated to 2.13.0
388  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
389  - Updated to 2.12.2
390
391* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
392- add BuildRequires: libicu-devel
393
394* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
395- synchronized to VinePlus/5 package
396  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
397  - Updated to 2.12.1
398- added --enable-R-shlib option to %%configure
399- added static subpackage
400- use BR: texlive instead of tetex on VineSeed
401
402* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
403- rebuilt with rpm-4.8.1 for pkg-config
404
405* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
406- recompiled because tcl/tk were not linked
407
408* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
409- Updated to 2.11.0
410- added Requires: libgfortran
411
412* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
413- Updated to 2.10.1
414
415* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
416- patched to 2.10.0
417
418* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
419- spec in UTF-8
420
421* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
422- Updated to 2.10.0
423
424* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
425- Updated to 2.9.2
426- deleted BuildRequires: lapack-devel blas-devel
427- rewrote SPEC file
428
429* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
430- Updated to 2.5.1
431- added BuildRequires: gcc-gfortran for VineSeed
432- added BuildRequires: lapack-devel blas-devel
433v- fixed %preun script
434
435* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
436- Updated to 2.4.1
437- Added INFO option
438- Exclude Japanese Rprofile.site
439
440* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
441- Updated to 2.4.0
442
443* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
444- Added optimization flags
445
446* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
447- Packaged for VineLinux3.2
448
449* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
450- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
451
452* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
453- Packaged for VineLinux3.2
454- Slipped texinfo
455- Fixed preun error
456- Preset Japanese fonts
457
458* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
459- Packaged for VineLinux3.2
460
461* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
462- Restored CAPABILITIES file lost in 2.2.1beta
463
464* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
465- Configure uses --without-blas by default.
466- Install pdf manuals.
467- All toplevel documentation files are installed into _libdir/R
468  as they may be required by R (qv note on AUTHORS and THANKS below).
469- Legacy scripts for rebuilding package indices removed.
470
471* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
472- R now compiles with gcc 4.0.1 and default rpm optimization flags.
473
474* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
475- The files AUTHORS and THANKS need to be installed into _libdir/R
476  as they are required by the function contributors().  Previously
477  they were installed only as documentation files.
478
479* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
480- Corrected date error in SPEC file.
481
482* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
483- Dropped support for Red Hat boxed set.
484- Synchronized with Fedora Extras 4 RPM by Tom Calloway
485  including support for shared R library.
486- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
487  with the default optimization flags, so there is a temporary work-around.
488
489* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
490- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
491
492* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
493- Install R-data.info file as well.
494- Make info processing conditional on texinfo version, not platform release,
495  so that if a new enough version is installed, we will build and install info.
496
497* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
498- Built R 2.1.0.  R now supports internationalization, so the patch
499  to set the locale to "C" is now dropped.
500- install.packages() exits gracefully with a helpful message if
501  the file INSTALL is not present, so this is now included in the
502  R-devel package.
503
504* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
505- Added support for Scientific Linux (http://www.scientificlinux.org)
506  A distribution based on RHEL. Thanks to Jon Peatfield.
507
508* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
509- Fixed file ownership in R-devel and libRmath packages
510
511* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
512- R-devel package is now a stub package with no files, except a documentation
513  file (RPM won't accept sub-packages with no files). R now conflicts
514  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
515- Created libRmath subpackage with shared library.
516
517* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
518- Created R-devel and libRmath-devel subpackages
519
520* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
521- Built R 2.0.1
522
523* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
524- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
525  gives "lpr".
526- Define macro fcx for all Fedora distributions. This replaces Rinfo
527
528* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
529- Info support is now conditional on the macro Rinfo, which is only
530  defined for Fedora 1 and 2.
531
532* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
533- Built R 2.0.0
534- There is no longer a BUGS file, so this is not installed as a
535  documentation file.
Note: See TracBrowser for help on using the repository browser.