source: projects/specs/trunk/R/R/R-vl.spec @ 1052

Revision 1052, 11.2 KB checked in by inagaki, 14 years ago (diff)

updated: R

Line 
1%define pkg_version 2.11.0
2%define pkg_release 2%{?_dist_release}
3
4Summary:          A language for data analysis and graphics
5Summary(ja):      データ解析・グラフィック化の言語
6Name:             R
7Version:          %{pkg_version}
8Release:          %{pkg_release}
9Source0:          ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
10#Patch0:           R-release.diff.gz
11License:          GPL2
12Group:            Applications/Engineering
13URL:              http://www.r-project.org
14
15Requires: libgfortran
16
17BuildRequires: gcc-c++
18BuildRequires: gcc-gfortran libgfortran
19BuildRequires: tetex texinfo tcl tk
20BuildRequires: libpng-devel libjpeg-devel
21BuildRequires: readline-devel libtermcap-devel
22BuildRequires: zlib-devel bzip2-devel XOrg-devel
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: Toshiaki Ara <ara_t@384.jp>
28
29%description
30'GNU S' - A language and environment for statistical computing and
31graphics. R is similar to the award-winning S system, which was
32developed at Bell Laboratories by John Chambers et al. It provides
33a wide variety of statistical and graphical techniques (linear and
34nonlinear modelling, statistical tests, time series analysis,
35classification, clustering, ...).
36
37R is designed as a true computer language with control-flow
38constructions for iteration and alternation, and it allows users to
39add additional functionality by defining new functions.
40For computationally intensive tasks, C, C++ and Fortran code
41can be linked and called at run time.
42
43%description -l ja
44'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
45Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
46線形・非線型モデル、統計検定、時系列分析、クラスター分析など
47幅広い統計解析・視覚化手法を提供する。
48Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
49として設計されており、ユーザが新たに関数を組み込むことが可能である。
50また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
51使用することができる。
52
53%package devel
54Summary:          files for development of R packages.
55Summary(ja):      Rパッケージ開発用ファイル
56Group:            Development/Libraries
57Requires:         R = %{version}-%{release}
58
59%description devel
60Install R-devel if you are going to develop or compile R packages.
61
62This is just a stub package containing the documentation on "Writing R
63Extensions".  However, installing it will ensure that the build
64environment for R packages is correct.
65
66%description -l ja devel
67Rパッケージを開発したりコンパイルする場合には、このR-develを
68インストールします。R-exts.pdf ("Writing R Extensions": 英文)
69が含まれているだけのサブパッケージですが、正しくRパッケージを
70開発するための助けになるでしょう。
71
72%package -n libRmath
73Summary:          standalone math library from the R project
74Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
75Group:            System Environment/Libraries
76
77%description -n libRmath
78A standalone library of mathematical and statistical functions derived
79from the R project.  This packages provides the shared libRmath library.
80
81%description -l ja -n libRmath
82単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
83共有ライブラリを提供する。
84
85%package -n libRmath-devel
86Summary:          standalone math library from the R project
87Summary(ja):      libRmathの開発ライブラリ
88Group:            Development/Libraries
89Requires:         libRmath = %{version}-%{release}
90
91%description -n libRmath-devel
92A standalone library of mathematical and statistical functions derived
93from the R project.  This packages provides the header files.
94
95%description -l ja -n libRmath-devel
96libRmathのヘッダファイル(Rmath.h)
97
98%prep
99%{__rm} -rf ${RPM_BUILD_ROOT}
100%setup -q
101#%patch0 -p1
102
103%build
104export R_BROWSER="%{_bindir}/firefox"
105%configure
106%{__make} %{?_smp_mflags}
107(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
108LANG=C make check-all
109%{__make} pdf
110#We can only "make info" if we have an up to date version of texinfo
111%{?INFO: %{__make} info}
112
113
114%install
115%{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
116%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
117%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
118
119#Install libRmath files
120(cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
121
122mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
123echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
124
125#Fix lication of R_HOME_DIR in shell wrapper
126sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
127  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
128chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
129sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
130  > ${RPM_BUILD_ROOT}%{_bindir}/R
131chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
132
133
134%files
135%defattr(-, root, root)
136%{_bindir}/R
137%{_bindir}/Rscript
138%{_libdir}/R
139%{?INFO:%{_infodir}/R-*.info*}
140%{_mandir}/man1/*
141/etc/ld.so.conf.d/*
142
143%files devel
144%defattr(-, root, root)
145%doc doc/manual/R-exts.pdf
146
147%files -n libRmath
148%defattr(-, root, root)
149%{_libdir}/libRmath.so
150
151%files -n libRmath-devel
152%defattr(-, root, root)
153%{_libdir}/pkgconfig/*.pc
154%{_includedir}/Rmath.h
155
156%clean
157%{__rm} -rf ${RPM_BUILD_ROOT}
158
159
160%post
161%if 0%{?INFO}
162   # Create directory entries for info files
163   # (optional doc files, so we must check that they are installed)
164   for doc in admin data exts FAQ intro lang; do
165      file=%{_infodir}/R-${doc}.info.gz
166      if [ -e $file ]; then
167         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
168      fi
169   done
170%endif
171%{_syssbindir}/ldconfig
172
173%preun
174%if 0%{?INFO}
175   if [ $1 = 0 ]; then
176      # Delete directory entries for info files (if they were installed)
177      for doc in admin data exts FAQ intro lang; do
178         file=%{_infodir}/R-${doc}.info.gz
179         if [ -e ${file} ]; then
180            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
181         fi
182      done
183   fi
184%endif
185
186%postun -p %{_syssbindir}/ldconfig
187
188%post -n libRmath -p %{_syssbindir}/ldconfig
189
190%postun -n libRmath -p %{_syssbindir}/ldconfig
191
192
193%changelog
194* Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
195- recompiled because tcl/tk were not linked
196
197* Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
198- Updated to 2.11.0
199- added Requires: libgfortran
200
201* Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
202- Updated to 2.10.1
203
204* Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
205- patched to 2.10.0
206
207* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
208- spec in UTF-8
209
210* Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
211- Updated to 2.10.0
212
213* Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
214- Updated to 2.9.2
215- deleted BuildRequires: lapack-devel blas-devel
216- rewrote SPEC file
217
218* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
219- Updated to 2.5.1
220- added BuildRequires: gcc-gfortran for VineSeed
221- added BuildRequires: lapack-devel blas-devel
222- fixed %preun script
223
224* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
225- Updated to 2.4.1
226- Added INFO option
227- Exclude Japanese Rprofile.site
228
229* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
230- Updated to 2.4.0
231
232* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
233- Added optimization flags
234
235* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
236- Packaged for VineLinux3.2
237
238* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
239- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
240
241* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
242- Packaged for VineLinux3.2
243- Slipped texinfo
244- Fixed preun error
245- Preset Japanese fonts
246
247* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
248- Packaged for VineLinux3.2
249
250* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
251- Restored CAPABILITIES file lost in 2.2.1beta
252
253* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
254- Configure uses --without-blas by default.
255- Install pdf manuals.
256- All toplevel documentation files are installed into _libdir/R
257  as they may be required by R (qv note on AUTHORS and THANKS below).
258- Legacy scripts for rebuilding package indices removed.
259
260* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
261- R now compiles with gcc 4.0.1 and default rpm optimization flags.
262
263* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
264- The files AUTHORS and THANKS need to be installed into _libdir/R
265  as they are required by the function contributors().  Previously
266  they were installed only as documentation files.
267
268* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
269- Corrected date error in SPEC file.
270
271* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
272- Dropped support for Red Hat boxed set.
273- Synchronized with Fedora Extras 4 RPM by Tom Calloway
274  including support for shared R library.
275- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
276  with the default optimization flags, so there is a temporary work-around.
277
278* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
279- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
280
281* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
282- Install R-data.info file as well.
283- Make info processing conditional on texinfo version, not platform release,
284  so that if a new enough version is installed, we will build and install info.
285
286* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
287- Built R 2.1.0.  R now supports internationalization, so the patch
288  to set the locale to "C" is now dropped.
289- install.packages() exits gracefully with a helpful message if
290  the file INSTALL is not present, so this is now included in the
291  R-devel package.
292
293* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
294- Added support for Scientific Linux (http://www.scientificlinux.org)
295  A distribution based on RHEL. Thanks to Jon Peatfield.
296
297* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
298- Fixed file ownership in R-devel and libRmath packages
299
300* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
301- R-devel package is now a stub package with no files, except a documentation
302  file (RPM won't accept sub-packages with no files). R now conflicts
303  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
304- Created libRmath subpackage with shared library.
305
306* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
307- Created R-devel and libRmath-devel subpackages
308
309* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
310- Built R 2.0.1
311
312* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
313- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
314  gives "lpr".
315- Define macro fcx for all Fedora distributions. This replaces Rinfo
316
317* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
318- Info support is now conditional on the macro Rinfo, which is only
319  defined for Fedora 1 and 2.
320
321* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
322- Built R 2.0.0
323- There is no longer a BUGS file, so this is not installed as a
324  documentation file.
Note: See TracBrowser for help on using the repository browser.