source: projects/specs/trunk/R/R/R-vl.spec @ 11245

Revision 11245, 18.4 KB checked in by ara_t, 7 years ago (diff)

R: update to 3.4.3

Line 
1%define pkg_name    R
2%define pkg_version 3.4.3
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License:     GPLv2
12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
14
15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16# Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
17# Patch0:      R-release.diff.gz
18
19# To avoid 'make check error'
20Patch1:      reg-tests-3.R.patch
21Patch2:      reg-tests-3.Rout.save.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: gcc-c++
25BuildRequires: gcc-gfortran libgfortran
26BuildRequires: texinfo
27%if %{?_dist_release} == "vl6"
28BuildRequires: R-pcre-devel
29BuildRequires: tcl85-devel tk85-devel
30%endif
31%if %{?_dist_release} >= "vl7"
32BuildRequires: pcre-devel
33BuildRequires: tcl-devel tk-devel
34%endif
35BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
36BuildRequires: readline-devel ncurses-devel
37BuildRequires: zlib-devel bzip2-devel xz-devel
38BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
39BuildRequires: cairo-devel pango-devel
40BuildRequires: libicu-devel
41BuildRequires: curl-devel
42BuildRequires: texlive-common
43BuildRequires: texlive-collection-basic
44BuildRequires: texlive-collection-latexextra
45BuildRequires: texlive-collection-fontsextra
46%if %{?_dist_release} == "vl6"
47BuildRequires: texlive-collection-texinfo
48%endif
49%if %{?_dist_release} >= "vl7"
50BuildRequires: texlive-collection-plaingeneric
51BuildRequires: texlive-collection-fontsrecommended
52%endif
53BuildRequires: java-devel
54
55Requires: gcc-gfortran
56Requires: libgfortran
57Requires: libicu
58%if %{?_dist_release} == "vl6"
59Requires: tcl85 tk85
60Requires: R-pcre
61%endif
62%if %{?_dist_release} >= "vl7"
63Requires: tcl tk
64%endif
65
66Conflicts: R-devel < %{version}-%{release}
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: ara_t
71
72
73%description
74'GNU S' - A language and environment for statistical computing and
75graphics. R is similar to the award-winning S system, which was
76developed at Bell Laboratories by John Chambers et al. It provides
77a wide variety of statistical and graphical techniques (linear and
78nonlinear modelling, statistical tests, time series analysis,
79classification, clustering, ...).
80
81R is designed as a true computer language with control-flow
82constructions for iteration and alternation, and it allows users to
83add additional functionality by defining new functions.
84For computationally intensive tasks, C, C++ and Fortran code
85can be linked and called at run time.
86
87%description -l ja
88'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
89Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
90線形・非線型モデル、統計検定、時系列分析、クラスター分析など
91幅広い統計解析・視覚化手法を提供する。
92Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
93として設計されており、ユーザが新たに関数を組み込むことが可能である。
94また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
95使用することができる。
96
97%package -n libRmath
98Summary:          standalone math library from the R project
99Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
100Group:            System Environment/Libraries
101
102%description -n libRmath
103A standalone library of mathematical and statistical functions derived
104from the R project.  This packages provides the shared libRmath library.
105
106%description -l ja -n libRmath
107単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
108共有ライブラリを提供する。
109
110%package -n libRmath-devel
111Summary:          standalone math library from the R project
112Summary(ja):      libRmathの開発ライブラリ
113Group:            Development/Libraries
114Requires:         libRmath = %{version}-%{release}
115
116%description -n libRmath-devel
117A standalone library of mathematical and statistical functions derived
118from the R project.  This packages provides the header files.
119
120%description -l ja -n libRmath-devel
121libRmathのヘッダファイル(Rmath.h)
122
123%package -n libRmath-static
124Summary: Static R Standalone math library
125Summary(ja): libRmath の静的ライブラリ
126Group: Development/Libraries
127Requires: libRmath-devel = %{version}-%{release}
128
129%description -n libRmath-static
130A standalone library of mathematical and statistical functions derived
131from the R project.  This package provides the static libRmath library.
132
133
134%prep
135%{__rm} -rf ${RPM_BUILD_ROOT}
136%setup -q
137# %patch0 -p1
138%patch1
139%patch2
140
141cat > R.desktop <<EOF
142[Desktop Entry]
143Name=GNU R
144Comment=A language for data analysis and graphics
145TryExec=/usr/bin/R
146Exec=/usr/bin/R
147Icon=/usr/share/icons/logo.jpg
148Terminal=true
149Type=Application
150Categories=Education;Science;
151StartupNotify=false
152EOF
153
154%build
155export R_PDFVIEWER="%{_bindir}/xdg-open"
156export R_PRINTCMD="lpr"
157export R_BROWSER="%{_bindir}/xdg-open"
158%if %{?_dist_release} == "vl6"
159export LD_LIBRARY_PATH=%{_libdir}/R/lib
160%endif
161
162%{configure} --enable-R-shlib --with-tcltk \
163%if %{?_dist_release} == "vl6"
164 --with-tcl-config=%{_libdir}/tclConfig85.sh \
165 --with-tk-config=%{_libdir}/tkConfig85.sh \
166 CPPFLAGS="-I%{_libdir}/R/include" \
167 LDFLAGS="-L%{_libdir}/R/lib"
168%endif
169
170%{__make} %{?_smp_mflags}
171(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
172%{__make} pdf
173
174%install
175%{make_install}
176%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
177%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
178%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
179
180# Install libRmath files
181(cd src/nmath/standalone; %{make_install})
182
183%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
184echo "%{_libdir}/R/lib" > \
185     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
186
187# Fix lication of R_HOME_DIR in shell wrapper
188%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
189  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
190%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
191%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
192  > ${RPM_BUILD_ROOT}%{_bindir}/R
193%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
194
195# add R into menu
196%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
197%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
198%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
199%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
200
201# move manuals
202%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
203%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
204 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
205
206%check
207export TZ="Asia/Tokyo"
208LANG=C %{__make} check
209
210%clean
211%{__rm} -rf ${RPM_BUILD_ROOT}
212
213
214%post -p %{_syssbindir}/ldconfig
215
216%postun -p %{_syssbindir}/ldconfig
217
218%post -n libRmath -p %{_syssbindir}/ldconfig
219
220%postun -n libRmath -p %{_syssbindir}/ldconfig
221
222
223%files
224%defattr(-, root, root)
225%{_bindir}/R
226%{_bindir}/Rscript
227%{_libdir}/R
228%{_datadir}/applications/*
229%{_datadir}/icons/*
230%{_mandir}/man1/*
231%{_docdir}/%{name}-%{version}
232%{_sysconfdir}/ld.so.conf.d/*
233
234%files -n libRmath
235%defattr(-, root, root)
236%{_libdir}/libRmath.so
237
238%files -n libRmath-devel
239%defattr(-, root, root)
240%{_libdir}/pkgconfig/*.pc
241%{_includedir}/Rmath.h
242
243%files -n libRmath-static
244%defattr(-, root, root)
245%{_libdir}/libRmath.a
246
247
248%changelog
249* Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
250- Updated to 3.4.3
251
252* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
253- Updated to 3.4.2
254- change download URL
255
256* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
257- left %%{_libdir}/R/doc
258
259* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
260- Updated to 3.4.1
261- rebuild under R-pcre (pcre-8.39) for Vine6
262- add Requires: gcc-gfortran
263- change to BuildRequires: texlive-collection-plaingeneric
264- delete unnecessary descriptions
265
266* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
267- Updated to 3.4.0
268- add Patch1 and Patch2 to avoid 'make check' error
269- add export TZ="Asia/Tokyo" to avoid 'make check' error
270- delete descrption about info
271
272* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
273- Updated to 3.3.3
274
275* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
276- use tcl-8.5/tk-8.5 for Vine6.5
277  - BuildRequires to tcl85-devel/tk85-devel
278  - Requires to tcl85/tk85
279
280* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
281- merge SPEC file for Vine6
282- drop devel package
283- move PDF manuals to /usr/share/doc/R-%%{version}
284- revert logo of menu item to logo.jpg
285
286* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
287- Updated to 3.3.2
288
289* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
290- Updated to 3.3.1
291- delete BuildRequires: texlive-collection-lang*
292
293* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
294- add BuildRequires: texlive-collection-lang*
295
296* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
297- Updated to 3.3.0
298- add BuildRequires: pcre-devel xz-devel
299- change logo of menu item to Rlogo.svg
300
301* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
302- correct SPEC file
303
304* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
305- Updated to 3.2.4-revised
306
307* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
308- Updated to 3.2.4
309- fixed build error in src/extra/xz
310
311* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
312- add BuildRequires: curl-devel
313- add BuildRequires: libgomp
314
315* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
316- Updated to 3.2.3
317
318* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
319- rebuild with icu-56.1
320
321* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
322- Updated to 3.2.2
323
324* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
325- add configure options: --with-tcltk
326- add BuildRequires: tcl-devel tk-devel
327- add Requires: tcl tk
328
329* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
330- Updated to 3.2.1
331
332* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
333- add "LIBS=-lbz2" to configure option
334
335* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
336- Updated to 3.2.0
337
338* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
339- Updated to 3.1.3
340- added BuildRequires: texlive-collection-fontsextra for Vine6
341- changed option "make check-all" to "make check"
342-   to avoid error in checking of mgcv package
343- changed orders of BuildRequires
344
345* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
346- rebuild with icu-54.1
347
348* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
349- Updated to 3.1.2
350
351* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
352- Updated to 3.1.1
353- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
354
355* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
356- add patch (2014-04-26)
357
358* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
359- Updated to 3.1.0
360
361* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
362- Updated to 3.0.3
363
364* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
365- rebuild current VineSeed
366- add patch (2014-01-06)
367
368* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
369- add Requires: libicu
370
371* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
372- combine spec files Vine6 and VineSeed
373- correct the days of the week in changelog
374
375* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
376- delete BuildRequires: texlive-collection-texinfo
377- add BuildRequires: texlive-collection-plainextra
378- add BuildRequires: texlive-collection-latexextra
379- add BuildRequires: texlive-collection-fontsrecommended
380-   for VineSeed
381
382* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
383- Updated to 3.0.2
384
385* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
386- Updated to 3.0.1
387- add BuildRequires: java-1.6.0-openjdk-devel
388
389* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
390- Updated to 3.0.0
391
392* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
393- Updated to 2.15.3
394- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
395- use BuildRequires ncurses-devel instead of libtermcap-devel
396
397* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
398- Updated to 2.15.2
399
400* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
401- changed group to Applications/Edutainment
402- added R to menu
403
404* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
405- Updated to 2.15.1
406
407* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
408- Updated to 2.15.0
409
410* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
411- Updated to 2.14.2
412
413* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
414- Updated to 2.14.1
415
416* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
417- Updated to 2.14.0
418- add BuildRequires: texlive-collection-fontsextra
419
420* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
421- Updated to 2.13.2
422- add BuildRequires: texlive-common
423- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
424- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
425
426* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
427- synchronized to VinePlus/5 package
428  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
429  - Updated to 2.13.1
430  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
431  - Updated to 2.13.0
432  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
433  - Updated to 2.12.2
434
435* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
436- add BuildRequires: libicu-devel
437
438* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
439- synchronized to VinePlus/5 package
440  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
441  - Updated to 2.12.1
442- added --enable-R-shlib option to %%configure
443- added static subpackage
444- use BR: texlive instead of tetex on VineSeed
445
446* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
447- rebuilt with rpm-4.8.1 for pkg-config
448
449* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
450- recompiled because tcl/tk were not linked
451
452* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
453- Updated to 2.11.0
454- added Requires: libgfortran
455
456* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
457- Updated to 2.10.1
458
459* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
460- patched to 2.10.0
461
462* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
463- spec in UTF-8
464
465* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
466- Updated to 2.10.0
467
468* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
469- Updated to 2.9.2
470- deleted BuildRequires: lapack-devel blas-devel
471- rewrote SPEC file
472
473* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
474- Updated to 2.5.1
475- added BuildRequires: gcc-gfortran for VineSeed
476- added BuildRequires: lapack-devel blas-devel
477v- fixed %preun script
478
479* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
480- Updated to 2.4.1
481- Added INFO option
482- Exclude Japanese Rprofile.site
483
484* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
485- Updated to 2.4.0
486
487* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
488- Added optimization flags
489
490* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
491- Packaged for VineLinux3.2
492
493* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
494- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
495
496* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
497- Packaged for VineLinux3.2
498- Slipped texinfo
499- Fixed preun error
500- Preset Japanese fonts
501
502* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
503- Packaged for VineLinux3.2
504
505* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
506- Restored CAPABILITIES file lost in 2.2.1beta
507
508* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
509- Configure uses --without-blas by default.
510- Install pdf manuals.
511- All toplevel documentation files are installed into _libdir/R
512  as they may be required by R (qv note on AUTHORS and THANKS below).
513- Legacy scripts for rebuilding package indices removed.
514
515* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
516- R now compiles with gcc 4.0.1 and default rpm optimization flags.
517
518* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
519- The files AUTHORS and THANKS need to be installed into _libdir/R
520  as they are required by the function contributors().  Previously
521  they were installed only as documentation files.
522
523* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
524- Corrected date error in SPEC file.
525
526* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
527- Dropped support for Red Hat boxed set.
528- Synchronized with Fedora Extras 4 RPM by Tom Calloway
529  including support for shared R library.
530- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
531  with the default optimization flags, so there is a temporary work-around.
532
533* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
534- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
535
536* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
537- Install R-data.info file as well.
538- Make info processing conditional on texinfo version, not platform release,
539  so that if a new enough version is installed, we will build and install info.
540
541* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
542- Built R 2.1.0.  R now supports internationalization, so the patch
543  to set the locale to "C" is now dropped.
544- install.packages() exits gracefully with a helpful message if
545  the file INSTALL is not present, so this is now included in the
546  R-devel package.
547
548* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
549- Added support for Scientific Linux (http://www.scientificlinux.org)
550  A distribution based on RHEL. Thanks to Jon Peatfield.
551
552* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
553- Fixed file ownership in R-devel and libRmath packages
554
555* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
556- R-devel package is now a stub package with no files, except a documentation
557  file (RPM won't accept sub-packages with no files). R now conflicts
558  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
559- Created libRmath subpackage with shared library.
560
561* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
562- Created R-devel and libRmath-devel subpackages
563
564* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
565- Built R 2.0.1
566
567* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
568- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
569  gives "lpr".
570- Define macro fcx for all Fedora distributions. This replaces Rinfo
571
572* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
573- Info support is now conditional on the macro Rinfo, which is only
574  defined for Fedora 1 and 2.
575
576* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
577- Built R 2.0.0
578- There is no longer a BUGS file, so this is not installed as a
579  documentation file.
Note: See TracBrowser for help on using the repository browser.