source: projects/specs/trunk/R/R/R-vl.spec @ 11193

Revision 11193, 18.3 KB checked in by ara_t, 7 years ago (diff)

R: update to 3.4.2

RevLine 
[10222]1%define pkg_name    R
[11193]2%define pkg_version 3.4.2
3%define pkg_release 1%{?_dist_release}
[521]4
[9800]5Summary:     A language for data analysis and graphics
6Summary(ja): データ解析・グラフィック化の言語
[10222]7Name:        %{pkg_name}
[9800]8Version:     %{pkg_version}
9Release:     %{pkg_release}
[4745]10
[10222]11License:     GPLv2
[9800]12Group:       Applications/Edutainment
13URL:         http://www.r-project.org
[521]14
[11193]15Source0:     https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
16# Source0:     ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
[9800]17# Patch0:      R-release.diff.gz
[1052]18
[11051]19# To avoid 'make check error'
20Patch1:      reg-tests-3.R.patch
21Patch2:      reg-tests-3.Rout.save.patch
22
[2765]23BuildRoot: %{_tmppath}/%{name}-%{version}-root
[521]24BuildRequires: gcc-c++
[1052]25BuildRequires: gcc-gfortran libgfortran
[9800]26BuildRequires: texinfo
[10817]27%if %{?_dist_release} == "vl6"
[11121]28BuildRequires: R-pcre-devel
[10817]29BuildRequires: tcl85-devel tk85-devel
30%endif
31%if %{?_dist_release} >= "vl7"
[11121]32BuildRequires: pcre-devel
[9800]33BuildRequires: tcl-devel tk-devel
[10817]34%endif
[9800]35BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
36BuildRequires: readline-devel ncurses-devel
[10222]37BuildRequires: zlib-devel bzip2-devel xz-devel
[9800]38BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
39BuildRequires: cairo-devel pango-devel
40BuildRequires: libicu-devel
[10135]41BuildRequires: curl-devel
[7300]42BuildRequires: texlive-common
43BuildRequires: texlive-collection-basic
[9222]44BuildRequires: texlive-collection-latexextra
[9800]45BuildRequires: texlive-collection-fontsextra
[10817]46%if %{?_dist_release} == "vl6"
47BuildRequires: texlive-collection-texinfo
48%endif
49%if %{?_dist_release} >= "vl7"
[11121]50BuildRequires: texlive-collection-plaingeneric
[9222]51BuildRequires: texlive-collection-fontsrecommended
[10817]52%endif
[10799]53BuildRequires: java-devel
[9222]54
[11121]55Requires: gcc-gfortran
[4745]56Requires: libgfortran
[9222]57Requires: libicu
[10817]58%if %{?_dist_release} == "vl6"
59Requires: tcl85 tk85
[11121]60Requires: R-pcre
[10817]61%endif
62%if %{?_dist_release} >= "vl7"
[9800]63Requires: tcl tk
[10817]64%endif
[521]65
[10817]66Conflicts: R-devel < %{version}-%{release}
67
[521]68Vendor: Project Vine
69Distribution: Vine Linux
[10222]70Packager: ara_t
[521]71
[10222]72
[521]73%description
74'GNU S' - A language and environment for statistical computing and
75graphics. R is similar to the award-winning S system, which was
76developed at Bell Laboratories by John Chambers et al. It provides
77a wide variety of statistical and graphical techniques (linear and
78nonlinear modelling, statistical tests, time series analysis,
79classification, clustering, ...).
80
81R is designed as a true computer language with control-flow
82constructions for iteration and alternation, and it allows users to
83add additional functionality by defining new functions.
84For computationally intensive tasks, C, C++ and Fortran code
85can be linked and called at run time.
86
87%description -l ja
88'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
89Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
90線形・非線型モデル、統計検定、時系列分析、クラスター分析など
91幅広い統計解析・視覚化手法を提供する。
92Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
93として設計されており、ユーザが新たに関数を組み込むことが可能である。
94また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
95使用することができる。
96
97%package -n libRmath
[10222]98Summary:          standalone math library from the R project
99Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
100Group:            System Environment/Libraries
[521]101
102%description -n libRmath
103A standalone library of mathematical and statistical functions derived
104from the R project.  This packages provides the shared libRmath library.
105
106%description -l ja -n libRmath
107単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
108共有ライブラリを提供する。
109
110%package -n libRmath-devel
[10222]111Summary:          standalone math library from the R project
112Summary(ja):      libRmathの開発ライブラリ
113Group:            Development/Libraries
114Requires:         libRmath = %{version}-%{release}
[521]115
116%description -n libRmath-devel
117A standalone library of mathematical and statistical functions derived
118from the R project.  This packages provides the header files.
119
120%description -l ja -n libRmath-devel
121libRmathのヘッダファイル(Rmath.h)
122
[2765]123%package -n libRmath-static
[10222]124Summary: Static R Standalone math library
[2765]125Summary(ja): libRmath の静的ライブラリ
[10222]126Group: Development/Libraries
127Requires: libRmath-devel = %{version}-%{release}
[2765]128
129%description -n libRmath-static
130A standalone library of mathematical and statistical functions derived
131from the R project.  This package provides the static libRmath library.
132
133
[521]134%prep
135%{__rm} -rf ${RPM_BUILD_ROOT}
[10222]136%setup -q
[9222]137# %patch0 -p1
[11051]138%patch1
139%patch2
[521]140
[10817]141cat > R.desktop <<EOF
142[Desktop Entry]
143Name=GNU R
144Comment=A language for data analysis and graphics
145TryExec=/usr/bin/R
146Exec=/usr/bin/R
147Icon=/usr/share/icons/logo.jpg
148Terminal=true
149Type=Application
150Categories=Education;Science;
151StartupNotify=false
152EOF
153
[521]154%build
[2765]155export R_PDFVIEWER="%{_bindir}/xdg-open"
156export R_PRINTCMD="lpr"
157export R_BROWSER="%{_bindir}/xdg-open"
[11121]158%if %{?_dist_release} == "vl6"
159export LD_LIBRARY_PATH=%{_libdir}/R/lib
160%endif
[7300]161
[10817]162%{configure} --enable-R-shlib --with-tcltk \
163%if %{?_dist_release} == "vl6"
164 --with-tcl-config=%{_libdir}/tclConfig85.sh \
[11121]165 --with-tk-config=%{_libdir}/tkConfig85.sh \
166 CPPFLAGS="-I%{_libdir}/R/include" \
167 LDFLAGS="-L%{_libdir}/R/lib"
[10817]168%endif
[7300]169
[521]170%{__make} %{?_smp_mflags}
171(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
172%{__make} pdf
173
174%install
[10138]175%{make_install}
[11051]176%{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
[521]177%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
178%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
179
[11051]180# Install libRmath files
[10135]181(cd src/nmath/standalone; %{make_install})
[521]182
[10135]183%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
184echo "%{_libdir}/R/lib" > \
185     ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
[521]186
[11051]187# Fix lication of R_HOME_DIR in shell wrapper
[10135]188%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
[521]189  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
[10135]190%{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
191%{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
[521]192  > ${RPM_BUILD_ROOT}%{_bindir}/R
[10135]193%{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
[521]194
[7300]195# add R into menu
[10135]196%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
197%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
[10817]198%{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
[10391]199%{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
[521]200
[11121]201# move manuals
[10817]202%{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
[11126]203%{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
[11121]204 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
[10817]205
[11121]206%check
207export TZ="Asia/Tokyo"
208LANG=C %{__make} check
209
[521]210%clean
211%{__rm} -rf ${RPM_BUILD_ROOT}
212
213
[11051]214%post -p %{_syssbindir}/ldconfig
[521]215
216%postun -p %{_syssbindir}/ldconfig
217
218%post -n libRmath -p %{_syssbindir}/ldconfig
219
220%postun -n libRmath -p %{_syssbindir}/ldconfig
221
222
[7300]223%files
224%defattr(-, root, root)
225%{_bindir}/R
226%{_bindir}/Rscript
227%{_libdir}/R
228%{_datadir}/applications/*
229%{_datadir}/icons/*
230%{_mandir}/man1/*
[11126]231%{_docdir}/%{name}-%{version}
[10817]232%{_sysconfdir}/ld.so.conf.d/*
[7300]233
234%files -n libRmath
235%defattr(-, root, root)
236%{_libdir}/libRmath.so
237
238%files -n libRmath-devel
239%defattr(-, root, root)
240%{_libdir}/pkgconfig/*.pc
241%{_includedir}/Rmath.h
242
243%files -n libRmath-static
244%defattr(-, root, root)
245%{_libdir}/libRmath.a
246
247
[521]248%changelog
[11193]249* Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
250- Updated to 3.4.2
251- change download URL
252
[11126]253* Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
254- left %%{_libdir}/R/doc
255
[11121]256* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
257- Updated to 3.4.1
258- rebuild under R-pcre (pcre-8.39) for Vine6
259- add Requires: gcc-gfortran
260- change to BuildRequires: texlive-collection-plaingeneric
261- delete unnecessary descriptions
262
[11051]263* Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
264- Updated to 3.4.0
265- add Patch1 and Patch2 to avoid 'make check' error
266- add export TZ="Asia/Tokyo" to avoid 'make check' error
267- delete descrption about info
268
[11023]269* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
270- Updated to 3.3.3
271
[10817]272* Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
273- use tcl-8.5/tk-8.5 for Vine6.5
274  - BuildRequires to tcl85-devel/tk85-devel
275  - Requires to tcl85/tk85
276
277* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
278- merge SPEC file for Vine6
279- drop devel package
280- move PDF manuals to /usr/share/doc/R-%%{version}
281- revert logo of menu item to logo.jpg
282
[10799]283* Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
284- Updated to 3.3.2
285
[10391]286* Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
287- Updated to 3.3.1
288- delete BuildRequires: texlive-collection-lang*
289
[10283]290* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
291- add BuildRequires: texlive-collection-lang*
292
[10222]293* Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
294- Updated to 3.3.0
295- add BuildRequires: pcre-devel xz-devel
296- change logo of menu item to Rlogo.svg
297
[10135]298* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
299- correct SPEC file
300
301* Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
302- Updated to 3.2.4-revised
303
304* Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
305- Updated to 3.2.4
306- fixed build error in src/extra/xz
307
308* Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
309- add BuildRequires: curl-devel
310- add BuildRequires: libgomp
311
312* Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
313- Updated to 3.2.3
314
[9800]315* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
316- rebuild with icu-56.1
317
318* Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
319- Updated to 3.2.2
320
321* Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
322- add configure options: --with-tcltk
323- add BuildRequires: tcl-devel tk-devel
324- add Requires: tcl tk
325
326* Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
327- Updated to 3.2.1
328
329* Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
330- add "LIBS=-lbz2" to configure option
331
332* Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
333- Updated to 3.2.0
334
335* Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
336- Updated to 3.1.3
337- added BuildRequires: texlive-collection-fontsextra for Vine6
338- changed option "make check-all" to "make check"
339-   to avoid error in checking of mgcv package
340- changed orders of BuildRequires
341
[9222]342* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
343- rebuild with icu-54.1
344
345* Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
346- Updated to 3.1.2
347
348* Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
349- Updated to 3.1.1
350- add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
351
352* Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
353- add patch (2014-04-26)
354
355* Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
356- Updated to 3.1.0
357
358* Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
359- Updated to 3.0.3
360
361* Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
362- rebuild current VineSeed
363- add patch (2014-01-06)
364
365* Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
366- add Requires: libicu
367
368* Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
369- combine spec files Vine6 and VineSeed
370- correct the days of the week in changelog
371
372* Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
373- delete BuildRequires: texlive-collection-texinfo
374- add BuildRequires: texlive-collection-plainextra
375- add BuildRequires: texlive-collection-latexextra
376- add BuildRequires: texlive-collection-fontsrecommended
377-   for VineSeed
378
379* Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
380- Updated to 3.0.2
381
382* Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
383- Updated to 3.0.1
384- add BuildRequires: java-1.6.0-openjdk-devel
385
386* Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
387- Updated to 3.0.0
388
389* Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
390- Updated to 2.15.3
391- use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
392- use BuildRequires ncurses-devel instead of libtermcap-devel
393
[7300]394* Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
395- Updated to 2.15.2
396
397* Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
398- changed group to Applications/Edutainment
399- added R to menu
400
[9222]401* Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
[7300]402- Updated to 2.15.1
403
404* Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
405- Updated to 2.15.0
406
407* Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
408- Updated to 2.14.2
409
410* Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
411- Updated to 2.14.1
412
413* Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
414- Updated to 2.14.0
415- add BuildRequires: texlive-collection-fontsextra
416
417* Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
418- Updated to 2.13.2
419- add BuildRequires: texlive-common
420- use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
421- removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
422
[4745]423* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
424- synchronized to VinePlus/5 package
425  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
426  - Updated to 2.13.1
427  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
428  - Updated to 2.13.0
429  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
430  - Updated to 2.12.2
431
[2788]432* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
433- add BuildRequires: libicu-devel
434
[2765]435* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
436- synchronized to VinePlus/5 package
437  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
438  - Updated to 2.12.1
439- added --enable-R-shlib option to %%configure
440- added static subpackage
441- use BR: texlive instead of tetex on VineSeed
442
[1919]443* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
444- rebuilt with rpm-4.8.1 for pkg-config
445
[9222]446* Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
[1052]447- recompiled because tcl/tk were not linked
448
[9222]449* Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
[1052]450- Updated to 2.11.0
451- added Requires: libgfortran
452
[9222]453* Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
[521]454- Updated to 2.10.1
455
[9222]456* Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
[521]457- patched to 2.10.0
458
459* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
460- spec in UTF-8
461
[9222]462* Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
[521]463- Updated to 2.10.0
464
[9222]465* Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
[521]466- Updated to 2.9.2
467- deleted BuildRequires: lapack-devel blas-devel
468- rewrote SPEC file
469
470* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
471- Updated to 2.5.1
472- added BuildRequires: gcc-gfortran for VineSeed
473- added BuildRequires: lapack-devel blas-devel
[9222]474v- fixed %preun script
[521]475
476* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
477- Updated to 2.4.1
478- Added INFO option
479- Exclude Japanese Rprofile.site
480
481* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
482- Updated to 2.4.0
483
484* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
485- Added optimization flags
486
487* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
488- Packaged for VineLinux3.2
489
490* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
491- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
492
493* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
494- Packaged for VineLinux3.2
495- Slipped texinfo
496- Fixed preun error
497- Preset Japanese fonts
498
499* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
500- Packaged for VineLinux3.2
501
502* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
503- Restored CAPABILITIES file lost in 2.2.1beta
504
505* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
506- Configure uses --without-blas by default.
507- Install pdf manuals.
508- All toplevel documentation files are installed into _libdir/R
509  as they may be required by R (qv note on AUTHORS and THANKS below).
510- Legacy scripts for rebuilding package indices removed.
511
512* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
513- R now compiles with gcc 4.0.1 and default rpm optimization flags.
514
515* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
516- The files AUTHORS and THANKS need to be installed into _libdir/R
517  as they are required by the function contributors().  Previously
518  they were installed only as documentation files.
519
520* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
521- Corrected date error in SPEC file.
522
523* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
524- Dropped support for Red Hat boxed set.
525- Synchronized with Fedora Extras 4 RPM by Tom Calloway
526  including support for shared R library.
527- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
528  with the default optimization flags, so there is a temporary work-around.
529
530* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
531- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
532
533* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
534- Install R-data.info file as well.
535- Make info processing conditional on texinfo version, not platform release,
536  so that if a new enough version is installed, we will build and install info.
537
538* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
539- Built R 2.1.0.  R now supports internationalization, so the patch
540  to set the locale to "C" is now dropped.
541- install.packages() exits gracefully with a helpful message if
542  the file INSTALL is not present, so this is now included in the
543  R-devel package.
544
545* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
546- Added support for Scientific Linux (http://www.scientificlinux.org)
547  A distribution based on RHEL. Thanks to Jon Peatfield.
548
549* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
550- Fixed file ownership in R-devel and libRmath packages
551
552* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
553- R-devel package is now a stub package with no files, except a documentation
554  file (RPM won't accept sub-packages with no files). R now conflicts
555  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
556- Created libRmath subpackage with shared library.
557
558* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
559- Created R-devel and libRmath-devel subpackages
560
561* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
562- Built R 2.0.1
563
564* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
565- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
566  gives "lpr".
567- Define macro fcx for all Fedora distributions. This replaces Rinfo
568
569* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
570- Info support is now conditional on the macro Rinfo, which is only
571  defined for Fedora 1 and 2.
572
573* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
574- Built R 2.0.0
575- There is no longer a BUGS file, so this is not installed as a
576  documentation file.
Note: See TracBrowser for help on using the repository browser.