source: projects/specs/trunk/Q/QtRuby/QtRuby-vl.spec @ 10570

Revision 10570, 7.4 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
2
3%global ruby_vendorlib %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorlibdir"]')
4%global ruby_vendorarch %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorarchdir"]')
5
6Name:    QtRuby
7Summary:  Ruby bindings for Qt4
8Summary(ja): Qt4 の Ruby バインディング
9Version: 4.14.3
10Release: 3%{?_dist_release}
11
12License: LGPLv2+ and GPLv2+
13Group:   System Environment/Libraries
14URL:     https://techbase.kde.org/Development/Languages/Ruby
15
16Source0: http://download.kde.org/stable/%{version}/src/qtruby-%{version}.tar.xz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: cmake
20BuildRequires: phonon-devel
21BuildRequires: qimageblitz-devel
22BuildRequires: qt4-devel
23BuildRequires: qscintilla-devel
24BuildRequires: qwt-qt4-devel
25BuildRequires: ruby-devel >= 1.8
26BuildRequires: smokeqt-devel >= %{version}
27
28# common name some other distros use
29Provides: ruby-qt = %{version}-%{release}
30
31Requires: qt4 >= %{_qt4_version}
32Requires: ruby >= 1.8
33Requires: smokeqt >= %{version}
34
35%description
36%{summary}.
37
38%package devel
39Summary: Development libraries for %{name}
40Summary(ja): %{name} の開発用ファイル
41Group:   Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Provides: ruby-qt-devel = %{version}-%{release}
44
45%description devel
46This package contains development files for the Ruby bindings
47for the Qt libraries.
48
49
50%prep
51%setup -q -n qtruby-%{version}
52
53
54%build
55mkdir -p %{_target_platform}
56pushd %{_target_platform}
57
58%cmake \
59    -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_vendorarch} \
60    -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_vendorlib} \
61    ..
62popd
63
64make %{?_smp_mflags} -C %{_target_platform}
65
66
67%install
68rm -rf $RPM_BUILD_ROOT
69make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
70
71
72%post -p /sbin/ldconfig
73%postun -p /sbin/ldconfig
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
79%defattr(-,root,root,-)
80%doc AUTHORS COPYING COPYING.LIB README
81%{_libdir}/libqtruby4shared.so.*
82%{ruby_vendorlib}/Qt*.rb
83%{ruby_vendorlib}/Qt/
84%{ruby_vendorlib}/phonon/
85%{ruby_vendorlib}/qscintilla/
86%{ruby_vendorlib}/qtdeclarative/
87%{ruby_vendorlib}/qtscript/
88%{ruby_vendorlib}/qttest/
89%{ruby_vendorlib}/qtuitools/
90%{ruby_vendorlib}/qtwebkit/
91%{ruby_vendorlib}/qwt/
92%{ruby_vendorarch}/*.so
93
94%files devel
95%defattr(-,root,root,-)
96%{_bindir}/rbqtapi
97%{_bindir}/rbrcc
98%{_bindir}/rbuic4
99%{_includedir}/qtruby
100%{_libdir}/libqtruby4shared.so
101%{_datadir}/qtruby4
102
103%changelog
104* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-3
105- rebuild with gcc-5.4.0
106
107* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
108- rebuild with ruby-2.2.3
109
110* Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-1
111- updated to 4.14.3
112
113* Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-2
114- installed modules to vendor_ruby
115- fixed URL
116
117* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-1
118- splitted from kdebindings
119
120* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
121- new upstream release
122
123* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
124- updated to 4.6.1
125- added BR: kdesdk-devel
126- disabled attica plugins temporaly
127- rebuilt with mono-2.10.1
128
129* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
130- rebuilt with rpm-4.8.1 for pkg-config
131
132* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
133- new upstream release
134- added Patch50
135- added more japanese summaries
136
137* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
138- new upstream release
139
140* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
141- new upstream release
142
143* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
144- new upstream release
145
146* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
147- new upstream release
148
149* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
150- new upstream release
151- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
152  (see https://bugs.kde.org/show_bug.cgi?id=214824)
153- built with new toolchain
154
155* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
156- new upstream release
157
158* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
159- merged 4.3.1-2 %changelog
160- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
161
162* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
163- use %%{_prefix}/lib for mono-dll (for x86_64)
164
165* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
166- new upstream release
167- built with PyQt4-4.6
168
169* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
170- define %%{mono_dir} to specify mono library install path
171
172* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
173- new upstream release
174- fixed ruby modules installation path
175
176* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
177- new upstream release
178- spilt sub package based on Fedora
179
180* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
181- applied new versioning policy
182- added Patch1
183  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
184
185* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
186- added --with-qt-libraries option
187
188* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
189- rebuild for VineSeed
190
191* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
192- new upstream release
193
194* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
195- rebuild for VineSeed
196
197* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
198- new upstream release
199- update Patch0
200- drop Patch1
201
202* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
203- new upstream release
204- add Patch1
205- add --enable-libsuffix option
206
207* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
208- rebuild for VineSeed
209
210* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
211- new upstream release
212
213* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
214- rebuild for VineSeed
215
216* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
217- new upstream release
218
219* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
220- rebuild for VineSeed
221
222* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
223- new upstream release
224
225* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
226- rebuild for VineSeed
227
228* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
229- new upstream release
230
231* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
232- rebuild for VineSeed
233
234* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
235- new upstream release
236- renew BuildPrereq and build section
237- renew %%files
238- enable python
239- change spec to make main and devel package
240- add BuildPrereq: ruby ruby-devel
241- add Patch0 to install ruby-bindings under /usr/lib/ruby
242
243* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
244- build for VineSeed
245- disable python and mozilla
246- objprelink (i386 only)
247
248* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
249- 2.2.2
250- build kmozilla binding only on x86/alpha
251
252* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
253- Make sure %%{name}-kmozilla isn't built on ia64
254
255* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
256- Move python bindings to separate package
257- Add perl bindings
258- Shut up rpmlint
259
260* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
261- 2.1
262
263* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
264- initial RPM
Note: See TracBrowser for help on using the repository browser.