source: projects/specs/trunk/P/PyYAML/PyYAML-vl.spec @ 5701

Revision 5701, 3.0 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1# %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           PyYAML
5Version:        3.10
6Release:        2%{?_dist_release}
7Summary:        YAML parser and emitter for Python
8
9Group:          Development/Libraries
10License:        MIT
11URL:            http://pyyaml.org/
12Source0:        http://pyyaml.org/download/pyyaml/%{name}-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  python-devel, python-setuptools, libyaml-devel
16
17%description
18YAML is a data serialization format designed for human readability and
19interaction with scripting languages.  PyYAML is a YAML parser and
20emitter for Python.
21
22PyYAML features a complete YAML 1.1 parser, Unicode support, pickle
23support, capable extension API, and sensible error messages.  PyYAML
24supports standard YAML tags and provides Python-specific tags that allow
25to represent an arbitrary Python object.
26
27PyYAML is applicable for a broad range of tasks from complex
28configuration files to object serialization and persistance.
29
30%prep
31%setup -q -n %{name}-%{version}
32
33
34%build
35%{__python} setup.py build
36chmod a-x examples/yaml-highlight/yaml_hl.py
37
38
39%install
40rm -rf $RPM_BUILD_ROOT
41mkdir -p $RPM_BUILD_ROOT/%{_bindir}
42%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
43
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48
49%files
50%defattr(-,root,root,-)
51%doc PKG-INFO README LICENSE examples
52# %{python_sitelib}/*
53%{python_sitearch}/*
54
55
56%changelog
57* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10-2
58- rebuild with python-2.7.2
59
60* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.10-1
61- new upstream release
62
63* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.09-1
64- new upstream release
65
66* Thu Jun 11 2009 Shu KONNO <owa@bg.wakwak.com> 3.08-2
67- s/python_sitelib/python_sitearch/
68
69* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.08-1
70- initial build for Vine Linux
71
72* Tue Mar 3 2009 John Eckersberg <jeckersb@redhat.com> - 3.08-4
73- Correction, change libyaml to libyaml-devel in BuildRequires
74
75* Mon Mar 2 2009 John Eckersberg <jeckersb@redhat.com> - 3.08-3
76- Add libyaml to BuildRequires
77
78* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.08-2
79- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
80
81* Wed Feb 18 2009 John Eckersberg <jeckersb@redhat.com> - 3.08-1
82- New upstream release
83
84* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.06-2
85- Rebuild for Python 2.6
86
87* Fri Oct 24 2008 John Eckersberg <jeckersb@redhat.com> - 3.06-1
88- New upstream release
89
90* Wed Jan 02 2008 John Eckersberg <jeckersb@redhat.com> - 3.05-2
91- Remove explicit dependency on python >= 2.3
92- Remove executable on example script in docs
93
94* Mon Dec 17 2007 John Eckersberg <jeckersb@redhat.com> - 3.05-1
95- Initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.