source: projects/specs/trunk/P/PyYAML/PyYAML-vl.spec @ 12469

Revision 12469, 4.3 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Name:           PyYAML
2Version:        5.3.1
3Release:        1%{?_dist_release}
4Summary:        YAML parser and emitter for Python
5Group:          programming
6Vendor:         Project Vine
7Distribution:   Vine Linux
8
9License:        MIT
10URL:            https://github.com/yaml/pyyaml
11Source0:        https://github.com/yaml/pyyaml/archive/%{version}.tar.gz#/pyyaml-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildRequires:  libyaml-devel
15BuildRequires:  python-rpm-macros
16BuildRequires:  python-devel, python-setuptools, python2-rpm-macros
17BuildRequires:  python3-devel, python3-setuptools, python3-rpm-macros
18BuildRequires:  python3-Cython
19
20%description
21YAML is a data serialization format designed for human readability and
22interaction with scripting languages.  PyYAML is a YAML parser and
23emitter for Python.
24
25PyYAML features a complete YAML 1.1 parser, Unicode support, pickle
26support, capable extension API, and sensible error messages.  PyYAML
27supports standard YAML tags and provides Python-specific tags that allow
28to represent an arbitrary Python object.
29
30PyYAML is applicable for a broad range of tasks from complex
31configuration files to object serialization and persistance.
32
33
34%package -n python3-pyyaml
35Summary:        %summary
36Group:          programming
37Provides:       python3-yaml = %{version}-%{release}
38Provides:       python3-yaml%{?_isa} = %{version}-%{release}
39%{?python_provide:%python_provide python3-pyyaml}
40# Remove before F31
41Provides:       python3-PyYAML = %{version}-%{release}
42Provides:       python3-PyYAML%{?_isa} = %{version}-%{release}
43
44%description -n python3-pyyaml
45YAML is a data serialization format designed for human readability and
46interaction with scripting languages.  PyYAML is a YAML parser and
47emitter for Python.
48
49PyYAML features a complete YAML 1.1 parser, Unicode support, pickle
50support, capable extension API, and sensible error messages.  PyYAML
51supports standard YAML tags and provides Python-specific tags that allow
52to represent an arbitrary Python object.
53
54PyYAML is applicable for a broad range of tasks from complex
55configuration files to object serialization and persistance.
56
57
58%prep
59%setup -q -n pyyaml-%{version}
60chmod a-x examples/yaml-highlight/yaml_hl.py
61
62# remove pre-generated file
63rm -f ext/_yaml.c
64
65
66%build
67%py3_build
68
69# py_build reuses Cython output from py3_build
70%py2_build
71
72
73%install
74rm -rf $RPM_BUILD_ROOT
75%py2_install
76%py3_install
77
78
79%check
80%{__python2} setup.py test
81%{__python3} setup.py test
82
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87
88%files
89%defattr(-,root,root,-)
90%license LICENSE
91%doc CHANGES README examples
92%{python2_sitearch}/*
93
94%files -n python3-pyyaml
95%license LICENSE
96%doc CHANGES README examples
97%{python3_sitearch}/*
98
99
100%changelog
101* Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.1-1
102- new upstream release.
103
104* Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.2-1
105- new upstream release.
106- added python3 support.
107
108* Mon Mar 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.10-3
109- rebuilt with libyaml-0.1.4
110
111* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10-2
112- rebuild with python-2.7.2
113
114* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.10-1
115- new upstream release
116
117* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.09-1
118- new upstream release
119
120* Thu Jun 11 2009 Shu KONNO <owa@bg.wakwak.com> 3.08-2
121- s/python_sitelib/python_sitearch/
122
123* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.08-1
124- initial build for Vine Linux
125
126* Tue Mar 3 2009 John Eckersberg <jeckersb@redhat.com> - 3.08-4
127- Correction, change libyaml to libyaml-devel in BuildRequires
128
129* Mon Mar 2 2009 John Eckersberg <jeckersb@redhat.com> - 3.08-3
130- Add libyaml to BuildRequires
131
132* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.08-2
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
134
135* Wed Feb 18 2009 John Eckersberg <jeckersb@redhat.com> - 3.08-1
136- New upstream release
137
138* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.06-2
139- Rebuild for Python 2.6
140
141* Fri Oct 24 2008 John Eckersberg <jeckersb@redhat.com> - 3.06-1
142- New upstream release
143
144* Wed Jan 02 2008 John Eckersberg <jeckersb@redhat.com> - 3.05-2
145- Remove explicit dependency on python >= 2.3
146- Remove executable on example script in docs
147
148* Mon Dec 17 2007 John Eckersberg <jeckersb@redhat.com> - 3.05-1
149- Initial packaging for Fedora
Note: See TracBrowser for help on using the repository browser.