source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 8430

Revision 8430, 10.6 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.12.5

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4
5%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.5)
6%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
7%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
8%define qt4qmake %{_qt4_prefix}/bin/qmake
9
10Name:    PyQt4
11Summary: Python bindings for Qt4
12Summary(ja): Qt4 の Python バインディング
13Version: 4.10.4
14Release: 1%{?_dist_release}
15
16# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
17License: GPLv3 or GPLv2 with exceptions
18Group:   Development/Languages
19URL:     http://www.riverbankcomputing.com/software/pyqt/
20
21Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
22Patch1:  PyQt-x11-gpl-4.10.4-64bit.patch
23# HACK! FIXME: ping upstream why this isn't working right. -- Rex
24Patch2:  PyQt-x11-gpl-4.5.2-QT_SHARED.patch
25Patch4:  PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
26
27# Vine Patch
28Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: dbus-devel dbus-python-devel
32BuildRequires: findutils
33BuildRequires: libXext-devel
34BuildRequires: phonon-devel
35BuildRequires: python-devel
36# beware of PyQt4/qscintilla bootstap issues
37#BuildRequires: qscintilla
38BuildRequires: qt4-devel >= 4.5.0
39BuildRequires: qt-assistant-adp-devel
40BuildRequires: sip-devel >= 4.13.1
41Requires: sip >= 4.13.1
42Requires: dbus-python
43Requires: qt4
44
45%description
46These are Python bindings for Qt4.
47
48%package devel
49Summary: Files needed to build other bindings based on Qt4
50Group:   Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: qt4-devel >= 4.5.0
53Requires: qt-assistant-adp-devel
54Requires: sip-devel >= 4.13.1
55
56%description devel
57Files needed to build other bindings for C++ classes that inherit from any
58of the Qt4 classes (e.g. KDE or your own).
59
60
61%prep
62%setup -q -n PyQt-x11-gpl-%{version}
63%ifarch x86_64
64%patch1 -p1 -b .64bit
65%endif
66%patch2 -p1 -b .QT_SHARED
67
68#patch100 -p1 -b .phononpath_vine
69
70## permissions
71# mark examples non-executable
72find examples/ -name "*.py" | xargs chmod a-x
73chmod a+rx pyuic/uic/pyuic.py
74
75%build
76CFLAGS="${CFLAGS:-%optflags}" \
77CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
78sed -i "s|0x040f00|0x040e07|" configure.py
79sed -i "s|4.15|4.14.7|" configure-ng.py
80%{__python} configure.py \
81  --confirm-license \
82  --qmake=%{qt4qmake} \
83  --no-qsci-api \
84  --verbose
85
86make %{?_smp_mflags}
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
92
93# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
94rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
95mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
96   $RPM_BUILD_ROOT%{_bindir}/pyuic4
97ln -s %{_bindir}/pyuic4 \
98      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%files
104%defattr(-,root,root,-)
105%doc NEWS README
106%doc OPENSOURCE-NOTICE.TXT
107%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
108%doc LICENSE.GPL3
109%{python_sitearch}/PyQt4/
110%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
111# fixme?  -> sitearch?  -- Rex
112%{python_sitelib}/dbus/mainloop/qt.so
113%{_qt4_plugindir}/designer/*
114
115%files devel
116%defattr(-,root,root,-)
117%doc doc/*
118%doc examples/
119%{_bindir}/pylupdate4
120%{_bindir}/pyrcc4
121%{_bindir}/pyuic4
122%{python_sitearch}/PyQt4/uic/pyuic.py*
123%{_datadir}/sip/PyQt4/
124#{_qt4_prefix}/qsci/api/python/PyQt4.api
125
126%changelog
127* Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.4-1
128- new upstream release
129- update Patch1 (PyQt-x11-gpl-4.10.4-64bit.patch)
130
131* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.3-1
132- new upstream release
133
134* Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.2-1
135- new upstream release
136
137* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.1-1
138- new upstream release
139
140* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.4-1
141- new upstream release
142- update Patch1 (PyQt-x11-gpl-4.9.4-64bit.patch)
143
144* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
145- rebuild with python-2.7.2
146
147* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
148- new upstream release
149- aaded BR: qt-assistant-adp-devel
150
151* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
152- update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
153
154* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
155- new upstream release
156
157* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
158- re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
159- remove %%sip_ver
160
161* Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
162- rebuilt with qt4-4.7.2
163
164* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
165- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
166
167* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
168- new upstream release
169- built with sip-4.12.1 and qt4-4.7.1
170
171* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
172- rebuild with qt4-4.6.3
173- fix %qtver (from 4.6.1 to 4.6.3)
174
175* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
176- new upstream release
177- rebuilt with sip-4.10.5 and qt4-4.6.3
178
179* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
180- new upstream release
181- updated Patch100
182
183* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
184- updated Patch100 to build phonon module
185
186* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
187- new upstream release
188- rebuilt with python-2.6.4
189- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
190
191* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
192- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
193
194* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
195- new upstream release
196- added BR: libXext-devel
197
198* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
199- added Patch100 for building phonon modules
200
201* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
202- Initial build for Vine
203
204* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
205- PyQt4-4.5.4
206
207* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
209
210* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
211- PyQt4-4.5.2
212
213* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
214- fix build with qt-4.5.2
215- PyQt4-devel multilib conflict (#509415)
216
217* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
218- PyQt-4.5.1
219
220* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
221- PyQt-4.5
222
223* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
224- fix generation of sip_ver
225
226* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
227- PyQt-4.5-snapshot-20090520
228
229* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
230- rebuild for phonon bindings (#497680)
231
232* Thu Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
233- move designer plugins to main/runtime (#487622)
234
235* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
237
238* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
239- rebuild against qt-4.5rc1
240
241* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
242- Rebuild for Python 2.6
243
244* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
245- PyQt-4.4.4
246
247* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
248- PyQt-4.4.3
249
250* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
251- PyQt4 is built without QtWebKit support (#451490)
252
253* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
254- PyQt-4.4.2
255
256* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
257- PyQt-4.4
258- License: GPLv3 or GPLv2 with exceptions
259
260* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
261- respin (gcc43)
262
263* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
264- PyQt-4.3.3
265
266* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
267- dbus support (#395741)
268
269* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
270- PyQt-4.3.1
271
272* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
273- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
274
275* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
276- fix QtDesigner plugin install
277
278* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
279- 64bit QtDesigner patch
280
281* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
282- -devel: Requires: qt4-devel
283
284* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
285- use %%python_sitearch
286- License: GPLv2
287
288* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
289- fix python_sitelib typo (wrt chrpath call)
290- move %%_bindir stuff to -devel
291- mark %%doc examples non-executable
292- add shebang to %%_bindir/pyuic4
293
294* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
295- remove rpath from QtDesigner.so
296- BR: qt4-devel > 4.3.0-8
297
298* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
299- PyQt4-4.2
300
301* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
302- fix build against multilib'd qt4
303
304* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
305- PyQt4-4.1.1
306- BR: sip-devel >= 4.5.1
307
308* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
309- PyQt4-4.1
310
311* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
312- don't own %%_datadir/sip (bug #206633)
313
314* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
315- BR: qt4-devel < 4.2
316
317* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
318- fix reference(s) to qmake(4)
319
320* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
321- PyQt-4.0.1
322
323* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
324- PyQt-4.0(final)
325- BR: sip-devel >= 4.4.4 (see bug #199430)
326
327* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
328- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
329- drop usage of (undefined) %%sip_min
330
331* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
332- cleanup for Extras
333
334* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
335- 4.0beta1
336
337* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
338- respin for sip-4.4.3
339- use sip-abi, sip-abi-min
340
341* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
342- 20060421 snapshot
343
344* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
345- first try, using 20060417 snapshot
346
Note: See TracBrowser for help on using the repository browser.