source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 521

Revision 521, 8.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4%global sip_ver %(sip -V 2>/dev/null | cut -d' ' -f1 | cut -d- -f1)
5
6# ugly hack for Qt4 version auto-detection -- inagaki
7%define _qt4_notfound %(eval "pkg-config --exists Qt"; echo $?)
8%if %{_qt4_notfound}
9%define qtver 4.6.1
10%else
11%define qtver %(pkg-config --modversion QtCore)
12%endif
13%define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
14
15Summary: Python bindings for Qt4
16Name:    PyQt4
17Version: 4.7
18Release: 2%{?_dist_release}
19
20# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
21License: GPLv3 or GPLv2 with exceptions
22Group:   Development/Languages
23URL:     http://www.riverbankcomputing.com/software/pyqt/
24Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
25Patch1:  PyQt-x11-gpl-4.4.4-64bit.patch
26# HACK! FIXME: ping upstream why this isn't working right. -- Rex
27Patch2:  PyQt-x11-gpl-4.5.2-QT_SHARED.patch
28Patch4:  PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
29
30# Vine Patch
31Patch100: PyQt-x11-gpl-4.7-phononpath_vine.patch
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34#BuildRequires: chrpath
35BuildRequires: dbus-devel dbus-python-devel
36BuildRequires: findutils
37BuildRequires: phonon-devel
38# beware of PyQt4/qscintilla bootstap issues
39#BuildRequires: qscintilla
40BuildRequires: qt4-devel >= 4.5.0
41BuildRequires: python-devel
42BuildRequires: sip-devel >= 4.9
43BuildRequires: libXext-devel
44Requires: sip >= %{sip_ver}
45Requires: dbus-python
46Requires: qt4 >= %{qtver}
47
48
49%description
50These are Python bindings for Qt4.
51
52%package devel
53Summary: Files needed to build other bindings based on Qt4
54Group:   Development/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: qt4-devel >= %{qtver}
57Requires: sip-devel >= 4.9
58
59%description devel
60Files needed to build other bindings for C++ classes that inherit from any
61of the Qt4 classes (e.g. KDE or your own).
62
63
64%prep
65%setup -q -n PyQt-x11-gpl-%{version}
66%patch1 -p1 -b .64bit
67%patch2 -p1 -b .QT_SHARED
68%patch4 -p1
69
70%patch100 -p1 -b .phononpath_vine
71
72## permissions
73# mark examples non-executable
74find examples/ -name "*.py" | xargs chmod a-x
75chmod a+rx pyuic/uic/pyuic.py
76
77
78%build
79unset QTDIR || : ; . /etc/profile.d/qt4.sh
80CFLAGS="${CFLAGS:-%optflags}" \
81CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
82%{__python} configure.py \
83  --confirm-license \
84  --qmake=%{qt4qmake} \
85  --no-qsci-api \
86  --verbose
87
88make %{?_smp_mflags}
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
94
95# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
96rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
97mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
98   $RPM_BUILD_ROOT%{_bindir}/pyuic4
99ln -s %{_bindir}/pyuic4 \
100      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%files
106%defattr(-,root,root,-)
107%doc NEWS README
108%doc OPENSOURCE-NOTICE.TXT
109%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
110%doc LICENSE.GPL3
111%{python_sitearch}/PyQt4/
112%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
113# fixme?  -> sitearch?  -- Rex
114%{python_sitelib}/dbus/mainloop/qt.so
115%{_libdir}/qt-%{qtver}/plugins/designer/*
116
117%files devel
118%defattr(-,root,root,-)
119%doc doc/*
120%doc examples/
121%{_bindir}/pylupdate4
122%{_bindir}/pyrcc4
123%{_bindir}/pyuic4
124%{python_sitearch}/PyQt4/uic/pyuic.py*
125%{_datadir}/sip/PyQt4/
126#{_qt4_prefix}/qsci/api/python/PyQt4.api
127
128
129%changelog
130* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
131- updated Patch100 to build phonon module
132
133* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
134- new upstream release
135- rebuilt with python-2.6.4
136- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
137
138* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
139- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
140
141* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
142- new upstream release
143- added BR: libXext-devel
144
145* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
146- added Patch100 for building phonon modules
147
148* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
149- Initial build for Vine
150
151* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
152- PyQt4-4.5.4
153
154* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
156
157* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
158- PyQt4-4.5.2
159
160* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
161- fix build with qt-4.5.2
162- PyQt4-devel multilib conflict (#509415)
163
164* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
165- PyQt-4.5.1
166
167* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
168- PyQt-4.5
169
170* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
171- fix generation of sip_ver
172
173* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
174- PyQt-4.5-snapshot-20090520
175
176* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
177- rebuild for phonon bindings (#497680)
178
179* Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
180- move designer plugins to main/runtime (#487622)
181
182* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
184
185* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
186- rebuild against qt-4.5rc1
187
188* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
189- Rebuild for Python 2.6
190
191* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
192- PyQt-4.4.4
193
194* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
195- PyQt-4.4.3
196
197* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
198- PyQt4 is built without QtWebKit support (#451490)
199
200* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
201- PyQt-4.4.2
202
203* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
204- PyQt-4.4
205- License: GPLv3 or GPLv2 with exceptions
206
207* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
208- respin (gcc43)
209
210* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
211- PyQt-4.3.3
212
213* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
214- dbus support (#395741)
215
216* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
217- PyQt-4.3.1
218
219* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
220- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
221
222* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
223- fix QtDesigner plugin install
224
225* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
226- 64bit QtDesigner patch
227
228* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
229- -devel: Requires: qt4-devel
230
231* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
232- use %%python_sitearch
233- License: GPLv2
234
235* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
236- fix python_sitelib typo (wrt chrpath call)
237- move %%_bindir stuff to -devel
238- mark %%doc examples non-executable
239- add shebang to %%_bindir/pyuic4
240
241* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
242- remove rpath from QtDesigner.so
243- BR: qt4-devel > 4.3.0-8
244
245* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
246- PyQt4-4.2
247
248* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
249- fix build against multilib'd qt4
250
251* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
252- PyQt4-4.1.1
253- BR: sip-devel >= 4.5.1
254
255* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
256- PyQt4-4.1
257
258* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
259- don't own %%_datadir/sip (bug #206633)
260
261* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
262- BR: qt4-devel < 4.2
263
264* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
265- fix reference(s) to qmake(4)
266
267* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
268- PyQt-4.0.1
269
270* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
271- PyQt-4.0(final)
272- BR: sip-devel >= 4.4.4 (see bug #199430)
273
274* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
275- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
276- drop usage of (undefined) %%sip_min
277
278* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
279- cleanup for Extras
280
281* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
282- 4.0beta1
283
284* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
285- respin for sip-4.4.3
286- use sip-abi, sip-abi-min
287
288* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
289- 20060421 snapshot
290
291* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
292- first try, using 20060417 snapshot
293
Note: See TracBrowser for help on using the repository browser.