source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 6655

Revision 6655, 10.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release or rebuild with exiv2-0.23

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4
5%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.0)
6%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
7%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
8%define qt4qmake %{_qt4_prefix}/bin/qmake
9
10Name:    PyQt4
11Summary: Python bindings for Qt4
12Summary(ja): Qt4 の Python バインディング
13Version: 4.9.4
14Release: 1%{?_dist_release}
15
16# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
17License: GPLv3 or GPLv2 with exceptions
18Group:   Development/Languages
19URL:     http://www.riverbankcomputing.com/software/pyqt/
20
21Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
22Patch1:  PyQt-x11-gpl-4.9.4-64bit.patch
23# HACK! FIXME: ping upstream why this isn't working right. -- Rex
24Patch2:  PyQt-x11-gpl-4.5.2-QT_SHARED.patch
25Patch4:  PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
26
27# Vine Patch
28Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: dbus-devel dbus-python-devel
32BuildRequires: findutils
33BuildRequires: libXext-devel
34BuildRequires: phonon-devel
35BuildRequires: python-devel
36# beware of PyQt4/qscintilla bootstap issues
37#BuildRequires: qscintilla
38BuildRequires: qt4-devel >= 4.5.0
39BuildRequires: qt-assistant-adp-devel
40BuildRequires: sip-devel >= 4.13.1
41Requires: sip >= 4.13.1
42Requires: dbus-python
43Requires: qt4
44
45%description
46These are Python bindings for Qt4.
47
48%package devel
49Summary: Files needed to build other bindings based on Qt4
50Group:   Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: qt4-devel >= 4.5.0
53Requires: qt-assistant-adp-devel
54Requires: sip-devel >= 4.13.1
55
56%description devel
57Files needed to build other bindings for C++ classes that inherit from any
58of the Qt4 classes (e.g. KDE or your own).
59
60
61%prep
62%setup -q -n PyQt-x11-gpl-%{version}
63%ifarch x86_64
64%patch1 -p1 -b .64bit
65%endif
66%patch2 -p1 -b .QT_SHARED
67
68#patch100 -p1 -b .phononpath_vine
69
70## permissions
71# mark examples non-executable
72find examples/ -name "*.py" | xargs chmod a-x
73chmod a+rx pyuic/uic/pyuic.py
74
75%build
76CFLAGS="${CFLAGS:-%optflags}" \
77CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
78%{__python} configure.py \
79  --confirm-license \
80  --qmake=%{qt4qmake} \
81  --no-qsci-api \
82  --verbose
83
84make %{?_smp_mflags}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
90
91# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
92rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
93mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
94   $RPM_BUILD_ROOT%{_bindir}/pyuic4
95ln -s %{_bindir}/pyuic4 \
96      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(-,root,root,-)
103%doc NEWS README
104%doc OPENSOURCE-NOTICE.TXT
105%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
106%doc LICENSE.GPL3
107%{python_sitearch}/PyQt4/
108%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
109# fixme?  -> sitearch?  -- Rex
110%{python_sitelib}/dbus/mainloop/qt.so
111%{_qt4_plugindir}/designer/*
112
113%files devel
114%defattr(-,root,root,-)
115%doc doc/*
116%doc examples/
117%{_bindir}/pylupdate4
118%{_bindir}/pyrcc4
119%{_bindir}/pyuic4
120%{python_sitearch}/PyQt4/uic/pyuic.py*
121%{_datadir}/sip/PyQt4/
122#{_qt4_prefix}/qsci/api/python/PyQt4.api
123
124%changelog
125* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.4-1
126- new upstream release
127- update Patch1 (PyQt-x11-gpl-4.9.4-64bit.patch)
128
129* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
130- rebuild with python-2.7.2
131
132* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
133- new upstream release
134- aaded BR: qt-assistant-adp-devel
135
136* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
137- update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
138
139* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
140- new upstream release
141
142* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
143- re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
144- remove %%sip_ver
145
146* Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
147- rebuilt with qt4-4.7.2
148
149* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
150- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
151
152* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
153- new upstream release
154- built with sip-4.12.1 and qt4-4.7.1
155
156* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
157- rebuild with qt4-4.6.3
158- fix %qtver (from 4.6.1 to 4.6.3)
159
160* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
161- new upstream release
162- rebuilt with sip-4.10.5 and qt4-4.6.3
163
164* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
165- new upstream release
166- updated Patch100
167
168* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
169- updated Patch100 to build phonon module
170
171* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
172- new upstream release
173- rebuilt with python-2.6.4
174- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
175
176* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
177- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
178
179* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
180- new upstream release
181- added BR: libXext-devel
182
183* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
184- added Patch100 for building phonon modules
185
186* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
187- Initial build for Vine
188
189* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
190- PyQt4-4.5.4
191
192* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
194
195* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
196- PyQt4-4.5.2
197
198* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
199- fix build with qt-4.5.2
200- PyQt4-devel multilib conflict (#509415)
201
202* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
203- PyQt-4.5.1
204
205* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
206- PyQt-4.5
207
208* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
209- fix generation of sip_ver
210
211* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
212- PyQt-4.5-snapshot-20090520
213
214* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
215- rebuild for phonon bindings (#497680)
216
217* Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
218- move designer plugins to main/runtime (#487622)
219
220* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
221- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
222
223* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
224- rebuild against qt-4.5rc1
225
226* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
227- Rebuild for Python 2.6
228
229* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
230- PyQt-4.4.4
231
232* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
233- PyQt-4.4.3
234
235* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
236- PyQt4 is built without QtWebKit support (#451490)
237
238* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
239- PyQt-4.4.2
240
241* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
242- PyQt-4.4
243- License: GPLv3 or GPLv2 with exceptions
244
245* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
246- respin (gcc43)
247
248* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
249- PyQt-4.3.3
250
251* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
252- dbus support (#395741)
253
254* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
255- PyQt-4.3.1
256
257* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
258- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
259
260* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
261- fix QtDesigner plugin install
262
263* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
264- 64bit QtDesigner patch
265
266* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
267- -devel: Requires: qt4-devel
268
269* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
270- use %%python_sitearch
271- License: GPLv2
272
273* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
274- fix python_sitelib typo (wrt chrpath call)
275- move %%_bindir stuff to -devel
276- mark %%doc examples non-executable
277- add shebang to %%_bindir/pyuic4
278
279* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
280- remove rpath from QtDesigner.so
281- BR: qt4-devel > 4.3.0-8
282
283* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
284- PyQt4-4.2
285
286* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
287- fix build against multilib'd qt4
288
289* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
290- PyQt4-4.1.1
291- BR: sip-devel >= 4.5.1
292
293* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
294- PyQt4-4.1
295
296* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
297- don't own %%_datadir/sip (bug #206633)
298
299* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
300- BR: qt4-devel < 4.2
301
302* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
303- fix reference(s) to qmake(4)
304
305* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
306- PyQt-4.0.1
307
308* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
309- PyQt-4.0(final)
310- BR: sip-devel >= 4.4.4 (see bug #199430)
311
312* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
313- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
314- drop usage of (undefined) %%sip_min
315
316* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
317- cleanup for Extras
318
319* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
320- 4.0beta1
321
322* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
323- respin for sip-4.4.3
324- use sip-abi, sip-abi-min
325
326* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
327- 20060421 snapshot
328
329* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
330- first try, using 20060417 snapshot
331
Note: See TracBrowser for help on using the repository browser.