source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 10611

Revision 10611, 10.8 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4
5%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
6%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
7%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
8%define qt4qmake %{_qt4_prefix}/bin/qmake
9
10Name:    PyQt4
11Summary: Python bindings for Qt4
12Summary(ja): Qt4 の Python バインディング
13Version: 4.11.4
14Release: 1%{?_dist_release}
15
16# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
17License: GPLv3 or GPLv2 with exceptions
18Group:   System Environment/Libraries
19URL:     http://www.riverbankcomputing.com/software/pyqt/
20
21Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
22
23## upstreamable patches
24Patch52:  PyQt-x11-gpl-4.10.4-pyuic_shbang.patch
25
26# Vine Patch
27Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: dbus-devel dbus-python-devel
31BuildRequires: findutils
32BuildRequires: libXext-devel
33BuildRequires: phonon-devel
34BuildRequires: python-devel
35# beware of PyQt4/qscintilla bootstap issues
36#BuildRequires: qscintilla
37BuildRequires: qt4-devel >= 4.5.0
38BuildRequires: qt-assistant-adp-devel
39BuildRequires: sip-devel >= 4.13.1
40Requires: sip >= 4.13.1
41Requires: dbus-python
42Requires: qt4
43
44%description
45These are Python bindings for Qt4.
46
47%package devel
48Summary: Files needed to build other bindings based on Qt4
49Group:   Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: qt4-devel >= 4.5.0
52Requires: qt-assistant-adp-devel
53Requires: sip-devel >= 4.13.1
54
55%description devel
56Files needed to build other bindings for C++ classes that inherit from any
57of the Qt4 classes (e.g. KDE or your own).
58
59
60%prep
61%setup -q -n PyQt-x11-gpl-%{version}
62# skip -b on this one, so the backup copy doesnt end up packaged too
63%patch52 -p1
64
65#patch100 -p1 -b .phononpath_vine
66
67# permissions, mark examples non-executable
68find examples/ -name "*.py" | xargs chmod a-x
69chmod a+rx pyuic/uic/pyuic.py
70
71%build
72QT4DIR=%{_qt4_prefix}
73PATH=%{_qt4_bindir}:$PATH ; export PATH
74%{__python} configure.py \
75  --assume-shared \
76  --confirm-license \
77  --no-timestamp \
78  --qmake=%{qt4qmake} \
79  --no-qsci-api \
80  --verbose
81
82make %{?_smp_mflags}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86
87make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
88
89# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
90rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
91mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
92   $RPM_BUILD_ROOT%{_bindir}/pyuic4
93ln -s %{_bindir}/pyuic4 \
94      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%files
100%defattr(-,root,root,-)
101%doc NEWS README
102%doc OPENSOURCE-NOTICE.TXT
103%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
104%doc LICENSE.GPL3
105%{python_sitearch}/PyQt4/
106%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
107# fixme?  -> sitearch?  -- Rex
108%{python_sitelib}/dbus/mainloop/qt.so
109%{_qt4_plugindir}/designer/*
110
111%files devel
112%defattr(-,root,root,-)
113%doc doc/*
114%doc examples/
115%{_bindir}/pylupdate4
116%{_bindir}/pyrcc4
117%{_bindir}/pyuic4
118%{python_sitearch}/PyQt4/uic/pyuic.py*
119%{_datadir}/sip/PyQt4/
120#{_qt4_prefix}/qsci/api/python/PyQt4.api
121
122%changelog
123* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
124- new upstream release
125- remove Patch50 (PyQt-x11-gpl-4.9.5-timestamp_multilib.patch)
126
127* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.2-2
128- rebuild with gcc-5.4.0
129
130* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.11.2-1
131- new upstream release
132- added Patch50 and 52
133- moved to System Environment/Libraries Group
134
135* Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.4-1
136- new upstream release
137- update Patch1 (PyQt-x11-gpl-4.10.4-64bit.patch)
138
139* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.3-1
140- new upstream release
141
142* Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.2-1
143- new upstream release
144
145* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.1-1
146- new upstream release
147
148* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.4-1
149- new upstream release
150- update Patch1 (PyQt-x11-gpl-4.9.4-64bit.patch)
151
152* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
153- rebuild with python-2.7.2
154
155* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
156- new upstream release
157- aaded BR: qt-assistant-adp-devel
158
159* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
160- update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
161
162* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
163- new upstream release
164
165* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
166- re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
167- remove %%sip_ver
168
169* Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
170- rebuilt with qt4-4.7.2
171
172* Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
173- update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
174
175* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
176- new upstream release
177- built with sip-4.12.1 and qt4-4.7.1
178
179* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
180- rebuild with qt4-4.6.3
181- fix %qtver (from 4.6.1 to 4.6.3)
182
183* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
184- new upstream release
185- rebuilt with sip-4.10.5 and qt4-4.6.3
186
187* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
188- new upstream release
189- updated Patch100
190
191* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
192- updated Patch100 to build phonon module
193
194* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
195- new upstream release
196- rebuilt with python-2.6.4
197- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
198
199* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
200- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
201
202* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
203- new upstream release
204- added BR: libXext-devel
205
206* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
207- added Patch100 for building phonon modules
208
209* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
210- Initial build for Vine
211
212* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
213- PyQt4-4.5.4
214
215* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
216- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
217
218* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
219- PyQt4-4.5.2
220
221* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
222- fix build with qt-4.5.2
223- PyQt4-devel multilib conflict (#509415)
224
225* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
226- PyQt-4.5.1
227
228* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
229- PyQt-4.5
230
231* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
232- fix generation of sip_ver
233
234* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
235- PyQt-4.5-snapshot-20090520
236
237* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
238- rebuild for phonon bindings (#497680)
239
240* Thu Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
241- move designer plugins to main/runtime (#487622)
242
243* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
244- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
245
246* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
247- rebuild against qt-4.5rc1
248
249* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
250- Rebuild for Python 2.6
251
252* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
253- PyQt-4.4.4
254
255* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
256- PyQt-4.4.3
257
258* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
259- PyQt4 is built without QtWebKit support (#451490)
260
261* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
262- PyQt-4.4.2
263
264* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
265- PyQt-4.4
266- License: GPLv3 or GPLv2 with exceptions
267
268* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
269- respin (gcc43)
270
271* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
272- PyQt-4.3.3
273
274* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
275- dbus support (#395741)
276
277* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
278- PyQt-4.3.1
279
280* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
281- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
282
283* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
284- fix QtDesigner plugin install
285
286* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
287- 64bit QtDesigner patch
288
289* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
290- -devel: Requires: qt4-devel
291
292* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
293- use %%python_sitearch
294- License: GPLv2
295
296* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
297- fix python_sitelib typo (wrt chrpath call)
298- move %%_bindir stuff to -devel
299- mark %%doc examples non-executable
300- add shebang to %%_bindir/pyuic4
301
302* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
303- remove rpath from QtDesigner.so
304- BR: qt4-devel > 4.3.0-8
305
306* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
307- PyQt4-4.2
308
309* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
310- fix build against multilib'd qt4
311
312* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
313- PyQt4-4.1.1
314- BR: sip-devel >= 4.5.1
315
316* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
317- PyQt4-4.1
318
319* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
320- don't own %%_datadir/sip (bug #206633)
321
322* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
323- BR: qt4-devel < 4.2
324
325* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
326- fix reference(s) to qmake(4)
327
328* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
329- PyQt-4.0.1
330
331* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
332- PyQt-4.0(final)
333- BR: sip-devel >= 4.4.4 (see bug #199430)
334
335* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
336- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
337- drop usage of (undefined) %%sip_min
338
339* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
340- cleanup for Extras
341
342* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
343- 4.0beta1
344
345* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
346- respin for sip-4.4.3
347- use sip-abi, sip-abi-min
348
349* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
350- 20060421 snapshot
351
352* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
353- first try, using 20060417 snapshot
354
Note: See TracBrowser for help on using the repository browser.