source: projects/specs/trunk/P/PyQt4/PyQt4-vl.spec @ 1670

Revision 1670, 8.9 KB checked in by Takemikaduchi, 14 years ago (diff)

xorg-x11-drv-*: new upstream release, PyQt4, qscintilla: rebuild with qt4-4.6.3

Line 
1%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
2%global python_sitelib  %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
4%global sip_ver %(sip -V 2>/dev/null | cut -d' ' -f1 | cut -d- -f1)
5
6# Qt4 version auto-detection -- inagaki
7%define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.3)
8%define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
9
10Summary: Python bindings for Qt4
11Name:    PyQt4
12Version: 4.7.4
13Release: 2%{?_dist_release}
14
15# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
16License: GPLv3 or GPLv2 with exceptions
17Group:   Development/Languages
18URL:     http://www.riverbankcomputing.com/software/pyqt/
19Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
20Patch1:  PyQt-x11-gpl-4.4.4-64bit.patch
21# HACK! FIXME: ping upstream why this isn't working right. -- Rex
22Patch2:  PyQt-x11-gpl-4.5.2-QT_SHARED.patch
23Patch4:  PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
24
25# Vine Patch
26Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29#BuildRequires: chrpath
30BuildRequires: dbus-devel dbus-python-devel
31BuildRequires: findutils
32BuildRequires: phonon-devel
33# beware of PyQt4/qscintilla bootstap issues
34#BuildRequires: qscintilla
35BuildRequires: qt4-devel >= 4.5.0
36BuildRequires: python-devel
37BuildRequires: sip-devel >= 4.9
38BuildRequires: libXext-devel
39Requires: sip >= %{sip_ver}
40Requires: dbus-python
41Requires: qt4 >= %{qtver}
42
43
44%description
45These are Python bindings for Qt4.
46
47%package devel
48Summary: Files needed to build other bindings based on Qt4
49Group:   Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: qt4-devel >= %{qtver}
52Requires: sip-devel >= 4.9
53
54%description devel
55Files needed to build other bindings for C++ classes that inherit from any
56of the Qt4 classes (e.g. KDE or your own).
57
58
59%prep
60%setup -q -n PyQt-x11-gpl-%{version}
61%patch1 -p1 -b .64bit
62%patch2 -p1 -b .QT_SHARED
63%patch4 -p1
64
65%patch100 -p1 -b .phononpath_vine
66
67## permissions
68# mark examples non-executable
69find examples/ -name "*.py" | xargs chmod a-x
70chmod a+rx pyuic/uic/pyuic.py
71
72
73%build
74unset QTDIR || : ; . /etc/profile.d/qt4.sh
75CFLAGS="${CFLAGS:-%optflags}" \
76CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
77%{__python} configure.py \
78  --confirm-license \
79  --qmake=%{qt4qmake} \
80  --no-qsci-api \
81  --verbose
82
83make %{?_smp_mflags}
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
89
90# HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
91rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
92mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
93   $RPM_BUILD_ROOT%{_bindir}/pyuic4
94ln -s %{_bindir}/pyuic4 \
95      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%files
101%defattr(-,root,root,-)
102%doc NEWS README
103%doc OPENSOURCE-NOTICE.TXT
104%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
105%doc LICENSE.GPL3
106%{python_sitearch}/PyQt4/
107%exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
108# fixme?  -> sitearch?  -- Rex
109%{python_sitelib}/dbus/mainloop/qt.so
110%{_libdir}/qt-%{qtver}/plugins/designer/*
111
112%files devel
113%defattr(-,root,root,-)
114%doc doc/*
115%doc examples/
116%{_bindir}/pylupdate4
117%{_bindir}/pyrcc4
118%{_bindir}/pyuic4
119%{python_sitearch}/PyQt4/uic/pyuic.py*
120%{_datadir}/sip/PyQt4/
121#{_qt4_prefix}/qsci/api/python/PyQt4.api
122
123
124%changelog
125* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
126- rebuild with qt4-4.6.3
127- fix %qtver (from 4.6.1 to 4.6.3)
128
129* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
130- new upstream release
131- rebuilt with sip-4.10.5 and qt4-4.6.3
132
133* Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
134- new upstream release
135- updated Patch100
136
137* Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
138- updated Patch100 to build phonon module
139
140* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
141- new upstream release
142- rebuilt with python-2.6.4
143- dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
144
145* Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
146- now BuildRequires sip-devel >= 4.9 (was 4.8.2)
147
148* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
149- new upstream release
150- added BR: libXext-devel
151
152* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
153- added Patch100 for building phonon modules
154
155* Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
156- Initial build for Vine
157
158* Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
159- PyQt4-4.5.4
160
161* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
163
164* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
165- PyQt4-4.5.2
166
167* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
168- fix build with qt-4.5.2
169- PyQt4-devel multilib conflict (#509415)
170
171* Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
172- PyQt-4.5.1
173
174* Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
175- PyQt-4.5
176
177* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
178- fix generation of sip_ver
179
180* Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
181- PyQt-4.5-snapshot-20090520
182
183* Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
184- rebuild for phonon bindings (#497680)
185
186* Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
187- move designer plugins to main/runtime (#487622)
188
189* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
190- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
191
192* Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
193- rebuild against qt-4.5rc1
194
195* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
196- Rebuild for Python 2.6
197
198* Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
199- PyQt-4.4.4
200
201* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
202- PyQt-4.4.3
203
204* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
205- PyQt4 is built without QtWebKit support (#451490)
206
207* Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
208- PyQt-4.4.2
209
210* Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
211- PyQt-4.4
212- License: GPLv3 or GPLv2 with exceptions
213
214* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
215- respin (gcc43)
216
217* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
218- PyQt-4.3.3
219
220* Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
221- dbus support (#395741)
222
223* Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
224- PyQt-4.3.1
225
226* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
227- drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
228
229* Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
230- fix QtDesigner plugin install
231
232* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
233- 64bit QtDesigner patch
234
235* Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
236- -devel: Requires: qt4-devel
237
238* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
239- use %%python_sitearch
240- License: GPLv2
241
242* Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
243- fix python_sitelib typo (wrt chrpath call)
244- move %%_bindir stuff to -devel
245- mark %%doc examples non-executable
246- add shebang to %%_bindir/pyuic4
247
248* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
249- remove rpath from QtDesigner.so
250- BR: qt4-devel > 4.3.0-8
251
252* Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
253- PyQt4-4.2
254
255* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
256- fix build against multilib'd qt4
257
258* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
259- PyQt4-4.1.1
260- BR: sip-devel >= 4.5.1
261
262* Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
263- PyQt4-4.1
264
265* Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
266- don't own %%_datadir/sip (bug #206633)
267
268* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
269- BR: qt4-devel < 4.2
270
271* Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
272- fix reference(s) to qmake(4)
273
274* Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
275- PyQt-4.0.1
276
277* Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
278- PyQt-4.0(final)
279- BR: sip-devel >= 4.4.4 (see bug #199430)
280
281* Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
282- drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
283- drop usage of (undefined) %%sip_min
284
285* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
286- cleanup for Extras
287
288* Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
289- 4.0beta1
290
291* Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
292- respin for sip-4.4.3
293- use sip-abi, sip-abi-min
294
295* Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
296- 20060421 snapshot
297
298* Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
299- first try, using 20060417 snapshot
300
Note: See TracBrowser for help on using the repository browser.