source: projects/specs/trunk/P/PyOpenGL/PyOpenGL-vl.spec @ 521

Revision 521, 3.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%define pyver %(python -c 'import sys;print(sys.version[0:3])')
3
4Name:           PyOpenGL
5Version:        3.0.0
6Release:        2%{_dist_release}
7Summary:        Python bindings for OpenGL
8License:        BSD
9Group:          System Environment/Libraries
10URL:            http://pyopengl.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/pyopengl/%{name}-%{version}.tar.gz
12Patch0:         PyOpenGL-3.0.0a6-shebang.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  python-devel python-setuptools
15BuildArch:      noarch
16Requires:       python-numeric python-setuptools
17Requires:       freeglut
18
19# in some other repositories this is named python-opengl
20Provides:       python-opengl = %{version}-%{release}
21Obsoletes:      python-opengl < %{version}-%{release}
22
23%description
24PyOpenGL is the cross platform Python binding to OpenGL and related APIs. It
25includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3 and WGL 4. It also
26includes support for dozens of extensions (where supported in the underlying
27implementation).
28
29PyOpenGL is interoperable with a large number of external GUI libraries
30for Python including (Tkinter, wxPython, FxPy, PyGame, and Qt).
31
32
33%package Tk
34Summary:        %{name} OpenGL Tk widget
35Group:          System Environment/Libraries
36Requires:       %{name} = %{version}-%{release}, tkinter
37
38%description Tk
39%{name} Togl (Tk OpenGL widget) 1.6 support.
40
41
42%package doc
43Summary:        Documentation files for %{name}
44Group:          Development/Languages
45Requires:       %{name} = %{version}-%{release}
46
47%description doc
48Documentation files for %{name}.
49
50
51%prep
52%setup -q
53%patch0 -p1 -z .shebang
54
55%build
56python setup.py build
57
58
59%install
60rm -rf $RPM_BUILD_ROOT
61python setup.py install -O1 --skip-build --root="$RPM_BUILD_ROOT" \
62  --prefix="%{_prefix}"
63chmod -x $RPM_BUILD_ROOT%{python_sitelib}/%{name}-%{version}-py%{pyver}.egg-info
64
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69
70%files
71%defattr(-,root,root,-)
72%doc license.txt
73%{python_sitelib}/*OpenGL*
74%exclude %{python_sitelib}/OpenGL/Tk
75
76%files Tk
77%defattr(-,root,root,-)
78%{python_sitelib}/OpenGL/Tk
79
80%files doc
81%defattr(-,root,root,-)
82%doc documentation/*
83
84
85%changelog
86* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.0-2
87- rebuilt with python-2.6.4
88
89* Sat Jul 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
90- new upstream release 3.0.0
91- remove Requires: XOrg-gl (libGL should be pulled by freeglut)
92
93* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.0-0.b1.2
94- rebuilt with python-2.5.2
95
96* Mon Apr 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0.0-0.b1.1
97- Initial build for Vine Linux
98
99* Mon Dec 31 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.5.b1
100- New upstream release 3.0.0b1
101
102* Thu Aug 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.4.a6
103- Change BuildRequires python-setuptools to python-setuptools-devel for
104  the python-setuptools package split
105
106* Fri Apr 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.3.a6
107- Add missing freeglut, libGL and libGLU requires (bz 236159)
108
109* Thu Mar 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.2.a6
110- Remove tests from the package (bz 234121)
111- Add -Tk subpackage (bz 234121)
112- Remove shebang from files with shebang instead of chmod +x (bz 234121)
113- Better description
114
115* Sat Mar 24 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.1.a6
116- Initial Fedora Extras package
Note: See TracBrowser for help on using the repository browser.