source: projects/specs/trunk/P/PyOpenGL/PyOpenGL-vl.spec @ 9105

Revision 9105, 3.9 KB checked in by inagaki, 9 years ago (diff)

2014-11-20 Ryoichi INAGAKI <ryo1@…>

  • PyOpenGL, polkit-qt: updated
  • lxrandr, polkit-gnome, polkit-kde: changed Group


Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%define pyver %(python -c 'import sys;print(sys.version[0:3])')
3
4Name:           PyOpenGL
5Version:        3.1.0
6Release:        1%{_dist_release}
7Summary:        Python bindings for OpenGL
8Summary(ja):    OpenGL の Python バインディング
9License:        BSD
10Group:          System Environment/Libraries
11URL:            http://pyopengl.sourceforge.net/
12Source0:        http://downloads.sourceforge.net/pyopengl/%{name}-%{version}.tar.gz
13Patch0:         PyOpenGL-3.0.0a6-shebang.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildArch:      noarch
17BuildRequires:  python-devel
18BuildRequires:  python-setuptools
19Requires:       python-numeric
20Requires:       python-setuptools
21Requires:       freeglut
22
23# in some other repositories this is named python-opengl
24Provides:       python-opengl = %{version}-%{release}
25Obsoletes:      python-opengl < %{version}-%{release}
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30
31%description
32PyOpenGL is the cross platform Python binding to OpenGL and related APIs. It
33includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3 and WGL 4. It also
34includes support for dozens of extensions (where supported in the underlying
35implementation).
36
37PyOpenGL is interoperable with a large number of external GUI libraries
38for Python including (Tkinter, wxPython, FxPy, PyGame, and Qt).
39
40
41%package Tk
42Summary:        %{name} OpenGL Tk widget
43Group:          System Environment/Libraries
44Requires:       %{name} = %{version}-%{release}, tkinter
45Requires:       tkinter
46
47%description Tk
48%{name} Togl (Tk OpenGL widget) 1.6 support.
49
50
51%package doc
52Summary:        Documentation files for %{name}
53Summary(ja):    %{name} のドキュメント
54Group:          Documentation
55Requires:       %{name} = %{version}-%{release}
56
57%description doc
58Documentation files for %{name}.
59
60
61%prep
62%setup -q
63#patch0 -p1 -z .shebang
64
65%build
66python setup.py build
67
68
69%install
70rm -rf $RPM_BUILD_ROOT
71python setup.py install -O1 --skip-build \
72       --root="$RPM_BUILD_ROOT" --prefix="%{_prefix}"
73
74#chmod -x $RPM_BUILD_ROOT%{python_sitelib}/%{name}-%{version}-py%{pyver}.egg-info
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79
80%files
81%defattr(-,root,root,-)
82%doc license.txt
83%{python_sitelib}/*OpenGL*
84%exclude %{python_sitelib}/OpenGL/Tk
85
86%files Tk
87%defattr(-,root,root,-)
88%{python_sitelib}/OpenGL/Tk
89
90%files doc
91%defattr(-,root,root,-)
92#doc documentation/*
93
94
95%changelog
96* Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.1.0-1
97- updated to 3.1.0
98
99* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-4
100- rebuild with python-2.7.2
101
102* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.0.0-3
103- rebuilt with rpm-4.8.1-3
104
105* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.0-2
106- rebuilt with python-2.6.4
107
108* Sat Jul 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
109- new upstream release 3.0.0
110- remove Requires: XOrg-gl (libGL should be pulled by freeglut)
111
112* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.0-0.b1.2
113- rebuilt with python-2.5.2
114
115* Mon Apr 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0.0-0.b1.1
116- Initial build for Vine Linux
117
118* Mon Dec 31 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.5.b1
119- New upstream release 3.0.0b1
120
121* Thu Aug 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.4.a6
122- Change BuildRequires python-setuptools to python-setuptools-devel for
123  the python-setuptools package split
124
125* Fri Apr 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.3.a6
126- Add missing freeglut, libGL and libGLU requires (bz 236159)
127
128* Thu Mar 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.2.a6
129- Remove tests from the package (bz 234121)
130- Add -Tk subpackage (bz 234121)
131- Remove shebang from files with shebang instead of chmod +x (bz 234121)
132- Better description
133
134* Sat Mar 24 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.1.a6
135- Initial Fedora Extras package
Note: See TracBrowser for help on using the repository browser.