source: projects/specs/trunk/P/PyKDE4/PyKDE4-vl.spec @ 10568

Revision 10568, 5.9 KB checked in by Takemikaduchi, 6 years ago (diff)

grantlee: update to 0.5.1
others: rebuils with gcc-5.4.0

Line 
1%define pykde4_akonadi 1
2%define pyqt4_version_min 4.8.5
3%define sip_version_min 4.12
4
5%global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
6%global pyqt4_version %(%{__python} -c 'import PyQt4.pyqtconfig; print(PyQt4.pyqtconfig._pkg_config["pyqt_version_str"])' 2> /dev/null || echo %{pyqt4_version_min})
7
8Name: PyKDE4
9Summary: Python bindings for KDE4
10Summary(ja): KDE4 の Python バインディング
11Version: 4.14.3
12Release: 4%{?_dist_release}
13
14# http://techbase.kde.org/Policies/Licensing_Policy
15License: LGPLv2+
16Group: System Environment/Libraries
17URL: http://developer.kde.org/language-bindings/
18
19Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/pykde4-%{version}.tar.xz
20
21# from fedora
22Patch0: pykde4-4.14.3-missing_symbols.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires:  akonadi-devel
26BuildRequires:  kdebase-workspace-devel >= 4.11.6
27BuildRequires:  kdelibs-devel >= %{version}
28BuildRequires:  kdepimlibs-devel >= %{version}
29BuildRequires:  python-devel
30BuildRequires:  PyQt4-devel >= %{pyqt4_version_min}
31#BuildRequires:  sip-devel >= %{sip_version_min}
32BuildRequires:  sip-devel
33BuildRequires:  qscintilla-devel >= 2.4
34BuildRequires:  qimageblitz-devel
35BuildRequires:  shared-desktop-ontologies-devel
36BuildRequires:  soprano-devel
37
38Requires: kdelibs >= %{version}
39Requires: PyQt4 >= %{pyqt4_version}
40
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%description
45%{summary}.
46
47%package akonadi
48Summary: Akonadi runtime support for PyKDE4
49Summary(ja): PyKDE4 の Akonadi ランタイムサポート
50Group:    System Environment/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: kdepimlibs-akonadi >= %{version}
53
54%description akonadi
55%{summary}.
56
57%package devel
58Summary:  Files needed to build PyKDE4-based applications
59Summary(ja): PyKDE4 ベースのアプリケーション開発に必要なファイル
60Group:    Development/Libraries
61Requires: PyQt4-devel
62Requires: %{name} = %{version}-%{release}
63Requires: %{name}-akonadi = %{version}-%{release}
64
65%description devel
66%{summary}.
67
68
69%prep
70%setup -q -n pykde4-%{version}
71%patch0 -p1 -b .missing_symbols
72
73%build
74mkdir -p %{_target_platform}
75pushd %{_target_platform}
76%cmake \
77    -DCMAKE_BUILD_TYPE=release \
78    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
79    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
80    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
81    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
82    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
83    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
84    -DPYTHON_LIBRARY=%{_libdir}/libpython%{python_ver}.so.1.0 \
85    -DPYTHON_LIBRARIES=%{_libdir}/libpython%{python_ver}.so.1.0 \
86    -DPYTHON_INCLUDE_PATH=%{_includedir}/python%{python_ver} \
87    ..
88popd
89 
90make %{?_smp_mflags} -C %{_target_platform}
91
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
97
98# HACK: fix multilib conflict, similar to PyQt4's http://bugzilla.redhat.com/509415
99rm -fv $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
100mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py \
101   $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
102ln -s %{_bindir}/pykdeuic4 \
103      $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py
104
105# install pykde4 examples under correct dir
106mkdir -p $RPM_BUILD_ROOT%{_docdir}
107rm -fv $RPM_BUILD_ROOT%{_datadir}/kde4/apps/pykde4/examples/*.py?
108mv $RPM_BUILD_ROOT%{_datadir}/kde4/apps/pykde4 $RPM_BUILD_ROOT%{_docdir}/
109
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114
115%files
116%defattr(-,root,root,-)
117%{_bindir}/pykdeuic4-2.7
118%{python_sitearch}/PyKDE4/
119%exclude %{python_sitearch}/PyKDE4/akonadi.so
120%{python_sitearch}/PyQt4/uic/widget-plugins/kde4.py*
121%dir %{_docdir}/pykde4
122%{_libdir}/kde4/kpythonpluginfactory.so
123
124%files akonadi
125%defattr(-,root,root,-)
126%{python_sitearch}/PyKDE4/akonadi.so
127
128%files devel
129%defattr(-,root,root,-)
130%{_bindir}/pykdeuic4
131%{python_sitearch}/PyQt4/uic/pykdeuic4.py*
132%{_datadir}/sip/PyKDE4/
133%{_docdir}/pykde4/examples/
134
135%changelog
136* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-4
137- rebuild with gcc-5.4.0
138- add Patch0 (pykde4-4.14.3-missing_symbols.patch) from fc
139
140* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-3
141- fixed typo at Group...
142
143* Sun Jan  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-2
144- moved main package to System Environment/Libraries Group
145
146* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
147- new upstream release
148- remove Patch0 (pykde4-4.12.3-sip_4_15_5.patch)
149
150* Tue May 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
151- new upstream release
152- add Patch0 (pykde4-4.12.3-sip_4_15_5.patch)
153
154* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
155- new upstream release
156
157* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
158- new upstream release
159
160* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
161- new upstream release
162
163* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
164- new upstream release
165- remove BuildRequires: okular-devel, kate-devel
166
167* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
168- new upstream release
169
170* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
171- new upstream release
172
173* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
174- new upstream release
175
176* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
177- new upstream release
178
179* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
180- new upstream release
181
182* Sun Feb 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
183- rebuild with python-2.7.2
184
185* Sat Dec 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
186- new upstream release
187
188* Sat Oct 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
189- new upstream release
190
191* Tue Aug  2 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
192- Initial build for Vine Linux
193
194* Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
195- 4.7.0
196
197* Fri Jul 08 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
198- 4.6.95
199
200* Thu Jul 07 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-1
201- first try
202
Note: See TracBrowser for help on using the repository browser.