source: projects/specs/trunk/O/OpenType-mikachan/OpenType-mikachan-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _fontdir %{_datadir}/fonts/OpenType-mikachan
2
3Summary:        Free Japanese Handwriting OpenType Font (mikachan_o)
4Summary(ja):    フリーの手書き風日本語 OpenType フォント (みかちゃん_o)
5Name:           OpenType-mikachan
6Version:        9.1
7Release:        2%{?_dist_release}
8URL:            http://mikachan-font.com/
9License:        distributable
10Group:          User Interface/X
11BuildArch:      noarch
12Buildroot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  lha
14Provides:       mikachanfont
15Requires(post):   xorg-x11-font-utils
16Requires(postun): xorg-x11-font-utils
17
18Source0:        http://mikachan.sourceforge.jp/mikachan_o.lzh
19Source1:        http://mikachan.sourceforge.jp/mikachanP_o.lzh
20Source2:        http://mikachan.sourceforge.jp/mikachanPB_o.lzh
21Source3:        http://mikachan.sourceforge.jp/mikachanPS_o.lzh
22
23Distribution:   Vine Linux
24Vendor:         Project Vine
25
26%description
27Free Japanese Handwriting OpenType Font (mikachan_o)
28
29    mikachan_o    : fixed-width fonts
30    mikachan_o-P  : proportional fonts (regular)
31    mikachan_o-PB : proportional fonts (bold style)
32    mikachan_o-PS : proportional fonts with somewhat smaller hiragana,
33                    katakana, alphabets, and numbers
34
35It is possible to display following characters.
36 - Hiragana
37 - Katakana
38 - Numbers
39 - Alphabets
40 - Symbols
41 - Kanji (for education, usual, person's name, JIS Level 1/2, IBM extended)
42
43# '
44%description -l ja
45フリーの手書き風日本語 OpenType フォント (みかちゃん_o) です。
46
47    mikachan_o    : 等幅フォント
48    mikachan_o-P  : プロポーショナルフォント
49    mikachan_o-PB : 太字のプロポーショナルフォント
50    mikachan_o-PS : ひらがな・カタカナ・数字・英字が少し小さめのプロポーショ
51                    ナルフォント
52
53次の文字を表示することができます。
54 - ひらがな
55 - カタカナ
56 - 数字
57 - 英字
58 - 記号
59 - 漢字 (教育/常用/人名/JIS第1水準/JIS第2水準/IBM拡張)
60
61%prep
62%setup -n %{name}-%{version} -c -T
63
64if `%{_bindir}/lha l --archive-kanji-code=sjis %{SOURCE0} > /dev/null 2>&1`
65then
66        srccode=euc-jp
67else
68        srccode=cp932
69fi
70
71%{_bindir}/lha xq %{SOURCE0}
72%{_bindir}/lha xq %{SOURCE1}
73%{_bindir}/lha xq %{SOURCE2}
74%{_bindir}/lha xq %{SOURCE3}
75
76# FIXME: convert file name (cp932 -> utf-8)
77for i in *.otf ; do
78        %__mv $i `echo $i \
79                | %{_bindir}/iconv -f $srccode -t utf-8 \
80                | %__sed -e 's/みかちゃん/mikachan/'`
81done
82
83%build
84
85%install
86%__rm -rf %{buildroot}
87%__mkdir -p %{buildroot}%{_fontdir}
88%__install -m644 -p *.otf %{buildroot}%{_fontdir}
89
90%post
91( umask 133 ; %{_bindir}/fc-cache %{_fontdir} ) ||:
92
93%postun
94( umask 133 ; %{_bindir}/fc-cache %{_fontdir} ) ||:
95
96%clean
97%__rm -rf %{buildroot}
98
99%files
100%defattr(-,root,root)
101%{_fontdir}/*
102
103%changelog
104* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9.1-2vl5
105- changed font path
106
107* Sun Oct 05 2008 Shu KONNO <owa@bg.wakwak.com> 9.1-1vl5
108- applied new versioning policy, spec in utf-8
109- updated scripts to convert file name's encode
110- changed font path
111
112* Fri Oct 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.1-0vl2
113- fix install script to support autoconfiscated lha
114
115* Sat May 07 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.1-0vl1
116- upstream release
117- fix scripts
118
119* Sun Feb 15 2004 KAZUKI SHIMURA <rito@pos.to> 9.0-0vl1
120- initial release
Note: See TracBrowser for help on using the repository browser.