source: projects/specs/trunk/O/OpenType-mikachan/OpenType-mikachan-vl.spec @ 8160

Revision 8160, 4.1 KB checked in by tanakanata, 10 years ago (diff)

only rebuild

Line 
1%define _fontdir %{_datadir}/fonts/%{name}
2
3Summary:        Free Japanese Handwriting OpenType Font (mikachan_o)
4Summary(ja):    フリーの手書き風日本語 OpenType フォント (みかちゃん_o)
5Name:           OpenType-mikachan
6Version:        9.1
7Release:        4%{?_dist_release}
8URL:            http://mikachan-font.com/
9License:        distributable
10Group:          User Interface/X
11BuildArch:      noarch
12Buildroot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  lha
14Requires(post):   xorg-x11-font-utils
15Requires(postun): xorg-x11-font-utils
16
17## Ver9.1 2005.02.12
18## see chksrc() in %%prep
19Source0:        http://mikachan.sourceforge.jp/mikachan_o.lzh
20Source1:        http://mikachan.sourceforge.jp/mikachanP_o.lzh
21Source2:        http://mikachan.sourceforge.jp/mikachanPB_o.lzh
22Source3:        http://mikachan.sourceforge.jp/mikachanPS_o.lzh
23
24## vine
25Source10:       README.vine
26
27Distribution:   Vine Linux
28Vendor:         Project Vine
29
30%description
31Free Japanese Handwriting OpenType Font (mikachan_o)
32
33    mikachan_o    : fixed-width fonts
34    mikachan_o-P  : proportional fonts (regular)
35    mikachan_o-PB : proportional fonts (bold style)
36    mikachan_o-PS : proportional fonts with somewhat smaller hiragana,
37                    katakana, alphabets, and numbers
38
39It is possible to display following characters.
40 - Hiragana
41 - Katakana
42 - Numbers
43 - Alphabets
44 - Symbols
45 - Kanji (for education, usual, person's name, JIS Level 1/2, IBM extended)
46
47# '
48%description -l ja
49フリーの手書き風日本語 OpenType フォント (みかちゃん_o) です。
50
51    mikachan_o    : 等幅フォント
52    mikachan_o-P  : プロポーショナルフォント
53    mikachan_o-PB : 太字のプロポーショナルフォント
54    mikachan_o-PS : ひらがな・カタカナ・数字・英字が少し小さめのプロポーショ
55                    ナルフォント
56
57次の文字を表示することができます。
58 - ひらがな
59 - カタカナ
60 - 数字
61 - 英字
62 - 記号
63 - 漢字 (教育/常用/人名/JIS第1水準/JIS第2水準/IBM拡張)
64
65%prep
66## check sha1sum of sources
67## For any mikachan*.lzh archives,
68## its filename has no versioning informations.
69chksrc(){
70    cd %_sourcedir
71#ad1b8d96e20f398661a18e4ba7704881705e1e21  mikachanPB_o.lzh
72    sha1sum -c --quiet - <<EOT
73ad1b8d96e20f398661a18e4ba7704881705e1e21  mikachanPB_o.lzh
74cca9a25cbff69fbdd1f03c7c07dae17f9bc183f0  mikachanPS_o.lzh
75da5f64708e108fe97f989587abe7153a488651d0  mikachanP_o.lzh
763896763b947fd4f5510fb3348435efce15879db6  mikachan_o.lzh
77EOT
78    [ $? -eq 1 ] && return 1
79    cd -
80    return 0
81}
82chksrc || exit 1
83
84%setup -n %{name}-%{version} -c -T
85
86if `%{_bindir}/lha l --archive-kanji-code=sjis %{SOURCE0} > /dev/null 2>&1`
87then
88        srccode=euc-jp
89else
90        srccode=cp932
91fi
92
93%{_bindir}/lha xq %{SOURCE0}
94%{_bindir}/lha xq %{SOURCE1}
95%{_bindir}/lha xq %{SOURCE2}
96%{_bindir}/lha xq %{SOURCE3}
97
98# FIXME: convert file name (cp932 -> utf-8)
99for i in *.otf ; do
100        %__mv $i `echo $i \
101                | %{_bindir}/iconv -f $srccode -t utf-8 \
102                | %__sed -e 's/みかちゃん/mikachan/'`
103done
104
105## copy README.vine
106%__cp %{SOURCE10} .
107
108%build
109
110%install
111%__rm -rf %{buildroot}
112%__mkdir -p %{buildroot}%{_fontdir}
113%__install -m644 -p *.otf %{buildroot}%{_fontdir}
114
115%post
116%__font_install_post %{_fontdir}
117
118%postun
119%__font_install_postun %{_fontdir}
120
121%clean
122%__rm -rf %{buildroot}
123
124%files
125%defattr(-,root,root)
126%doc README.vine
127%{_fontdir}/*
128
129%changelog
130* Sun Jan 12 2014 TANAKA hiroaki <mosaicist@jcom.home.ne.jp> 9.1-4
131- rebuilt with gcc-4.8
132
133* Wed Jun 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 9.1-3
134- added README.vine
135- drooped Provides: mikachanfont
136- checked sha1sum of sources
137  - defined chksrc() in %%prep
138- use %%__font_install_post, %%__font_install_postun
139
140* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9.1-2vl5
141- changed font path
142
143* Sun Oct 05 2008 Shu KONNO <owa@bg.wakwak.com> 9.1-1vl5
144- applied new versioning policy, spec in utf-8
145- updated scripts to convert file name's encode
146- changed font path
147
148* Fri Oct 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.1-0vl2
149- fix install script to support autoconfiscated lha
150
151* Sat May 07 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.1-0vl1
152- upstream release
153- fix scripts
154
155* Sun Feb 15 2004 KAZUKI SHIMURA <rito@pos.to> 9.0-0vl1
156- initial release
Note: See TracBrowser for help on using the repository browser.