source: projects/specs/trunk/O/OpenImageIO/OpenImageIO-vl.spec @ 12484

Revision 12484, 8.8 KB checked in by tomop, 4 years ago (diff)

updated 8 packages

LibRaw?-0.20.0-1

OpenImageIO-2.2.6.1-1

babl-0.1.78-1

gegl04-0.4.26-1

gthumb-3.10.0-1

jasper-2.0.19-1

pugixml-1.10-1

pybind11-2.5.0-7

Line 
1%bcond_with external_pugixml
2
3%global subname oiio
4
5Name:           OpenImageIO
6Version:        2.2.6.1
7Release:        1%{?_dist_release}
8Summary:        Library for reading and writing images
9Group:          system
10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13License:        BSD
14URL:            https://sites.google.com/site/openimageio/home
15Source0:        https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
16# Images for test suite
17#Source1:        oiio-images.tar.gz
18
19BuildRequires:  cmake
20BuildRequires:  git
21BuildRequires:  txt2man
22BuildRequires:  qt5-qtbase-devel
23BuildRequires:  libboost-devel
24BuildRequires:  libboost-python3
25BuildRequires:  libboost-filesystem
26BuildRequires:  glew-devel
27BuildRequires:  OpenEXR-devel
28BuildRequires:  python3-devel
29BuildRequires:  python3-rpm-macros
30# BuildRequires:  openssl-devel
31BuildRequires:  libpng-devel libtiff-devel openjpeg2-devel giflib-devel
32BuildRequires:  libwebp-devel
33BuildRequires:  Field3D-devel
34BuildRequires:  hdf5-devel
35BuildRequires:  zlib-devel
36BuildRequires:  jasper-devel
37BuildRequires:  LibRaw-devel
38%if %{with external_pugixml}
39BuildRequires:  pugixml-devel
40%endif
41BuildRequires:  pybind11-devel
42
43# WARNING: OpenColorIO and OpenImageIO are cross dependent.
44# If an ABI incompatible update is done in one, the other also needs to be
45# rebuilt.
46BuildRequires:  OpenColorIO-devel
47
48Obsoletes:      python-OpenImageIO
49
50# We don't want to provide private python extension libs
51%{?filter_setup:
52%filter_provides_in %{python3_sitearch}/.*\.so$
53%filter_setup
54}
55
56%description
57OpenImageIO is a library for reading and writing images, and a bunch of related
58classes, utilities, and applications. Main features include:
59- Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
60  writing 2D images that is format agnostic.
61- Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
62  DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
63  PNM/PPM/PGM/PBM, Field3d.
64- An ImageCache class that transparently manages a cache so that it can access
65  truly vast amounts of image data.
66
67
68%package -n python3-%{name}
69Summary:        Python 3 bindings for %{name}
70Group:          programming
71Requires:       %{name} = %{version}-%{release}
72
73%description -n python3-%{name}
74Python3 bindings for %{name}.
75
76
77%package utils
78Summary:        Command line utilities for %{name}
79Group:          graphics
80Requires:       %{name} = %{version}-%{release}
81
82%description utils
83Command-line tools to manipulate and get information on images using the
84%{name} library.
85
86
87%package iv
88Summary:        %{name} based image viewer
89Group:          graphics
90Requires:       %{name} = %{version}-%{release}
91
92%description iv
93A really nice image viewer, iv, based on %{name} classes (and so will work
94with any formats for which plugins are available).
95
96
97%package devel
98Summary:        Documentation for %{name}
99Group:          programming
100Requires:       %{name} = %{version}-%{release}
101
102%description devel
103Development files for package %{name}
104
105
106%debug_package
107
108
109%prep
110%setup -q -n oiio-Release-%{version}
111
112%if %{with external_pugixml}
113# Remove bundled pugixml
114rm -f src/include/OpenImageIO/pugixml.hpp \
115      src/include/OpenImageIO/pugiconfig.hpp \
116      src/libutil/OpenImageIO/pugixml.cpp
117%endif
118
119# Remove bundled tbb
120%{__rm} -rf src/include/tbb
121
122# Install test images
123#rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
124#tar --strip-components=1 -xzf %{SOURCE1}
125
126
127%build
128%{__rm} -rf build/linux && %{__mkdir_p} build/linux && pushd build/linux
129# CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
130# CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
131%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
132       -DCMAKE_SKIP_RPATH:BOOL=TRUE \
133       -DBUILDSTATIC=OFF \
134       -DLINKSTATIC=OFF \
135       -DPYTHON_VERSION=%{python3_version} \
136       -DINSTALL_DOCS:BOOL=FALSE \
137       -DINSTALL_FONTS:BOOL=FALSE \
138%if %{with external_pugixml}
139       -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
140%endif
141       -DUSE_TBB:BOOL=FALSE \
142       -DUSE_OPENSSL:BOOL=TRUE \
143       -DSTOP_ON_WARNING:BOOL=FALSE \
144       -DJPEG_INCLUDE_DIR=$(pkg-config --variable=includedir libopenjp2) \
145       -DVERBOSE=TRUE \
146       ../../
147
148%{__make} %{?_smp_mflags}
149popd
150
151%install
152pushd build/linux
153%{make_install}
154popd
155
156# # Move man pages to the right directory
157# mkdir -p %{buildroot}%{_mandir}/man1
158# cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
159
160%post -p %{_syssbindir}/ldconfig
161%postun -p %{_syssbindir}/ldconfig
162
163
164%files
165%license LICENSE*
166%doc CHANGES.md CONTRIBUTING.md README.md
167%{_libdir}/libOpenImageIO.so.*
168%{_libdir}/libOpenImageIO_Util.so.*
169
170%files -n python3-%{name}
171%{python3_sitearch}/OpenImageIO.so
172
173%files utils
174%exclude %{_bindir}/iv
175%{_bindir}/*
176# %exclude %{_mandir}/man1/iv.1.gz
177# %{_mandir}/man1/*.1.gz
178
179%files iv
180%{_bindir}/iv
181# %{_mandir}/man1/iv.1.gz
182
183%files devel
184%doc src/doc/*.pdf
185%{_libdir}/libOpenImageIO.so
186%{_libdir}/libOpenImageIO_Util.so
187%dir %{_libdir}/pkgconfig
188%{_libdir}/pkgconfig/OpenImageIO.pc
189%dir %{_datadir}/cmake
190%dir %{_datadir}/cmake/Modules
191%dir %{_libdir}/cmake/OpenImageIO
192%{_datadir}/cmake/Modules/FindOpenImageIO.cmake
193%{_libdir}/cmake/OpenImageIO/*
194%{_includedir}/*
195
196
197%changelog
198* Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6.1-1
199- new upstream release.
200
201* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.10.1-1
202- new upstream release.
203- built with boost-1.72.0.
204
205* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.11-1
206- new upstream release.
207
208* Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
209- update to 1.8.17
210
211* Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
212- update to 1.8.16
213- change BuildRequires: qt4-devel to qt5-qtbase-devel
214- drop BuildRequires: openssl-devel
215
216* Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
217- update to 1.7.19
218- using macro
219
220* Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
221- rebuild with hdf5-1.8.20
222
223* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
224- update to 1.7.17
225
226* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
227- rebuilt with LibRaw-0.17.2.
228
229* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
230- rebuild with gcc-5.4.0
231
232* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
233- new upstream release
234
235* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
236- new upstream release
237- remove Patch0
238- create python-%%{name} subpackage
239
240* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
241- rebuild with glew-1.13.0
242
243* Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
244- initial build for Vine Linux
245- add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
246
247
248* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
249- rebuild (openexr)
250
251* Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
252- Update to latest upstream release.
253
254* Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
255- Update to latest upstream release.
256
257* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
258- Rebuild for Field3D 1.4.3.
259
260* Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
261- Rebuild for pugixml 1.4
262
263* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
264- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
265
266* Fri Aug  1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
267- Update to latest upstream release.
268
269* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
270- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
271
272* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
273- Rebuild for boost 1.55.0
274
275* Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
276- rebuild for boost 1.55.0
277
278* Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
279- Update to latest upstream release.
280
281* Tue Jan  7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
282- Update to latest upstream release.
283- Add libgif as build requirement.
284
285* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
286- rebuild (openexr)
287
288* Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
289- rebuilt for GLEW 1.10
290
291* Wed Nov  6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
292- Update to latest upstream release.
293- Fix ppc builds (BZ#1021977).
294- Add conditionals to build requirements for EPEL 6.
295
296* Wed Oct  2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
297- Update to latest upstream release.
298
299* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
300- rebuild (ilmbase/openexr)
301
302* Thu Aug  8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
303- Update to latest upstream release.
304
305* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
306- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
307
308* Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
309- Rebuild for boost 1.54.0
Note: See TracBrowser for help on using the repository browser.