source: projects/specs/trunk/O/OpenImageIO/OpenImageIO-vl.spec @ 12191

Revision 12191, 7.9 KB checked in by ara_t, 5 years ago (diff)

OpenImageIO: update to 1.8.17

Line 
1%global subname oiio
2
3Name:           OpenImageIO
4Version:        1.8.17
5Release:        1%{?_dist_release}
6Summary:        Library for reading and writing images
7
8Group:          System Environment/Libraries
9License:        BSD
10URL:            https://sites.google.com/site/openimageio/home
11
12Source0:        https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
13# Images for test suite
14#Source1:        oiio-images.tar.gz
15
16BuildRequires:  cmake
17BuildRequires:  txt2man
18BuildRequires:  qt5-qtbase-devel
19BuildRequires:  libboost-devel
20BuildRequires:  libboost-python
21BuildRequires:  libboost-filesystem
22BuildRequires:  glew-devel
23BuildRequires:  OpenEXR-devel ilmbase-devel
24BuildRequires:  python-devel
25# BuildRequires:  openssl-devel
26BuildRequires:  libpng-devel libtiff-devel openjpeg-devel giflib-devel
27BuildRequires:  libwebp-devel
28BuildRequires:  Field3D-devel
29BuildRequires:  hdf5-devel
30BuildRequires:  zlib-devel
31BuildRequires:  jasper-devel
32BuildRequires:  LibRaw-devel
33BuildRequires:  pugixml-devel
34
35# WARNING: OpenColorIO and OpenImageIO are cross dependent.
36# If an ABI incompatible update is done in one, the other also needs to be
37# rebuilt.
38BuildRequires:  OpenColorIO-devel
39
40# We don't want to provide private python extension libs
41%{?filter_setup:
42%filter_provides_in %{python_sitearch}/.*\.so$
43%filter_setup
44}
45
46
47%description
48OpenImageIO is a library for reading and writing images, and a bunch of related
49classes, utilities, and applications. Main features include:
50- Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
51  writing 2D images that is format agnostic.
52- Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
53  DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
54  PNM/PPM/PGM/PBM, Field3d.
55- An ImageCache class that transparently manages a cache so that it can access
56  truly vast amounts of image data.
57
58
59%package -n python-%{name}
60Summary:        Python 2 bindings for %{name}
61Requires:       %{name} = %{version}-%{release}
62
63%description -n python-%{name}
64Python bindings for %{name}.
65
66
67%package utils
68Summary:        Command line utilities for %{name}
69Requires:       %{name} = %{version}-%{release}
70
71%description utils
72Command-line tools to manipulate and get information on images using the
73%{name} library.
74
75
76%package iv
77Summary:        %{name} based image viewer
78Requires:       %{name} = %{version}-%{release}
79
80%description iv
81A really nice image viewer, iv, based on %{name} classes (and so will work
82with any formats for which plugins are available).
83
84
85%package devel
86Summary:        Documentation for %{name}
87Group:          Development/Libraries
88Requires:       %{name} = %{version}-%{release}
89
90%description devel
91Development files for package %{name}
92
93
94%prep
95%setup -q -n oiio-Release-%{version}
96
97# Remove bundled pugixml
98%{__rm} -f src/include/pugixml.hpp \
99        src/include/pugiconfig.hpp \
100        src/libutil/pugixml.cpp
101
102# Remove bundled tbb
103%{__rm} -rf src/include/tbb
104
105# Install test images
106#rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
107#tar --strip-components=1 -xzf %{SOURCE1}
108
109
110%build
111%{__rm} -rf build/linux && %{__mkdir_p} build/linux && pushd build/linux
112# CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
113# CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
114%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
115       -DCMAKE_SKIP_RPATH:BOOL=TRUE \
116       -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
117       -DPYLIB_INSTALL_DIR:PATH=%{python_sitearch} \
118       -DINSTALL_DOCS:BOOL=FALSE \
119       -DINSTALL_FONTS:BOOL=FALSE \
120       -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
121       -DUSE_TBB:BOOL=FALSE \
122       -DUSE_OPENSSL:BOOL=TRUE \
123       -DSTOP_ON_WARNING:BOOL=FALSE \
124       -DUSE_CPP:STRING=14 \
125%ifarch ppc ppc64
126       -DNOTHREADS:BOOL=FALSE \
127%endif
128       -DJPEG_INCLUDE_DIR=%{_includedir} \
129       -DVERBOSE=TRUE \
130       ../../
131
132%{__make} %{?_smp_mflags}
133popd
134
135%install
136pushd build/linux
137%{make_install}
138popd
139
140# # Move man pages to the right directory
141# mkdir -p %{buildroot}%{_mandir}/man1
142# cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
143
144%post -p %{_syssbindir}/ldconfig
145%postun -p %{_syssbindir}/ldconfig
146
147
148%files
149%doc CHANGES.md CONTRIBUTING.md README.md LICENSE
150%{_libdir}/libOpenImageIO.so.*
151%{_libdir}/libOpenImageIO_Util.so.*
152
153%files -n python-%{name}
154%{python_sitearch}/OpenImageIO.so
155
156%files utils
157%exclude %{_bindir}/iv
158%{_bindir}/*
159# %exclude %{_mandir}/man1/iv.1.gz
160# %{_mandir}/man1/*.1.gz
161
162%files iv
163%{_bindir}/iv
164# %{_mandir}/man1/iv.1.gz
165
166%files devel
167%doc src/doc/*.pdf
168%{_libdir}/libOpenImageIO.so
169%{_libdir}/libOpenImageIO_Util.so
170%{_includedir}/*
171
172
173%changelog
174* Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
175- update to 1.8.17
176
177* Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
178- update to 1.8.16
179- change BuildRequires: qt4-devel to qt5-qtbase-devel
180- drop BuildRequires: openssl-devel
181
182* Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
183- update to 1.7.19
184- using macro
185
186* Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
187- rebuild with hdf5-1.8.20
188
189* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
190- update to 1.7.17
191
192* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
193- rebuilt with LibRaw-0.17.2.
194
195* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
196- rebuild with gcc-5.4.0
197
198* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
199- new upstream release
200
201* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
202- new upstream release
203- remove Patch0
204- create python-%%{name} subpackage
205
206* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
207- rebuild with glew-1.13.0
208
209* Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
210- initial build for Vine Linux
211- add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
212
213
214* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
215- rebuild (openexr)
216
217* Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
218- Update to latest upstream release.
219
220* Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
221- Update to latest upstream release.
222
223* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
224- Rebuild for Field3D 1.4.3.
225
226* Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
227- Rebuild for pugixml 1.4
228
229* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
230- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
231
232* Fri Aug  1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
233- Update to latest upstream release.
234
235* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
237
238* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
239- Rebuild for boost 1.55.0
240
241* Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
242- rebuild for boost 1.55.0
243
244* Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
245- Update to latest upstream release.
246
247* Tue Jan  7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
248- Update to latest upstream release.
249- Add libgif as build requirement.
250
251* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
252- rebuild (openexr)
253
254* Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
255- rebuilt for GLEW 1.10
256
257* Wed Nov  6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
258- Update to latest upstream release.
259- Fix ppc builds (BZ#1021977).
260- Add conditionals to build requirements for EPEL 6.
261
262* Wed Oct  2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
263- Update to latest upstream release.
264
265* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
266- rebuild (ilmbase/openexr)
267
268* Thu Aug  8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
269- Update to latest upstream release.
270
271* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
272- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
273
274* Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
275- Rebuild for boost 1.54.0
Note: See TracBrowser for help on using the repository browser.