source: projects/specs/trunk/O/OpenImageIO/OpenImageIO-vl.spec @ 11354

Revision 11354, 7.3 KB checked in by ara_t, 6 years ago (diff)

OpenImageIO: rebuild under libboost-1.66.0

Line 
1%global subname oiio
2
3Name:           OpenImageIO
4Version:        1.7.17
5Release:        1%{?_dist_release}
6Summary:        Library for reading and writing images
7
8Group:          System Environment/Libraries
9License:        BSD
10URL:            https://sites.google.com/site/openimageio/home
11
12Source0:        https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
13# Images for test suite
14#Source1:        oiio-images.tar.gz
15
16BuildRequires:  cmake
17BuildRequires:  txt2man
18BuildRequires:  qt4-devel
19BuildRequires:  libboost-devel
20BuildRequires:  libboost-python
21BuildRequires:  libboost-filesystem
22BuildRequires:  glew-devel
23BuildRequires:  OpenEXR-devel ilmbase-devel
24BuildRequires:  python-devel
25BuildRequires:  openssl-devel
26BuildRequires:  libpng-devel libtiff-devel openjpeg-devel giflib-devel
27BuildRequires:  libwebp-devel
28BuildRequires:  Field3D-devel
29BuildRequires:  hdf5-devel
30BuildRequires:  zlib-devel
31BuildRequires:  jasper-devel
32BuildRequires:  LibRaw-devel
33BuildRequires:  pugixml-devel
34
35# WARNING: OpenColorIO and OpenImageIO are cross dependent.
36# If an ABI incompatible update is done in one, the other also needs to be
37# rebuilt.
38BuildRequires:  OpenColorIO-devel
39
40# We don't want to provide private python extension libs
41%{?filter_setup:
42%filter_provides_in %{python_sitearch}/.*\.so$
43%filter_setup
44}
45
46
47%description
48OpenImageIO is a library for reading and writing images, and a bunch of related
49classes, utilities, and applications. Main features include:
50- Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
51  writing 2D images that is format agnostic.
52- Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
53  DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
54  PNM/PPM/PGM/PBM, Field3d.
55- An ImageCache class that transparently manages a cache so that it can access
56  truly vast amounts of image data.
57
58
59%package -n python-%{name}
60Summary:        Python 2 bindings for %{name}
61Requires:       %{name} = %{version}-%{release}
62
63%description -n python-%{name}
64Python bindings for %{name}.
65
66
67%package utils
68Summary:        Command line utilities for %{name}
69Requires:       %{name} = %{version}-%{release}
70
71%description utils
72Command-line tools to manipulate and get information on images using the
73%{name} library.
74
75
76%package iv
77Summary:        %{name} based image viewer
78Requires:       %{name} = %{version}-%{release}
79
80%description iv
81A really nice image viewer, iv, based on %{name} classes (and so will work
82with any formats for which plugins are available).
83
84
85%package devel
86Summary:        Documentation for %{name}
87Group:          Development/Libraries
88Requires:       %{name} = %{version}-%{release}
89
90%description devel
91Development files for package %{name}
92
93
94%prep
95%setup -q -n oiio-Release-%{version}
96
97# Remove bundled pugixml
98rm -f src/include/pugixml.hpp \
99      src/include/pugiconfig.hpp \
100      src/libutil/pugixml.cpp
101
102# Remove bundled tbb
103rm -rf src/include/tbb
104
105# Install test images
106#rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
107#tar --strip-components=1 -xzf %{SOURCE1}
108
109
110%build
111rm -rf build/linux && mkdir -p build/linux && pushd build/linux
112# CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
113# CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
114%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
115       -DCMAKE_SKIP_RPATH:BOOL=TRUE \
116       -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
117       -DPYLIB_INSTALL_DIR:PATH=%{python_sitearch} \
118       -DINSTALL_DOCS:BOOL=FALSE \
119       -DINSTALL_FONTS:BOOL=FALSE \
120       -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
121       -DUSE_TBB:BOOL=FALSE \
122%ifarch ppc ppc64
123       -DNOTHREADS:BOOL=FALSE \
124%endif
125       -DVERBOSE=TRUE \
126       ../../
127
128make %{?_smp_mflags}
129
130
131%install
132pushd build/linux
133make DESTDIR=%{buildroot} install
134
135# # Move man pages to the right directory
136# mkdir -p %{buildroot}%{_mandir}/man1
137# cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
138
139%post -p /sbin/ldconfig
140%postun -p /sbin/ldconfig
141
142
143
144%files
145%doc CHANGES.md CONTRIBUTING.md README.md LICENSE
146%{_libdir}/libOpenImageIO.so.*
147%{_libdir}/libOpenImageIO_Util.so.*
148
149%files -n python-%{name}
150%{python_sitearch}/OpenImageIO.so
151
152%files utils
153%exclude %{_bindir}/iv
154%{_bindir}/*
155# %exclude %{_mandir}/man1/iv.1.gz
156# %{_mandir}/man1/*.1.gz
157
158%files iv
159%{_bindir}/iv
160# %{_mandir}/man1/iv.1.gz
161
162%files devel
163%doc src/doc/*.pdf
164%{_libdir}/libOpenImageIO.so
165%{_libdir}/libOpenImageIO_Util.so
166%{_includedir}/*
167
168
169%changelog
170* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
171- update to 1.7.17
172
173* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
174- rebuilt with LibRaw-0.17.2.
175
176* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
177- rebuild with gcc-5.4.0
178
179* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
180- new upstream release
181
182* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
183- new upstream release
184- remove Patch0
185- create python-%%{name} subpackage
186
187* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
188- rebuild with glew-1.13.0
189
190* Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
191- initial build for Vine Linux
192- add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
193
194
195* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
196- rebuild (openexr)
197
198* Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
199- Update to latest upstream release.
200
201* Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
202- Update to latest upstream release.
203
204* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
205- Rebuild for Field3D 1.4.3.
206
207* Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
208- Rebuild for pugixml 1.4
209
210* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
212
213* Fri Aug  1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
214- Update to latest upstream release.
215
216* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
218
219* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
220- Rebuild for boost 1.55.0
221
222* Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
223- rebuild for boost 1.55.0
224
225* Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
226- Update to latest upstream release.
227
228* Tue Jan  7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
229- Update to latest upstream release.
230- Add libgif as build requirement.
231
232* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
233- rebuild (openexr)
234
235* Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
236- rebuilt for GLEW 1.10
237
238* Wed Nov  6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
239- Update to latest upstream release.
240- Fix ppc builds (BZ#1021977).
241- Add conditionals to build requirements for EPEL 6.
242
243* Wed Oct  2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
244- Update to latest upstream release.
245
246* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
247- rebuild (ilmbase/openexr)
248
249* Thu Aug  8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
250- Update to latest upstream release.
251
252* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
253- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
254
255* Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
256- Rebuild for boost 1.54.0
Note: See TracBrowser for help on using the repository browser.