source: projects/specs/trunk/O/OpenImageIO/OpenImageIO-vl.spec @ 12537

Revision 12537, 9.0 KB checked in by tomop, 3 years ago (diff)

updated 8 packages

Field3D-1.7.3-3

OpenImageIO-2.2.11.1-1

c-ares-1.17.1-1

curl-7.75.0-1

galera-26.4.6-1

libboost-1.75.0-1

nghttp2-1.43.0-1

source-highlight-3.1.8-3

Line 
1%bcond_with external_pugixml
2
3%global subname oiio
4
5Name:           OpenImageIO
6Version:        2.2.11.1
7Release:        1%{?_dist_release}
8Summary:        Library for reading and writing images
9Group:          system
10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13License:        BSD
14URL:            https://sites.google.com/site/openimageio/home
15Source0:        https://github.com/OpenImageIO/oiio/archive/v%{version}.tar.gz#/oiio-%{version}.tar.gz
16# Images for test suite
17#Source1:        oiio-images.tar.gz
18
19BuildRequires:  cmake
20BuildRequires:  git
21BuildRequires:  txt2man
22BuildRequires:  qt5-qtbase-devel
23BuildRequires:  fmt-devel
24BuildRequires:  robin-map-devel
25BuildRequires:  libboost-devel
26BuildRequires:  libboost-python3
27BuildRequires:  libboost-filesystem
28#BuildRequires:  glew-devel
29BuildRequires:  OpenEXR-devel
30BuildRequires:  python3-devel
31BuildRequires:  python3-rpm-macros
32# BuildRequires:  openssl-devel
33BuildRequires:  libpng-devel libtiff-devel openjpeg2-devel giflib-devel
34BuildRequires:  libwebp-devel
35BuildRequires:  Field3D-devel
36BuildRequires:  hdf5-devel
37BuildRequires:  zlib-devel
38BuildRequires:  jasper-devel
39BuildRequires:  LibRaw-devel
40%if %{with external_pugixml}
41BuildRequires:  pugixml-devel
42%endif
43BuildRequires:  pybind11-devel
44
45# WARNING: OpenColorIO and OpenImageIO are cross dependent.
46# If an ABI incompatible update is done in one, the other also needs to be
47# rebuilt.
48BuildRequires:  OpenColorIO-devel
49
50Obsoletes:      python-OpenImageIO
51
52# We don't want to provide private python extension libs
53%{?filter_setup:
54%filter_provides_in %{python3_sitearch}/.*\.so$
55%filter_setup
56}
57
58%description
59OpenImageIO is a library for reading and writing images, and a bunch of related
60classes, utilities, and applications. Main features include:
61- Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
62  writing 2D images that is format agnostic.
63- Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
64  DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
65  PNM/PPM/PGM/PBM, Field3d.
66- An ImageCache class that transparently manages a cache so that it can access
67  truly vast amounts of image data.
68
69
70%package -n python3-%{name}
71Summary:        Python 3 bindings for %{name}
72Group:          programming
73Requires:       %{name} = %{version}-%{release}
74
75%description -n python3-%{name}
76Python3 bindings for %{name}.
77
78
79%package utils
80Summary:        Command line utilities for %{name}
81Group:          graphics
82Requires:       %{name} = %{version}-%{release}
83
84%description utils
85Command-line tools to manipulate and get information on images using the
86%{name} library.
87
88
89%package iv
90Summary:        %{name} based image viewer
91Group:          graphics
92Requires:       %{name} = %{version}-%{release}
93
94%description iv
95A really nice image viewer, iv, based on %{name} classes (and so will work
96with any formats for which plugins are available).
97
98
99%package devel
100Summary:        Documentation for %{name}
101Group:          programming
102Requires:       %{name} = %{version}-%{release}
103
104%description devel
105Development files for package %{name}
106
107
108%debug_package
109
110
111%prep
112%setup -q -n oiio-%{version}
113
114%if %{with external_pugixml}
115# Remove bundled pugixml
116rm -f src/include/OpenImageIO/pugixml.hpp \
117      src/include/OpenImageIO/pugiconfig.hpp \
118      src/libutil/OpenImageIO/pugixml.cpp
119%endif
120
121# Remove bundled tbb
122%{__rm} -rf src/include/tbb
123
124# Install test images
125#rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
126#tar --strip-components=1 -xzf %{SOURCE1}
127
128
129%build
130%{__rm} -rf build/linux && %{__mkdir_p} build/linux && pushd build/linux
131# CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
132# CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
133%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
134       -DCMAKE_SKIP_RPATH:BOOL=TRUE \
135       -DBUILDSTATIC=OFF \
136       -DLINKSTATIC=OFF \
137       -DPYTHON_VERSION=%{python3_version} \
138       -DINSTALL_DOCS:BOOL=FALSE \
139       -DINSTALL_FONTS:BOOL=FALSE \
140%if %{with external_pugixml}
141       -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
142%endif
143       -DUSE_TBB:BOOL=FALSE \
144       -DUSE_OPENSSL:BOOL=TRUE \
145       -DSTOP_ON_WARNING:BOOL=FALSE \
146       -DJPEG_INCLUDE_DIR=$(pkg-config --variable=includedir libopenjp2) \
147       -DVERBOSE=TRUE \
148       ../../
149
150%{__make} %{?_smp_mflags}
151popd
152
153%install
154pushd build/linux
155%{make_install}
156popd
157
158# # Move man pages to the right directory
159# mkdir -p %{buildroot}%{_mandir}/man1
160# cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
161
162%post -p %{_syssbindir}/ldconfig
163%postun -p %{_syssbindir}/ldconfig
164
165
166%files
167%license LICENSE*
168%doc CHANGES.md CONTRIBUTING.md README.md
169%{_libdir}/libOpenImageIO.so.*
170%{_libdir}/libOpenImageIO_Util.so.*
171
172%files -n python3-%{name}
173%{python3_sitearch}/OpenImageIO*.so
174
175%files utils
176%exclude %{_bindir}/iv
177%{_bindir}/*
178# %exclude %{_mandir}/man1/iv.1.gz
179# %{_mandir}/man1/*.1.gz
180
181%files iv
182%{_bindir}/iv
183# %{_mandir}/man1/iv.1.gz
184
185%files devel
186%doc src/doc/*.pdf
187%{_libdir}/libOpenImageIO.so
188%{_libdir}/libOpenImageIO_Util.so
189%dir %{_libdir}/pkgconfig
190%{_libdir}/pkgconfig/OpenImageIO.pc
191%dir %{_datadir}/cmake
192%dir %{_datadir}/cmake/Modules
193%dir %{_libdir}/cmake/OpenImageIO
194%{_datadir}/cmake/Modules/FindOpenImageIO.cmake
195%{_libdir}/cmake/OpenImageIO/*
196%{_includedir}/*
197
198
199%changelog
200* Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.11.1-1
201- new upstream release.
202
203* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9.0-1
204- new upstream release.
205
206* Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6.1-1
207- new upstream release.
208
209* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.10.1-1
210- new upstream release.
211- built with boost-1.72.0.
212
213* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.11-1
214- new upstream release.
215
216* Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
217- update to 1.8.17
218
219* Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
220- update to 1.8.16
221- change BuildRequires: qt4-devel to qt5-qtbase-devel
222- drop BuildRequires: openssl-devel
223
224* Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
225- update to 1.7.19
226- using macro
227
228* Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
229- rebuild with hdf5-1.8.20
230
231* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
232- update to 1.7.17
233
234* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
235- rebuilt with LibRaw-0.17.2.
236
237* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
238- rebuild with gcc-5.4.0
239
240* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
241- new upstream release
242
243* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
244- new upstream release
245- remove Patch0
246- create python-%%{name} subpackage
247
248* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
249- rebuild with glew-1.13.0
250
251* Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
252- initial build for Vine Linux
253- add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
254
255
256* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
257- rebuild (openexr)
258
259* Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
260- Update to latest upstream release.
261
262* Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
263- Update to latest upstream release.
264
265* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
266- Rebuild for Field3D 1.4.3.
267
268* Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
269- Rebuild for pugixml 1.4
270
271* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
272- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
273
274* Fri Aug  1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
275- Update to latest upstream release.
276
277* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
278- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
279
280* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
281- Rebuild for boost 1.55.0
282
283* Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
284- rebuild for boost 1.55.0
285
286* Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
287- Update to latest upstream release.
288
289* Tue Jan  7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
290- Update to latest upstream release.
291- Add libgif as build requirement.
292
293* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
294- rebuild (openexr)
295
296* Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
297- rebuilt for GLEW 1.10
298
299* Wed Nov  6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
300- Update to latest upstream release.
301- Fix ppc builds (BZ#1021977).
302- Add conditionals to build requirements for EPEL 6.
303
304* Wed Oct  2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
305- Update to latest upstream release.
306
307* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
308- rebuild (ilmbase/openexr)
309
310* Thu Aug  8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
311- Update to latest upstream release.
312
313* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
314- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
315
316* Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
317- Rebuild for boost 1.54.0
Note: See TracBrowser for help on using the repository browser.