source: projects/specs/trunk/O/OpenIPMI/OpenIPMI-vl.spec @ 9005

Revision 9005, 14.4 KB checked in by inagaki, 10 years ago (diff)

2014-10-12 Ryoichi INAGAKI <ryo1@…>

  • GeoIP: rebuild
  • OpenIPMI, nasm, yasm: update


Line 
1# TODO: uses private copy of libedit, should be modified to use system one
2
3%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
4Summary: IPMI (Intelligent Platform Management Interface) library and tools
5Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
6Name: OpenIPMI
7Version: 2.0.21
8Release: 1%{?_dist_release}
9License: LGPLv2+ and GPLv2+ or BSD
10Group: System Environment/Base
11URL: http://sourceforge.net/projects/openipmi/
12Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
13Source1: openipmi.sysconf
14Source2: openipmi.initscript
15Source3: openipmigui.desktop
16Source4: README.initscript
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: desktop-file-utils
19BuildRequires: gdbm-devel
20BuildRequires: glib2-devel
21BuildRequires: ncurses-devel
22BuildRequires: net-snmp-devel
23BuildRequires: openssl-devel
24BuildRequires: perl
25BuildRequires: popt-devel
26BuildRequires: python-devel
27BuildRequires: swig
28BuildRequires: tcl
29BuildRequires: tkinter
30Requires(post): chkconfig
31Requires(preun): chkconfig
32
33Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39The Open IPMI project aims to develop an open code base to allow access to
40platform information using Intelligent Platform Management Interface (IPMI).
41This package contains the tools of the OpenIPMI project.
42
43%package libs
44Summary: The OpenIPMI runtime libraries
45Summary(ja): OpenIPMI ランタイムライブラリ
46Group: System Environment/Libraries
47
48%description libs
49The OpenIPMI-libs package contains the runtime libraries for shared binaries
50and applications.
51
52%package perl
53Summary: IPMI Perl language bindings
54Summary(ja): IPMI Perl 言語バインディング
55Group: Development/Libraries
56Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
57
58%description perl
59The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
60
61%package python
62Group: Development/Libraries
63Summary: IPMI Python language bindings
64Summary(ja): IPMI Python 言語バインディング
65Requires: python
66
67%description python
68The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
69
70%package devel
71Summary: The development environment for the OpenIPMI project
72Summary(ja): OpenIPMI の開発キット
73Group: Development/Libraries
74Requires: %{name} = %{version}-%{release}
75Requires: pkgconfig
76
77%description devel
78The OpenIPMI-devel package contains the development libraries and header files
79of the OpenIPMI project.
80
81%package gui
82Summary: IPMI graphical user interface tool
83Summary(ja): IPMI GUI ツール
84Group: System Environment/Base
85Requires: tix
86Requires: tkinter
87Requires: %{name}-python = %{version}-%{release}
88
89%description gui
90The OpenIPMI-gui package contains the graphical user interface to monitor
91and control IPMI-enabled devices.
92
93
94%prep
95%setup -q
96%patch1 -p1
97
98%build
99export CFLAGS="-fPIC $RPM_OPT_FLAGS"
100%configure \
101  --with-pythoninstall=%{python_sitearch} \
102  --disable-dependency-tracking \
103  --with-tcl=no \
104  --with-glib12=no \
105  --disable-static
106# get rid of rpath
107sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
108sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
109
110make   # not %{?_smp_mflags} safe
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make install DESTDIR=$RPM_BUILD_ROOT
115rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
116
117install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
118install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
119install -d ${RPM_BUILD_ROOT}%{_initrddir}
120install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
121
122desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
123
124install -m 644 %SOURCE4 .
125
126%post
127/sbin/chkconfig --add ipmi
128
129%preun
130if [ $1 = 0 ]; then
131   service ipmi stop >/dev/null 2>&1
132   /sbin/chkconfig --del ipmi
133fi
134
135%postun
136if [ "$1" -ge "1" ]; then
137    service ipmi condrestart >/dev/null 2>&1 || :
138fi
139
140%post libs -p /sbin/ldconfig
141
142%postun libs -p /sbin/ldconfig
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%files
148%defattr(-,root,root)
149%doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
150%config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
151%config(noreplace) %{_sysconfdir}/ipmi/lan.conf
152%config(noreplace) %{_sysconfdir}/sysconfig/ipmi
153%{_initrddir}/ipmi
154%{_bindir}/ipmicmd
155%{_bindir}/ipmilan
156%{_bindir}/ipmish
157%{_bindir}/ipmi_sim
158%{_bindir}/ipmi_ui
159%{_bindir}/openipmicmd
160%{_bindir}/openipmish
161%{_bindir}/rmcp_ping
162%{_bindir}/sdrcomp
163%{_bindir}/solterm
164%{_mandir}/man1/ipmi_*
165%{_mandir}/man1/openipmicmd*
166%{_mandir}/man1/openipmish*
167%{_mandir}/man1/rmcp_ping*
168%{_mandir}/man1/solterm*
169%{_mandir}/man5/ipmi_*
170%{_mandir}/man7/ipmi_cmdlang*
171%{_mandir}/man7/openipmi_conparms*
172%{_mandir}/man8/ipmilan*
173
174%files perl
175%defattr(-,root,root)
176%attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
177%{perl_vendorarch}/auto/OpenIPMI/
178
179%files python
180%defattr(-,root,root)
181%{python_sitearch}/*OpenIPMI*
182
183%files libs
184%defattr(-,root,root)
185%{_libdir}/*.so.*
186
187%files devel
188%defattr(-,root,root)
189%{_includedir}/OpenIPMI
190%{_libdir}/*.so
191%{_libdir}/pkgconfig/*.pc
192
193%files gui
194%defattr(-,root,root)
195%{_bindir}/openipmigui
196%{_mandir}/man1/openipmigui*
197%{python_sitearch}/openipmigui
198%{_datadir}/applications/fedora-openipmigui.desktop
199
200%changelog
201* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.21-1
202- updated to 2.0.21
203- rebuilt with perl-5.16.3
204
205* Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-5
206- rebuild with net-snmp-5.7.1
207
208* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
209- rebuild with python-2.7.2
210
211* Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
212- build with perl 5.12.3
213- add Vendor and Distribution tags
214
215* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
216- rebuild with openssl-1.0.0d
217
218* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
219- initial build for Vine Linux
220
221* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
222- Mass rebuild with perl-5.12.0
223
224* Wed May  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
225- updated to OpenIPMI-2.0.18
226- fixed OpenIPMIpthread pkgconfig file (#468067)
227
228* Mon May  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
229- updated to OpenIPMI-2.0.17
230
231* Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
232- implemented mandatory 'force-reload' command in ipmi service
233
234* Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
235- rebuild against new gdbm
236
237* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
238- add README.initscript describing /etc/init.d/ipmi initscript exit codes
239  (#562151)
240
241* Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
242- fix package License: field, there *are* sources with BSD header
243- distribute README files and COPYING in package
244
245* Tue Jan  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
246- fix package License: field, there is no source with BSD header
247
248* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
249- rebuild against perl 5.10.1
250
251* Tue Dec  1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
252- fix package compilation to remove rpmlint errors
253
254* Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
255- rebuilt with new net-snmp
256
257* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
258- rebuilt with new openssl
259
260* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
261- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
262
263* Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
264- fix compilation flags, debuginfo package is correctly generated now
265
266* Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
267- new upstream release
268
269* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
270- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
271
272* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
273- rebuild with new openssl
274
275* Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
276- fix linking without rpath, prelink won't screw up the libraries
277  anymore (#475265)
278
279* Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
280- shorter probe interval is used in init script, making the service startup
281  quicker in most situations (#475101)
282
283* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
284- Rebuild for Python 2.6
285
286* Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
287- removed static libraries from the -devel subpackage
288- fixed openipmigui.desktop file
289
290* Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
291- fixed typos in the descriptions
292- added .desktop file for openipmigui tool
293
294* Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
295- fixed description of the package
296
297* Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
298- split ipmitool to separate package
299- added 'reload' functionality to init script
300- added seraparate -gui subpackage
301
302* Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
303- Fixed rpath problem in libOpenIPMIposix.so.0.0.1
304
305* Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
306- Fixed several specfile problems (#453751)
307- Update to OpenIPMI-2.0.14
308
309* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
310- Autorebuild for GCC 4.3
311
312* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
313- Updated to OpenIPMI-2.0.13
314- Rebuild due to new openssl
315
316* Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
317- Added missing perl-devel buildrequires
318
319* Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
320- Added missing popt-devel buildrequires
321
322* Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
323- Fix rebuild problems due to glibc change
324- License review and fixes
325
326* Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
327- Update to OpenIPMI-2.0.11
328
329* Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
330- Update for ipmitool-1.8.9
331
332* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
333- rebuild for python 2.5
334
335* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
336- Update due to new net-snmp-5.4
337- Some specfile updates
338
339* Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
340- Fixed check for udev in initscript (#197956)
341
342* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
343- rebuild
344
345* Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
346- don't include <linux/compiler.h>
347
348* Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
349- Fix a build requires (needs glibc-kernheaders)
350
351* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
352- Bump for new glib2
353
354* Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
355- Fixed bug with type conversion in ipmitool (#191091)
356- Added python bindings
357- Split off perl and python bindings in separate subpackages
358- Dropped obsolete patches
359- Added missing buildprereq on readline-devel
360- Made it install the python bindings properly on 64bit archs
361
362* Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
363- Updated ipmitool to 1.8.8
364- Updated OpenIPMI to 2.0.6
365
366* Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
367- Added missing PreReq for chkconfig
368
369* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
370- rebump for build order issues during double-long bump
371
372* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
373- bump again for double-long bug on ppc(64)
374
375* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
376- rebuilt for new gcc4.1 snapshot and glibc changes
377
378* Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
379- Updated ipmitool to latest upstream version.
380- Removed 3 patches for already fixed bugs in latest ipmitool.
381- Adapted warning message fix for ipmitool for latest version.
382
383* Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
384- Fixed some minor things in initscripts.
385
386* Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
387- Included FRU fix for displaying FRUs with ipmitool
388- Included patch for new option to specify a BMC password for IPMI 2.0 sessions
389
390* Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
391- Rebuilt against new libnetsnmp
392
393* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
394- rebuilt
395
396* Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
397- Some more initscript and sysconfig updates from Dell.
398
399* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
400- Rebuilt to link against latest openssl libs.
401- Fixed ipmitool not setting session privilege level (#172312)
402
403* Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
404- Rebuild to link against new net-snmp libs.
405
406* Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
407- Updated initscript to fix missing redhat-lsb bug (#169901)
408
409* Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
410- Another update to latest initscripts from Dell
411- Fixed some missing return statements for non-void functions (#164138)
412
413* Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
414- Updated initscript to latest version from Dell
415
416* Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
417- Fixed the unwanted output of failed module loading of the initscript. Behaves
418  now like all our other initscripts (#165476)
419
420* Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
421- Fixed build problem on 64bit machines
422
423* Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
424- Fixed missing change to not autostart in the initscript
425
426* Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
427- Made the initscript a replacing configfile
428
429* Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
430- Updated versions of the initscripts and sysconf files
431- Fixed typo in preun script and changelog
432
433* Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
434- Updated to OpenIPMI-1.4.14
435- Split the main package into normal and libs package for multilib support
436- Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
437- Added sysconf and initscript (#158270)
438- Fixed oob subscripts (#149142)
439
440* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
441- Correctly put libs in the proper packages
442
443* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
444- gcc4 rebuild fixes
445- Added missing gdbm-devel buildprereq
446
447* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
448- bump release and rebuild with gcc 4
449
450* Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
451- update
452
453* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
454- Initial version
Note: See TracBrowser for help on using the repository browser.