source: projects/specs/trunk/O/OpenIPMI/OpenIPMI-vl.spec @ 9560

Revision 9560, 14.5 KB checked in by Takemikaduchi, 9 years ago (diff)

ImageMagick?: new upstream release
others: remove *.la files

Line 
1# TODO: uses private copy of libedit, should be modified to use system one
2
3%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
4Summary: IPMI (Intelligent Platform Management Interface) library and tools
5Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
6Name: OpenIPMI
7Version: 2.0.21
8Release: 2%{?_dist_release}
9License: LGPLv2+ and GPLv2+ or BSD
10Group: System Environment/Base
11URL: http://sourceforge.net/projects/openipmi/
12Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
13Source1: openipmi.sysconf
14Source2: openipmi.initscript
15Source3: openipmigui.desktop
16Source4: README.initscript
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: desktop-file-utils
19BuildRequires: gdbm-devel
20BuildRequires: glib2-devel
21BuildRequires: ncurses-devel
22BuildRequires: net-snmp-devel
23BuildRequires: openssl-devel
24BuildRequires: perl
25BuildRequires: popt-devel
26BuildRequires: python-devel
27BuildRequires: swig
28BuildRequires: tcl
29BuildRequires: tkinter
30Requires(post): chkconfig
31Requires(preun): chkconfig
32
33Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39The Open IPMI project aims to develop an open code base to allow access to
40platform information using Intelligent Platform Management Interface (IPMI).
41This package contains the tools of the OpenIPMI project.
42
43%package libs
44Summary: The OpenIPMI runtime libraries
45Summary(ja): OpenIPMI ランタイムライブラリ
46Group: System Environment/Libraries
47
48%description libs
49The OpenIPMI-libs package contains the runtime libraries for shared binaries
50and applications.
51
52%package perl
53Summary: IPMI Perl language bindings
54Summary(ja): IPMI Perl 言語バインディング
55Group: Development/Libraries
56Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
57
58%description perl
59The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
60
61%package python
62Group: Development/Libraries
63Summary: IPMI Python language bindings
64Summary(ja): IPMI Python 言語バインディング
65Requires: python
66
67%description python
68The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
69
70%package devel
71Summary: The development environment for the OpenIPMI project
72Summary(ja): OpenIPMI の開発キット
73Group: Development/Libraries
74Requires: %{name} = %{version}-%{release}
75Requires: pkgconfig
76
77%description devel
78The OpenIPMI-devel package contains the development libraries and header files
79of the OpenIPMI project.
80
81%package gui
82Summary: IPMI graphical user interface tool
83Summary(ja): IPMI GUI ツール
84Group: System Environment/Base
85Requires: tix
86Requires: tkinter
87Requires: %{name}-python = %{version}-%{release}
88
89%description gui
90The OpenIPMI-gui package contains the graphical user interface to monitor
91and control IPMI-enabled devices.
92
93
94%prep
95%setup -q
96%patch1 -p1
97
98%build
99export CFLAGS="-fPIC $RPM_OPT_FLAGS"
100%configure \
101  --with-pythoninstall=%{python_sitearch} \
102  --disable-dependency-tracking \
103  --with-tcl=no \
104  --with-glib12=no \
105  --disable-static
106# get rid of rpath
107sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
108sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
109
110make   # not %{?_smp_mflags} safe
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make install DESTDIR=$RPM_BUILD_ROOT
115
116find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
117
118install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
119install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
120install -d ${RPM_BUILD_ROOT}%{_initrddir}
121install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
122
123desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
124
125install -m 644 %SOURCE4 .
126
127%post
128/sbin/chkconfig --add ipmi
129
130%preun
131if [ $1 = 0 ]; then
132   service ipmi stop >/dev/null 2>&1
133   /sbin/chkconfig --del ipmi
134fi
135
136%postun
137if [ "$1" -ge "1" ]; then
138    service ipmi condrestart >/dev/null 2>&1 || :
139fi
140
141%post libs -p /sbin/ldconfig
142
143%postun libs -p /sbin/ldconfig
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%files
149%defattr(-,root,root)
150%doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
151%config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
152%config(noreplace) %{_sysconfdir}/ipmi/lan.conf
153%config(noreplace) %{_sysconfdir}/sysconfig/ipmi
154%{_initrddir}/ipmi
155%{_bindir}/ipmicmd
156%{_bindir}/ipmilan
157%{_bindir}/ipmish
158%{_bindir}/ipmi_sim
159%{_bindir}/ipmi_ui
160%{_bindir}/openipmicmd
161%{_bindir}/openipmish
162%{_bindir}/rmcp_ping
163%{_bindir}/sdrcomp
164%{_bindir}/solterm
165%{_mandir}/man1/ipmi_*
166%{_mandir}/man1/openipmicmd*
167%{_mandir}/man1/openipmish*
168%{_mandir}/man1/rmcp_ping*
169%{_mandir}/man1/solterm*
170%{_mandir}/man5/ipmi_*
171%{_mandir}/man7/ipmi_cmdlang*
172%{_mandir}/man7/openipmi_conparms*
173%{_mandir}/man8/ipmilan*
174
175%files perl
176%defattr(-,root,root)
177%attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
178%{perl_vendorarch}/auto/OpenIPMI/
179
180%files python
181%defattr(-,root,root)
182%{python_sitearch}/*OpenIPMI*
183
184%files libs
185%defattr(-,root,root)
186%{_libdir}/*.so.*
187
188%files devel
189%defattr(-,root,root)
190%{_includedir}/OpenIPMI
191%{_libdir}/*.so
192%{_libdir}/pkgconfig/*.pc
193
194%files gui
195%defattr(-,root,root)
196%{_bindir}/openipmigui
197%{_mandir}/man1/openipmigui*
198%{python_sitearch}/openipmigui
199%{_datadir}/applications/fedora-openipmigui.desktop
200
201%changelog
202* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-2
203- remove *.la files
204
205* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.21-1
206- updated to 2.0.21
207- rebuilt with perl-5.16.3
208
209* Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-5
210- rebuild with net-snmp-5.7.1
211
212* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
213- rebuild with python-2.7.2
214
215* Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
216- build with perl 5.12.3
217- add Vendor and Distribution tags
218
219* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
220- rebuild with openssl-1.0.0d
221
222* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
223- initial build for Vine Linux
224
225* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
226- Mass rebuild with perl-5.12.0
227
228* Wed May  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
229- updated to OpenIPMI-2.0.18
230- fixed OpenIPMIpthread pkgconfig file (#468067)
231
232* Mon May  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
233- updated to OpenIPMI-2.0.17
234
235* Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
236- implemented mandatory 'force-reload' command in ipmi service
237
238* Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
239- rebuild against new gdbm
240
241* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
242- add README.initscript describing /etc/init.d/ipmi initscript exit codes
243  (#562151)
244
245* Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
246- fix package License: field, there *are* sources with BSD header
247- distribute README files and COPYING in package
248
249* Tue Jan  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
250- fix package License: field, there is no source with BSD header
251
252* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
253- rebuild against perl 5.10.1
254
255* Tue Dec  1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
256- fix package compilation to remove rpmlint errors
257
258* Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
259- rebuilt with new net-snmp
260
261* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
262- rebuilt with new openssl
263
264* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
265- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
266
267* Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
268- fix compilation flags, debuginfo package is correctly generated now
269
270* Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
271- new upstream release
272
273* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
274- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
275
276* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
277- rebuild with new openssl
278
279* Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
280- fix linking without rpath, prelink won't screw up the libraries
281  anymore (#475265)
282
283* Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
284- shorter probe interval is used in init script, making the service startup
285  quicker in most situations (#475101)
286
287* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
288- Rebuild for Python 2.6
289
290* Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
291- removed static libraries from the -devel subpackage
292- fixed openipmigui.desktop file
293
294* Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
295- fixed typos in the descriptions
296- added .desktop file for openipmigui tool
297
298* Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
299- fixed description of the package
300
301* Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
302- split ipmitool to separate package
303- added 'reload' functionality to init script
304- added seraparate -gui subpackage
305
306* Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
307- Fixed rpath problem in libOpenIPMIposix.so.0.0.1
308
309* Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
310- Fixed several specfile problems (#453751)
311- Update to OpenIPMI-2.0.14
312
313* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
314- Autorebuild for GCC 4.3
315
316* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
317- Updated to OpenIPMI-2.0.13
318- Rebuild due to new openssl
319
320* Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
321- Added missing perl-devel buildrequires
322
323* Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
324- Added missing popt-devel buildrequires
325
326* Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
327- Fix rebuild problems due to glibc change
328- License review and fixes
329
330* Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
331- Update to OpenIPMI-2.0.11
332
333* Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
334- Update for ipmitool-1.8.9
335
336* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
337- rebuild for python 2.5
338
339* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
340- Update due to new net-snmp-5.4
341- Some specfile updates
342
343* Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
344- Fixed check for udev in initscript (#197956)
345
346* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
347- rebuild
348
349* Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
350- don't include <linux/compiler.h>
351
352* Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
353- Fix a build requires (needs glibc-kernheaders)
354
355* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
356- Bump for new glib2
357
358* Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
359- Fixed bug with type conversion in ipmitool (#191091)
360- Added python bindings
361- Split off perl and python bindings in separate subpackages
362- Dropped obsolete patches
363- Added missing buildprereq on readline-devel
364- Made it install the python bindings properly on 64bit archs
365
366* Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
367- Updated ipmitool to 1.8.8
368- Updated OpenIPMI to 2.0.6
369
370* Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
371- Added missing PreReq for chkconfig
372
373* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
374- rebump for build order issues during double-long bump
375
376* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
377- bump again for double-long bug on ppc(64)
378
379* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
380- rebuilt for new gcc4.1 snapshot and glibc changes
381
382* Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
383- Updated ipmitool to latest upstream version.
384- Removed 3 patches for already fixed bugs in latest ipmitool.
385- Adapted warning message fix for ipmitool for latest version.
386
387* Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
388- Fixed some minor things in initscripts.
389
390* Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
391- Included FRU fix for displaying FRUs with ipmitool
392- Included patch for new option to specify a BMC password for IPMI 2.0 sessions
393
394* Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
395- Rebuilt against new libnetsnmp
396
397* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
398- rebuilt
399
400* Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
401- Some more initscript and sysconfig updates from Dell.
402
403* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
404- Rebuilt to link against latest openssl libs.
405- Fixed ipmitool not setting session privilege level (#172312)
406
407* Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
408- Rebuild to link against new net-snmp libs.
409
410* Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
411- Updated initscript to fix missing redhat-lsb bug (#169901)
412
413* Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
414- Another update to latest initscripts from Dell
415- Fixed some missing return statements for non-void functions (#164138)
416
417* Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
418- Updated initscript to latest version from Dell
419
420* Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
421- Fixed the unwanted output of failed module loading of the initscript. Behaves
422  now like all our other initscripts (#165476)
423
424* Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
425- Fixed build problem on 64bit machines
426
427* Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
428- Fixed missing change to not autostart in the initscript
429
430* Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
431- Made the initscript a replacing configfile
432
433* Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
434- Updated versions of the initscripts and sysconf files
435- Fixed typo in preun script and changelog
436
437* Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
438- Updated to OpenIPMI-1.4.14
439- Split the main package into normal and libs package for multilib support
440- Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
441- Added sysconf and initscript (#158270)
442- Fixed oob subscripts (#149142)
443
444* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
445- Correctly put libs in the proper packages
446
447* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
448- gcc4 rebuild fixes
449- Added missing gdbm-devel buildprereq
450
451* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
452- bump release and rebuild with gcc 4
453
454* Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
455- update
456
457* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
458- Initial version
Note: See TracBrowser for help on using the repository browser.