source: projects/specs/trunk/O/OpenIPMI/OpenIPMI-vl.spec @ 12486

Revision 12486, 17.2 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

OpenIPMI-2.0.29-1

hplip-3.20.6-2

keepalived-2.1.5-1

net-snmp-5.9-1

php74-7.4.10-2

rsyslog-8.2008.0-1

zabbix-5.0.3-1

Line 
1%bcond_with systemd
2%bcond_without python3
3
4# TODO: uses private copy of libedit, should be modified to use system one
5
6Summary: IPMI (Intelligent Platform Management Interface) library and tools
7Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
8Name: OpenIPMI
9Version: 2.0.29
10Release: 1%{?_dist_release}%{?with_systemd:.systemd}
11Group: admin-tools
12Vendor: Project Vine
13Distribution: Vine Linux
14
15License: LGPLv2+ and GPLv2+ or BSD
16URL: https://sourceforge.net/projects/openipmi/
17Source: https://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
18Source1: openipmi.sysconf
19Source2: openipmi.initscript
20Source3: openipmigui.desktop
21Source4: README.initscript
22Source5: openipmi-helper
23Source6: ipmi.service
24Patch1: 0001-man.patch
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildRequires: desktop-file-utils
27BuildRequires: gdbm-devel
28BuildRequires: glib2-devel
29BuildRequires: readline-devel
30BuildRequires: libxcrypt-devel
31BuildRequires: ncurses-devel
32BuildRequires: net-snmp-devel
33BuildRequires: openssl-devel
34BuildRequires: perl
35BuildRequires: popt-devel
36BuildRequires: swig
37BuildRequires: tcl
38
39BuildRequires: python-rpm-macros
40%if %{with python3}
41BuildRequires: python3-devel
42BuildRequires: python3-rpm-macros
43BuildRequires: python3-tkinter
44%else
45BuildRequires: python-devel
46BuildRequires: python2-rpm-macros
47BuildRequires: tkinter
48%endif
49%if %{with systemd}
50BuildRequires:   systemd
51%{?systemd_requires}
52%else
53Requires(post): chkconfig
54Requires(preun): chkconfig
55%endif
56
57# Prevent bogus provides of private libs from perl
58%global __provides_exclude_from %{?__provides_exclude_from:%{__provides_exclude_
59from}|}^%{perl_vendorarch}/auto/.*\\.so$
60
61%description
62The Open IPMI project aims to develop an open code base to allow access to
63platform information using Intelligent Platform Management Interface (IPMI).
64This package contains the tools of the OpenIPMI project.
65
66
67%package libs
68Summary: The OpenIPMI runtime libraries
69Summary(ja): OpenIPMI ランタイムライブラリ
70Group: system
71
72%description libs
73The OpenIPMI-libs package contains the runtime libraries for shared binaries
74and applications.
75
76
77%package perl
78Summary: IPMI Perl language bindings
79Summary(ja): IPMI Perl 言語バインディング
80Group: programming
81Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
82
83%description perl
84The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
85
86
87%if %{with python3}
88%package -n python3-openipmi
89Summary: IPMI Python3 language bindings
90Summary(ja): IPMI Python3 言語バインディング
91Group: programming
92Requires: python3
93Obsoletes: %{name}-python < %{version}-%{release}
94Provides: %{name}-python = %{version}-%{release}
95
96%description -n python3-openipmi
97The OpenIPMI-python3 package contains the Python3 language bindings for OpenIPMI.
98
99
100%else
101%package python
102Summary: IPMI Python language bindings
103Summary(ja): IPMI Python 言語バインディング
104Group: programming
105Requires: python
106
107%description python
108The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
109%endif
110
111
112%package devel
113Summary: The development environment for the OpenIPMI project
114Summary(ja): OpenIPMI の開発キット
115Group: programming
116Requires: %{name} = %{version}-%{release}
117Requires: pkgconfig
118
119%description devel
120The OpenIPMI-devel package contains the development libraries and header files
121of the OpenIPMI project.
122
123
124%package gui
125Summary: IPMI graphical user interface tool
126Summary(ja): IPMI GUI ツール
127Group: admin-tools
128Requires: tix
129Requires: tkinter
130%if %{with python3}
131Requires: python3-openipmi = %{version}-%{release}
132%else
133Requires: %{name}-python = %{version}-%{release}
134%endif
135
136%description gui
137The OpenIPMI-gui package contains the graphical user interface to monitor
138and control IPMI-enabled devices.
139
140
141%debug_package
142
143
144%prep
145%autosetup -p1
146
147
148%build
149%configure \
150  CFLAGS="-fPIC %{optflags} -z now -fno-strict-aliasing" \
151  LDFLAGS="%{?__global_ldflags} -Wl,--as-needed" \
152  --disable-dependency-tracking \
153  --disable-static \
154%if %{with python3}
155  --with-python=%{__python3} \
156  --with-pythoninstall=%{python3_sitearch} \
157%else
158  --with-pythoninstall=%{python_sitearch} \
159%endif
160  --with-tcl=no \
161  --with-tkinter=yes
162# get rid of rpath
163sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
164sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
165
166make   # not %{?_smp_mflags} safe
167
168
169%install
170rm -rf $RPM_BUILD_ROOT
171make install DESTDIR=$RPM_BUILD_ROOT
172
173find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
174
175%if %{with systemd}
176install -d %{buildroot}{%{_unitdir},%{_libexecdir}}
177install -m 755 %{SOURCE5} %{buildroot}%{_libexecdir}/openipmi-helper
178install -m 644 %{SOURCE6} %{buildroot}%{_unitdir}/ipmi.service
179%else
180install -d ${RPM_BUILD_ROOT}%{_initrddir}
181install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
182%endif
183install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
184install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
185install -d %{buildroot}%{_sysconfdir}/modprobe.d
186
187# add missing documentation
188echo ".so man1/openipmicmd.1" > %{buildroot}%{_mandir}/man1/ipmicmd.1
189echo ".so man1/openipmish.1" > %{buildroot}%{_mandir}/man1/ipmish.1
190
191desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
192
193install -m 644 %SOURCE4 .
194
195
196%post
197%if %{with systemd}
198%systemd_post ipmi.service
199%else
200/sbin/chkconfig --add ipmi
201%endif
202
203%preun
204%if %{with systemd}
205%systemd_preun ipmi.service
206%else
207if [ $1 = 0 -o -x /bin/systemctl ]; then
208   service ipmi stop >/dev/null 2>&1
209   /sbin/chkconfig --del ipmi
210fi
211%endif
212
213%postun
214%if %{with systemd}
215%systemd_postun_with_restart ipmi.service
216%else
217if [ "$1" -ge "1" ]; then
218    service ipmi condrestart >/dev/null 2>&1 || :
219fi
220%endif
221
222%post libs -p /sbin/ldconfig
223%postun libs -p /sbin/ldconfig
224
225
226%clean
227rm -rf $RPM_BUILD_ROOT
228
229
230%files
231%defattr(-,root,root)
232%license COPYING COPYING.BSD COPYING.LIB
233%doc CONFIGURING_FOR_LAN FAQ README README.Force README.MotorolaMXP README.initscript
234%config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
235%config(noreplace) %{_sysconfdir}/ipmi/lan.conf
236%config(noreplace) %{_sysconfdir}/sysconfig/ipmi
237%if %{with systemd}
238%{_unitdir}/ipmi.service
239%{_libexecdir}/openipmi-helper
240%else
241%{_initrddir}/ipmi
242%endif
243%{_bindir}/ipmicmd
244%{_bindir}/ipmilan
245%{_bindir}/ipmish
246%{_bindir}/ipmi_sim
247%{_bindir}/ipmi_ui
248%{_bindir}/openipmicmd
249%{_bindir}/openipmish
250%{_bindir}/rmcp_ping
251%{_bindir}/sdrcomp
252%{_bindir}/solterm
253%{_bindir}/openipmi_eventd
254%{_mandir}/man1/ipmi_*
255%{_mandir}/man1/ipmicmd.*
256%{_mandir}/man1/ipmish.*
257%{_mandir}/man1/openipmicmd*
258%{_mandir}/man1/openipmish*
259%{_mandir}/man1/rmcp_ping*
260%{_mandir}/man1/solterm*
261%{_mandir}/man5/ipmi_*
262%{_mandir}/man1/openipmi_eventd*
263%{_mandir}/man7/ipmi_cmdlang*
264%{_mandir}/man7/openipmi_conparms*
265%{_mandir}/man8/ipmilan*
266
267%files perl
268%defattr(-,root,root)
269%attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
270%{perl_vendorarch}/auto/OpenIPMI/
271
272%if %{with python3}
273%files -n python3-openipmi
274%defattr(-,root,root)
275%{python3_sitearch}/*OpenIPMI*
276%else
277%files python
278%defattr(-,root,root)
279%{python_sitearch}/*OpenIPMI*
280%endif
281
282%files libs
283%defattr(-,root,root)
284%{_libdir}/*.so.*
285
286%files devel
287%defattr(-,root,root)
288%{_includedir}/OpenIPMI
289%{_libdir}/*.so
290%{_libdir}/pkgconfig/*.pc
291
292%files gui
293%defattr(-,root,root)
294%{_bindir}/openipmigui
295%{_mandir}/man1/openipmigui*
296%if %{with python3}
297%{python3_sitearch}/openipmigui
298%else
299%{python_sitearch}/openipmigui
300%endif
301%{_datadir}/applications/fedora-openipmigui.desktop
302
303%changelog
304* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.29-1
305- updated to 2.0.29.
306- imported Source5-6 and Patch1 from rawhide.
307- added systemd support (disabled as default).
308
309* Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.27-1
310- updated to 2.0.27.
311- dropped Patch2 (fixed in upstream).
312- added BR:libxcrypt-devel.
313- switched to python3.
314
315* Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.25-1
316- updated to 2.0.25.
317- dropped Patch1 (fixed in upstream).
318- imported Patch2 from rawhide.
319- added BR:libedit-devel.
320
321* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-3
322- rebuild with openssl-1.0.2
323
324* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-2
325- remove *.la files
326
327* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.21-1
328- updated to 2.0.21
329- rebuilt with perl-5.16.3
330
331* Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-5
332- rebuild with net-snmp-5.7.1
333
334* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
335- rebuild with python-2.7.2
336
337* Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
338- build with perl 5.12.3
339- add Vendor and Distribution tags
340
341* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
342- rebuild with openssl-1.0.0d
343
344* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
345- initial build for Vine Linux
346
347* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
348- Mass rebuild with perl-5.12.0
349
350* Wed May  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
351- updated to OpenIPMI-2.0.18
352- fixed OpenIPMIpthread pkgconfig file (#468067)
353
354* Mon May  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
355- updated to OpenIPMI-2.0.17
356
357* Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
358- implemented mandatory 'force-reload' command in ipmi service
359
360* Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
361- rebuild against new gdbm
362
363* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
364- add README.initscript describing /etc/init.d/ipmi initscript exit codes
365  (#562151)
366
367* Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
368- fix package License: field, there *are* sources with BSD header
369- distribute README files and COPYING in package
370
371* Tue Jan  5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
372- fix package License: field, there is no source with BSD header
373
374* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
375- rebuild against perl 5.10.1
376
377* Tue Dec  1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
378- fix package compilation to remove rpmlint errors
379
380* Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
381- rebuilt with new net-snmp
382
383* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
384- rebuilt with new openssl
385
386* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
387- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
388
389* Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
390- fix compilation flags, debuginfo package is correctly generated now
391
392* Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
393- new upstream release
394
395* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
396- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
397
398* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
399- rebuild with new openssl
400
401* Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
402- fix linking without rpath, prelink won't screw up the libraries
403  anymore (#475265)
404
405* Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
406- shorter probe interval is used in init script, making the service startup
407  quicker in most situations (#475101)
408
409* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
410- Rebuild for Python 2.6
411
412* Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
413- removed static libraries from the -devel subpackage
414- fixed openipmigui.desktop file
415
416* Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
417- fixed typos in the descriptions
418- added .desktop file for openipmigui tool
419
420* Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
421- fixed description of the package
422
423* Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
424- split ipmitool to separate package
425- added 'reload' functionality to init script
426- added seraparate -gui subpackage
427
428* Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
429- Fixed rpath problem in libOpenIPMIposix.so.0.0.1
430
431* Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
432- Fixed several specfile problems (#453751)
433- Update to OpenIPMI-2.0.14
434
435* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
436- Autorebuild for GCC 4.3
437
438* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
439- Updated to OpenIPMI-2.0.13
440- Rebuild due to new openssl
441
442* Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
443- Added missing perl-devel buildrequires
444
445* Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
446- Added missing popt-devel buildrequires
447
448* Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
449- Fix rebuild problems due to glibc change
450- License review and fixes
451
452* Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
453- Update to OpenIPMI-2.0.11
454
455* Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
456- Update for ipmitool-1.8.9
457
458* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
459- rebuild for python 2.5
460
461* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
462- Update due to new net-snmp-5.4
463- Some specfile updates
464
465* Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
466- Fixed check for udev in initscript (#197956)
467
468* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
469- rebuild
470
471* Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
472- don't include <linux/compiler.h>
473
474* Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
475- Fix a build requires (needs glibc-kernheaders)
476
477* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
478- Bump for new glib2
479
480* Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
481- Fixed bug with type conversion in ipmitool (#191091)
482- Added python bindings
483- Split off perl and python bindings in separate subpackages
484- Dropped obsolete patches
485- Added missing buildprereq on readline-devel
486- Made it install the python bindings properly on 64bit archs
487
488* Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
489- Updated ipmitool to 1.8.8
490- Updated OpenIPMI to 2.0.6
491
492* Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
493- Added missing PreReq for chkconfig
494
495* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
496- rebump for build order issues during double-long bump
497
498* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
499- bump again for double-long bug on ppc(64)
500
501* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
502- rebuilt for new gcc4.1 snapshot and glibc changes
503
504* Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
505- Updated ipmitool to latest upstream version.
506- Removed 3 patches for already fixed bugs in latest ipmitool.
507- Adapted warning message fix for ipmitool for latest version.
508
509* Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
510- Fixed some minor things in initscripts.
511
512* Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
513- Included FRU fix for displaying FRUs with ipmitool
514- Included patch for new option to specify a BMC password for IPMI 2.0 sessions
515
516* Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
517- Rebuilt against new libnetsnmp
518
519* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
520- rebuilt
521
522* Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
523- Some more initscript and sysconfig updates from Dell.
524
525* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
526- Rebuilt to link against latest openssl libs.
527- Fixed ipmitool not setting session privilege level (#172312)
528
529* Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
530- Rebuild to link against new net-snmp libs.
531
532* Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
533- Updated initscript to fix missing redhat-lsb bug (#169901)
534
535* Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
536- Another update to latest initscripts from Dell
537- Fixed some missing return statements for non-void functions (#164138)
538
539* Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
540- Updated initscript to latest version from Dell
541
542* Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
543- Fixed the unwanted output of failed module loading of the initscript. Behaves
544  now like all our other initscripts (#165476)
545
546* Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
547- Fixed build problem on 64bit machines
548
549* Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
550- Fixed missing change to not autostart in the initscript
551
552* Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
553- Made the initscript a replacing configfile
554
555* Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
556- Updated versions of the initscripts and sysconf files
557- Fixed typo in preun script and changelog
558
559* Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
560- Updated to OpenIPMI-1.4.14
561- Split the main package into normal and libs package for multilib support
562- Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
563- Added sysconf and initscript (#158270)
564- Fixed oob subscripts (#149142)
565
566* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
567- Correctly put libs in the proper packages
568
569* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
570- gcc4 rebuild fixes
571- Added missing gdbm-devel buildprereq
572
573* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
574- bump release and rebuild with gcc 4
575
576* Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
577- update
578
579* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
580- Initial version
Note: See TracBrowser for help on using the repository browser.