source: projects/specs/trunk/O/OpenEXR/OpenEXR-vl.spec @ 12423

Revision 12423, 8.2 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

OpenEXR-2.4.2-1

pam-1.4.0-1

python-pillow-7.2.0-1

python-qt5-5.12.3-3

sane-1.0.30-1

Line 
1%bcond_with check
2
3Name:           OpenEXR
4Summary:        A high dynamic-range (HDR) image file format
5Summary(ja):    高ダイナミックレンジ(HDR)画像ファイルフォーマット
6Version:        2.4.2
7Release:        1%{?_dist_release}
8Group:          Applications/Graphics
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        BSD
13URL:            http://www.openexr.com/
14Source0:        https://github.com/openexr/openexr/archive/v%{version}.tar.gz#/openexr-%{version}.tar.gz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: cmake
18BuildRequires: zlib-devel
19BuildRequires: pkgconfig
20# https://github.com/openexr/openexr/issues/130
21BuildConflicts: OpenEXR-devel < 2.2.0
22
23Requires: %{name}-libs = %{version}-%{release}
24
25Obsoletes: openexr < %{version}-%{release}
26Provides:  openexr = %{version}-%{release}
27
28%description
29OpenEXR is a high dynamic-range (HDR) image file format developed by Industrial
30Light & Magic for use in computer imaging applications. This package contains
31sample applications for handling the format.
32
33%package        libs
34Summary:        %{name} runtime libraries
35Summary(ja):    %{name} のランタイムライブラリ
36Group:          System Environment/Libraries
37
38%description    libs
39%{summary}.
40
41
42%package        devel
43Summary:        Development files for %{name}
44Summary(ja):    %{name} の開発用ファイル
45Group:          Development/Libraries
46Requires:       %{name}-libs = %{version}-%{release}
47Requires:       ilmbase-devel
48Obsoletes:      openexr-devel < %{version}-%{release}
49Provides:       openexr-devel = %{version}-%{release}
50
51%description devel
52%{summary}.
53
54
55%package -n     ilmbase
56Summary:        Abraction/convenience libraries
57Group:          System Environment/Libraries
58BuildRequires:  libGL-devel
59BuildRequires:  libGLU-devel
60
61%description -n ilmbase
62Half is a class that encapsulates the ilm 16-bit floating-point format.
63
64IlmThread is a thread abstraction library for use with OpenEXR
65and other software packages.
66
67Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
68and other useful 2D and 3D math functions.
69
70Iex is an exception-handling library.
71
72
73%package -n     ilmbase-devel
74Summary:        Headers and libraries for building apps that use ilmbase
75Summary(ja):    ilmbaseを使うアプリケーションをビルドするためのヘッダファイル及びライブラリ
76Group:          Development/Libraries
77Requires:       ilmbase = %{version}-%{release}
78Requires:       pkgconfig
79Requires:       libGL-devel
80Requires:       libGLU-devel
81
82%description -n ilmbase-devel
83Headers and libraries for building apps that use ilmbase.
84
85
86%prep
87%setup -q -n openexr-%{version}
88
89pushd IlmBase
90echo "Requires.private: gl glu" >> IlmBase.pc.in
91popd
92
93# *.pc built by cmake is broken
94# https://github.com/openexr/openexr/issues/595
95sed -i \
96        -e 's,@exec_prefix@,${prefix}/@exec_prefix@,' \
97        -e 's,@libdir@,\${prefix}/@libdir@,' \
98        -e 's,@includedir@,${prefix}/@includedir@,' \
99        IlmBase/IlmBase.pc.in
100sed -i \
101        -e 's,@exec_prefix@,${prefix}/@exec_prefix@,' \
102        -e 's,@libdir@,\${prefix}/@libdir@,' \
103        -e 's,@includedir@,${prefix}/@includedir@,' \
104        OpenEXR/OpenEXR.pc.in
105
106
107%build
108
109mkdir build
110pushd build
111%cmake \
112        -DPYILMBASE_ENABLE=no \
113        -DOPENEXR_VIEWERS_ENABLE=no \
114        ..
115make %{?_smp_mflags}
116popd
117
118
119%install
120rm -rf %{buildroot}
121
122pushd build
123make install DESTDIR=%{buildroot}
124popd
125
126# prepare docs
127mkdir -p rpmdocs
128cp -a %{buildroot}%{_docdir}/OpenEXR/* rpmdocs/
129rm -rf %{buildroot}%{_docdir}/OpenEXR
130
131
132%if %{with check}
133%check
134pushd build
135%ifarch %{ix86}
136make %{_smp_mflags} test ||:
137%else
138make %{_smp_mflags} test
139%endif
140popd
141%endif
142
143
144%clean
145rm -rf %{buildroot}
146
147
148%post libs -p /sbin/ldconfig
149
150%postun libs -p /sbin/ldconfig
151
152
153%files
154%defattr(-,root,root,-)
155%license LICENSE.md
156%doc README.md
157%{_bindir}/*
158
159%files libs
160%defattr(-,root,root,-)
161%license LICENSE.md
162%doc OpenEXR/README.md
163%doc rpmdocs/*
164%{_libdir}/libIlmImf*.so.*
165
166%files devel
167%defattr(-,root,root,-)
168%{_includedir}/OpenEXR/Imf*.h
169%{_includedir}/OpenEXR/OpenEXRConfig.h
170%{_libdir}/lib*.so
171%dir %{_libdir}/pkgconfig
172%{_libdir}/pkgconfig/OpenEXR.pc
173%dir %{_libdir}/cmake
174%{_libdir}/cmake/OpenEXR
175
176%files -n ilmbase
177%doc IlmBase/README.md
178%license LICENSE.md
179%{_libdir}/lib*.so.*
180%exclude %{_libdir}/libIlmImf*.so.*
181
182%files -n ilmbase-devel
183%dir %{_includedir}/OpenEXR/
184%{_includedir}/OpenEXR/Iex*.h
185%{_includedir}/OpenEXR/Ilm*.h
186%{_includedir}/OpenEXR/Imath*.h
187%{_includedir}/OpenEXR/half*.h
188%{_libdir}/lib*.so
189%exclude %{_libdir}/libIlmImf*.so
190%dir %{_libdir}/pkgconfig
191%{_libdir}/pkgconfig/IlmBase.pc
192%dir %{_libdir}/cmake
193%{_libdir}/cmake/IlmBase
194
195
196%changelog
197* Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-1
198- new upstream release.
199
200* Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
201- new upstream release.
202
203* Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-1
204- new upstream release.
205- unified IlmBase into OpenEXR.
206
207* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-2
208- rebuild with gcc-5.4.0
209
210* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.0-1
211- new upstream release
212- removed Patch100 and 101
213- built with ilmbase 2.2.0
214
215* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
216- new upstream release
217- remove Patch1,2,102
218- update Patch100 (openexr-2.1.0-CVE-2009-1720-1.patch)
219- update Patch101 (openexr-2.1.0-CVE-2009-1720-2.patch)
220
221* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-3
222- rebuilt with rpm-4.8.1 for pkg-config
223
224* Wed Aug  5 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.1-2
225- add Patch100,101 for fix CVE-2009-1720 (Integer BOF)
226- add Patch102 for fix CVE-2009-1721
227- Patch100-102 are from FC11
228
229* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-1
230- initial build for Vine Linux
231
232* Fri May 09 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-4
233- drop: Obsoletes: OpenEXR-utils (see OpenEXR_Viewers review, bug #428228c3)
234
235* Fri Feb 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-3
236- gcc43 patch
237- purge rpaths
238
239* Wed Jan 09 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-2
240- hack to omit unused-direct-shlib-dependencies
241- conditionalize -libs (f8+)
242
243* Mon Jan 07 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-1
244- openexr-1.6.1
245
246* Tue Oct 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-5
247- multiarch conflicts in OpenEXR (#342781)
248- don't own %%_includedir/OpenEXR (leave that to ilmbase)
249
250* Mon Oct 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-4
251- -libs: %%post/%%postun -p /sbin/ldconfig
252
253* Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-2
254- openexr-1.6.0
255
256* Mon Sep 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-6
257- libs: -Requires: %%name
258
259* Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-5
260- -libs: new subpkg to be multilib friendly
261- -utils: package exrdisplay separately (separate fltk dep)
262
263* Sat Oct 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-4
264- Obsoletes/Provides: openexr(-devel) (rpmforge compatibility)
265
266* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-3
267- pkgconfig patch to use Libs.private
268
269* Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-2
270- -devel: +Requires: pkgconfig
271
272* Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-1
273- openexr-1.4.0a
274
275* Sat Feb 18 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-7
276- Further zlib fixes (#165729)
277
278* Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-6
279- Rebuild for Fedora Extras 5
280
281* Wed Aug 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-5
282- Remove *.a from %%files devel
283
284* Tue Aug 16 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-4
285- Removed -devel dep on zlib-devel (#165729)
286- Added --disable-static to %%configure
287- Fixed build with GCC 4.0.1
288- Added .so links to -devel
289
290* Wed May 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-3
291- Add zlib-devel to BR
292- Delete all .la files (#157652)
293
294* Mon May  9 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
295- Add disttag
296
297* Sun May  8 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
298- Fix BuildRequires
299- Fix Requires on -devel
300- Add %%post[un] scriptlets
301- Fix ownership in -devel
302- Don't have .deps files in %%doc
303
304* Wed Mar 30 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-1
305- Initial RPM release
Note: See TracBrowser for help on using the repository browser.