source: projects/specs/trunk/O/OpenDX/OpenDX-vl.spec @ 521

Revision 521, 10.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define samplesname     dxsamples
2%define sver    4.4.0
3%define dxdir   %{_libdir}/dx
4
5Name:           OpenDX
6Summary:        IBM OpenDX (Data Explorer)
7
8Version:        4.4.4
9Release:        0vl1
10
11Source:         http://opendx.npaci.edu/source/dx-%{version}.tar.gz
12Source1:        http://opendx.npaci.edu/source/dxsamples-%{sver}.tar.gz
13Source2:        icons-dx.tar.bz2
14Patch4:         dx-4.2.0-errno.patch.bz2
15Patch5:         dx-4.2.0-xkb.patch.bz2
16Patch6:         dx-4.3.2-types.patch.bz2
17
18URL:            http://www.opendx.org/
19Group:          Applications/Engineering
20License:        IBM Public License
21
22BuildRequires:  autoconf
23BuildRequires:  bison
24BuildRequires:  flex
25BuildRequires:  freetype2-devel
26BuildRequires:  XOrg-gl-devel
27BuildRequires:  ImageMagick-devel
28BuildRequires:  openMotif-devel
29BuildRequires:  libjbig-devel
30BuildRequires:  netcdf-devel
31%ifnarch ppc
32BuildRequires:  hdf-devel
33%endif
34BuildRoot:      %{_tmppath}/%{name}-%{version}-root
35
36%description
37OpenDX is a uniquely powerful, full-featured software package for the
38visualization of scientific, engineering and analytical data: Its open
39system design is built on a standard interface environments. And its
40sophisticated data model provides users with great flexibility in
41creating visualizations.
42
43%package devel
44Summary:        Development libraries for OpenDX
45Summary(ja):    OpenDX ¤Î³«È¯ÍÑ¥Õ¥¡¥¤¥ë
46Group:          Development/Libraries
47Requires:       OpenDX = %{version}
48
49%description devel
50This package contains the header files and includes necessary to for developing
51applications with OpenDX.
52
53%prep
54%setup -q -n dx-%{version} -a 1
55%patch4 -p1 -b .errno
56%patch5 -p1 -b .xkb
57%patch6 -p1 -b .types
58autoconf
59
60%build
61CFLAGS="%optflags -O1 -fno-fast-math -fno-exceptions" \
62CXXFLAGS="%optflags -O1 -fno-fast-math -fno-exceptions -Wno-deprecated" \
63%configure --prefix=%{_libdir} \
64           --with-x \
65           --with-magick \
66           --with-netcdf \
67           --with-jbig \
68           --without-javadx
69%__make LIBTOOL=/usr/bin/libtool
70
71(cd %{samplesname}-%{sver}
72%configure --prefix=%{_libdir}
73%__make LIBTOOL=/usr/bin/libtool)
74
75%install
76rm -rf $RPM_BUILD_ROOT
77mkdir -p $RPM_BUILD_ROOT%{_libdir} \
78        $RPM_BUILD_ROOT%{_includedir}
79%makeinstall prefix=$RPM_BUILD_ROOT%{_libdir} \
80        libdir=$RPM_BUILD_ROOT%{dxdir} \
81        mandir=$RPM_BUILD_ROOT%{_mandir} LIBTOOL=/usr/bin/libtool
82ln -sf %{dxdir}/include/dxconfig.h $RPM_BUILD_ROOT%{_includedir}/dxconfig.h
83ln -sf %{dxdir}/include/dxl.h $RPM_BUILD_ROOT%{_includedir}/dxl.h
84ln -sf %{dxdir}/include/dx $RPM_BUILD_ROOT%{_includedir}/dx
85ln -sf %{dxdir}/lib_linux/libDX.a $RPM_BUILD_ROOT%{_libdir}/libDX.a
86ln -sf %{dxdir}/lib_linux/libDXcallm.a $RPM_BUILD_ROOT%{_libdir}/libDXcallm.a
87ln -sf %{dxdir}/lib_linux/libDXL.a $RPM_BUILD_ROOT%{_libdir}/libDXL.a
88ln -sf %{dxdir}/lib_linux/libDXlite.a $RPM_BUILD_ROOT%{_libdir}/libDXlite.a
89rm -rf $RPM_BUILD_ROOT%{dxdir}/man
90#
91(cd $RPM_BUILD_ROOT/%{dxdir}/html
92ln -sf allguide.htm index.htm
93ln -sf allguide.htm index.html
94)
95#
96(cd %{samplesname}-%{sver}
97make install prefix=$RPM_BUILD_ROOT%{_libdir} LIBTOOL=/usr/bin/libtool
98)
99
100mkdir -p $RPM_BUILD_ROOT%{dxdir}/lib
101install -m 644 ./lib/mdf2c.awk $RPM_BUILD_ROOT%{dxdir}/lib/
102
103# fix dxexec path
104mv $RPM_BUILD_ROOT%{_bindir}/dxexec $RPM_BUILD_ROOT%{dxdir}/bin_linux/dxexec
105ln -s %{dxdir}/bin_linux/dxexec $RPM_BUILD_ROOT%{_bindir}/dxexec
106
107# remove files not packaged
108rm -rf $RPM_BUILD_ROOT%{_libdir}/bin/dx
109
110# icons
111mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps \
112         $RPM_BUILD_ROOT%{_datadir}/applications
113tar xjf %{SOURCE2} -C $RPM_BUILD_ROOT%{_datadir}/pixmaps
114
115# desktop file entry
116cat >$RPM_BUILD_ROOT%{_datadir}/applications/opendx.desktop <<EOF
117[Desktop Entry]
118Name=OpenDX
119Comment=IBM OpenDX Visualization Data Explorer
120exec=%{_bindir}/dx
121Icon=dx.png
122Terminal=0
123Type=Application
124Encoding=UTF-8
125Category=Application;Graphics;3DGraphics;Visualization;
126EOF
127
128# Clean installed tree
129find $RPM_BUILD_ROOT/%_libdir -type f -or -type d | xargs chmod go-w
130rm -f $RPM_BUILD_ROOT%{dxdir}/samples/outboard/Makefile_os2 \
131        $RPM_BUILD_ROOT%{dxdir}/samples/user/Makefile_os2
132
133rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_alphax
134rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_hp700
135rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_ibm6000
136rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_sgi
137rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_solaris
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%files
143%defattr(-,root,root)
144%doc AUTHORS LICENSE README
145%dir %{dxdir}
146%{_bindir}/*
147%{_mandir}/*/*
148%{dxdir}/bin
149%{dxdir}/bin_linux
150%{dxdir}/doc
151%{dxdir}/fonts
152%{dxdir}/help
153%{dxdir}/html
154%{dxdir}/lib
155%{dxdir}/lib_linux/lib*.so.*
156%{dxdir}/ui
157%{dxdir}/java
158%{_datadir}/pixmaps/*
159%{_datadir}/applications/opendx.desktop
160
161%files devel
162%defattr(-,root,root)
163%attr(644,root,root) %{_libdir}/*.a
164%doc dxsamples-%{version}/ChangeLog
165%{_includedir}/*
166%{dxdir}/include
167%{dxdir}/samples
168%{dxdir}/lib_linux/lib*.a
169%{dxdir}/lib_linux/lib*.la
170%{dxdir}/lib_linux/lib*.so
171%{dxdir}/lib_linux/arch.mak
172%{dxdir}/lib/mdf2c.awk
173
174%changelog
175* Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 4.4.4-0vl1
176- updated dx to 4.4.4
177- updated dxsamples to 4.4.0
178
179* Tue Jun 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-0vl4
180- rebuilt with new toolchain
181
182* Thu Jul 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-0vl3
183- rebuilt with ImageMagick 6.2.6.3
184- changed devel Group to Development/Libraries
185
186* Tue Oct 25 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.3.2-0vl2
187- s/jbigkit-devel/libjbig-devel/
188
189* Sat Oct 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.2-0vl1
190- initial build for Vine Linux based on MDK package.
191
192* Wed Aug 24 2005 Oden Eriksson <oeriksson@mandriva.com> 4.3.2-11mdk
193- rebuilt against new Magick libs
194
195* Mon Jul 11 2005 Giuseppe Ghib¥á<ghibo@mandriva.com> 4.3.2-10mdk
196- Rebuilt with gcc 4.0.1.
197- Added Patch6 to avoid problems with graphwiz types.h.
198
199* Wed Mar 23 2005 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.3.2-9mdk
200- Rebuilt against latest ImageMagick.
201
202* Mon Feb 07 2005 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.3.2-8mdk
203- Rebuilt against latest ImageMagick.
204
205* Thu Jan 20 2005 Frederic Lepied <flepied@mandrakesoft.com> 4.3.2-7mdk
206- rebuild to have the correct dependencies
207
208* Fri Aug 20 2004 Laurent MONTEL <lmontel@mandrakesoft.com> 4.3.2-6mdk
209- Rebuild with new menu
210
211* Thu Jul 29 2004 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.3.2-5mdk
212- Merged Gwenole patch: fix deps (from AMD64 4.3.2-1.1mdk version).
213
214* Mon Jul 19 2004 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.3.2-4mdk
215- Rebuilt under new gcc 3.4.1.
216
217* Thu Jul 01 2004 Michael Scherer <misc@mandrake.org> 4.3.2-3mdk
218- rebuild for new ImageMagick
219
220* Sat Jun 12 2004 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.3.2-2mdk
221- Rebuilt.
222
223* Thu Dec 18 2003 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.3.2-1mdk
224- Release 4.3.2.
225
226* Thu Nov 06 2003 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.3.0-4mdk
227- Fixed path for dxexec executable, which prevents dx to start properly.
228
229* Fri Oct 24 2003 Stefan van der Eijk <stefan@eijk.nu> 4.3.0-3mdk
230- BuildRequires.
231
232* Wed Aug 27 2003 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.3.0-2mdk
233- Fixed DIRM distriblint prob.
234- Removed unused patches.
235
236* Fri Aug 08 2003 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.3.0-1mdk
237- Release 4.3.0.
238- Use -O1 for now for gcc 3.3.1.
239- Moved samples to devel package.
240- Disabled Patch1,2,3,6 as no longer needed.
241- Don't use %%make macro on building, otherwise doesn't build.
242
243* Thu Jul 17 2003 David BAUDENS <baudens@mandrakesoft.com> 4.2.0-8mdk
244- Rebuild
245
246* Tue Jul 15 2003 Per ¥êyvind Karlsen <peroyvind@sintrax.net> 4.2.0-7mdk
247- fix gcc-3.3 build (P6)
248- use %%make macro
249- fix location of man pages
250
251* Tue Feb 18 2003 Giuseppe Ghib¥á<ghibo@mandrakesoft.cm> 4.2.0-6mdk
252- Added Patch2,3 from cvs (report by Nikos Platis).
253- Added Patch4,5 for get compiling under latest glibc and XFree86.
254
255* Sat Nov 30 2002 Stefan van der Eijk <stefan@eijk.nu> 4.2.0-5mdk
256- BuildRequires
257- Remove files not packaged
258
259* Mon Nov 25 2002 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.2.0-4mdk
260- Less verbose %%description.
261
262* Fri Nov 22 2002 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.2.0-3mdk
263- Rebuilt against latest ImageMagick.
264
265* Mon Nov 11 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 4.2.0-2mdk
266- Added patch to use stringstreams and not deprecated C++ classes.
267
268* Tue Sep 10 2002 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.2.0-1mdk
269- New version: 4.2.0.
270
271* Tue Sep 10 2002 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.3-12mdk
272- Added missed file mdf2c.awk (reported by Nikos Platis).
273
274* Wed Aug 28 2002 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.3-11mdk
275- Rebuilt against latest netcdf-devel package.
276
277* Wed Aug 14 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 4.1.3-10mdk
278- Automated rebuild with gcc 3.2-0.3mdk
279
280* Thu Jul 25 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 4.1.3-9mdk
281- Automated rebuild with gcc3.2
282
283* Mon Jun  3 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 4.1.3-8mdk
284- Use %%make
285- Patch1: ISO C++ fixes
286- Patch0: Don't include /usr/include in include search path
287
288* Thu Feb 21 2002 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.3-7mdk
289- rebuilt.
290
291* Sat Feb 02 2002 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.3-6mdk
292- rebuilt against HDF 4.1r5.
293
294* Thu Jan 24 2002 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.3-5mdk
295- fixed icons (png).
296
297* Mon Oct 15 2001 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.3-4mdk
298- Rebuilt against latest libpng.
299
300* Thu Sep 06 2001 Stefan van der Eijk <stefan@eijk.nu> 4.1.3-3mdk
301- BuildRequires:        flex
302- Removed BuildRequires:        zlib-devel
303
304* Wed Aug 01 2001 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.3-2mdk
305- added -fno-exceptions to compilation flags (thanks to Randall Hopper).
306- forced -O2 due to gcc bug.
307
308* Tue Jun 12 2001 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.3-1mdk
309- updated to version 4.1.3.
310- cleaned SPEC file.
311
312* Thu Mar 22 2001 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.0-7mdk
313- run aclocal/autoconf only for non ix86 architectures.
314- added menu entry.
315
316* Sat Mar 17 2001 David BAUDENS <baudens@mandrakesoft.com> 4.1.0-6mdk
317- Don't BuildRequires HDF on PPC (HDF doesn't support PPC architecture)
318- Use optimizations on PPC
319
320* Fri Mar 16 2001 Jeff Garzik <jgarzik@mandrakesoft.com> 4.1.0-5mdk
321- Prefer arch "linux" to arch "alphax", for alpha.
322- Re-generate configure with autoconf for each build.
323
324* Mon Feb 26 2001 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.0-4mdk
325- add netcdf support.
326
327* Sat Feb 24 2001 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.0-3mdk
328- added samples.
329- added patches for allowing static building (thanks jloup).
330- added mandirs.
331- fixed docs.
332- split into main and devel package.
333
334* Tue Dec 26 2000 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.0-2mdk
335- added netcdf, hdf, cdf support.
336
337* Mon Oct 09 2000 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.0-1mdk
338- more macros.
339- added patch for ImageMagick.
340
341* Sat Oct 07 2000 Giuseppe Ghib¥á<ghibo@mandrakesoft.com> 4.1.0-0.9mdk
342- initial release.
Note: See TracBrowser for help on using the repository browser.