source: projects/specs/trunk/O/OpenColorIO/OpenColorIO-vl.spec @ 10406

Revision 10406, 5.7 KB checked in by Takemikaduchi, 8 years ago (diff)

blender: new upstream release
others: rebuild with gcc-5.4.0

Line 
1# Filter provides from Python libraries
2%{?filter_setup:
3%filter_provides_in %{python_sitearch}.*\.so$
4%filter_setup
5}
6
7Name:           OpenColorIO
8Version:        1.0.8
9Release:        8%{?_dist_release}
10Summary:        Enables color transforms and image display across graphics apps
11Summary(ja):    アプリケーション間での色変換と画像表示を行うためのライブラリ
12
13License:        BSD
14Group:          System Environment/Libraries
15URL:            http://opencolorio.org/
16# Github archive was generated on the fly using the following URL:
17# https://github.com/imageworks/OpenColorIO/tarball/v1.0.8
18
19Source0:        %{name}-%{version}.tar.gz
20Patch0:         OpenColorIO-pull_300.patch
21Patch1:         OpenColorIO-yaml_cpp3.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24BuildRequires:  cmake
25BuildRequires:  help2man
26BuildRequires:  texlive-collection-fontsrecommended
27BuildRequires:  texlive-collection-latexextra
28BuildRequires:  texlive-collection-latexrecommended
29
30# Libraries
31BuildRequires:  python-devel
32BuildRequires:  mesa-libGL-devel mesa-libGLU-devel
33BuildRequires:  libX11-devel libXmu-devel libXi-devel
34BuildRequires:  freeglut-devel
35BuildRequires:  glew-devel
36BuildRequires:  zlib-devel
37
38#######################
39# Unbundled libraries #
40#######################
41BuildRequires:  tinyxml-devel
42BuildRequires:  lcms2-devel
43#BuildRequires:  yaml-cpp-devel
44
45# The following bundled projects  are only used for document generation.
46#BuildRequires:  python-docutils
47#BuildRequires:  python-jinja2
48#BuildRequires:  python-pygments
49#BuildRequires:  python-setuptools
50#BuildRequires:  python-sphinx
51
52%description
53OCIO enables color transforms and image display to be handled in a consistent
54manner across multiple graphics applications. Unlike other color management
55solutions, OCIO is geared towards motion-picture post production, with an
56emphasis on visual effects and animation color pipelines.
57
58
59%package devel
60Summary:        Development libraries and headers for %{name}
61Summary(ja):    %{name} の開発用ライブラリおよびヘッダファイル
62Group:          Development/Libraries
63Requires:       %{name} = %{version}-%{release}
64
65%description devel
66Development libraries and headers for %{name}.
67
68
69%package doc
70Summary:        API Documentation for %{name}
71Summary(ja):    %{name} API のドキュメント
72Group:          Documentation
73BuildArch:      noarch
74Requires:       %{name} = %{version}-%{release}
75
76%description doc
77API documentation for %{name}.
78
79
80%prep
81%setup -q
82%patch0 -p1 -b .pull300
83#patch1 -p1 -b .yaml3
84
85# Remove what bundled libraries
86rm -f ext/lcms*
87rm -f ext/tinyxml*
88#rm -f ext/yaml*
89
90
91%build
92rm -rf build && mkdir build && pushd build
93%cmake -DOCIO_BUILD_STATIC=OFF \
94       -DOCIO_BUILD_DOCS=ON \
95       -DOCIO_BUILD_TESTS=ON \
96       -DOCIO_PYGLUE_SONAME=OFF \
97       -DUSE_EXTERNAL_YAML=FALSE \
98       -DUSE_EXTERNAL_TINYXML=TRUE \
99       -DUSE_EXTERNAL_LCMS=TRUE \
100%ifnarch x86_64
101       -DOCIO_USE_SSE=OFF \
102%endif
103       -DCMAKE_SKIP_RPATH=OFF \
104       ../
105
106#       -DUSE_EXTERNAL_YAML=FALSE \
107make %{?_smp_mflags}
108
109                         
110%install
111rm -rf %{buildroot}
112pushd build
113make install DESTDIR=%{buildroot}
114
115# Generate man pages
116mkdir -p %{buildroot}%{_mandir}/man1
117help2man -N -s 1 --version-string=%{version} \
118         -o %{buildroot}%{_mandir}/man1/ociocheck.1 \
119         src/apps/ociocheck/ociocheck
120help2man -N -s 1 --version-string=%{version} \
121         -o %{buildroot}%{_mandir}/man1/ociobakelut.1 \
122         src/apps/ociobakelut/ociobakelut
123
124# Move installed documentation back so it doesn't conflict with the main package
125popd
126
127rm -rf _tmpdoc
128mkdir -p _tmpdoc
129mv %{buildroot}%{_docdir}/%{name}/* _tmpdoc/
130
131
132%check
133# Testing passes locally in mock but fails on the fedora build servers.
134#pushd build && make test
135
136
137%post -p /sbin/ldconfig
138%postun -p /sbin/ldconfig
139
140%clean
141rm -rf %{buildroot}
142
143
144%files
145%doc ChangeLog LICENSE README
146%{_bindir}/*
147%{_libdir}/*.so.*
148%dir %{_datadir}/ocio
149%{_datadir}/ocio/setup_ocio.sh
150%{_mandir}/man1/*
151%{python_sitearch}/*.so
152
153%files devel
154%{_includedir}/OpenColorIO/
155%{_includedir}/PyOpenColorIO/
156%{_libdir}/*.so
157%{_libdir}/pkgconfig/%{name}.pc
158
159%files doc
160%doc _tmpdoc/*
161
162
163%changelog
164* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.8-8
165- rebuild with gcc-5.4.0
166
167* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.8-7
168- Initial build for Vine Linux
169- used bundled yaml-cpp
170
171* Mon Sep 23 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-6
172- Rebuild against yaml-cpp03 compatibility package.
173
174* Mon Aug 26 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-5
175- Fix for new F20 feature, unversion doc dir. Fixes BZ#1001264
176
177* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-3
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
179
180* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-2
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
182
183* Tue Dec 11 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-1
184- Update to latest upstream release.
185
186* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
188
189* Thu Apr 26 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-4
190- Only use SSE instructions on x86_64.
191
192* Wed Apr 25 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-3
193- Misc spec cleanup for packaging guidelines.
194- Disable testing for now since it fails on the build servers.
195
196* Wed Apr 18 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-1
197- Latest upstream release.
198
199* Thu Apr 05 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.6-1
200- Latest upstream release.
201
202* Wed Nov 16 2011 Richard Shaw <hobbes1069@gmail.com> - 1.0.2-1
203- Initial release.
Note: See TracBrowser for help on using the repository browser.