source: projects/specs/trunk/O/OpenColorIO/OpenColorIO-vl.spec @ 12286

Revision 12286, 6.5 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

Field3D-1.7.2-2

ImageMagick?-6.9.10.69-1

OpenColorIO-1.1.1-1

OpenEXR-2.4.0-1

OpenImageIO-2.0.11-1

babl-0.1.72-1

e2fsprogs-1.45.4-1

elfutils-0.177-1

gegl04-0.4.16-1

python3-3.5.7-5

Line 
1%bcond_with doc
2
3# Filter provides from Python libraries
4%{?filter_setup:
5%filter_provides_in %{python3_sitearch}.*\.so$
6%filter_setup
7}
8
9Name:           OpenColorIO
10Version:        1.1.1
11Release:        1%{?_dist_release}
12Summary:        Enables color transforms and image display across graphics apps
13Summary(ja):    アプリケーション間での色変換と画像表示を行うためのライブラリ
14Group:          System Environment/Libraries
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19License:        BSD
20URL:            https://opencolorio.org/
21# Github archive was generated on the fly using the following URL:
22# https://github.com/imageworks/OpenColorIO/tarball/v1.0.8
23
24Source0:        https://github.com/AcademySoftwareFoundation/OpenColorIO/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
25Patch1:         OpenColorIO-yaml_cpp3.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires:  cmake
29BuildRequires:  git
30BuildRequires:  help2man
31%if %{with doc}
32BuildRequires:  texlive-collection-fontsrecommended
33BuildRequires:  texlive-collection-latexextra
34BuildRequires:  texlive-collection-latexrecommended
35%endif
36
37# Libraries
38BuildRequires:  python3-devel
39BuildRequires:  python3-rpm-macros
40BuildRequires:  mesa-libGL-devel mesa-libGLU-devel
41BuildRequires:  libX11-devel libXmu-devel libXi-devel
42BuildRequires:  freeglut-devel
43BuildRequires:  glew-devel
44BuildRequires:  zlib-devel
45
46#######################
47# Unbundled libraries #
48#######################
49BuildRequires:  tinyxml-devel
50BuildRequires:  lcms2-devel
51#BuildRequires:  yaml-cpp-devel
52
53# The following bundled projects  are only used for document generation.
54#BuildRequires:  python-docutils
55#BuildRequires:  python-jinja2
56#BuildRequires:  python-pygments
57#BuildRequires:  python-setuptools
58#BuildRequires:  python-sphinx
59
60%if ! %{with doc}
61Obsoletes: %{name}-doc < %{version}-%{release}
62%endif
63
64
65%description
66OCIO enables color transforms and image display to be handled in a consistent
67manner across multiple graphics applications. Unlike other color management
68solutions, OCIO is geared towards motion-picture post production, with an
69emphasis on visual effects and animation color pipelines.
70
71
72%package devel
73Summary:        Development libraries and headers for %{name}
74Summary(ja):    %{name} の開発用ライブラリおよびヘッダファイル
75Group:          Development/Libraries
76Requires:       %{name} = %{version}-%{release}
77
78%description devel
79Development libraries and headers for %{name}.
80
81
82%package doc
83Summary:        API Documentation for %{name}
84Summary(ja):    %{name} API のドキュメント
85Group:          Documentation
86BuildArch:      noarch
87Requires:       %{name} = %{version}-%{release}
88
89%description doc
90API documentation for %{name}.
91
92
93%prep
94%setup -q
95#patch1 -p1 -b .yaml3
96
97# Remove what bundled libraries
98rm -f ext/lcms*
99rm -f ext/tinyxml*
100#rm -f ext/yaml*
101
102
103%build
104rm -rf build && mkdir build && pushd build
105
106export CXXFLAGS="%{optflags} -Wno-deprecated-declarations -Wno-cast-function-type -Wno-unused-function"
107
108%cmake \
109       -DPYTHON=%{__python3} \
110       -DPYLIB_INSTALL_DIR:PATH=%{python3_sitearch} \
111       -DOCIO_BUILD_STATIC=OFF \
112%if %{with doc}
113       -DOCIO_BUILD_DOCS=ON \
114%else
115       -DOCIO_BUILD_DOCS=OFF \
116%endif
117       -DOCIO_BUILD_TESTS=ON \
118       -DOCIO_PYGLUE_SONAME=OFF \
119       -DUSE_EXTERNAL_YAML=FALSE \
120       -DUSE_EXTERNAL_TINYXML=TRUE \
121       -DUSE_EXTERNAL_LCMS=TRUE \
122%ifnarch x86_64
123       -DOCIO_USE_SSE=OFF \
124%endif
125       -DCMAKE_SKIP_RPATH=OFF \
126       ..
127
128#       -DUSE_EXTERNAL_YAML=FALSE \
129
130make %{_smp_mflags}
131
132                         
133%install
134rm -rf %{buildroot}
135pushd build
136%make_install
137
138# Generate man pages
139mkdir -p %{buildroot}%{_mandir}/man1
140help2man -N -s 1 --version-string=%{version} \
141         -o %{buildroot}%{_mandir}/man1/ociocheck.1 \
142         src/apps/ociocheck/ociocheck
143help2man -N -s 1 --version-string=%{version} \
144         -o %{buildroot}%{_mandir}/man1/ociobakelut.1 \
145         src/apps/ociobakelut/ociobakelut
146
147# Move installed documentation back so it doesn't conflict with the main package
148popd
149
150%if %{with doc}
151rm -rf _tmpdoc
152mkdir -p _tmpdoc
153mv %{buildroot}%{_docdir}/%{name}/* _tmpdoc/
154%endif
155
156mv -f %{buildroot}%{_prefix}/cmake %{buildroot}%{_libdir}/
157mv -f %{buildroot}%{_prefix}/*.cmake %{buildroot}%{_libdir}/cmake/
158
159%check
160# Testing passes locally in mock but fails on the fedora build servers.
161#pushd build && make test
162
163
164%post -p /sbin/ldconfig
165%postun -p /sbin/ldconfig
166
167%clean
168rm -rf %{buildroot}
169
170
171%files
172%license LICENSE
173%doc CHANGELOG* README*
174%{_bindir}/*
175%{_libdir}/*.so.*
176%dir %{_datadir}/ocio
177%{_datadir}/ocio/setup_ocio.sh
178%{_mandir}/man1/*
179%{python3_sitearch}/*.so
180
181%files devel
182%{_includedir}/OpenColorIO/
183%{_includedir}/PyOpenColorIO/
184%{_libdir}/*.so
185%dir %{_libdir}/pkgconfig
186%{_libdir}/pkgconfig/%{name}.pc
187%dir %{_libdir}/cmake
188%{_libdir}/cmake/*
189
190%if %{with doc}
191%files doc
192%doc _tmpdoc/*
193%endif
194
195
196%changelog
197* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.1-1
198- new upstream release.
199
200* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.8-8
201- rebuild with gcc-5.4.0
202
203* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.8-7
204- Initial build for Vine Linux
205- used bundled yaml-cpp
206
207* Mon Sep 23 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-6
208- Rebuild against yaml-cpp03 compatibility package.
209
210* Mon Aug 26 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-5
211- Fix for new F20 feature, unversion doc dir. Fixes BZ#1001264
212
213* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-3
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
215
216* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-2
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
218
219* Tue Dec 11 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-1
220- Update to latest upstream release.
221
222* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
224
225* Thu Apr 26 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-4
226- Only use SSE instructions on x86_64.
227
228* Wed Apr 25 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-3
229- Misc spec cleanup for packaging guidelines.
230- Disable testing for now since it fails on the build servers.
231
232* Wed Apr 18 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-1
233- Latest upstream release.
234
235* Thu Apr 05 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.6-1
236- Latest upstream release.
237
238* Wed Nov 16 2011 Richard Shaw <hobbes1069@gmail.com> - 1.0.2-1
239- Initial release.
Note: See TracBrowser for help on using the repository browser.